TheBoxSoftware.Reflection Namespaces

Namespace
TheBoxSoftware.Reflection
Produced by the Live Documenter developed by The Box Software.


TheBoxSoftware.Reflection Namespace

Classes

 | Class | Summary
public class | ArgInlineNoneILInstruction |
public class | AssemblyDef | The AssemblyDef provides the top level information and entry point to all types, methods etc reflected from a .NET executable.
sealed class | AssemblyDefBuilder |
public class | AssemblyRef | Represents a reference to an external library.
sealed class | BuildReferences |
public class | ConstantInfo |
public class | CustomAttribute |
public class | EventDef | Represents a single event for a type. An event is made up from one or two MethodDef entries in the type. These are generally prefixed with add_ and remove_. This class allows those events to be treated as a single unit.
public class | FieldDef | Describes the construction of a field in the CLR metadata.
public class | GenericTypeRef | A class that represents a generic type; generic types are defined on types and methods. These types however will never resolve to an actual type instance because they are determined at call time, not at definition.
public class | ILInstruction | Represents a single Intermediate Language Instruction
public class | InlineBrTargetILInstruction |
public class | InlineFieldILInstruction | Represents an IL instruction of type InlineField
public class | InlineI8ILInstruction |
public class | InlineIILInstruction |
public class | InlineMethodILInstruction | Represents an IL instruction of type InlineMethod
public class | InlineNoneILInstruction | Represents an IL Instruction of Type InlineNone
public class | InlineRILInstruction |
public class | InlineSigILInstruction |
public class | InlineStringILInstruction |
public class | InlineSwitchILInstruction | Represents an IL instruction of type InlineSwitch
public class | InlineTokenILInstruction | Represents an IL instruction of type InlineMethod
public class | InlineTypeILInstruction | Represents an IL instruction of type InlineMethod
public class | InlineVarILInstruction |
public class | MemberRef | Represents an instance of a Member that is referenced from an external source.
sealed class | MetadataToDefinitionMap | A mapper class that allows the quick retrieval of metadata or definition information, from either direction.
public class | MethodBody | Contains the details and MSIL for a method definition.
public class | MethodDef | Represents a method definition as a reflected element.
public class | ModuleDef | Provides a definition for a module in an assembly.
public class | OpCodes |
public class | OpCodesMap | Creates a nice searchable and iterable version of the OpCodes class.
public class | ParamDef | Describes a parameter
public class | PropertyDef | A class that describes a property that has been defined in an TypeDef.
public class | ReflectedMember | Base class for all elements that are reflected from a PeCoffFile.
public class | ReflectionException | Exception that describes issues working with reflection based code.
public class | ShortInlineBrTargetILInstruction | Represents an IL instruction of type ShortInlineBrTarget
public class | ShortInlineIILInstruction |
public class | ShortInlineRILInstruction |
public class | ShortInlineVarILInstruction |
public class | TypeDef | Contains the information regarding the construction and elements of a type reflected from the metadata information. A type definition is a metadata reflected type which is defined in an assembly.
sealed class | TypeInNamespaceMap |
public class | TypeRef | Details a reference to a Type that resides in another assembly.
sealed class | TypeSpec | Details the specification of a type. This is generally used by the metadata to allow for types to derive from and implement interfaces and classes that are generic.
public class | WellKnownTypeDef |

Structures

 | Name | Summary
public structure | OpCode |

Enumerations

 | Name | Summary
public enum | FlowControl | Describes how the instruction effects the flow of execution.
sealed enum | ILMetadataToken |
public enum | MemberTypes | Enumeration of members that can be defined in an assembly.
public enum | OpCodeType |
public enum | OperandType |
public enum | StackBehaviour |
public enum | Visibility | Visibility flags that apply to all members in the reflection namespace.


ArgInlineNoneILInstruction

ArgInlineNoneILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.ArgInlineNoneILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ArgInlineNoneILInstruction : ILInstruction

The ArgInlineNoneILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ArgInlineNoneILInstruction(OpCode) | Initialises a new instance of the InlineNoneILInstruction class


ArgInlineNoneILInstruction Constructors

The ArgInlineNoneILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ArgInlineNoneILInstruction(OpCode) | Initialises a new instance of the InlineNoneILInstruction class


ArgInlineNoneILInstruction(OpCode)

Initialises a new instance of the InlineNoneILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ArgInlineNoneILInstruction(
OpCode code
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction


AssemblyDef

AssemblyDef Class

The AssemblyDef provides the top level information and entry point to all types, methods etc reflected from a .NET executable.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.AssemblyDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyDef : ReflectedMember

The AssemblyDef type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | AssemblyDef() |
sealed constructor | AssemblyDef(PeCoffFile) |

Methods

 | Name | Summary
public method | Create(String) | Creates and instantiates an AssemblyDef based on the provided library name.
public method | Create(PeCoffFile) | Initialises and instantiates an AssemblyDef instance for the provided PeCoffFile (assembly).
sealed method | CreateUniqueId() | Get the next available unique identifier for this assembly.
sealed method | FileAddressFromRVA(UInt32) |
public method | FindType(String, String) | Searches the assembly for the named type in the specified assembly.
sealed method | GetExtendindTypes(TypeDef, CodedIndex) |
sealed method | GetFileContents() |
public method | GetGloballyUniqueId() | Returns a unique identifier for this AssemblyDef.
public method | GetNamespaces() | Obtains a collection of all the namespaces defined in this assembly.
sealed method | GetSigniture(BlobIndex) | Returns the unique identifier of the AssemblyDef
public method | GetTypesInNamespaces() | Returns all the types in their respective namespaces.
sealed method | ResolveCodedIndex(CodedIndex) |
public method | ResolveMetadataToken(UInt32) | Helps to resolve tokens from the metadata to there associated types and elements inside this assembly.

Properties

 | Name | Summary
public properties | FileName | The filename of the underlying assembly used to build this assembly definition.
sealed properties | Map() |
public properties | Modules() |
public properties | ReferencedAssemblies() |
public properties | StringStream() | Gets or sets a reference to the string stream.
public properties | Types() |
public properties | Version() | The version details for this assembly.

Fields

 | Name | Description
private field | _blobStream |
private field | _fileContents |
private field | _fileName |
private field | _map |
private field | _metadataDirectory |
private field | _metadataMap |
private field | _metadataStream |
private field | _modules |
private field | _peCoffFile |
private field | _referencedAssemblies |
private field | _stringStream |
private field | _types |
private field | _uniqueIdCounter |
private field | _version |

Remarks

The AssemblyDef is the starting point for obtaining reflected information about a .NET assembly. This information is obtained by parsing and discerning information about TypeDefs, MethodDefs etc from the .NET metadata stored in the PeCoffFile.

The assembly implements a mechanism for generating unique identifiers that can be assigned to each of the elements reflected in this assembly. The unique identifier is not really required but can help other applications to store keys and find reflected elements more quickly and uses less memory than string based unique identifiers.

// Instantiate from a full file path and name
AssemblyDef assembly = AssemblyDef.Create(myAssemblyPath);

// Instantiate from an already existing loaded metadata file
PeCoffFile peCoffFile = new PeCoffFile(myAssemblyPath);
AssemblyDef assembly = AssemblyDef.Create(peCoffFile);

See also

PeCoffFile


AssemblyDef Constructors

The AssemblyDef type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | AssemblyDef() |
sealed constructor | AssemblyDef(PeCoffFile) |


AssemblyDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal AssemblyDef()


AssemblyDef(PeCoffFile)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal AssemblyDef(
PeCoffFile peCoffFile
)

Parameters

peCoffFile
Type: PeCoffFile


AssemblyDef Fields

The AssemblyDef type exposes the following members.

Fields

 | Name | Description
private field | _blobStream |
private field | _fileContents |
private field | _fileName |
private field | _map |
private field | _metadataDirectory |
private field | _metadataMap |
private field | _metadataStream |
private field | _modules |
private field | _peCoffFile |
private field | _referencedAssemblies |
private field | _stringStream |
private field | _types |
private field | _uniqueIdCounter |
private field | _version |


_blobStream

_blobStream Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobStream _blobStream


_fileContents

_fileContents Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _fileContents


_fileName

_fileName Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _fileName


_map

_map Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeInNamespaceMap _map


_metadataDirectory

_metadataDirectory Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataDirectory _metadataDirectory


_metadataMap

_metadataMap Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataToDefinitionMap _metadataMap


_metadataStream

_metadataStream Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataStream _metadataStream


_modules

_modules Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _modules


_peCoffFile

_peCoffFile Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PeCoffFile _peCoffFile


_referencedAssemblies

_referencedAssemblies Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _referencedAssemblies


_stringStream

_stringStream Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private IStringStream _stringStream


_types

_types Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _types


_uniqueIdCounter

_uniqueIdCounter Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _uniqueIdCounter


_version

_version Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Version _version


AssemblyDef Methods

The AssemblyDef type exposes the following members.

Methods

 | Name | Summary
public method | Create(String) | Creates and instantiates an AssemblyDef based on the provided library name.
public method | Create(PeCoffFile) | Initialises and instantiates an AssemblyDef instance for the provided PeCoffFile (assembly).
sealed method | CreateUniqueId() | Get the next available unique identifier for this assembly.
sealed method | FileAddressFromRVA(UInt32) |
public method | FindType(String, String) | Searches the assembly for the named type in the specified assembly.
sealed method | GetExtendindTypes(TypeDef, CodedIndex) |
sealed method | GetFileContents() |
public method | GetGloballyUniqueId() | Returns a unique identifier for this AssemblyDef.
public method | GetNamespaces() | Obtains a collection of all the namespaces defined in this assembly.
sealed method | GetSigniture(BlobIndex) | Returns the unique identifier of the AssemblyDef
public method | GetTypesInNamespaces() | Returns all the types in their respective namespaces.
sealed method | ResolveCodedIndex(CodedIndex) |
public method | ResolveMetadataToken(UInt32) | Helps to resolve tokens from the metadata to there associated types and elements inside this assembly.


Create(String)

Create(String) Method

Creates and instantiates an AssemblyDef based on the provided library name.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static AssemblyDef Create(
    string fileName
    )

Parameters

fileName
Type: String
The file name of the assembly to reflect.

Exceptions

Exception | Condition
System.ArgumentNullException | The filename was null or empty.
NotAManagedLibraryException | Thrown when a PeCoff file is passed to the function and the fileNamedoes not contain a CommonLanguageRuntimeHeader.


Create(PeCoffFile)

Create(PeCoffFile) Method

Initialises and instantiates an AssemblyDef instance for the provided PeCoffFile (assembly).
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static AssemblyDef Create(
    PeCoffFile peCoffFile
    )

Parameters

peCoffFile
Type: PeCoffFile
The PeCoffFile to load the AssemblyDef from.

Exceptions

Exception | Condition
System.ArgumentNullException | Thrown when the PeCoffFile is null.
NotAManagedLibraryException | Thrown when a PeCoff file is passed to the function and the peCoffFiledoes not contain a CommonLanguageRuntimeHeader.


CreateUniqueId()

CreateUniqueId() Method

Get the next available unique identifier for this assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal int CreateUniqueId()


FileAddressFromRVA(UInt32)

FileAddressFromRVA(UInt32) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal uint FileAddressFromRVA(
    uint rva
    )

Parameters

rva
Type: UInt32


FindType(String, String)

FindType(String, String) Method

Searches the assembly for the named type in the specified assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef FindType(
    string theNamespace,
    string theTypeName
    )

Parameters

theNamespace
Type: String
The namespace to search for the type in.
theTypeName
Type: String
The name of the type


GetExtendindTypes(TypeDef, CodedIndex)

GetExtendindTypes(TypeDef, CodedIndex) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal List<TypeRef> GetExtendindTypes(
    TypeDef type,
    CodedIndex ciForThisType
    )

Parameters

type
Type: TypeDef
ciForThisType
Type: CodedIndex


GetFileContents()

GetFileContents() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal byte[] GetFileContents()


GetGloballyUniqueId()

GetGloballyUniqueId() Method

Returns a unique identifier for this AssemblyDef.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public long GetGloballyUniqueId()


GetNamespaces()

GetNamespaces() Method

Obtains a collection of all the namespaces defined in this assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<string> GetNamespaces()


GetSigniture(BlobIndex)

GetSigniture(BlobIndex) Method

Returns the unique identifier of the AssemblyDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal Signature GetSigniture(
    BlobIndex fromIndex
    )

Parameters

fromIndex
Type: BlobIndex


GetTypesInNamespaces()

GetTypesInNamespaces() Method

Returns all the types in their respective namespaces.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<string, List<TypeDef>> GetTypesInNamespaces()


ResolveCodedIndex(CodedIndex)

ResolveCodedIndex(CodedIndex) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal object ResolveCodedIndex(
    CodedIndex index
    )

Parameters

index
Type: CodedIndex


ResolveMetadataToken(UInt32)

ResolveMetadataToken(UInt32) Method

Helps to resolve tokens from the metadata to there associated types and elements inside this assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectedMember ResolveMetadataToken(
    uint metadataToken
    )

Parameters

metadataToken
Type: UInt32
The metadata token to resolve

Remarks

A token is specific to an assembly.


AssemblyDef Properties

The AssemblyDef type exposes the following members.

Properties

 | Name | Summary
public properties | FileName | The filename of the underlying assembly used to build this assembly definition.
sealed properties | Map() |
public properties | Modules() |
public properties | ReferencedAssemblies() |
public properties | StringStream() | Gets or sets a reference to the string stream.
public properties | Types() |
public properties | Version() | The version details for this assembly.


FileName

FileName Property

The filename of the underlying assembly used to build this assembly definition.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string FileName {
    get;
    }


Map()

Map() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeInNamespaceMap this[] {
    get;
    set;
    }


Modules()

Modules() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ModuleDef> this[] {
    get;
    set;
    }


ReferencedAssemblies()

ReferencedAssemblies() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<AssemblyRef> this[] {
    get;
    set;
    }


StringStream()

StringStream() Property

Gets or sets a reference to the string stream.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public IStringStream this[] {
    get;
    set;
    }

Remarks

This has been created to reduce the cost of obtaining this information, it is a well access field and storing it behind a property just increases cost for no reason.


Types()

Types() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<TypeDef> this[] {
    get;
    set;
    }


Version()

Version() Property

The version details for this assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Version this[] {
    get;
    set;
    }


AssemblyDefBuilder

AssemblyDefBuilder Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.AssemblyDefBuilder
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class AssemblyDefBuilder

The AssemblyDefBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyDefBuilder(PeCoffFile) |

Methods

 | Name | Summary
public method | Build() |
private method | LoadAssemblyMetadata() |
private method | LoadAssemblyRefMetadata() |
private method | LoadConstantMetadata() |
private method | LoadCustomAttributeMetadata() |
private method | LoadInterfaceImplMetadata() |
private method | LoadMemberRefMetadata() |
private method | LoadModuleMetadata() |
private method | LoadNestedClassMetadata() |
private method | LoadTypeDefMetadata() |
private method | LoadTypeRefMetadata() |
private method | LoadTypeSpecMetadata() |

Fields

 | Name | Description
private field | _assembly |
private field | _map |
private field | _metadata |
private field | _peCoffFile |
private field | _references |
private field | _stream |


AssemblyDefBuilder Constructors

The AssemblyDefBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyDefBuilder(PeCoffFile) |


AssemblyDefBuilder(PeCoffFile)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyDefBuilder(
PeCoffFile peCoffFile
)

Parameters

peCoffFile
Type: PeCoffFile


AssemblyDefBuilder Fields

The AssemblyDefBuilder type exposes the following members.

Fields

 | Name | Description
private field | _assembly |
private field | _map |
private field | _metadata |
private field | _peCoffFile |
private field | _references |
private field | _stream |


_assembly

_assembly Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private AssemblyDef _assembly


_map

_map Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataToDefinitionMap _map


_metadata

_metadata Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataDirectory _metadata


_references

_references Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BuildReferences _references


_stream

_stream Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataStream _stream


AssemblyDefBuilder Methods

The AssemblyDefBuilder type exposes the following members.

Methods

 | Name | Summary
public method | Build() |
private method | LoadAssemblyMetadata() |
private method | LoadAssemblyRefMetadata() |
private method | LoadConstantMetadata() |
private method | LoadCustomAttributeMetadata() |
private method | LoadInterfaceImplMetadata() |
private method | LoadMemberRefMetadata() |
private method | LoadModuleMetadata() |
private method | LoadNestedClassMetadata() |
private method | LoadTypeDefMetadata() |
private method | LoadTypeRefMetadata() |
private method | LoadTypeSpecMetadata() |


Build()

Build() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyDef Build()


LoadAssemblyMetadata()

LoadAssemblyMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadAssemblyMetadata()


LoadAssemblyRefMetadata()

LoadAssemblyRefMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadAssemblyRefMetadata()


LoadConstantMetadata()

LoadConstantMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadConstantMetadata()


LoadCustomAttributeMetadata()

LoadCustomAttributeMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadCustomAttributeMetadata()


LoadInterfaceImplMetadata()

LoadInterfaceImplMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadInterfaceImplMetadata()


LoadMemberRefMetadata()

LoadMemberRefMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadMemberRefMetadata()


LoadModuleMetadata()

LoadModuleMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadModuleMetadata()


LoadNestedClassMetadata()

LoadNestedClassMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadNestedClassMetadata()


LoadTypeDefMetadata()

LoadTypeDefMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadTypeDefMetadata()


LoadTypeRefMetadata()

LoadTypeRefMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadTypeRefMetadata()


LoadTypeSpecMetadata()

LoadTypeSpecMetadata() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadTypeSpecMetadata()


AssemblyRef

AssemblyRef Class

Represents a reference to an external library.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.AssemblyRef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class AssemblyRef : ReflectedMember

The AssemblyRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRef() |

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, AssemblyRefMetadataTableRow) | Initialises a new instance of the AssemblyRef class from the provided details.

Properties

 | Name | Summary
public properties | Culture() | The string representing the culture of the assembly.
public properties | Version() | The full version details of the referenced assembly.

Fields

 | Name | Description
private field | _culture |
private field | _version |


AssemblyRef Constructors

The AssemblyRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRef() |


AssemblyRef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyRef()


AssemblyRef Fields

The AssemblyRef type exposes the following members.

Fields

 | Name | Description
private field | _culture |
private field | _version |


_culture

_culture Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _culture


AssemblyRef Methods

The AssemblyRef type exposes the following members.

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, AssemblyRefMetadataTableRow) | Initialises a new instance of the AssemblyRef class from the provided details.


CreateFromMetadata(BuildReferences, AssemblyRefMetadataTableRow)

CreateFromMetadata(BuildReferences, AssemblyRefMetadataTableRow) Method

Initialises a new instance of the AssemblyRef class from the provided details.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static AssemblyRef CreateFromMetadata(
    BuildReferences references,
    AssemblyRefMetadataTableRow row
    )

Parameters

references
Type: BuildReferences
Container of all the references required to build this type.
row
Type: AssemblyRefMetadataTableRow
The row that provides the assembly reference details.


AssemblyRef Properties

The AssemblyRef type exposes the following members.

Properties

 | Name | Summary
public properties | Culture() | The string representing the culture of the assembly.
public properties | Version() | The full version details of the referenced assembly.


Culture()

Culture() Property

The string representing the culture of the assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


Version()

Version() Property

The full version details of the referenced assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Version this[] {
    get;
    set;
    }


BuildReferences

BuildReferences Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.BuildReferences
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class BuildReferences

The BuildReferences type exposes the following members.

Constructors

 | Class | Summary
public constructor | BuildReferences() |

Properties

 | Name | Summary
public properties | Assembly() |
public properties | Map() |
public properties | Metadata() |
public properties | PeCoffFile() |


BuildReferences Constructors

The BuildReferences type exposes the following members.

Constructors

 | Class | Summary
public constructor | BuildReferences() |


BuildReferences()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BuildReferences()


BuildReferences Properties

The BuildReferences type exposes the following members.

Properties

 | Name | Summary
public properties | Assembly() |
public properties | Map() |
public properties | Metadata() |
public properties | PeCoffFile() |


Assembly()

Assembly() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyDef this[] {
    get;
    set;
    }


Map()

Map() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataToDefinitionMap this[] {
    get;
    set;
    }


Metadata()

Metadata() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataDirectory this[] {
    get;
    set;
    }


PeCoffFile()

PeCoffFile() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PeCoffFile this[] {
    get;
    set;
    }


ConstantInfo

ConstantInfo Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ConstantInfo
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ConstantInfo

The ConstantInfo type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstantInfo() |

Methods

 | Name | Summary
public method | CreateFromMetadata(AssemblyDef, MetadataStream, ConstantMetadataTableRow) |


ConstantInfo Constructors

The ConstantInfo type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstantInfo() |


ConstantInfo()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ConstantInfo()


ConstantInfo Methods

The ConstantInfo type exposes the following members.

Methods

 | Name | Summary
public method | CreateFromMetadata(AssemblyDef, MetadataStream, ConstantMetadataTableRow) |


CreateFromMetadata(AssemblyDef, MetadataStream, ConstantMetadataTableRow)

CreateFromMetadata(AssemblyDef, MetadataStream, ConstantMetadataTableRow) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static ConstantInfo CreateFromMetadata(
    AssemblyDef assembly,
    MetadataStream stream,
    ConstantMetadataTableRow row
    )

Parameters

assembly
Type: AssemblyDef
stream
Type: MetadataStream
row
Type: ConstantMetadataTableRow


CustomAttribute

CustomAttribute Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.CustomAttribute
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class CustomAttribute

The CustomAttribute type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomAttribute(MemberRef) |

Properties

 | Name | Summary
public properties | Name |

Fields

 | Name | Description
private field | _attributeType |


CustomAttribute Constructors

The CustomAttribute type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomAttribute(MemberRef) |


CustomAttribute(MemberRef)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CustomAttribute(
MemberRef attributeType
)

Parameters

attributeType
Type: MemberRef


CustomAttribute Fields

The CustomAttribute type exposes the following members.

Fields

 | Name | Description
private field | _attributeType |


_attributeType

_attributeType Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MemberRef _attributeType


CustomAttribute Properties

The CustomAttribute type exposes the following members.

Properties

 | Name | Summary
public properties | Name |


Name

Name Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string Name {
    get;
    }


EventDef

EventDef Class

Represents a single event for a type. An event is made up from one or two MethodDef entries in the type. These are generally prefixed with add_ and remove_. This class allows those events to be treated as a single unit.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.EventDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class EventDef : ReflectedMember

The EventDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventDef() |
public constructor | EventDef(String, AssemblyDef, TypeDef) |

Methods

 | Name | Summary
private method | CalculateVisibility() |
public method | FindAddMethod() | Attemps to find the add method for this event from its containing type.
public method | FindRemoveMethod() | Attemps to find the remove method for this event from its containing type.
private method | GetInternalName(String) | Gets a version of the events name that can be checked against the events method names (add, remove) in the owning type.

Properties

 | Name | Summary
public properties | MemberAccess |
public properties | Type() | The type which contains this event.

Fields

 | Name | Description
private field | _containingType |

See also

MethodDef


EventDef Constructors

The EventDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventDef() |
public constructor | EventDef(String, AssemblyDef, TypeDef) |


EventDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventDef()


EventDef(String, AssemblyDef, TypeDef)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventDef(
string name,
AssemblyDef definingAssembly,
TypeDef containingType
)

Parameters

name
Type: String
definingAssembly
Type: AssemblyDef
containingType
Type: TypeDef


EventDef Fields

The EventDef type exposes the following members.

Fields

 | Name | Description
private field | _containingType |


_containingType

_containingType Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _containingType


EventDef Methods

The EventDef type exposes the following members.

Methods

 | Name | Summary
private method | CalculateVisibility() |
public method | FindAddMethod() | Attemps to find the add method for this event from its containing type.
public method | FindRemoveMethod() | Attemps to find the remove method for this event from its containing type.
private method | GetInternalName(String) | Gets a version of the events name that can be checked against the events method names (add, remove) in the owning type.


CalculateVisibility()

CalculateVisibility() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Visibility CalculateVisibility()


FindAddMethod()

FindAddMethod() Method

Attemps to find the add method for this event from its containing type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef FindAddMethod()


FindRemoveMethod()

FindRemoveMethod() Method

Attemps to find the remove method for this event from its containing type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef FindRemoveMethod()


GetInternalName(String)

GetInternalName(String) Method

Gets a version of the events name that can be checked against the events method names (add, remove) in the owning type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string GetInternalName(
    string addOrRemove
    )

Parameters

addOrRemove
Type: String


EventDef Properties

The EventDef type exposes the following members.

Properties

 | Name | Summary
public properties | MemberAccess |
public properties | Type() | The type which contains this event.


MemberAccess

MemberAccess Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility MemberAccess {
    get;
    }


Type()

Type() Property

The type which contains this event.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef this[] {
    get;
    set;
    }


FieldDef

FieldDef Class

Describes the construction of a field in the CLR metadata.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.MemberRef
        • TheBoxSoftware.Reflection.FieldDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class FieldDef : MemberRef

The FieldDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldDef() |
public constructor | FieldDef(String, AssemblyDef, TypeDef, FieldAttributes, BlobIndex) |

Properties

 | Name | Summary
public properties | Constants() | TODO: Document
public properties | Flags() | The flags detailing information about the field
public properties | IsConstant | Indicates if the field is declared as a constant.
public properties | IsSystemGenerated | Indicates if this field is system generated. .NET creates backing fields in certain situations.
public properties | MemberAccess |

Fields

 | Name | Description
private field | _constants |
private field | _flags |


FieldDef Constructors

The FieldDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldDef() |
public constructor | FieldDef(String, AssemblyDef, TypeDef, FieldAttributes, BlobIndex) |


FieldDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldDef()


FieldDef(String, AssemblyDef, TypeDef, FieldAttributes, BlobIndex)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldDef(
string name,
AssemblyDef definingAssembly,
TypeDef containingType,
FieldAttributes attributes,
BlobIndex signitureIndex
)

Parameters

name
Type: String
definingAssembly
Type: AssemblyDef
containingType
Type: TypeDef
attributes
Type: FieldAttributes
signitureIndex
Type: BlobIndex


FieldDef Fields

The FieldDef type exposes the following members.

Fields

 | Name | Description
private field | _constants |
private field | _flags |


_constants

_constants Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _constants


_flags

_flags Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FieldAttributes _flags


FieldDef Properties

The FieldDef type exposes the following members.

Properties

 | Name | Summary
public properties | Constants() | TODO: Document
public properties | Flags() | The flags detailing information about the field
public properties | IsConstant | Indicates if the field is declared as a constant.
public properties | IsSystemGenerated | Indicates if this field is system generated. .NET creates backing fields in certain situations.
public properties | MemberAccess |


Constants()

Constants() Property

TODO: Document
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ConstantInfo> this[] {
    get;
    set;
    }


Flags()

Flags() Property

The flags detailing information about the field
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldAttributes this[] {
    get;
    set;
    }


IsConstant

IsConstant Property

Indicates if the field is declared as a constant.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsConstant {
    get;
    }


IsSystemGenerated

IsSystemGenerated Property

Indicates if this field is system generated. .NET creates backing fields in certain situations.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsSystemGenerated {
    get;
    }


FlowControl

FlowControl Enumeration

Describes how the instruction effects the flow of execution.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum FlowControl : int

Members

Name | Description
Branch |
Break |
Call |
Cond_Branch |
Meta |
Next |
Phi |
Return |
Throw |


GenericTypeRef

GenericTypeRef Class

A class that represents a generic type; generic types are defined on types and methods. These types however will never resolve to an actual type instance because they are determined at call time, not at definition.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.TypeRef
        • TheBoxSoftware.Reflection.GenericTypeRef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class GenericTypeRef : TypeRef

The GenericTypeRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericTypeRef() |

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, GenericParamMetadataTableRow) | Initialises and populates a new GenericTypeRef instance based on the details provided in the metadata row.

Properties

 | Name | Summary
public properties | Sequence() | A number that represents the location in the generic type sequence this GenericTypeRef resides.

Fields

 | Name | Description
private field | _sequence |

See also

TypeDef
MethodDef


GenericTypeRef Constructors

The GenericTypeRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericTypeRef() |


GenericTypeRef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericTypeRef()


GenericTypeRef Fields

The GenericTypeRef type exposes the following members.

Fields

 | Name | Description
private field | _sequence |


_sequence

_sequence Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private short _sequence


GenericTypeRef Methods

The GenericTypeRef type exposes the following members.

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, GenericParamMetadataTableRow) | Initialises and populates a new GenericTypeRef instance based on the details provided in the metadata row.


CreateFromMetadata(BuildReferences, GenericParamMetadataTableRow)

CreateFromMetadata(BuildReferences, GenericParamMetadataTableRow) Method

Initialises and populates a new GenericTypeRef instance based on the details provided in the metadata row.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static GenericTypeRef CreateFromMetadata(
    BuildReferences references,
    GenericParamMetadataTableRow fromRow
    )

Parameters

references
Type: BuildReferences
All the required references the create requires to build the type.
fromRow
Type: GenericParamMetadataTableRow
The metadata row.


GenericTypeRef Properties

The GenericTypeRef type exposes the following members.

Properties

 | Name | Summary
public properties | Sequence() | A number that represents the location in the generic type sequence this GenericTypeRef resides.


Sequence()

Sequence() Property

A number that represents the location in the generic type sequence this GenericTypeRef resides.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public short this[] {
    get;
    set;
    }

Remarks

When multiple generic types are defined against a method or type, the number is used by the metadata to distinguish which type is being called or passed in Signatures.


ILInstruction

ILInstruction Class

Represents a single Intermediate Language Instruction

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineNoneILInstruction
      • TheBoxSoftware.Reflection.ArgInlineNoneILInstruction
      • TheBoxSoftware.Reflection.InlineBrTargetILInstruction
      • TheBoxSoftware.Reflection.ShortInlineIILInstruction
      • TheBoxSoftware.Reflection.ShortInlineVarILInstruction
      • TheBoxSoftware.Reflection.ShortInlineRILInstruction
      • TheBoxSoftware.Reflection.InlineIILInstruction
      • TheBoxSoftware.Reflection.InlineVarILInstruction
      • TheBoxSoftware.Reflection.InlineStringILInstruction
      • TheBoxSoftware.Reflection.InlineSigILInstruction
      • TheBoxSoftware.Reflection.InlineRILInstruction
      • TheBoxSoftware.Reflection.InlineI8ILInstruction
      • TheBoxSoftware.Reflection.ShortInlineBrTargetILInstruction
      • TheBoxSoftware.Reflection.InlineMethodILInstruction
      • TheBoxSoftware.Reflection.InlineTypeILInstruction
      • TheBoxSoftware.Reflection.InlineTokenILInstruction
      • TheBoxSoftware.Reflection.InlineFieldILInstruction
      • TheBoxSoftware.Reflection.InlineSwitchILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ILInstruction

The ILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ILInstruction(OpCode) | Initialises a new instance of the ILInstruction class

Properties

 | Name | Summary
public properties | OpCode | The OpCode of the IL Instruction

Fields

 | Name | Description
private field | _code |


ILInstruction Constructors

The ILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ILInstruction(OpCode) | Initialises a new instance of the ILInstruction class


ILInstruction(OpCode)

Initialises a new instance of the ILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ILInstruction(
OpCode code
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction


ILInstruction Fields

The ILInstruction type exposes the following members.

Fields

 | Name | Description
private field | _code |


_code

_code Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private OpCode _code


ILInstruction Properties

The ILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | OpCode | The OpCode of the IL Instruction


OpCode

OpCode Property

The OpCode of the IL Instruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode OpCode {
    get;
    }


ILMetadataToken

ILMetadataToken Enumeration

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal enum ILMetadataToken : int

Members

Name | Description
Module |
TypeRef |
TypeDef |
FieldDef |
MethodDef |
ParamDef |
InterfaceImpl |
MemberRef |
CustomAttribute |
Permission |
Signiture |
Event |
Property |
ModuleRef |
TypeSpec |
Assembly |
AssemblyRef |
File |
ExportedType |
ManifestResource |
GenericParam |
MethodSpec |
GenericParamConstraint |
String |
Name |
BaseType |


InlineBrTargetILInstruction

InlineBrTargetILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineBrTargetILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineBrTargetILInstruction : ILInstruction

The InlineBrTargetILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineBrTargetILInstruction(OpCode, Int32) | Initialises a new instance of the InlineBrTargetILInstruction class

Properties

 | Name | Summary
public properties | Target() | The target offset for this instruction


InlineBrTargetILInstruction Constructors

The InlineBrTargetILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineBrTargetILInstruction(OpCode, Int32) | Initialises a new instance of the InlineBrTargetILInstruction class


InlineBrTargetILInstruction(OpCode, Int32)

Initialises a new instance of the InlineBrTargetILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineBrTargetILInstruction(
OpCode code,
int target
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
target
Type: Int32
The offset target to break to


InlineBrTargetILInstruction Properties

The InlineBrTargetILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Target() | The target offset for this instruction


Target()

Target() Property

The target offset for this instruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


InlineFieldILInstruction

InlineFieldILInstruction Class

Represents an IL instruction of type InlineField

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineFieldILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineFieldILInstruction : ILInstruction

The InlineFieldILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineFieldILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class

Properties

 | Name | Summary
public properties | Field | The definition of the method this instruction calls

Fields

 | Name | Description
private field | _fieldDef |
private field | _index |
private field | _token |


InlineFieldILInstruction Constructors

The InlineFieldILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineFieldILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class


InlineFieldILInstruction(AssemblyDef, OpCode, UInt32)

Initialises a new instance of the InlineMethodILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineFieldILInstruction(
AssemblyDef assembly,
OpCode code,
uint metadataToken
)

Parameters

assembly
Type: AssemblyDef
code
Type: OpCode
The OpCode describing the operation of the instruction
metadataToken
Type: UInt32


InlineFieldILInstruction Fields

The InlineFieldILInstruction type exposes the following members.

Fields

 | Name | Description
private field | _fieldDef |
private field | _index |
private field | _token |


_fieldDef

_fieldDef Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MemberRef _fieldDef


_index

_index Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _index


_token

_token Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ILMetadataToken _token


InlineFieldILInstruction Properties

The InlineFieldILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Field | The definition of the method this instruction calls


Field

Field Property

The definition of the method this instruction calls
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MemberRef Field {
    get;
    }


InlineI8ILInstruction

InlineI8ILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineI8ILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineI8ILInstruction : ILInstruction

The InlineI8ILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineI8ILInstruction(OpCode, UInt64) | Initialises a new instance of the InlineIILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The long constant to be pushed on to the stack


InlineI8ILInstruction Constructors

The InlineI8ILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineI8ILInstruction(OpCode, UInt64) | Initialises a new instance of the InlineIILInstruction class


InlineI8ILInstruction(OpCode, UInt64)

Initialises a new instance of the InlineIILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineI8ILInstruction(
OpCode code,
ulong constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: UInt64
The long constant to be pushed on to the stack


InlineI8ILInstruction Properties

The InlineI8ILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The long constant to be pushed on to the stack


Constant()

Constant() Property

The long constant to be pushed on to the stack
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


InlineIILInstruction

InlineIILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineIILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineIILInstruction : ILInstruction

The InlineIILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineIILInstruction(OpCode, UInt32) | Initialises a new instance of the InlineIILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The integer constant to be pushed on to the stack


InlineIILInstruction Constructors

The InlineIILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineIILInstruction(OpCode, UInt32) | Initialises a new instance of the InlineIILInstruction class


InlineIILInstruction(OpCode, UInt32)

Initialises a new instance of the InlineIILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineIILInstruction(
OpCode code,
uint constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: UInt32
The integer constant to be pushed on to the stack


InlineIILInstruction Properties

The InlineIILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The integer constant to be pushed on to the stack


Constant()

Constant() Property

The integer constant to be pushed on to the stack
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


InlineMethodILInstruction

InlineMethodILInstruction Class

Represents an IL instruction of type InlineMethod

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineMethodILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineMethodILInstruction : ILInstruction

The InlineMethodILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineMethodILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class

Properties

 | Name | Summary
public properties | Method | The definition of the method this instruction calls

Fields

 | Name | Description
private field | _methodDef |


InlineMethodILInstruction Constructors

The InlineMethodILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineMethodILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class


InlineMethodILInstruction(AssemblyDef, OpCode, UInt32)

Initialises a new instance of the InlineMethodILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineMethodILInstruction(
AssemblyDef assembly,
OpCode code,
uint metadataToken
)

Parameters

assembly
Type: AssemblyDef
code
Type: OpCode
The OpCode describing the operation of the instruction
metadataToken
Type: UInt32


InlineMethodILInstruction Fields

The InlineMethodILInstruction type exposes the following members.

Fields

 | Name | Description
private field | _methodDef |


_methodDef

_methodDef Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MemberRef _methodDef


InlineMethodILInstruction Properties

The InlineMethodILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Method | The definition of the method this instruction calls


Method

Method Property

The definition of the method this instruction calls
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MemberRef Method {
    get;
    }


InlineNoneILInstruction

InlineNoneILInstruction Class

Represents an IL Instruction of Type InlineNone

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineNoneILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineNoneILInstruction : ILInstruction

The InlineNoneILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineNoneILInstruction(OpCode) | Initialises a new instance of the InlineNoneILInstruction class


InlineNoneILInstruction Constructors

The InlineNoneILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineNoneILInstruction(OpCode) | Initialises a new instance of the InlineNoneILInstruction class


InlineNoneILInstruction(OpCode)

Initialises a new instance of the InlineNoneILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineNoneILInstruction(
OpCode code
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction


InlineRILInstruction

InlineRILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineRILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineRILInstruction : ILInstruction

The InlineRILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineRILInstruction(OpCode, Double) | Initialises a new instance of the InlineRILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The integer constant to be pushed on to the stack


InlineRILInstruction Constructors

The InlineRILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineRILInstruction(OpCode, Double) | Initialises a new instance of the InlineRILInstruction class


InlineRILInstruction(OpCode, Double)

Initialises a new instance of the InlineRILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineRILInstruction(
OpCode code,
double constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: Double
The integer constant to be pushed on to the stack


InlineRILInstruction Properties

The InlineRILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The integer constant to be pushed on to the stack


Constant()

Constant() Property

The integer constant to be pushed on to the stack
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public double this[] {
    get;
    set;
    }


InlineSigILInstruction

InlineSigILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineSigILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineSigILInstruction : ILInstruction

The InlineSigILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineSigILInstruction(AssemblyDef, OpCode, Int32) | Initialises a new instance of the InlineSigILInstruction class

Properties

 | Name | Summary
public properties | SignitureToken() | The integer constant to be pushed on to the stack


InlineSigILInstruction Constructors

The InlineSigILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineSigILInstruction(AssemblyDef, OpCode, Int32) | Initialises a new instance of the InlineSigILInstruction class


InlineSigILInstruction(AssemblyDef, OpCode, Int32)

Initialises a new instance of the InlineSigILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineSigILInstruction(
AssemblyDef assembly,
OpCode code,
int signitureToken
)

Parameters

assembly
Type: AssemblyDef
code
Type: OpCode
The OpCode describing the operation of the instruction
signitureToken
Type: Int32


InlineSigILInstruction Properties

The InlineSigILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | SignitureToken() | The integer constant to be pushed on to the stack


SignitureToken()

SignitureToken() Property

The integer constant to be pushed on to the stack
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }

Remarks

THIS WILL BE REMOVED WHEN THE STRING IS PROPERLY LOADED


InlineStringILInstruction

InlineStringILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineStringILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineStringILInstruction : ILInstruction

The InlineStringILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineStringILInstruction(AssemblyDef, OpCode, Int32) | Initialises a new instance of the InlineVarILInstruction class

Properties

 | Name | Summary
public properties | String() | The string being loaded by the instruction
public properties | UDStringToken() | The integer constant to be pushed on to the stack


InlineStringILInstruction Constructors

The InlineStringILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineStringILInstruction(AssemblyDef, OpCode, Int32) | Initialises a new instance of the InlineVarILInstruction class


InlineStringILInstruction(AssemblyDef, OpCode, Int32)

Initialises a new instance of the InlineVarILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineStringILInstruction(
AssemblyDef assembly,
OpCode code,
int udStringToken
)

Parameters

assembly
Type: AssemblyDef
code
Type: OpCode
The OpCode describing the operation of the instruction
udStringToken
Type: Int32


InlineStringILInstruction Properties

The InlineStringILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | String() | The string being loaded by the instruction
public properties | UDStringToken() | The integer constant to be pushed on to the stack


String()

String() Property

The string being loaded by the instruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


UDStringToken()

UDStringToken() Property

The integer constant to be pushed on to the stack
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }

Remarks

THIS WILL BE REMOVED WHEN THE STRING IS PROPERLY LOADED


InlineSwitchILInstruction

InlineSwitchILInstruction Class

Represents an IL instruction of type InlineSwitch

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineSwitchILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineSwitchILInstruction : ILInstruction

The InlineSwitchILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineSwitchILInstruction(OpCode, Int32[]) | Initialises a new instance of the InlineSwitchILInstruction class

Properties

 | Name | Summary
public properties | JumpTargets() | The offset targets for each of the case statements in the switch operation


InlineSwitchILInstruction Constructors

The InlineSwitchILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineSwitchILInstruction(OpCode, Int32[]) | Initialises a new instance of the InlineSwitchILInstruction class


InlineSwitchILInstruction(OpCode, Int32[])

Initialises a new instance of the InlineSwitchILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineSwitchILInstruction(
OpCode code,
int[] jumpTargets
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
jumpTargets
Type: Int32


InlineSwitchILInstruction Properties

The InlineSwitchILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | JumpTargets() | The offset targets for each of the case statements in the switch operation


JumpTargets()

JumpTargets() Property

The offset targets for each of the case statements in the switch operation
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int[] this[] {
    get;
    set;
    }


InlineTokenILInstruction

InlineTokenILInstruction Class

Represents an IL instruction of type InlineMethod

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineTokenILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineTokenILInstruction : ILInstruction

The InlineTokenILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineTokenILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class

Properties

 | Name | Summary
public properties | Type | The definition of the method this instruction calls

Fields

 | Name | Description
private field | _entry |
private field | _index |
private field | _token |


InlineTokenILInstruction Constructors

The InlineTokenILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineTokenILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class


InlineTokenILInstruction(AssemblyDef, OpCode, UInt32)

Initialises a new instance of the InlineMethodILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineTokenILInstruction(
AssemblyDef assembly,
OpCode code,
uint metadataToken
)

Parameters

assembly
Type: AssemblyDef
code
Type: OpCode
The OpCode describing the operation of the instruction
metadataToken
Type: UInt32


InlineTokenILInstruction Fields

The InlineTokenILInstruction type exposes the following members.

Fields

 | Name | Description
private field | _entry |
private field | _index |
private field | _token |


_entry

_entry Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private object _entry


InlineTokenILInstruction Properties

The InlineTokenILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Type | The definition of the method this instruction calls


Type

Type Property

The definition of the method this instruction calls
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public object Type {
    get;
    }


InlineTypeILInstruction

InlineTypeILInstruction Class

Represents an IL instruction of type InlineMethod

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineTypeILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineTypeILInstruction : ILInstruction

The InlineTypeILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineTypeILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class

Properties

 | Name | Summary
public properties | Type | The definition of the method this instruction calls

Fields

 | Name | Description
private field | _index |
private field | _token |
private field | _typeDef |


InlineTypeILInstruction Constructors

The InlineTypeILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineTypeILInstruction(AssemblyDef, OpCode, UInt32) | Initialises a new instance of the InlineMethodILInstruction class


InlineTypeILInstruction(AssemblyDef, OpCode, UInt32)

Initialises a new instance of the InlineMethodILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineTypeILInstruction(
AssemblyDef assembly,
OpCode code,
uint metadataToken
)

Parameters

assembly
Type: AssemblyDef
code
Type: OpCode
The OpCode describing the operation of the instruction
metadataToken
Type: UInt32


InlineTypeILInstruction Fields

The InlineTypeILInstruction type exposes the following members.

Fields

 | Name | Description
private field | _index |
private field | _token |
private field | _typeDef |


_typeDef

_typeDef Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeRef _typeDef


InlineTypeILInstruction Properties

The InlineTypeILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Type | The definition of the method this instruction calls


Type

Type Property

The definition of the method this instruction calls
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef Type {
    get;
    }


InlineVarILInstruction

InlineVarILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.InlineVarILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InlineVarILInstruction : ILInstruction

The InlineVarILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineVarILInstruction(OpCode, UInt16) | Initialises a new instance of the InlineVarILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The integer constant to be pushed on to the stack


InlineVarILInstruction Constructors

The InlineVarILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | InlineVarILInstruction(OpCode, UInt16) | Initialises a new instance of the InlineVarILInstruction class


InlineVarILInstruction(OpCode, UInt16)

Initialises a new instance of the InlineVarILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal InlineVarILInstruction(
OpCode code,
ushort constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: UInt16
The integer constant to be pushed on to the stack


InlineVarILInstruction Properties

The InlineVarILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The integer constant to be pushed on to the stack


Constant()

Constant() Property

The integer constant to be pushed on to the stack
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MemberRef

MemberRef Class

Represents an instance of a Member that is referenced from an external source.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.MemberRef
        • TheBoxSoftware.Reflection.FieldDef
        • TheBoxSoftware.Reflection.MethodDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MemberRef : ReflectedMember

The MemberRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | MemberRef() |

Methods

 | Name | Summary
sealed method | CreateFromMetadata(AssemblyDef, MetadataDirectory, MemberRefMetadataTableRow) | Factor method for instantiating and populating MemberRef instances from Metadata.

Properties

 | Name | Summary
public properties | IsConstructor() | Gets a value indicating if this member is a constructor.
public properties | IsOperator() | Gets a value indicating if this method referes to an operator overloaded method implementation.
sealed properties | Signiture | Gets the signiture defined for this member.
protected properties | SignitureBlob() | Obtains the index in the BlobStream where the methods signiture is stored.
public properties | Type() | Gets or sets the type which defines this member

Fields

 | Name | Description
private field | _class |
private field | _isConstructor |
private field | _isOperator |
private field | _signitureBlob |
private field | _type |


MemberRef Constructors

The MemberRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | MemberRef() |


MemberRef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MemberRef()


MemberRef Fields

The MemberRef type exposes the following members.

Fields

 | Name | Description
private field | _class |
private field | _isConstructor |
private field | _isOperator |
private field | _signitureBlob |
private field | _type |


_class

_class Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _class


_isConstructor

_isConstructor Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isConstructor


_isOperator

_isOperator Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isOperator


_signitureBlob

_signitureBlob Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobIndex _signitureBlob


_type

_type Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeRef _type


MemberRef Methods

The MemberRef type exposes the following members.

Methods

 | Name | Summary
sealed method | CreateFromMetadata(AssemblyDef, MetadataDirectory, MemberRefMetadataTableRow) | Factor method for instantiating and populating MemberRef instances from Metadata.


CreateFromMetadata(AssemblyDef, MetadataDirectory, MemberRefMetadataTableRow)

CreateFromMetadata(AssemblyDef, MetadataDirectory, MemberRefMetadataTableRow) Method

Factor method for instantiating and populating MemberRef instances from Metadata.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static MemberRef CreateFromMetadata(
    AssemblyDef assembly,
    MetadataDirectory metadata,
    MemberRefMetadataTableRow row
    )

Parameters

assembly
Type: AssemblyDef
The assembly the reference is defined in.
metadata
Type: MetadataDirectory
The metadata the reference is detailed in.
row
Type: MemberRefMetadataTableRow
The actual metadata row with the details of the member.


MemberRef Properties

The MemberRef type exposes the following members.

Properties

 | Name | Summary
public properties | IsConstructor() | Gets a value indicating if this member is a constructor.
public properties | IsOperator() | Gets a value indicating if this method referes to an operator overloaded method implementation.
sealed properties | Signiture | Gets the signiture defined for this member.
protected properties | SignitureBlob() | Obtains the index in the BlobStream where the methods signiture is stored.
public properties | Type() | Gets or sets the type which defines this member


IsConstructor()

IsConstructor() Property

Gets a value indicating if this member is a constructor.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    protected set;
    }


IsOperator()

IsOperator() Property

Gets a value indicating if this method referes to an operator overloaded method implementation.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    protected set;
    }


Signiture

Signiture Property

Gets the signiture defined for this member.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal Signature Signiture {
    get;
    }


SignitureBlob()

SignitureBlob() Property

Obtains the index in the BlobStream where the methods signiture is stored.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected BlobIndex this[] {
    get;
    set;
    }

See also

Signiture


Type()

Type() Property

Gets or sets the type which defines this member
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef this[] {
    get;
    set;
    }


MemberTypes

MemberTypes Enumeration

Enumeration of members that can be defined in an assembly.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum MemberTypes : byte

Members

Name | Description
Property |
Field |
Method |
Constructor |
Event |


MetadataToDefinitionMap

MetadataToDefinitionMap Class

A mapper class that allows the quick retrieval of metadata or definition information, from either direction.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.MetadataToDefinitionMap
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class MetadataToDefinitionMap

The MetadataToDefinitionMap type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataToDefinitionMap() |

Methods

 | Name | Summary
public method | Add(MetadataTables, MetadataRow, ReflectedMember) | Adds a new entry in to the definition map.
public method | GetDefinition(MetadataTables, MetadataRow) | Obatains the definition for the specified metadataRow and table.
public method | GetDefinition(MetadataTables, Int32) |

Properties

 | Name | Summary
public properties | Assembly() | The instance of the Assembly this defenition map is used for.

Fields

 | Name | Description
private field | _assembly |
private field | _uniqueCounter |
private field | internalMap |


MetadataToDefinitionMap Constructors

The MetadataToDefinitionMap type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataToDefinitionMap() |


MetadataToDefinitionMap()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataToDefinitionMap()


MetadataToDefinitionMap Fields

The MetadataToDefinitionMap type exposes the following members.

Fields

 | Name | Description
private field | _assembly |
private field | _uniqueCounter |
private field | internalMap |


_uniqueCounter

_uniqueCounter Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private long _uniqueCounter


internalMap

internalMap Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary internalMap


MetadataToDefinitionMap Methods

The MetadataToDefinitionMap type exposes the following members.

Methods

 | Name | Summary
public method | Add(MetadataTables, MetadataRow, ReflectedMember) | Adds a new entry in to the definition map.
public method | GetDefinition(MetadataTables, MetadataRow) | Obatains the definition for the specified metadataRow and table.
public method | GetDefinition(MetadataTables, Int32) |


Add(MetadataTables, MetadataRow, ReflectedMember)

Add(MetadataTables, MetadataRow, ReflectedMember) Method

Adds a new entry in to the definition map.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void Add(
    MetadataTables table,
    MetadataRow metadataRow,
    ReflectedMember definition
    )

Parameters

table
Type: MetadataTables
The table this row and definition are from
metadataRow
Type: MetadataRow
The row the definition is associated with
definition
Type: ReflectedMember
The definition the row is associated with

Remarks

If a table is created and no unique key is provided for it, you will not be able to use a unique key for that table at any point.


GetDefinition(MetadataTables, MetadataRow)

GetDefinition(MetadataTables, MetadataRow) Method

Obatains the definition for the specified metadataRow and table.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectedMember GetDefinition(
    MetadataTables table,
    MetadataRow metadataRow
    )

Parameters

table
Type: MetadataTables
The table the row and definition are from
metadataRow
Type: MetadataRow
The row the definition was instantiated from


GetDefinition(MetadataTables, Int32)

GetDefinition(MetadataTables, Int32) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectedMember GetDefinition(
    MetadataTables table,
    int metadataRowOffset
    )

Parameters

table
Type: MetadataTables
metadataRowOffset
Type: Int32


MetadataToDefinitionMap Properties

The MetadataToDefinitionMap type exposes the following members.

Properties

 | Name | Summary
public properties | Assembly() | The instance of the Assembly this defenition map is used for.


Assembly()

Assembly() Property

The instance of the Assembly this defenition map is used for.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyDef this[] {
    get;
    set;
    }


MethodBody

MethodBody Class

Contains the details and MSIL for a method definition.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.MethodBody
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class MethodBody

The MethodBody type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | MethodBody(List<ILInstruction>, Int32) | Initialsies a new instance of the MethodBody class.

Properties

 | Name | Summary
public properties | Instructions | Obtains the MSIL instructions for this method.
public properties | MaxStack | Indicates the maximum number of items that appear on the stack in this method.

Fields

 | Name | Description
private field | _instructions |
private field | _maxStack |

Remarks

The internal constructor is so that these classes can be instantiated from a valid MethodDef instance. Further this is the only way these objects should be created.

See also

GetMethodBody
MethodDef


MethodBody Constructors

The MethodBody type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | MethodBody(List<ILInstruction>, Int32) | Initialsies a new instance of the MethodBody class.


MethodBody(List<ILInstruction>, Int32)

Initialsies a new instance of the MethodBody class.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal MethodBody(
List<ILInstruction> instructions,
int maxStack
)

Parameters

instructions
Type: List<>
The instructions that make up the methods body.
maxStack
Type: Int32
The maximum size of the stack for this method.


MethodBody Fields

The MethodBody type exposes the following members.

Fields

 | Name | Description
private field | _instructions |
private field | _maxStack |


_instructions

_instructions Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _instructions


_maxStack

_maxStack Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _maxStack


MethodBody Properties

The MethodBody type exposes the following members.

Properties

 | Name | Summary
public properties | Instructions | Obtains the MSIL instructions for this method.
public properties | MaxStack | Indicates the maximum number of items that appear on the stack in this method.


Instructions

Instructions Property

Obtains the MSIL instructions for this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ILInstruction> Instructions {
    get;
    }


MaxStack

MaxStack Property

Indicates the maximum number of items that appear on the stack in this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int MaxStack {
    get;
    }


MethodDef

MethodDef Class

Represents a method definition as a reflected element.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.MemberRef
        • TheBoxSoftware.Reflection.MethodDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MethodDef : MemberRef

The MethodDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodDef() |

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, TypeDef, MethodMetadataTableRow) | Initialises a new instance of MethodDef for the provided data
public method | GetDisplayName(Boolean, Boolean) | Obtains a display ready version of the method name.
public method | GetDisplayName(Boolean) | Obtains a display ready version of the method name, which includes the parameters of the MethodDef.
public method | GetGenericTypes() | Obtains the list of generic types that are defined and owned only by this member.
private method | GetIL(UInt32, Int32) | Obtains the Intermediate Language instructions for this method
private method | GetInstructions(Byte[]) | Returns an array of instructions that describe the code portion of this method.
public method | GetMethodBody() | Obtains the details about the IL and body of this method and the contents of the MSIL.
public method | ResolveParameter(Int32) | Resolves the parameter indicated by the sequence to it's defining type.

Properties

 | Name | Summary
public properties | GenericTypes() | Collection of the generic types defined against this method.
public properties | ImplementationFlags() | Gets or sets a set of flags detailing the implementation details of this method.
public properties | IsCompilerGenerated | Denotes if this method is generated and or managed by the compiler and not the programmer.
public properties | IsConversionOperator | A boolean value indicating if this method is a conversion operator.
public properties | IsExtensionMethod | Indicates if this method is an extension method or not.
public properties | IsGeneric() | Indicates if this method is a generic method or not.
public properties | IsSpecialName | Indicates if this method has a special name which is interpreted by the runtime, this is generally associated with the getters and setters or properties and events.
public properties | MemberAccess |
public properties | MethodAttributes() | Gets or sets an set of flags detailing generic information about this method.
public properties | Parameters() | The parameters for this method.

Fields

 | Name | Description
private field | _attributes |
private field | _genericTypes |
private field | _implementationFlags |
private field | _isGeneric |
private field | _parameters |
private field | _rva |
private constant | MethodBodySizeMask |


MethodDef Constructors

The MethodDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodDef() |


MethodDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef()


MethodDef Fields

The MethodDef type exposes the following members.

Fields

 | Name | Description
private field | _attributes |
private field | _genericTypes |
private field | _implementationFlags |
private field | _isGeneric |
private field | _parameters |
private field | _rva |
private constant | MethodBodySizeMask |


_attributes

_attributes Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodAttributes _attributes


_genericTypes

_genericTypes Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _genericTypes


_implementationFlags

_implementationFlags Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodImplFlags _implementationFlags


_isGeneric

_isGeneric Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isGeneric


_parameters

_parameters Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _parameters


_rva

_rva Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _rva


MethodBodySizeMask

MethodBodySizeMask Constant

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const int MethodBodySizeMask


MethodDef Methods

The MethodDef type exposes the following members.

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, TypeDef, MethodMetadataTableRow) | Initialises a new instance of MethodDef for the provided data
public method | GetDisplayName(Boolean, Boolean) | Obtains a display ready version of the method name.
public method | GetDisplayName(Boolean) | Obtains a display ready version of the method name, which includes the parameters of the MethodDef.
public method | GetGenericTypes() | Obtains the list of generic types that are defined and owned only by this member.
private method | GetIL(UInt32, Int32) | Obtains the Intermediate Language instructions for this method
private method | GetInstructions(Byte[]) | Returns an array of instructions that describe the code portion of this method.
public method | GetMethodBody() | Obtains the details about the IL and body of this method and the contents of the MSIL.
public method | ResolveParameter(Int32) | Resolves the parameter indicated by the sequence to it's defining type.


CreateFromMetadata(BuildReferences, TypeDef, MethodMetadataTableRow)

CreateFromMetadata(BuildReferences, TypeDef, MethodMetadataTableRow) Method

Initialises a new instance of MethodDef for the provided data
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static MethodDef CreateFromMetadata(
    BuildReferences references,
    TypeDef container,
    MethodMetadataTableRow row
    )

Parameters

references
Type: BuildReferences
The references required to build the methods
container
Type: TypeDef
The owning type for this method
row
Type: MethodMetadataTableRow
The row detailing the method


GetDisplayName(Boolean, Boolean)

GetDisplayName(Boolean, Boolean) Method

Obtains a display ready version of the method name.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetDisplayName(
    bool includeNamespace,
    bool includeParameters
    )

Parameters

includeNamespace
Type: Boolean
Indicates if the namespace should be included, this will include the type name.
includeParameters
Type: Boolean
Indicates if the parameters should be included.


GetDisplayName(Boolean)

GetDisplayName(Boolean) Method

Obtains a display ready version of the method name, which includes the parameters of the MethodDef.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetDisplayName(
    bool includeNamespace
    )

Parameters

includeNamespace
Type: Boolean
Indicates if the namespace should be included, this will include the type name.


GetGenericTypes()

GetGenericTypes() Method

Obtains the list of generic types that are defined and owned only by this member.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<GenericTypeRef> GetGenericTypes()


GetIL(UInt32, Int32)

GetIL(UInt32, Int32) Method

Obtains the Intermediate Language instructions for this method
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte[] GetIL(
    uint address,
    int codeSize
    )

Parameters

address
Type: UInt32
The address of the start of the actual code
codeSize
Type: Int32
The size of the actual code.


GetInstructions(Byte[])

GetInstructions(Byte[]) Method

Returns an array of instructions that describe the code portion of this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ILInstruction[] GetInstructions(
    byte[] fromILBytes
    )

Parameters

fromILBytes
Type: Byte


GetMethodBody()

GetMethodBody() Method

Obtains the details about the IL and body of this method and the contents of the MSIL.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodBody GetMethodBody()


ResolveParameter(Int32)

ResolveParameter(Int32) Method

Resolves the parameter indicated by the sequence to it's defining type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef ResolveParameter(
    int sequence
    )

Parameters

sequence
Type: Int32
The sequence in the parameter list.


MethodDef Properties

The MethodDef type exposes the following members.

Properties

 | Name | Summary
public properties | GenericTypes() | Collection of the generic types defined against this method.
public properties | ImplementationFlags() | Gets or sets a set of flags detailing the implementation details of this method.
public properties | IsCompilerGenerated | Denotes if this method is generated and or managed by the compiler and not the programmer.
public properties | IsConversionOperator | A boolean value indicating if this method is a conversion operator.
public properties | IsExtensionMethod | Indicates if this method is an extension method or not.
public properties | IsGeneric() | Indicates if this method is a generic method or not.
public properties | IsSpecialName | Indicates if this method has a special name which is interpreted by the runtime, this is generally associated with the getters and setters or properties and events.
public properties | MemberAccess |
public properties | MethodAttributes() | Gets or sets an set of flags detailing generic information about this method.
public properties | Parameters() | The parameters for this method.


GenericTypes()

GenericTypes() Property

Collection of the generic types defined against this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<GenericTypeRef> this[] {
    get;
    set;
    }

Remarks

If you need the generic types from this type and all its parent classes then utilise the GetGenericTypes() method instead.

See also

GetGenericTypes


ImplementationFlags()

ImplementationFlags() Property

Gets or sets a set of flags detailing the implementation details of this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodImplFlags this[] {
    get;
    set;
    }


IsCompilerGenerated

IsCompilerGenerated Property

Denotes if this method is generated and or managed by the compiler and not the programmer.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsCompilerGenerated {
    get;
    }

Remarks

There is no actual property in the metadata that informs us of this, we simply user information from existing properties.


IsConversionOperator

IsConversionOperator Property

A boolean value indicating if this method is a conversion operator.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsConversionOperator {
    get;
    }


IsExtensionMethod

IsExtensionMethod Property

Indicates if this method is an extension method or not.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsExtensionMethod {
    get;
    }


IsGeneric()

IsGeneric() Property

Indicates if this method is a generic method or not.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsSpecialName

IsSpecialName Property

Indicates if this method has a special name which is interpreted by the runtime, this is generally associated with the getters and setters or properties and events.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsSpecialName {
    get;
    }


MethodAttributes()

MethodAttributes() Property

Gets or sets an set of flags detailing generic information about this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodAttributes this[] {
    get;
    set;
    }


Parameters()

Parameters() Property

The parameters for this method.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ParamDef> this[] {
    get;
    set;
    }


ModuleDef

ModuleDef Class

Provides a definition for a module in an assembly.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.ModuleDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ModuleDef : ReflectedMember

The ModuleDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | ModuleDef() |
public constructor | ModuleDef(String, AssemblyDef, Guid) |

Properties

 | Name | Summary
public properties | ModuleVersionId() | The GUID that represents the Modules version identifier.

Fields

 | Name | Description
private field | _moduleVersionId |


ModuleDef Constructors

The ModuleDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | ModuleDef() |
public constructor | ModuleDef(String, AssemblyDef, Guid) |


ModuleDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ModuleDef()


ModuleDef(String, AssemblyDef, Guid)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ModuleDef(
string name,
AssemblyDef definingAssembly,
Guid moduleVersionId
)

Parameters

name
Type: String
definingAssembly
Type: AssemblyDef
moduleVersionId
Type: Guid


ModuleDef Fields

The ModuleDef type exposes the following members.

Fields

 | Name | Description
private field | _moduleVersionId |


_moduleVersionId

_moduleVersionId Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Guid _moduleVersionId


ModuleDef Properties

The ModuleDef type exposes the following members.

Properties

 | Name | Summary
public properties | ModuleVersionId() | The GUID that represents the Modules version identifier.


ModuleVersionId()

ModuleVersionId() Property

The GUID that represents the Modules version identifier.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Guid this[] {
    get;
    set;
    }


OpCode

OpCode Structure

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct OpCode

The OpCode type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | OpCode(String, StackBehaviour, StackBehaviour, OperandType, OpCodeType, Int32, Byte, Byte, FlowControl, Boolean, Int32) |

Methods

 | Name | Summary
sealed method | EndsUncondJmpBlk() |
public method | Equals(Object) |
public method | Equals(OpCode) |
public method | GetHashCode() |
sealed method | StackChange() |
public method | ToString() |

Properties

 | Name | Summary
public properties | FlowControl |
public properties | Name |
public properties | OpCodeType |
public properties | OperandType |
public properties | Size |
public properties | StackBehaviourPop |
public properties | StackBehaviourPush |
public properties | Value |

Fields

 | Name | Description
sealed field | m_ctrl |
sealed field | m_endsUncondJmpBlk |
sealed field | m_operand |
sealed field | m_pop |
sealed field | m_push |
sealed field | m_s1 |
sealed field | m_s2 |
sealed field | m_size |
sealed field | m_stackChange |
sealed field | m_stringname |
sealed field | m_type |


OpCode Constructors

The OpCode type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | OpCode(String, StackBehaviour, StackBehaviour, OperandType, OpCodeType, Int32, Byte, Byte, FlowControl, Boolean, Int32) |


OpCode(String, StackBehaviour, StackBehaviour, OperandType, OpCodeType, Int32, Byte, Byte, FlowControl, Boolean, Int32)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal OpCode(
string stringname,
StackBehaviour pop,
StackBehaviour push,
OperandType operand,
OpCodeType type,
int size,
byte s1,
byte s2,
FlowControl ctrl,
bool endsjmpblk,
int stack
)

Parameters

stringname
Type: String
pop
Type: StackBehaviour
push
Type: StackBehaviour
operand
Type: OperandType
type
Type: OpCodeType
size
Type: Int32
s1
Type: Byte
s2
Type: Byte
ctrl
Type: FlowControl
endsjmpblk
Type: Boolean
stack
Type: Int32


OpCode Fields

The OpCode type exposes the following members.

Fields

 | Name | Description
sealed field | m_ctrl |
sealed field | m_endsUncondJmpBlk |
sealed field | m_operand |
sealed field | m_pop |
sealed field | m_push |
sealed field | m_s1 |
sealed field | m_s2 |
sealed field | m_size |
sealed field | m_stackChange |
sealed field | m_stringname |
sealed field | m_type |


m_ctrl

m_ctrl Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal FlowControl m_ctrl


m_endsUncondJmpBlk

m_endsUncondJmpBlk Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal bool m_endsUncondJmpBlk


m_operand

m_operand Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal OperandType m_operand


m_pop

m_pop Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal StackBehaviour m_pop


m_push

m_push Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal StackBehaviour m_push


m_s1

m_s1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal byte m_s1


m_s2

m_s2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal byte m_s2


m_size

m_size Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal int m_size


m_stackChange

m_stackChange Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal int m_stackChange


m_stringname

m_stringname Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal string m_stringname


m_type

m_type Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal OpCodeType m_type


OpCode Methods

The OpCode type exposes the following members.

Methods

 | Name | Summary
sealed method | EndsUncondJmpBlk() |
public method | Equals(Object) |
public method | Equals(OpCode) |
public method | GetHashCode() |
sealed method | StackChange() |
public method | ToString() |


EndsUncondJmpBlk()

EndsUncondJmpBlk() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal bool EndsUncondJmpBlk()


Equals(Object)

Equals(Object) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool Equals(
    object obj
    )

Parameters

obj
Type: Object


Equals(OpCode)

Equals(OpCode) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool Equals(
    OpCode obj
    )

Parameters

obj
Type: OpCode


GetHashCode()

GetHashCode() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int GetHashCode()


StackChange()

StackChange() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal int StackChange()


ToString()

ToString() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


OpCode Properties

The OpCode type exposes the following members.

Properties

 | Name | Summary
public properties | FlowControl |
public properties | Name |
public properties | OpCodeType |
public properties | OperandType |
public properties | Size |
public properties | StackBehaviourPop |
public properties | StackBehaviourPush |
public properties | Value |


FlowControl

FlowControl Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FlowControl FlowControl {
    get;
    }


OpCodeType

OpCodeType Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCodeType OpCodeType {
    get;
    }


OperandType

OperandType Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OperandType OperandType {
    get;
    }


Size

Size Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Size {
    get;
    }


StackBehaviourPop

StackBehaviourPop Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StackBehaviour StackBehaviourPop {
    get;
    }


StackBehaviourPush

StackBehaviourPush Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StackBehaviour StackBehaviourPush {
    get;
    }


Value

Value Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public short Value {
    get;
    }


OpCodes

OpCodes Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.OpCodes
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class OpCodes

The OpCodes type exposes the following members.

Constructors

 | Class | Summary
private constructor | OpCodes() |
private constructor | OpCodes() |

Methods

 | Name | Summary
public method | TakesSingleByteArgument(OpCode) |

Fields

 | Name | Description
public field | Add |
public field | Add_Ovf |
public field | Add_Ovf_Un |
public field | And |
public field | Arglist |
public field | Beq |
public field | Beq_S |
public field | Bge |
public field | Bge_S |
public field | Bge_Un |
public field | Bge_Un_S |
public field | Bgt |
public field | Bgt_S |
public field | Bgt_Un |
public field | Bgt_Un_S |
public field | Ble |
public field | Ble_S |
public field | Ble_Un |
public field | Ble_Un_S |
public field | Blt |
public field | Blt_S |
public field | Blt_Un |
public field | Blt_Un_S |
public field | Bne_Un |
public field | Bne_Un_S |
public field | Box |
public field | Br |
public field | Br_S |
public field | Break |
public field | Brfalse |
public field | Brfalse_S |
public field | Brtrue |
public field | Brtrue_S |
public field | Call |
public field | Calli |
public field | Callvirt |
public field | Castclass |
public field | Ceq |
public field | Cgt |
public field | Cgt_Un |
public field | Ckfinite |
public field | Clt |
public field | Clt_Un |
public field | Constrained |
public field | Conv_I |
public field | Conv_I1 |
public field | Conv_I2 |
public field | Conv_I4 |
public field | Conv_I8 |
public field | Conv_Ovf_I |
public field | Conv_Ovf_I_Un |
public field | Conv_Ovf_I1 |
public field | Conv_Ovf_I1_Un |
public field | Conv_Ovf_I2 |
public field | Conv_Ovf_I2_Un |
public field | Conv_Ovf_I4 |
public field | Conv_Ovf_I4_Un |
public field | Conv_Ovf_I8 |
public field | Conv_Ovf_I8_Un |
public field | Conv_Ovf_U |
public field | Conv_Ovf_U_Un |
public field | Conv_Ovf_U1 |
public field | Conv_Ovf_U1_Un |
public field | Conv_Ovf_U2 |
public field | Conv_Ovf_U2_Un |
public field | Conv_Ovf_U4 |
public field | Conv_Ovf_U4_Un |
public field | Conv_Ovf_U8 |
public field | Conv_Ovf_U8_Un |
public field | Conv_R_Un |
public field | Conv_R4 |
public field | Conv_R8 |
public field | Conv_U |
public field | Conv_U1 |
public field | Conv_U2 |
public field | Conv_U4 |
public field | Conv_U8 |
public field | Cpblk |
public field | Cpobj |
public field | Div |
public field | Div_Un |
public field | Dup |
public field | Endfilter |
public field | Endfinally |
public field | Initblk |
public field | Initobj |
public field | Isinst |
public field | Jmp |
public field | Ldarg |
public field | Ldarg_0 |
public field | Ldarg_1 |
public field | Ldarg_2 |
public field | Ldarg_3 |
public field | Ldarg_S |
public field | Ldarga |
public field | Ldarga_S |
public field | Ldc_I4 |
public field | Ldc_I4_0 |
public field | Ldc_I4_1 |
public field | Ldc_I4_2 |
public field | Ldc_I4_3 |
public field | Ldc_I4_4 |
public field | Ldc_I4_5 |
public field | Ldc_I4_6 |
public field | Ldc_I4_7 |
public field | Ldc_I4_8 |
public field | Ldc_I4_M1 |
public field | Ldc_I4_S |
public field | Ldc_I8 |
public field | Ldc_R4 |
public field | Ldc_R8 |
public field | Ldelem |
public field | Ldelem_I |
public field | Ldelem_I1 |
public field | Ldelem_I2 |
public field | Ldelem_I4 |
public field | Ldelem_I8 |
public field | Ldelem_R4 |
public field | Ldelem_R8 |
public field | Ldelem_Ref |
public field | Ldelem_U1 |
public field | Ldelem_U2 |
public field | Ldelem_U4 |
public field | Ldelema |
public field | Ldfld |
public field | Ldflda |
public field | Ldftn |
public field | Ldind_I |
public field | Ldind_I1 |
public field | Ldind_I2 |
public field | Ldind_I4 |
public field | Ldind_I8 |
public field | Ldind_R4 |
public field | Ldind_R8 |
public field | Ldind_Ref |
public field | Ldind_U1 |
public field | Ldind_U2 |
public field | Ldind_U4 |
public field | Ldlen |
public field | Ldloc |
public field | Ldloc_0 |
public field | Ldloc_1 |
public field | Ldloc_2 |
public field | Ldloc_3 |
public field | Ldloc_S |
public field | Ldloca |
public field | Ldloca_S |
public field | Ldnull |
public field | Ldobj |
public field | Ldsfld |
public field | Ldsflda |
public field | Ldstr |
public field | Ldtoken |
public field | Ldvirtftn |
public field | Leave |
public field | Leave_S |
public field | Localloc |
public field | Mkrefany |
public field | Mul |
public field | Mul_Ovf |
public field | Mul_Ovf_Un |
public field | Neg |
public field | Newarr |
public field | Newobj |
public field | Nop |
public field | Not |
public field | Or |
public field | Pop |
public field | Prefix1 |
public field | Prefix2 |
public field | Prefix3 |
public field | Prefix4 |
public field | Prefix5 |
public field | Prefix6 |
public field | Prefix7 |
public field | Prefixref |
public field | Readonly |
public field | Refanytype |
public field | Refanyval |
public field | Rem |
public field | Rem_Un |
public field | Ret |
public field | Rethrow |
public field | Shl |
public field | Shr |
public field | Shr_Un |
public field | Sizeof |
public field | Starg |
public field | Starg_S |
public field | Stelem |
public field | Stelem_I |
public field | Stelem_I1 |
public field | Stelem_I2 |
public field | Stelem_I4 |
public field | Stelem_I8 |
public field | Stelem_R4 |
public field | Stelem_R8 |
public field | Stelem_Ref |
public field | Stfld |
public field | Stind_I |
public field | Stind_I1 |
public field | Stind_I2 |
public field | Stind_I4 |
public field | Stind_I8 |
public field | Stind_R4 |
public field | Stind_R8 |
public field | Stind_Ref |
public field | Stloc |
public field | Stloc_0 |
public field | Stloc_1 |
public field | Stloc_2 |
public field | Stloc_3 |
public field | Stloc_S |
public field | Stobj |
public field | Stsfld |
public field | Sub |
public field | Sub_Ovf |
public field | Sub_Ovf_Un |
public field | Switch |
public field | Tailcall |
public field | Throw |
public field | Unaligned |
public field | Unbox |
public field | Unbox_Any |
public field | Volatile |
public field | Xor |


OpCodes Constructors

The OpCodes type exposes the following members.

Constructors

 | Class | Summary
private constructor | OpCodes() |
private constructor | OpCodes() |


OpCodes()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private OpCodes()


OpCodes()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static OpCodes()


OpCodes Fields

The OpCodes type exposes the following members.

Fields

 | Name | Description
public field | Add |
public field | Add_Ovf |
public field | Add_Ovf_Un |
public field | And |
public field | Arglist |
public field | Beq |
public field | Beq_S |
public field | Bge |
public field | Bge_S |
public field | Bge_Un |
public field | Bge_Un_S |
public field | Bgt |
public field | Bgt_S |
public field | Bgt_Un |
public field | Bgt_Un_S |
public field | Ble |
public field | Ble_S |
public field | Ble_Un |
public field | Ble_Un_S |
public field | Blt |
public field | Blt_S |
public field | Blt_Un |
public field | Blt_Un_S |
public field | Bne_Un |
public field | Bne_Un_S |
public field | Box |
public field | Br |
public field | Br_S |
public field | Break |
public field | Brfalse |
public field | Brfalse_S |
public field | Brtrue |
public field | Brtrue_S |
public field | Call |
public field | Calli |
public field | Callvirt |
public field | Castclass |
public field | Ceq |
public field | Cgt |
public field | Cgt_Un |
public field | Ckfinite |
public field | Clt |
public field | Clt_Un |
public field | Constrained |
public field | Conv_I |
public field | Conv_I1 |
public field | Conv_I2 |
public field | Conv_I4 |
public field | Conv_I8 |
public field | Conv_Ovf_I |
public field | Conv_Ovf_I_Un |
public field | Conv_Ovf_I1 |
public field | Conv_Ovf_I1_Un |
public field | Conv_Ovf_I2 |
public field | Conv_Ovf_I2_Un |
public field | Conv_Ovf_I4 |
public field | Conv_Ovf_I4_Un |
public field | Conv_Ovf_I8 |
public field | Conv_Ovf_I8_Un |
public field | Conv_Ovf_U |
public field | Conv_Ovf_U_Un |
public field | Conv_Ovf_U1 |
public field | Conv_Ovf_U1_Un |
public field | Conv_Ovf_U2 |
public field | Conv_Ovf_U2_Un |
public field | Conv_Ovf_U4 |
public field | Conv_Ovf_U4_Un |
public field | Conv_Ovf_U8 |
public field | Conv_Ovf_U8_Un |
public field | Conv_R_Un |
public field | Conv_R4 |
public field | Conv_R8 |
public field | Conv_U |
public field | Conv_U1 |
public field | Conv_U2 |
public field | Conv_U4 |
public field | Conv_U8 |
public field | Cpblk |
public field | Cpobj |
public field | Div |
public field | Div_Un |
public field | Dup |
public field | Endfilter |
public field | Endfinally |
public field | Initblk |
public field | Initobj |
public field | Isinst |
public field | Jmp |
public field | Ldarg |
public field | Ldarg_0 |
public field | Ldarg_1 |
public field | Ldarg_2 |
public field | Ldarg_3 |
public field | Ldarg_S |
public field | Ldarga |
public field | Ldarga_S |
public field | Ldc_I4 |
public field | Ldc_I4_0 |
public field | Ldc_I4_1 |
public field | Ldc_I4_2 |
public field | Ldc_I4_3 |
public field | Ldc_I4_4 |
public field | Ldc_I4_5 |
public field | Ldc_I4_6 |
public field | Ldc_I4_7 |
public field | Ldc_I4_8 |
public field | Ldc_I4_M1 |
public field | Ldc_I4_S |
public field | Ldc_I8 |
public field | Ldc_R4 |
public field | Ldc_R8 |
public field | Ldelem |
public field | Ldelem_I |
public field | Ldelem_I1 |
public field | Ldelem_I2 |
public field | Ldelem_I4 |
public field | Ldelem_I8 |
public field | Ldelem_R4 |
public field | Ldelem_R8 |
public field | Ldelem_Ref |
public field | Ldelem_U1 |
public field | Ldelem_U2 |
public field | Ldelem_U4 |
public field | Ldelema |
public field | Ldfld |
public field | Ldflda |
public field | Ldftn |
public field | Ldind_I |
public field | Ldind_I1 |
public field | Ldind_I2 |
public field | Ldind_I4 |
public field | Ldind_I8 |
public field | Ldind_R4 |
public field | Ldind_R8 |
public field | Ldind_Ref |
public field | Ldind_U1 |
public field | Ldind_U2 |
public field | Ldind_U4 |
public field | Ldlen |
public field | Ldloc |
public field | Ldloc_0 |
public field | Ldloc_1 |
public field | Ldloc_2 |
public field | Ldloc_3 |
public field | Ldloc_S |
public field | Ldloca |
public field | Ldloca_S |
public field | Ldnull |
public field | Ldobj |
public field | Ldsfld |
public field | Ldsflda |
public field | Ldstr |
public field | Ldtoken |
public field | Ldvirtftn |
public field | Leave |
public field | Leave_S |
public field | Localloc |
public field | Mkrefany |
public field | Mul |
public field | Mul_Ovf |
public field | Mul_Ovf_Un |
public field | Neg |
public field | Newarr |
public field | Newobj |
public field | Nop |
public field | Not |
public field | Or |
public field | Pop |
public field | Prefix1 |
public field | Prefix2 |
public field | Prefix3 |
public field | Prefix4 |
public field | Prefix5 |
public field | Prefix6 |
public field | Prefix7 |
public field | Prefixref |
public field | Readonly |
public field | Refanytype |
public field | Refanyval |
public field | Rem |
public field | Rem_Un |
public field | Ret |
public field | Rethrow |
public field | Shl |
public field | Shr |
public field | Shr_Un |
public field | Sizeof |
public field | Starg |
public field | Starg_S |
public field | Stelem |
public field | Stelem_I |
public field | Stelem_I1 |
public field | Stelem_I2 |
public field | Stelem_I4 |
public field | Stelem_I8 |
public field | Stelem_R4 |
public field | Stelem_R8 |
public field | Stelem_Ref |
public field | Stfld |
public field | Stind_I |
public field | Stind_I1 |
public field | Stind_I2 |
public field | Stind_I4 |
public field | Stind_I8 |
public field | Stind_R4 |
public field | Stind_R8 |
public field | Stind_Ref |
public field | Stloc |
public field | Stloc_0 |
public field | Stloc_1 |
public field | Stloc_2 |
public field | Stloc_3 |
public field | Stloc_S |
public field | Stobj |
public field | Stsfld |
public field | Sub |
public field | Sub_Ovf |
public field | Sub_Ovf_Un |
public field | Switch |
public field | Tailcall |
public field | Throw |
public field | Unaligned |
public field | Unbox |
public field | Unbox_Any |
public field | Volatile |
public field | Xor |


Add

Add Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Add


Add_Ovf

Add_Ovf Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Add_Ovf


Add_Ovf_Un

Add_Ovf_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Add_Ovf_Un


And

And Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode And


Arglist

Arglist Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Arglist


Beq

Beq Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Beq


Beq_S

Beq_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Beq_S


Bge

Bge Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bge


Bge_S

Bge_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bge_S


Bge_Un

Bge_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bge_Un


Bge_Un_S

Bge_Un_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bge_Un_S


Bgt

Bgt Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bgt


Bgt_S

Bgt_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bgt_S


Bgt_Un

Bgt_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bgt_Un


Bgt_Un_S

Bgt_Un_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bgt_Un_S


Ble

Ble Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ble


Ble_S

Ble_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ble_S


Ble_Un

Ble_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ble_Un


Ble_Un_S

Ble_Un_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ble_Un_S


Blt

Blt Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Blt


Blt_S

Blt_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Blt_S


Blt_Un

Blt_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Blt_Un


Blt_Un_S

Blt_Un_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Blt_Un_S


Bne_Un

Bne_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bne_Un


Bne_Un_S

Bne_Un_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Bne_Un_S


Box

Box Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Box


Br

Br Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Br


Br_S

Br_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Br_S


Break

Break Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Break


Brfalse

Brfalse Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Brfalse


Brfalse_S

Brfalse_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Brfalse_S


Brtrue

Brtrue Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Brtrue


Brtrue_S

Brtrue_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Brtrue_S


Call

Call Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Call


Calli

Calli Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Calli


Callvirt

Callvirt Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Callvirt


Castclass

Castclass Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Castclass


Ceq

Ceq Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ceq


Cgt

Cgt Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Cgt


Cgt_Un

Cgt_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Cgt_Un


Ckfinite

Ckfinite Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ckfinite


Clt

Clt Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Clt


Clt_Un

Clt_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Clt_Un


Constrained

Constrained Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Constrained


Conv_I

Conv_I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_I


Conv_I1

Conv_I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_I1


Conv_I2

Conv_I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_I2


Conv_I4

Conv_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_I4


Conv_I8

Conv_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_I8


Conv_Ovf_I

Conv_Ovf_I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I


Conv_Ovf_I_Un

Conv_Ovf_I_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I_Un


Conv_Ovf_I1

Conv_Ovf_I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I1


Conv_Ovf_I1_Un

Conv_Ovf_I1_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I1_Un


Conv_Ovf_I2

Conv_Ovf_I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I2


Conv_Ovf_I2_Un

Conv_Ovf_I2_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I2_Un


Conv_Ovf_I4

Conv_Ovf_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I4


Conv_Ovf_I4_Un

Conv_Ovf_I4_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I4_Un


Conv_Ovf_I8

Conv_Ovf_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I8


Conv_Ovf_I8_Un

Conv_Ovf_I8_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_I8_Un


Conv_Ovf_U

Conv_Ovf_U Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U


Conv_Ovf_U_Un

Conv_Ovf_U_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U_Un


Conv_Ovf_U1

Conv_Ovf_U1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U1


Conv_Ovf_U1_Un

Conv_Ovf_U1_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U1_Un


Conv_Ovf_U2

Conv_Ovf_U2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U2


Conv_Ovf_U2_Un

Conv_Ovf_U2_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U2_Un


Conv_Ovf_U4

Conv_Ovf_U4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U4


Conv_Ovf_U4_Un

Conv_Ovf_U4_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U4_Un


Conv_Ovf_U8

Conv_Ovf_U8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U8


Conv_Ovf_U8_Un

Conv_Ovf_U8_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_Ovf_U8_Un


Conv_R_Un

Conv_R_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_R_Un


Conv_R4

Conv_R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_R4


Conv_R8

Conv_R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_R8


Conv_U

Conv_U Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_U


Conv_U1

Conv_U1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_U1


Conv_U2

Conv_U2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_U2


Conv_U4

Conv_U4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_U4


Conv_U8

Conv_U8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Conv_U8


Cpblk

Cpblk Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Cpblk


Cpobj

Cpobj Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Cpobj


Div

Div Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Div


Div_Un

Div_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Div_Un


Dup

Dup Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Dup


Endfilter

Endfilter Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Endfilter


Endfinally

Endfinally Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Endfinally


Initblk

Initblk Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Initblk


Initobj

Initobj Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Initobj


Isinst

Isinst Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Isinst


Jmp

Jmp Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Jmp


Ldarg

Ldarg Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarg


Ldarg_0

Ldarg_0 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarg_0


Ldarg_1

Ldarg_1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarg_1


Ldarg_2

Ldarg_2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarg_2


Ldarg_3

Ldarg_3 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarg_3


Ldarg_S

Ldarg_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarg_S


Ldarga

Ldarga Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarga


Ldarga_S

Ldarga_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldarga_S


Ldc_I4

Ldc_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4


Ldc_I4_0

Ldc_I4_0 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_0


Ldc_I4_1

Ldc_I4_1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_1


Ldc_I4_2

Ldc_I4_2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_2


Ldc_I4_3

Ldc_I4_3 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_3


Ldc_I4_4

Ldc_I4_4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_4


Ldc_I4_5

Ldc_I4_5 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_5


Ldc_I4_6

Ldc_I4_6 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_6


Ldc_I4_7

Ldc_I4_7 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_7


Ldc_I4_8

Ldc_I4_8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_8


Ldc_I4_M1

Ldc_I4_M1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_M1


Ldc_I4_S

Ldc_I4_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I4_S


Ldc_I8

Ldc_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_I8


Ldc_R4

Ldc_R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_R4


Ldc_R8

Ldc_R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldc_R8


Ldelem

Ldelem Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem


Ldelem_I

Ldelem_I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_I


Ldelem_I1

Ldelem_I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_I1


Ldelem_I2

Ldelem_I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_I2


Ldelem_I4

Ldelem_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_I4


Ldelem_I8

Ldelem_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_I8


Ldelem_R4

Ldelem_R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_R4


Ldelem_R8

Ldelem_R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_R8


Ldelem_Ref

Ldelem_Ref Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_Ref


Ldelem_U1

Ldelem_U1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_U1


Ldelem_U2

Ldelem_U2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_U2


Ldelem_U4

Ldelem_U4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelem_U4


Ldelema

Ldelema Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldelema


Ldfld

Ldfld Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldfld


Ldflda

Ldflda Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldflda


Ldftn

Ldftn Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldftn


Ldind_I

Ldind_I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_I


Ldind_I1

Ldind_I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_I1


Ldind_I2

Ldind_I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_I2


Ldind_I4

Ldind_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_I4


Ldind_I8

Ldind_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_I8


Ldind_R4

Ldind_R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_R4


Ldind_R8

Ldind_R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_R8


Ldind_Ref

Ldind_Ref Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_Ref


Ldind_U1

Ldind_U1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_U1


Ldind_U2

Ldind_U2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_U2


Ldind_U4

Ldind_U4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldind_U4


Ldlen

Ldlen Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldlen


Ldloc

Ldloc Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloc


Ldloc_0

Ldloc_0 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloc_0


Ldloc_1

Ldloc_1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloc_1


Ldloc_2

Ldloc_2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloc_2


Ldloc_3

Ldloc_3 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloc_3


Ldloc_S

Ldloc_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloc_S


Ldloca

Ldloca Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloca


Ldloca_S

Ldloca_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldloca_S


Ldnull

Ldnull Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldnull


Ldobj

Ldobj Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldobj


Ldsfld

Ldsfld Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldsfld


Ldsflda

Ldsflda Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldsflda


Ldstr

Ldstr Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldstr


Ldtoken

Ldtoken Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldtoken


Ldvirtftn

Ldvirtftn Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ldvirtftn


Leave

Leave Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Leave


Leave_S

Leave_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Leave_S


Localloc

Localloc Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Localloc


Mkrefany

Mkrefany Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Mkrefany


Mul

Mul Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Mul


Mul_Ovf

Mul_Ovf Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Mul_Ovf


Mul_Ovf_Un

Mul_Ovf_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Mul_Ovf_Un


Neg

Neg Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Neg


Newarr

Newarr Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Newarr


Newobj

Newobj Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Newobj


Nop

Nop Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Nop


Not

Not Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Not


Or

Or Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Or


Pop

Pop Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Pop


Prefix1

Prefix1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix1


Prefix2

Prefix2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix2


Prefix3

Prefix3 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix3


Prefix4

Prefix4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix4


Prefix5

Prefix5 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix5


Prefix6

Prefix6 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix6


Prefix7

Prefix7 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefix7


Prefixref

Prefixref Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Prefixref


Readonly

Readonly Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Readonly


Refanytype

Refanytype Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Refanytype


Refanyval

Refanyval Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Refanyval


Rem

Rem Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Rem


Rem_Un

Rem_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Rem_Un


Ret

Ret Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Ret


Rethrow

Rethrow Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Rethrow


Shl

Shl Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Shl


Shr

Shr Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Shr


Shr_Un

Shr_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Shr_Un


Sizeof

Sizeof Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Sizeof


Starg

Starg Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Starg


Starg_S

Starg_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Starg_S


Stelem

Stelem Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem


Stelem_I

Stelem_I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_I


Stelem_I1

Stelem_I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_I1


Stelem_I2

Stelem_I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_I2


Stelem_I4

Stelem_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_I4


Stelem_I8

Stelem_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_I8


Stelem_R4

Stelem_R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_R4


Stelem_R8

Stelem_R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_R8


Stelem_Ref

Stelem_Ref Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stelem_Ref


Stfld

Stfld Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stfld


Stind_I

Stind_I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_I


Stind_I1

Stind_I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_I1


Stind_I2

Stind_I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_I2


Stind_I4

Stind_I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_I4


Stind_I8

Stind_I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_I8


Stind_R4

Stind_R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_R4


Stind_R8

Stind_R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_R8


Stind_Ref

Stind_Ref Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stind_Ref


Stloc

Stloc Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stloc


Stloc_0

Stloc_0 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stloc_0


Stloc_1

Stloc_1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stloc_1


Stloc_2

Stloc_2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stloc_2


Stloc_3

Stloc_3 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stloc_3


Stloc_S

Stloc_S Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stloc_S


Stobj

Stobj Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stobj


Stsfld

Stsfld Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Stsfld


Sub

Sub Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Sub


Sub_Ovf

Sub_Ovf Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Sub_Ovf


Sub_Ovf_Un

Sub_Ovf_Un Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Sub_Ovf_Un


Switch

Switch Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Switch


Tailcall

Tailcall Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Tailcall


Throw

Throw Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Throw


Unaligned

Unaligned Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Unaligned


Unbox

Unbox Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Unbox


Unbox_Any

Unbox_Any Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Unbox_Any


Volatile

Volatile Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Volatile


Xor

Xor Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode Xor


OpCodes Methods

The OpCodes type exposes the following members.

Methods

 | Name | Summary
public method | TakesSingleByteArgument(OpCode) |


TakesSingleByteArgument(OpCode)

TakesSingleByteArgument(OpCode) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static bool TakesSingleByteArgument(
    OpCode inst
    )

Parameters

inst
Type: OpCode


OpCodesMap

OpCodesMap Class

Creates a nice searchable and iterable version of the OpCodes class.

Inheritance Hierarchy

  • System.Collections.Generic.List<>
    • TheBoxSoftware.Reflection.OpCodesMap
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class OpCodesMap : List<OpCode>

The OpCodesMap type exposes the following members.

Constructors

 | Class | Summary
private constructor | OpCodesMap() | Initialises a new instance of the OpCodesMap class

Methods

 | Name | Summary
public method | GetCode(Int16) | Returns the description of the instruction represented by 'instruction'
public method | GetSingleton() | Obtains a reference to the singleton

Fields

 | Name | Description
private field | _map |
private field | _singleton |


OpCodesMap Constructors

The OpCodesMap type exposes the following members.

Constructors

 | Class | Summary
private constructor | OpCodesMap() | Initialises a new instance of the OpCodesMap class


OpCodesMap()

Initialises a new instance of the OpCodesMap class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private OpCodesMap()


OpCodesMap Fields

The OpCodesMap type exposes the following members.

Fields

 | Name | Description
private field | _map |
private field | _singleton |


_map

_map Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _map


_singleton

_singleton Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private OpCodesMap _singleton


OpCodesMap Methods

The OpCodesMap type exposes the following members.

Methods

 | Name | Summary
public method | GetCode(Int16) | Returns the description of the instruction represented by 'instruction'
public method | GetSingleton() | Obtains a reference to the singleton


GetCode(Int16)

GetCode(Int16) Method

Returns the description of the instruction represented by 'instruction'
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OpCode GetCode(
    short instruction
    )

Parameters

instruction
Type: Int16
The instruction


GetSingleton()

GetSingleton() Method

Obtains a reference to the singleton
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static OpCodesMap GetSingleton()


OpCodeType

OpCodeType Enumeration

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum OpCodeType : int

Members

Name | Description
Annotation |
Macro |
Nternal |
Objmodel |
Prefix |
Primitive |


OperandType

OperandType Enumeration

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum OperandType : int

Members

Name | Description
InlineBrTarget |
InlineField |
InlineI |
InlineI8 |
InlineMethod |
InlineNone |
InlinePhi |
InlineR |
InlineSig |
InlineString |
InlineSwitch |
InlineTok |
InlineType |
InlineVar |
ShortInlineBrTarget |
ShortInlineI |
ShortInlineR |
ShortInlineVar |


ParamDef

ParamDef Class

Describes a parameter

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.ParamDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ParamDef : ReflectedMember

The ParamDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParamDef() |
public constructor | ParamDef(String, MethodDef, Int32, AssemblyDef, ParamAttributeFlags) | Constructs a ParamDef with the provided details.

Properties

 | Name | Summary
public properties | Constants() | The constant values associated with the parameters if any.
public properties | IsIn | Indicates if the parameter has been declared as an in paramter
public properties | IsOptional | Indicates if the parameter has been declared as optional.
public properties | IsOut | Indicates if the parameter has been declared as an out parameter
public properties | Method() | Reference to the method that owns the parameter
public properties | Sequence() |

Fields

 | Name | Description
private field | _constants |
private field | _flags |
private field | _method |
private field | _sequence |


ParamDef Constructors

The ParamDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParamDef() |
public constructor | ParamDef(String, MethodDef, Int32, AssemblyDef, ParamAttributeFlags) | Constructs a ParamDef with the provided details.


ParamDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParamDef()


ParamDef(String, MethodDef, Int32, AssemblyDef, ParamAttributeFlags)

Constructs a ParamDef with the provided details.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParamDef(
string name,
MethodDef container,
int sequence,
AssemblyDef definingAssembly,
ParamAttributeFlags flags
)

Parameters

name
Type: String
The name for the parameter
container
Type: MethodDef
The method that defines and contains the parameter
sequence
Type: Int32
The sequence in the parameter list for this parameter
definingAssembly
Type: AssemblyDef
The assembly in which the parameter is defined
flags
Type: ParamAttributeFlags
The attribute flags for the parameter


ParamDef Fields

The ParamDef type exposes the following members.

Fields

 | Name | Description
private field | _constants |
private field | _flags |
private field | _method |
private field | _sequence |


_flags

_flags Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ParamAttributeFlags _flags


_method

_method Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _method


_sequence

_sequence Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _sequence


ParamDef Properties

The ParamDef type exposes the following members.

Properties

 | Name | Summary
public properties | Constants() | The constant values associated with the parameters if any.
public properties | IsIn | Indicates if the parameter has been declared as an in paramter
public properties | IsOptional | Indicates if the parameter has been declared as optional.
public properties | IsOut | Indicates if the parameter has been declared as an out parameter
public properties | Method() | Reference to the method that owns the parameter
public properties | Sequence() |


Constants()

Constants() Property

The constant values associated with the parameters if any.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ConstantInfo> this[] {
    get;
    set;
    }


IsIn

IsIn Property

Indicates if the parameter has been declared as an in paramter
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsIn {
    get;
    }


IsOptional

IsOptional Property

Indicates if the parameter has been declared as optional.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsOptional {
    get;
    }


IsOut

IsOut Property

Indicates if the parameter has been declared as an out parameter
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsOut {
    get;
    }


Method()

Method() Property

Reference to the method that owns the parameter
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef this[] {
    get;
    set;
    }


Sequence()

Sequence() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


PropertyDef

PropertyDef Class

A class that describes a property that has been defined in an TypeDef.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.PropertyDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class PropertyDef : ReflectedMember

The PropertyDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyDef() |
public constructor | PropertyDef(AssemblyDef, String, TypeDef) | Initialises an instance of the PropertyDef with the specified details.

Methods

 | Name | Summary
private method | CalculateVisibility() |
public method | IsIndexer() | Indicates if this property is an Indexer based on the Getter and Setter methods.

Properties

 | Name | Summary
public properties | Getter() | Gets or sets the MethodDef which relates to the associated get method for the property.
public properties | MemberAccess | Obtains the level of access for this member
public properties | OwningType() | Reference to the TypeDef where this property is defined.
public properties | Setter() | Gest or sets the MethodDef which relates to the associated set method for the property.

Fields

 | Name | Description
private field | _getMethod |
private field | _owningType |
private field | _setMethod |


PropertyDef Constructors

The PropertyDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyDef() |
public constructor | PropertyDef(AssemblyDef, String, TypeDef) | Initialises an instance of the PropertyDef with the specified details.


PropertyDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyDef()


PropertyDef(AssemblyDef, String, TypeDef)

Initialises an instance of the PropertyDef with the specified details.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyDef(
AssemblyDef definingAssembly,
string name,
TypeDef containingType
)

Parameters

definingAssembly
Type: AssemblyDef
The assembly in which the property is defined.
name
Type: String
The name of the property
containingType
Type: TypeDef
The type that the property is defined in.


PropertyDef Fields

The PropertyDef type exposes the following members.

Fields

 | Name | Description
private field | _getMethod |
private field | _owningType |
private field | _setMethod |


_getMethod

_getMethod Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _getMethod


_owningType

_owningType Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _owningType


_setMethod

_setMethod Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _setMethod


PropertyDef Methods

The PropertyDef type exposes the following members.

Methods

 | Name | Summary
private method | CalculateVisibility() |
public method | IsIndexer() | Indicates if this property is an Indexer based on the Getter and Setter methods.


IsIndexer()

IsIndexer() Method

Indicates if this property is an Indexer based on the Getter and Setter methods.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsIndexer()


PropertyDef Properties

The PropertyDef type exposes the following members.

Properties

 | Name | Summary
public properties | Getter() | Gets or sets the MethodDef which relates to the associated get method for the property.
public properties | MemberAccess | Obtains the level of access for this member
public properties | OwningType() | Reference to the TypeDef where this property is defined.
public properties | Setter() | Gest or sets the MethodDef which relates to the associated set method for the property.


Getter()

Getter() Property

Gets or sets the MethodDef which relates to the associated get method for the property.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef this[] {
    get;
    set;
    }


MemberAccess

MemberAccess Property

Obtains the level of access for this member
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility MemberAccess {
    get;
    }


OwningType()

OwningType() Property

Reference to the TypeDef where this property is defined.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef this[] {
    get;
    set;
    }


Setter()

Setter() Property

Gest or sets the MethodDef which relates to the associated set method for the property.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef this[] {
    get;
    set;
    }


ReflectedMember

ReflectedMember Class

Base class for all elements that are reflected from a PeCoffFile.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.AssemblyDef
      • TheBoxSoftware.Reflection.AssemblyRef
      • TheBoxSoftware.Reflection.EventDef
      • TheBoxSoftware.Reflection.MemberRef
      • TheBoxSoftware.Reflection.ModuleDef
      • TheBoxSoftware.Reflection.ParamDef
      • TheBoxSoftware.Reflection.PropertyDef
      • TheBoxSoftware.Reflection.TypeRef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract class ReflectedMember

The ReflectedMember type exposes the following members.

Constructors

 | Class | Summary
protected constructor | ReflectedMember() |

Methods

 | Name | Summary
public method | GetGloballyUniqueId() | Returns an identifier which can uniquely identify this member across many AssemblyDefs.

Properties

 | Name | Summary
public properties | Assembly() | A reference to the assembly which defines this member.
public properties | Attributes() | The attributes associated with this member.
public properties | MemberAccess |
public properties | Name() | Gets or sets the name for this ReflectedMember.
public properties | UniqueId() | Represents an identifier that uniquly identifies this reflected element inside its containing AssemblyDef.

Fields

 | Name | Description
private field | _assembly |
private field | _attributes |
private field | _name |
private field | _uniqueId |


ReflectedMember Constructors

The ReflectedMember type exposes the following members.

Constructors

 | Class | Summary
protected constructor | ReflectedMember() |


ReflectedMember()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected ReflectedMember()


ReflectedMember Fields

The ReflectedMember type exposes the following members.

Fields

 | Name | Description
private field | _assembly |
private field | _attributes |
private field | _name |
private field | _uniqueId |


_attributes

_attributes Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _attributes


_name

_name Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _name


_uniqueId

_uniqueId Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _uniqueId


ReflectedMember Methods

The ReflectedMember type exposes the following members.

Methods

 | Name | Summary
public method | GetGloballyUniqueId() | Returns an identifier which can uniquely identify this member across many AssemblyDefs.


GetGloballyUniqueId()

GetGloballyUniqueId() Method

Returns an identifier which can uniquely identify this member across many AssemblyDefs.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public long GetGloballyUniqueId()


ReflectedMember Properties

The ReflectedMember type exposes the following members.

Properties

 | Name | Summary
public properties | Assembly() | A reference to the assembly which defines this member.
public properties | Attributes() | The attributes associated with this member.
public properties | MemberAccess |
public properties | Name() | Gets or sets the name for this ReflectedMember.
public properties | UniqueId() | Represents an identifier that uniquly identifies this reflected element inside its containing AssemblyDef.


Assembly()

Assembly() Property

A reference to the assembly which defines this member.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyDef this[] {
    get;
    set;
    }


Attributes()

Attributes() Property

The attributes associated with this member.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<CustomAttribute> this[] {
    get;
    set;
    }


Name()

Name() Property

Gets or sets the name for this ReflectedMember.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


UniqueId()

UniqueId() Property

Represents an identifier that uniquly identifies this reflected element inside its containing AssemblyDef.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


ReflectionException

ReflectionException Class

Exception that describes issues working with reflection based code.

Inheritance Hierarchy

  • System.Exception
    • TheBoxSoftware.Reflection.ReflectionException
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ReflectionException : Exception,
    IExtendedException

The ReflectionException type exposes the following members.

Constructors

 | Class | Summary
public constructor | ReflectionException() | Initialises a new instance of the ReflectionException.
public constructor | ReflectionException(String) | Initialises a new instance of the ReflectionException.
public constructor | ReflectionException(String, Exception) | Initialises a new instance of the ReflectionException.
public constructor | ReflectionException(ReflectedMember, String, Exception) | Initialises a new instance of the ReflectionException.
protected constructor | ReflectionException(SerializationInfo, StreamingContext) | Serialization constructor.

Methods

 | Name | Summary
public method | GetExtendedInformation() | Extracts as much information from the internal state of the exception.

Properties

 | Name | Summary
public properties | Member() | The member the exception is related to.

Fields

 | Name | Description
private field | _member |


ReflectionException Constructors

The ReflectionException type exposes the following members.

Constructors

 | Class | Summary
public constructor | ReflectionException() | Initialises a new instance of the ReflectionException.
public constructor | ReflectionException(String) | Initialises a new instance of the ReflectionException.
public constructor | ReflectionException(String, Exception) | Initialises a new instance of the ReflectionException.
public constructor | ReflectionException(ReflectedMember, String, Exception) | Initialises a new instance of the ReflectionException.
protected constructor | ReflectionException(SerializationInfo, StreamingContext) | Serialization constructor.


ReflectionException()

Initialises a new instance of the ReflectionException.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectionException()


ReflectionException(String)

Initialises a new instance of the ReflectionException.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectionException(
string message
)

Parameters

message
Type: String
Message describing the error.


ReflectionException(String, Exception)

Initialises a new instance of the ReflectionException.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectionException(
string message,
Exception innerException
)

Parameters

message
Type: String
Message describing the error.
innerException
Type: Exception
The thrown exception.


ReflectionException(ReflectedMember, String, Exception)

Initialises a new instance of the ReflectionException.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectionException(
ReflectedMember member,
string message,
Exception innerException
)

Parameters

member
Type: ReflectedMember
The member associated with this exception.
message
Type: String
Message describing the error.
innerException
Type: Exception
The thrown exception.


ReflectionException(SerializationInfo, StreamingContext)

Serialization constructor.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected ReflectionException(
SerializationInfo info,
StreamingContext context
)

Parameters

info
Type: SerializationInfo
The info describing the exception.
context
Type: StreamingContext
The serialization context.


ReflectionException Fields

The ReflectionException type exposes the following members.

Fields

 | Name | Description
private field | _member |


_member

_member Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ReflectedMember _member


ReflectionException Methods

The ReflectionException type exposes the following members.

Methods

 | Name | Summary
public method | GetExtendedInformation() | Extracts as much information from the internal state of the exception.


GetExtendedInformation()

GetExtendedInformation() Method

Extracts as much information from the internal state of the exception.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetExtendedInformation()


ReflectionException Properties

The ReflectionException type exposes the following members.

Properties

 | Name | Summary
public properties | Member() | The member the exception is related to.


Member()

Member() Property

The member the exception is related to.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectedMember this[] {
    get;
    set;
    }


ShortInlineBrTargetILInstruction

ShortInlineBrTargetILInstruction Class

Represents an IL instruction of type ShortInlineBrTarget

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.ShortInlineBrTargetILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ShortInlineBrTargetILInstruction : ILInstruction

The ShortInlineBrTargetILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineBrTargetILInstruction(OpCode, Byte) | Initialises a new instance of the ShortInlineBrTargetILInstruction class

Properties

 | Name | Summary
public properties | Target() |


ShortInlineBrTargetILInstruction Constructors

The ShortInlineBrTargetILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineBrTargetILInstruction(OpCode, Byte) | Initialises a new instance of the ShortInlineBrTargetILInstruction class


ShortInlineBrTargetILInstruction(OpCode, Byte)

Initialises a new instance of the ShortInlineBrTargetILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ShortInlineBrTargetILInstruction(
OpCode code,
byte target
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
target
Type: Byte
The targetes offset


ShortInlineBrTargetILInstruction Properties

The ShortInlineBrTargetILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Target() |


Target()

Target() Property

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte this[] {
    get;
    set;
    }


ShortInlineIILInstruction

ShortInlineIILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.ShortInlineIILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ShortInlineIILInstruction : ILInstruction

The ShortInlineIILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineIILInstruction(OpCode, Byte) | Initialises a new instance of the ShortInlineIILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The constant being pushed on to the stack in this operation


ShortInlineIILInstruction Constructors

The ShortInlineIILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineIILInstruction(OpCode, Byte) | Initialises a new instance of the ShortInlineIILInstruction class


ShortInlineIILInstruction(OpCode, Byte)

Initialises a new instance of the ShortInlineIILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ShortInlineIILInstruction(
OpCode code,
byte constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: Byte


ShortInlineIILInstruction Properties

The ShortInlineIILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The constant being pushed on to the stack in this operation


Constant()

Constant() Property

The constant being pushed on to the stack in this operation
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


ShortInlineRILInstruction

ShortInlineRILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.ShortInlineRILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ShortInlineRILInstruction : ILInstruction

The ShortInlineRILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineRILInstruction(OpCode, Single) | Initialises a new instance of the ShortInlineRILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The constant being pushed on to the stack in this operation


ShortInlineRILInstruction Constructors

The ShortInlineRILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineRILInstruction(OpCode, Single) | Initialises a new instance of the ShortInlineRILInstruction class


ShortInlineRILInstruction(OpCode, Single)

Initialises a new instance of the ShortInlineRILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ShortInlineRILInstruction(
OpCode code,
float constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: Single


ShortInlineRILInstruction Properties

The ShortInlineRILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The constant being pushed on to the stack in this operation


Constant()

Constant() Property

The constant being pushed on to the stack in this operation
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public float this[] {
    get;
    set;
    }


ShortInlineVarILInstruction

ShortInlineVarILInstruction Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ILInstruction
      • TheBoxSoftware.Reflection.ShortInlineVarILInstruction
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ShortInlineVarILInstruction : ILInstruction

The ShortInlineVarILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineVarILInstruction(OpCode, Byte) | Initialises a new instance of the ShortInlineVarILInstruction class

Properties

 | Name | Summary
public properties | Constant() | The constant being pushed on to the stack in this operation


ShortInlineVarILInstruction Constructors

The ShortInlineVarILInstruction type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ShortInlineVarILInstruction(OpCode, Byte) | Initialises a new instance of the ShortInlineVarILInstruction class


ShortInlineVarILInstruction(OpCode, Byte)

Initialises a new instance of the ShortInlineVarILInstruction class
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ShortInlineVarILInstruction(
OpCode code,
byte constant
)

Parameters

code
Type: OpCode
The OpCode describing the operation of the instruction
constant
Type: Byte


ShortInlineVarILInstruction Properties

The ShortInlineVarILInstruction type exposes the following members.

Properties

 | Name | Summary
public properties | Constant() | The constant being pushed on to the stack in this operation


StackBehaviour

StackBehaviour Enumeration

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum StackBehaviour : int

Members

Name | Description
Pop0 |
Pop1 |
Pop1_pop1 |
Popi |
Popi_pop1 |
Popi_popi |
Popi_popi8 |
Popi_popi_popi |
Popi_popr4 |
Popi_popr8 |
Popref |
Popref_pop1 |
Popref_popi |
Popref_popi_popi |
Popref_popi_popi8 |
Popref_popi_popr4 |
Popref_popi_popr8 |
Popref_popi_popref |
Push0 |
Push1 |
Push1_push1 |
Pushi |
Pushi8 |
Pushr4 |
Pushr8 |
Pushref |
Varpop |
Varpush |
Popref_popi_pop1 |


TypeDef

TypeDef Class

Contains the information regarding the construction and elements of a type reflected from the metadata information. A type definition is a metadata reflected type which is defined in an assembly.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.TypeRef
        • TheBoxSoftware.Reflection.TypeDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class TypeDef : TypeRef

The TypeDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDef() |

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, TypeDefMetadataTableRow) |
public method | GetConstructors() | Returns a collection of constructor methods defined for this type.
public method | GetConstructors(Boolean) | Returns a collection of constructors defined for this type.
public method | GetEvents() | Obtains a collection of events that are defined in this type.
public method | GetExtendingTypes() | Obtains all of the TypeRefs that extend this TypeDef.
public method | GetFields() | Obtains the fields that are defined in this type. System generated fields will not be returned.
public method | GetFields(Boolean) | Obtains the fields that are defined in this TypeDef.
public method | GetGenericTypes() | Obtains the list of generic types that are defined and owned only by this member.
public method | GetMethods() | Obtains only the methods, not property accessors or operand overload methods for this type
public method | GetMethods(Boolean) | Obtains the methods defined in this type.
public method | GetOperators() | Returns a collection of operator methods defined for this type.
public method | GetOperators(Boolean) | Returns a collection of operator methods defined for this type.
public method | GetProperties() | Returns a collection of properties that have been defined for this type. Properties are stored as a series of MethodDef structures, representing the get_ and set_ methods. The PropertyDef wraps these methods up and provides a nice wrapper to retrieve the names and other details of the property.

Properties

 | Name | Summary
public properties | ContainingClass() | When this class is a nested class this property will contain the class which owns this class.
public properties | Events() | The events this type contains.
public properties | Fields() | The fields this type contains
public properties | Flags() | Flags defining extra information about the type.
public properties | GenericTypes() | Collection of all the generic types that are relevant for this member, this includes the types defined in parent and containing classes.
public properties | HasMembers | Indicates if this type has any members defined
public properties | Implements() | Collection of TypeRef instances defining the interfaces this class implements.
public properties | InheritsFrom | Returns a reference to the TypeDef or Ref which this type inherits from.
public properties | IsCompilerGenerated | Indicates if this type is compiler generated.
public properties | IsDelegate | Indicates if this class is a delegate
public properties | IsEnumeration | Indicates if this class is an enumeration.
public properties | IsInterface | Indicates if this class is an Interface.
public properties | IsNested | Indicates if this class is a nested class, if so the ContainingClass property details its container.
public properties | IsStructure | Indicates if this TypeDef is a structure
public properties | MemberAccess | Returns the Visibility of the TypeDef.
public properties | Methods() | The methods this type contains
public properties | Namespace() | Returns the namespace for the current class. This is obtained from the Types metadata.
public properties | Properties() | The properties this type contains.

Fields

 | Name | Description
private field | _containingClass |
private field | _events |
private field | _extends |
private field | _fields |
private field | _flags |
private field | _genericTypes |
private field | _implements |
private field | _index |
private field | _methods |
private field | _properties |
private field | _table |


TypeDef Constructors

The TypeDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDef() |


TypeDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef()


TypeDef Fields

The TypeDef type exposes the following members.

Fields

 | Name | Description
private field | _containingClass |
private field | _events |
private field | _extends |
private field | _fields |
private field | _flags |
private field | _genericTypes |
private field | _implements |
private field | _index |
private field | _methods |
private field | _properties |
private field | _table |


_containingClass

_containingClass Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _containingClass


_events

_events Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _events


_extends

_extends Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _extends


_fields

_fields Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _fields


_flags

_flags Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeAttributes _flags


_implements

_implements Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _implements


_index

_index Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _index


_methods

_methods Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _methods


_properties

_properties Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _properties


_table

_table Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataTables _table


TypeDef Methods

The TypeDef type exposes the following members.

Methods

 | Name | Summary
sealed method | CreateFromMetadata(BuildReferences, TypeDefMetadataTableRow) |
public method | GetConstructors() | Returns a collection of constructor methods defined for this type.
public method | GetConstructors(Boolean) | Returns a collection of constructors defined for this type.
public method | GetEvents() | Obtains a collection of events that are defined in this type.
public method | GetExtendingTypes() | Obtains all of the TypeRefs that extend this TypeDef.
public method | GetFields() | Obtains the fields that are defined in this type. System generated fields will not be returned.
public method | GetFields(Boolean) | Obtains the fields that are defined in this TypeDef.
public method | GetGenericTypes() | Obtains the list of generic types that are defined and owned only by this member.
public method | GetMethods() | Obtains only the methods, not property accessors or operand overload methods for this type
public method | GetMethods(Boolean) | Obtains the methods defined in this type.
public method | GetOperators() | Returns a collection of operator methods defined for this type.
public method | GetOperators(Boolean) | Returns a collection of operator methods defined for this type.
public method | GetProperties() | Returns a collection of properties that have been defined for this type. Properties are stored as a series of MethodDef structures, representing the get_ and set_ methods. The PropertyDef wraps these methods up and provides a nice wrapper to retrieve the names and other details of the property.


CreateFromMetadata(BuildReferences, TypeDefMetadataTableRow)

CreateFromMetadata(BuildReferences, TypeDefMetadataTableRow) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static TypeDef CreateFromMetadata(
    BuildReferences references,
    TypeDefMetadataTableRow fromRow
    )

Parameters

references
Type: BuildReferences
fromRow
Type: TypeDefMetadataTableRow


GetConstructors()

GetConstructors() Method

Returns a collection of constructor methods defined for this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> GetConstructors()


GetConstructors(Boolean)

GetConstructors(Boolean) Method

Returns a collection of constructors defined for this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> GetConstructors(
    bool includeSystemGenerated
    )

Parameters

includeSystemGenerated
Type: Boolean
Indicates if system generated methods should be included.


GetEvents()

GetEvents() Method

Obtains a collection of events that are defined in this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<EventDef> GetEvents()


GetExtendingTypes()

GetExtendingTypes() Method

Obtains all of the TypeRefs that extend this TypeDef.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<TypeRef> GetExtendingTypes()


GetFields()

GetFields() Method

Obtains the fields that are defined in this type. System generated fields will not be returned.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<FieldDef> GetFields()


GetFields(Boolean)

GetFields(Boolean) Method

Obtains the fields that are defined in this TypeDef.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<FieldDef> GetFields(
    bool includeSystemGenerated
    )

Parameters

includeSystemGenerated
Type: Boolean
Indicates if system generated fields should be returned.


GetMethods()

GetMethods() Method

Obtains only the methods, not property accessors or operand overload methods for this type
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> GetMethods()


GetMethods(Boolean)

GetMethods(Boolean) Method

Obtains the methods defined in this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> GetMethods(
    bool includeSystemGenerated
    )

Parameters

includeSystemGenerated
Type: Boolean
Indicates if system generated methods should be returned.


GetOperators()

GetOperators() Method

Returns a collection of operator methods defined for this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> GetOperators()


GetOperators(Boolean)

GetOperators(Boolean) Method

Returns a collection of operator methods defined for this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> GetOperators(
    bool includeSystemGenerated
    )

Parameters

includeSystemGenerated
Type: Boolean
Indicates if system generated operators should be included.


GetProperties()

GetProperties() Method

Returns a collection of properties that have been defined for this type. Properties are stored as a series of MethodDef structures, representing the get_ and set_ methods. The PropertyDef wraps these methods up and provides a nice wrapper to retrieve the names and other details of the property.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<PropertyDef> GetProperties()


TypeDef Properties

The TypeDef type exposes the following members.

Properties

 | Name | Summary
public properties | ContainingClass() | When this class is a nested class this property will contain the class which owns this class.
public properties | Events() | The events this type contains.
public properties | Fields() | The fields this type contains
public properties | Flags() | Flags defining extra information about the type.
public properties | GenericTypes() | Collection of all the generic types that are relevant for this member, this includes the types defined in parent and containing classes.
public properties | HasMembers | Indicates if this type has any members defined
public properties | Implements() | Collection of TypeRef instances defining the interfaces this class implements.
public properties | InheritsFrom | Returns a reference to the TypeDef or Ref which this type inherits from.
public properties | IsCompilerGenerated | Indicates if this type is compiler generated.
public properties | IsDelegate | Indicates if this class is a delegate
public properties | IsEnumeration | Indicates if this class is an enumeration.
public properties | IsInterface | Indicates if this class is an Interface.
public properties | IsNested | Indicates if this class is a nested class, if so the ContainingClass property details its container.
public properties | IsStructure | Indicates if this TypeDef is a structure
public properties | MemberAccess | Returns the Visibility of the TypeDef.
public properties | Methods() | The methods this type contains
public properties | Namespace() | Returns the namespace for the current class. This is obtained from the Types metadata.
public properties | Properties() | The properties this type contains.


ContainingClass()

ContainingClass() Property

When this class is a nested class this property will contain the class which owns this class.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef this[] {
    get;
    set;
    }


Events()

Events() Property

The events this type contains.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<EventDef> this[] {
    get;
    set;
    }


Fields()

Fields() Property

The fields this type contains
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<FieldDef> this[] {
    get;
    set;
    }


Flags()

Flags() Property

Flags defining extra information about the type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeAttributes this[] {
    get;
    set;
    }


GenericTypes()

GenericTypes() Property

Collection of all the generic types that are relevant for this member, this includes the types defined in parent and containing classes.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<GenericTypeRef> this[] {
    get;
    set;
    }

See also

GetGenericTypes


HasMembers

HasMembers Property

Indicates if this type has any members defined
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool HasMembers {
    get;
    }


Implements()

Implements() Property

Collection of TypeRef instances defining the interfaces this class implements.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<TypeRef> this[] {
    get;
    set;
    }


InheritsFrom

InheritsFrom Property

Returns a reference to the TypeDef or Ref which this type inherits from.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef InheritsFrom {
    get;
    }


IsCompilerGenerated

IsCompilerGenerated Property

Indicates if this type is compiler generated.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsCompilerGenerated {
    get;
    }


IsDelegate

IsDelegate Property

Indicates if this class is a delegate
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsDelegate {
    get;
    }


IsEnumeration

IsEnumeration Property

Indicates if this class is an enumeration.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsEnumeration {
    get;
    }


IsInterface

IsInterface Property

Indicates if this class is an Interface.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsInterface {
    get;
    }


IsNested

IsNested Property

Indicates if this class is a nested class, if so the ContainingClass property details its container.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsNested {
    get;
    }


IsStructure

IsStructure Property

Indicates if this TypeDef is a structure
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsStructure {
    get;
    }


MemberAccess

MemberAccess Property

Returns the Visibility of the TypeDef.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility MemberAccess {
    get;
    }


Methods()

Methods() Property

The methods this type contains
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> this[] {
    get;
    set;
    }


Namespace()

Namespace() Property

Returns the namespace for the current class. This is obtained from the Types metadata.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }

Remarks

When the class IsNested the namespace returned is the namespace of the enclosing type. Where the class is nested multiple times each nested class is checked until one its containers defines a namespace and that is returned.


Properties()

Properties() Property

The properties this type contains.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<PropertyDef> this[] {
    get;
    set;
    }


TypeInNamespaceMap

TypeInNamespaceMap Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.TypeInNamespaceMap
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class TypeInNamespaceMap

The TypeInNamespaceMap type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeInNamespaceMap() |

Methods

 | Name | Summary
public method | Add(TypeDef) |
public method | ContainsNamespace(String) |
public method | FindTypeInNamespace(String, String) |
public method | GetAllNamespaces() |
public method | GetAllTypesInNamespaces() |
public method | Remove(TypeDef) |

Fields

 | Name | Description
private field | _typeInNamespace |


TypeInNamespaceMap Constructors

The TypeInNamespaceMap type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeInNamespaceMap() |


TypeInNamespaceMap()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeInNamespaceMap()


TypeInNamespaceMap Fields

The TypeInNamespaceMap type exposes the following members.

Fields

 | Name | Description
private field | _typeInNamespace |


_typeInNamespace

_typeInNamespace Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _typeInNamespace


TypeInNamespaceMap Methods

The TypeInNamespaceMap type exposes the following members.

Methods

 | Name | Summary
public method | Add(TypeDef) |
public method | ContainsNamespace(String) |
public method | FindTypeInNamespace(String, String) |
public method | GetAllNamespaces() |
public method | GetAllTypesInNamespaces() |
public method | Remove(TypeDef) |


Add(TypeDef)

Add(TypeDef) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void Add(
    TypeDef type
    )

Parameters

type
Type: TypeDef


ContainsNamespace(String)

ContainsNamespace(String) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool ContainsNamespace(
    string theNamespace
    )

Parameters

theNamespace
Type: String


FindTypeInNamespace(String, String)

FindTypeInNamespace(String, String) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef FindTypeInNamespace(
    string inNamespace,
    string typeName
    )

Parameters

inNamespace
Type: String
typeName
Type: String


GetAllNamespaces()

GetAllNamespaces() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<string> GetAllNamespaces()


GetAllTypesInNamespaces()

GetAllTypesInNamespaces() Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<string, List<TypeDef>> GetAllTypesInNamespaces()


Remove(TypeDef)

Remove(TypeDef) Method

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void Remove(
    TypeDef type
    )

Parameters

type
Type: TypeDef


TypeRef

TypeRef Class

Details a reference to a Type that resides in another assembly.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.TypeRef
        • TheBoxSoftware.Reflection.GenericTypeRef
        • TheBoxSoftware.Reflection.TypeDef
        • TheBoxSoftware.Reflection.TypeSpec
        • TheBoxSoftware.Reflection.WellKnownTypeDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class TypeRef : ReflectedMember

The TypeRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeRef() |
public constructor | TypeRef(AssemblyDef, String, String, CodedIndex) | Initiliases a new instance of the TypeRef class using the provided details.

Methods

 | Name | Summary
public method | GetDisplayName(Boolean) | Returns a nice display name for the type
public method | GetFullyQualifiedName() | Returns the fully qualified name for this type
sealed method | GetUniqueName() | Returns the unique name for this definition
public method | ToString() | Returns a string representation of the TypeRef

Properties

 | Name | Summary
public properties | ExtensionMethods() | Extension methods associated with this type.
public properties | IsExternalReference() | Indicates wether or not this member is a reference to an external type.
public properties | IsGeneric() | TODO Should implement this properly for TypeDef, TypeRef entries
public properties | Namespace() | The namespace in which this type resides.
public properties | ResolvingAssembly | Returns a reference to the extenral member that this reference can be resolved in. This will generally be a reference to the external

Fields

 | Name | Description
private field | _extensionMethods |
private field | _isExternalReference |
private field | _isGeneric |
private field | _namespace |
private field | _resolutionScope |


TypeRef Constructors

The TypeRef type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeRef() |
public constructor | TypeRef(AssemblyDef, String, String, CodedIndex) | Initiliases a new instance of the TypeRef class using the provided details.


TypeRef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef()


TypeRef(AssemblyDef, String, String, CodedIndex)

Initiliases a new instance of the TypeRef class using the provided details.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef(
AssemblyDef definingAssembly,
string name,
string namespaceName,
CodedIndex resolutionScope
)

Parameters

definingAssembly
Type: AssemblyDef
The assembly which defines the type reference
name
Type: String
The name of the type reference
namespaceName
Type: String
The namespace it is defined in
resolutionScope
Type: CodedIndex
A CodedIndex determining the resolve the external reference


TypeRef Fields

The TypeRef type exposes the following members.

Fields

 | Name | Description
private field | _extensionMethods |
private field | _isExternalReference |
private field | _isGeneric |
private field | _namespace |
private field | _resolutionScope |


_extensionMethods

_extensionMethods Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _extensionMethods


_isExternalReference

_isExternalReference Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isExternalReference


_namespace

_namespace Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _namespace


_resolutionScope

_resolutionScope Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _resolutionScope


TypeRef Methods

The TypeRef type exposes the following members.

Methods

 | Name | Summary
public method | GetDisplayName(Boolean) | Returns a nice display name for the type
public method | GetFullyQualifiedName() | Returns the fully qualified name for this type
sealed method | GetUniqueName() | Returns the unique name for this definition
public method | ToString() | Returns a string representation of the TypeRef


GetDisplayName(Boolean)

GetDisplayName(Boolean) Method

Returns a nice display name for the type
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetDisplayName(
    bool includeNamespace
    )

Parameters

includeNamespace
Type: Boolean
Indicates wether or not the namespace should be included.

Remarks

This method will return a name that can be used to display to users of applications utilising this type. Generic Type: List<MyClass> Array: MyClass[] Normal: MyClass


GetFullyQualifiedName()

GetFullyQualifiedName() Method

Returns the fully qualified name for this type
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetFullyQualifiedName()


GetUniqueName()

GetUniqueName() Method

Returns the unique name for this definition
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal string GetUniqueName()


ToString()

ToString() Method

Returns a string representation of the TypeRef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


TypeRef Properties

The TypeRef type exposes the following members.

Properties

 | Name | Summary
public properties | ExtensionMethods() | Extension methods associated with this type.
public properties | IsExternalReference() | Indicates wether or not this member is a reference to an external type.
public properties | IsGeneric() | TODO Should implement this properly for TypeDef, TypeRef entries
public properties | Namespace() | The namespace in which this type resides.
public properties | ResolvingAssembly | Returns a reference to the extenral member that this reference can be resolved in. This will generally be a reference to the external


ExtensionMethods()

ExtensionMethods() Property

Extension methods associated with this type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<MethodDef> this[] {
    get;
    set;
    }

Remarks

Extension methods are defined on the TypeRef as this represents a reference which is used in this library. So in essance all types loaded will be recorded. TypeDef derives for this type too, which means all assembly defined types will get this functionality.


IsExternalReference()

IsExternalReference() Property

Indicates wether or not this member is a reference to an external type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsGeneric()

IsGeneric() Property

TODO Should implement this properly for TypeDef, TypeRef entries
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


Namespace()

Namespace() Property

The namespace in which this type resides.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


ResolvingAssembly

ResolvingAssembly Property

Returns a reference to the extenral member that this reference can be resolved in. This will generally be a reference to the external
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyRef ResolvingAssembly {
    get;
    }


TypeSpec

TypeSpec Class

Details the specification of a type. This is generally used by the metadata to allow for types to derive from and implement interfaces and classes that are generic.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.TypeRef
        • TheBoxSoftware.Reflection.TypeSpec
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class TypeSpec : TypeRef

The TypeSpec type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSpec() |
public constructor | TypeSpec(AssemblyDef, BlobIndex) | Creates a new instance of the TypeSpec class using the provided information.

Methods

 | Name | Summary
private method | LoadDetails() | Loads the details of the underlying type and specification.

Properties

 | Name | Summary
public properties | ImplementingType() | Gets or sets the type which is implementing this base type or interface.
public properties | IsGeneric() | Indicates if this type is a generic type.
public properties | Name() | Gets the name of the underlying type in this specification.
public properties | Namespace() | Gets the namespace of the underlying type in this specification.
sealed properties | Signiture | The signiture defined for this member.
public properties | TypeDetails | Gets a reference to the details of the underlying type.

Fields

 | Name | Description
private field | _details |
private field | _implementingType |
private field | _signitureIndexInBlob |


TypeSpec Constructors

The TypeSpec type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSpec() |
public constructor | TypeSpec(AssemblyDef, BlobIndex) | Creates a new instance of the TypeSpec class using the provided information.


TypeSpec()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeSpec()


TypeSpec(AssemblyDef, BlobIndex)

Creates a new instance of the TypeSpec class using the provided information.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeSpec(
AssemblyDef definingAssembly,
BlobIndex signitureIndex
)

Parameters

definingAssembly
Type: AssemblyDef
The assembly which defines the type specification
signitureIndex
Type: BlobIndex
The index in to the blod where the signiture for this type is defined.


TypeSpec Fields

The TypeSpec type exposes the following members.

Fields

 | Name | Description
private field | _details |
private field | _implementingType |
private field | _signitureIndexInBlob |


_details

_details Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDetails _details


_implementingType

_implementingType Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _implementingType


_signitureIndexInBlob

_signitureIndexInBlob Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobIndex _signitureIndexInBlob


TypeSpec Methods

The TypeSpec type exposes the following members.

Methods

 | Name | Summary
private method | LoadDetails() | Loads the details of the underlying type and specification.


LoadDetails()

LoadDetails() Method

Loads the details of the underlying type and specification.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadDetails()


TypeSpec Properties

The TypeSpec type exposes the following members.

Properties

 | Name | Summary
public properties | ImplementingType() | Gets or sets the type which is implementing this base type or interface.
public properties | IsGeneric() | Indicates if this type is a generic type.
public properties | Name() | Gets the name of the underlying type in this specification.
public properties | Namespace() | Gets the namespace of the underlying type in this specification.
sealed properties | Signiture | The signiture defined for this member.
public properties | TypeDetails | Gets a reference to the details of the underlying type.


ImplementingType()

ImplementingType() Property

Gets or sets the type which is implementing this base type or interface.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef this[] {
    get;
    set;
    }


IsGeneric()

IsGeneric() Property

Indicates if this type is a generic type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


Name()

Name() Property

Gets the name of the underlying type in this specification.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


Namespace()

Namespace() Property

Gets the namespace of the underlying type in this specification.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


Signiture

Signiture Property

The signiture defined for this member.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeSpecificationSignature Signiture {
    get;
    }


TypeDetails

TypeDetails Property

Gets a reference to the details of the underlying type.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails TypeDetails {
    get;
    }


Visibility

Visibility Enumeration

Visibility flags that apply to all members in the reflection namespace.
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum Visibility : byte

Members

Name | Description
NotApplicable |
Private |
Protected |
InternalProtected |
Internal |
Public |


WellKnownTypeDef

WellKnownTypeDef Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.ReflectedMember
      • TheBoxSoftware.Reflection.TypeRef
        • TheBoxSoftware.Reflection.WellKnownTypeDef
Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class WellKnownTypeDef : TypeRef

The WellKnownTypeDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | WellKnownTypeDef(AssemblyDef, String, String) |
private constructor | WellKnownTypeDef() |

Fields

 | Name | Description
public field | Boolean |
public field | Char |
public field | I |
public field | I1 |
public field | I2 |
public field | I4 |
public field | I8 |
public field | Object |
public field | R4 |
public field | R8 |
public field | String |
public field | TypedByRef |
public field | U |
public field | U1 |
public field | U2 |
public field | U4 |
public field | U8 |
public field | Void |


WellKnownTypeDef Constructors

The WellKnownTypeDef type exposes the following members.

Constructors

 | Class | Summary
public constructor | WellKnownTypeDef(AssemblyDef, String, String) |
private constructor | WellKnownTypeDef() |


WellKnownTypeDef(AssemblyDef, String, String)

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef(
AssemblyDef assembly,
string namespaceName,
string name
)

Parameters

assembly
Type: AssemblyDef
namespaceName
Type: String
name
Type: String


WellKnownTypeDef()

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static WellKnownTypeDef()


WellKnownTypeDef Fields

The WellKnownTypeDef type exposes the following members.

Fields

 | Name | Description
public field | Boolean |
public field | Char |
public field | I |
public field | I1 |
public field | I2 |
public field | I4 |
public field | I8 |
public field | Object |
public field | R4 |
public field | R8 |
public field | String |
public field | TypedByRef |
public field | U |
public field | U1 |
public field | U2 |
public field | U4 |
public field | U8 |
public field | Void |


Boolean

Boolean Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef Boolean


Char

Char Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef Char


I

I Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef I


I1

I1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef I1


I2

I2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef I2


I4

I4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef I4


I8

I8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef I8


Object

Object Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef Object


R4

R4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef R4


R8

R8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef R8


String

String Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef String


TypedByRef

TypedByRef Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef TypedByRef


U

U Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef U


U1

U1 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef U1


U2

U2 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef U2


U4

U4 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef U4


U8

U8 Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef U8


Void

Void Field

Namespace: TheBoxSoftware.ReflectionAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public WellKnownTypeDef Void


TheBoxSoftware.Reflection.Comments Namespaces

Namespace
TheBoxSoftware.Reflection.Comments


TheBoxSoftware.Reflection.Comments Namespace

Classes

 | Class | Summary
public class | AttributeRequiredException | Exception which details that an attribute on one of the XmlCodeElements is missing when it is required.
public class | BoldXmlCodeElement |
public class | CodeXmlCodeElement | Represents a pre-formatted code entry as a block level element.
sealed class | CRefConstants | Set of constants that define all of the different cref identifiers that can be used in code comments.
public class | CRefPath | Class that handles and parses a CRef comment path. A CRef path can contain a fully qualified link to a type, property, method etc in an assembly.
public class | CXmlCodeElement | Represents a tokenised version of the inine <c> comment element.
public class | DescriptionXmlCodeElement |
public class | ErrorXmlCodeElement |
public class | ExampleXmlCodeElement | An internal representation of the example XML comment element.
public class | ExceptionXmlCodeElement | CodeElement that describes an exception that can be thrown.
public class | ItalicXmlCodeElement |
public class | ListHeaderXmlCodeElement |
public class | ListItemXmlCodeElement |
public class | ListXmlCodeElement | An internal representation of the list XML element.
public class | ParamRefXmlCodeElement |
public class | ParamXmlCodeElement |
public class | ParaXmlCodeElement |
public class | PermissionXmlCodeElement | Represents the permission XML code element.
public class | RemarksXmlCodeElement |
public class | ReturnsXmlCodeElement |
public class | SeeAlsoXmlCodeElement | This XML element allows people to associate other useful elements to the current documentation. I.e. for further reading.
public class | SeeXmlCodeElement |
public class | SummaryXmlCodeElement |
public class | TermXmlCodeElement |
public class | TextXmlCodeElement | Not really an allowed xml code comment element; but this is used by the system to aid in the parsing of inline textual elements from other XmlCodeElement implementations.
public class | TypeParamRefXmlCodeElement |
public class | TypeParamXmlCodeElement |
public class | ValueXmlCodeElement |
public class | XmlCodeComment | The details of the comments associated with a single member.
public class | XmlCodeElement | Base class for all the implementations of the XmlCodeComments.
public class | XmlCodeElementCollection | Manages a collection of XmlCodeElement instances.
public class | XmlCommentException | Describes errors that occur while using the members and methods defined to read XML code comments
public class | XmlCommentFile | Implementation of ICommentSource that uses an underlying XML Comment File.
public class | XmlContainerCodeElement |

Interfaces

 | Name | Summary
public interface | ICommentSource |

Enumerations

 | Name | Summary
public enum | CRefTypes | An enumeration of the available types of element that can be referenced by a cref path in the xml code comments for an assembly.
public enum | ListTypes | An enumeration of the available types that a ListXmlCodeElementcan be.
public enum | XmlCodeElements | Enumeration of supported XML Code Comment tags


AttributeRequiredException

AttributeRequiredException Class

Exception which details that an attribute on one of the XmlCodeElements is missing when it is required.

Inheritance Hierarchy

  • System.Exception
    • TheBoxSoftware.Reflection.Comments.AttributeRequiredException
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class AttributeRequiredException : Exception

The AttributeRequiredException type exposes the following members.

Constructors

 | Class | Summary
public constructor | AttributeRequiredException(String, XmlCodeElements) | Initialises a new instance of the AttributeRequiredException class.

Properties

 | Name | Summary
public properties | Attribute() | The attribute that was missing from the XmlCodeElement.

Fields

 | Name | Description
private field | _attribute |


AttributeRequiredException Constructors

The AttributeRequiredException type exposes the following members.

Constructors

 | Class | Summary
public constructor | AttributeRequiredException(String, XmlCodeElements) | Initialises a new instance of the AttributeRequiredException class.


AttributeRequiredException(String, XmlCodeElements)

Initialises a new instance of the AttributeRequiredException class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AttributeRequiredException(
string attribute,
XmlCodeElements fromElement
)

Parameters

attribute
Type: String
The attribute that was missing
fromElement
Type: XmlCodeElements
The element the attribute is missing from


AttributeRequiredException Fields

The AttributeRequiredException type exposes the following members.

Fields

 | Name | Description
private field | _attribute |


_attribute

_attribute Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _attribute


AttributeRequiredException Properties

The AttributeRequiredException type exposes the following members.

Properties

 | Name | Summary
public properties | Attribute() | The attribute that was missing from the XmlCodeElement.


Attribute()

Attribute() Property

The attribute that was missing from the XmlCodeElement.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


BoldXmlCodeElement

BoldXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.BoldXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class BoldXmlCodeElement : XmlCodeElement

The BoldXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | BoldXmlCodeElement(XmlNode) |


BoldXmlCodeElement Constructors

The BoldXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | BoldXmlCodeElement(XmlNode) |


BoldXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal BoldXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


CodeXmlCodeElement

CodeXmlCodeElement Class

Represents a pre-formatted code entry as a block level element.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.CodeXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class CodeXmlCodeElement : XmlCodeElement

The CodeXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | CodeXmlCodeElement(XmlNode) | Initialises a new instance of the CodeXmlCodeElement class.

Methods

 | Name | Summary
private method | CalculateLeadingSpaceToTrim(String[]) |
private method | StripStartAndEndWhitespace(XmlNode) |
private method | TrimLeadingWhiteSpaceFromLines(String[], Int32) |


CodeXmlCodeElement Constructors

The CodeXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | CodeXmlCodeElement(XmlNode) | Initialises a new instance of the CodeXmlCodeElement class.


CodeXmlCodeElement(XmlNode)

Initialises a new instance of the CodeXmlCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal CodeXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The node to parse.


CodeXmlCodeElement Methods

The CodeXmlCodeElement type exposes the following members.

Methods

 | Name | Summary
private method | CalculateLeadingSpaceToTrim(String[]) |
private method | StripStartAndEndWhitespace(XmlNode) |
private method | TrimLeadingWhiteSpaceFromLines(String[], Int32) |


CalculateLeadingSpaceToTrim(String[])

CalculateLeadingSpaceToTrim(String[]) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int CalculateLeadingSpaceToTrim(
    string[] strippedStrings
    )

Parameters

strippedStrings
Type: String


StripStartAndEndWhitespace(XmlNode)

StripStartAndEndWhitespace(XmlNode) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string[] StripStartAndEndWhitespace(
    XmlNode node
    )

Parameters

node
Type: XmlNode


TrimLeadingWhiteSpaceFromLines(String[], Int32)

TrimLeadingWhiteSpaceFromLines(String[], Int32) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void TrimLeadingWhiteSpaceFromLines(
    string[] strippedStrings,
    int charsToTrim
    )

Parameters

strippedStrings
Type: String
charsToTrim
Type: Int32


CRefConstants

CRefConstants Class

Set of constants that define all of the different cref identifiers that can be used in code comments.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.CRefConstants
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static class CRefConstants

The CRefConstants type exposes the following members.

Methods

 | Name | Summary
public method | GetIndicatorFor(CRefTypes) | Returns the string indicator for the specified CRef type.

Fields

 | Name | Description
public constant | ErrorTypeIndicator | Constant that defines a resolution error reference.
public constant | EventTypeIndicator | Constant that defines an event reference.
public constant | FieldTypeIndicator | Constant that defines a field reference.
public constant | MethodTypeIndicator | Constant that defines a method reference.
public constant | NamespaceTypeIndicator | Constant that defines a namespace reference.
public constant | PropertyTypeIndicator | Constant that defines a property reference.
public constant | TypeIndicator | Constant that defines a type reference.


CRefConstants Fields

The CRefConstants type exposes the following members.

Fields

 | Name | Description
public constant | ErrorTypeIndicator | Constant that defines a resolution error reference.
public constant | EventTypeIndicator | Constant that defines an event reference.
public constant | FieldTypeIndicator | Constant that defines a field reference.
public constant | MethodTypeIndicator | Constant that defines a method reference.
public constant | NamespaceTypeIndicator | Constant that defines a namespace reference.
public constant | PropertyTypeIndicator | Constant that defines a property reference.
public constant | TypeIndicator | Constant that defines a type reference.


ErrorTypeIndicator

ErrorTypeIndicator Constant

Constant that defines a resolution error reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string ErrorTypeIndicator


EventTypeIndicator

EventTypeIndicator Constant

Constant that defines an event reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string EventTypeIndicator


FieldTypeIndicator

FieldTypeIndicator Constant

Constant that defines a field reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string FieldTypeIndicator


MethodTypeIndicator

MethodTypeIndicator Constant

Constant that defines a method reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string MethodTypeIndicator


NamespaceTypeIndicator

NamespaceTypeIndicator Constant

Constant that defines a namespace reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string NamespaceTypeIndicator


PropertyTypeIndicator

PropertyTypeIndicator Constant

Constant that defines a property reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string PropertyTypeIndicator


TypeIndicator

TypeIndicator Constant

Constant that defines a type reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const string TypeIndicator


CRefConstants Methods

The CRefConstants type exposes the following members.

Methods

 | Name | Summary
public method | GetIndicatorFor(CRefTypes) | Returns the string indicator for the specified CRef type.


GetIndicatorFor(CRefTypes)

GetIndicatorFor(CRefTypes) Method

Returns the string indicator for the specified CRef type.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static string GetIndicatorFor(
    CRefTypes type
    )

Parameters

type
Type: CRefTypes
The type to return the indicator for.

Exceptions

Exception | Condition
System.NotImplementedException | The provided constant in the enumeration type has not been implemented.


CRefPath

CRefPath Class

Class that handles and parses a CRef comment path. A CRef path can contain a fully qualified link to a type, property, method etc in an assembly.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureConvertor
      • TheBoxSoftware.Reflection.Comments.CRefPath
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class CRefPath : SignatureConvertor

The CRefPath type exposes the following members.

Constructors

 | Class | Summary
public constructor | CRefPath() | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(FieldDef) | Constructs a cref path for the provided field.
public constructor | CRefPath(TypeRef) | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(PropertyDef) | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(EventDef) | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(MethodDef) | Initialises a new instance of the CRefPath class.
private constructor | CRefPath(CRefTypes, TypeRef, String) | Private constructor initialises a new instance of the CRefPath class.

Methods

 | Name | Summary
public method | Create(ReflectedMember) | Factory method for creating CRefPath entries when the type is unknown.
public method | FindIn(TypeDef) | Finds the member this CRefPath refers to in the provided type.
public method | Parse(String) | Parses the provided path and returns a populated cref path instance.
private method | Parse() | Parses the contents of the contained path and stores the details in the classes properties.
private method | ParseType() | Extracts the cref type portion of the string and sets the PathType.
public method | ToString() | Returns a string representation of this CRefPath.

Properties

 | Name | Summary
public properties | PathType() | Indicates the type of element that is referenced by the CRef path.

Fields

 | Name | Description
private field | _crefPath |
private field | _isOperator |
private field | _pathType |
private field | _returnType |
private constant | SeperatorIndex |


CRefPath Constructors

The CRefPath type exposes the following members.

Constructors

 | Class | Summary
public constructor | CRefPath() | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(FieldDef) | Constructs a cref path for the provided field.
public constructor | CRefPath(TypeRef) | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(PropertyDef) | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(EventDef) | Initialises a new instance of the CRefPath class.
public constructor | CRefPath(MethodDef) | Initialises a new instance of the CRefPath class.
private constructor | CRefPath(CRefTypes, TypeRef, String) | Private constructor initialises a new instance of the CRefPath class.


CRefPath()

Initialises a new instance of the CRefPath class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath()


CRefPath(FieldDef)

Constructs a cref path for the provided field.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath(
FieldDef field
)

Parameters

field
Type: FieldDef
The field to create the path for.


CRefPath(TypeRef)

Initialises a new instance of the CRefPath class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath(
TypeRef type
)

Parameters

type
Type: TypeRef
The TypRef to initialise the path with.


CRefPath(PropertyDef)

Initialises a new instance of the CRefPath class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath(
PropertyDef property
)

Parameters

property
Type: PropertyDef
The property to initialise the path with.


CRefPath(EventDef)

Initialises a new instance of the CRefPath class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath(
EventDef cEvent
)

Parameters

cEvent
Type: EventDef
The event to create the path to.


CRefPath(MethodDef)

Initialises a new instance of the CRefPath class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath(
MethodDef method
)

Parameters

method
Type: MethodDef
The method to initialise the path with.


CRefPath(CRefTypes, TypeRef, String)

Private constructor initialises a new instance of the CRefPath class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CRefPath(
CRefTypes crefPathType,
TypeRef type,
string element
)

Parameters

crefPathType
Type: CRefTypes
The cref path type.
type
Type: TypeRef
The type information.
element
Type: String
The element name for the path.


CRefPath Fields

The CRefPath type exposes the following members.

Fields

 | Name | Description
private field | _crefPath |
private field | _isOperator |
private field | _pathType |
private field | _returnType |
private constant | SeperatorIndex |


_crefPath

_crefPath Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _crefPath


_isOperator

_isOperator Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isOperator


_pathType

_pathType Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CRefTypes _pathType


_returnType

_returnType Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _returnType


SeperatorIndex

SeperatorIndex Constant

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const int SeperatorIndex


CRefPath Methods

The CRefPath type exposes the following members.

Methods

 | Name | Summary
public method | Create(ReflectedMember) | Factory method for creating CRefPath entries when the type is unknown.
public method | FindIn(TypeDef) | Finds the member this CRefPath refers to in the provided type.
public method | Parse(String) | Parses the provided path and returns a populated cref path instance.
private method | Parse() | Parses the contents of the contained path and stores the details in the classes properties.
private method | ParseType() | Extracts the cref type portion of the string and sets the PathType.
public method | ToString() | Returns a string representation of this CRefPath.


Create(ReflectedMember)

Create(ReflectedMember) Method

Factory method for creating CRefPath entries when the type is unknown.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static CRefPath Create(
    ReflectedMember member
    )

Parameters

member
Type: ReflectedMember
The member to create a path for

Exceptions

Exception | Condition
System.NotImplementedException | Thrown when the type of the ReflectedMember is not implemented.


FindIn(TypeDef)

FindIn(TypeDef) Method

Finds the member this CRefPath refers to in the provided type.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReflectedMember FindIn(
    TypeDef type
    )

Parameters

type
Type: TypeDef
The type.

Exceptions

Exception | Condition
System.ArgumentNullException | When type is null.


Parse(String)

Parse(String) Method

Parses the provided path and returns a populated cref path instance.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static CRefPath Parse(
    string crefPath
    )

Parameters

crefPath
Type: String
The cref path to control.

Exceptions

Exception | Condition
System.ArgumentNullException | The specified path was null or empty.


Parse()

Parse() Method

Parses the contents of the contained path and stores the details in the classes properties.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void Parse()


ParseType()

ParseType() Method

Extracts the cref type portion of the string and sets the PathType.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ParseType()


ToString()

ToString() Method

Returns a string representation of this CRefPath.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


CRefPath Properties

The CRefPath type exposes the following members.

Properties

 | Name | Summary
public properties | PathType() | Indicates the type of element that is referenced by the CRef path.


PathType()

PathType() Property

Indicates the type of element that is referenced by the CRef path.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefTypes this[] {
    get;
    set;
    }


CRefTypes

CRefTypes Enumeration

An enumeration of the available types of element that can be referenced by a cref path in the xml code comments for an assembly.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum CRefTypes : byte

Members

Name | Description
Namespace | Represents a cref link to a namespace; these can not have commented directly but can be referenced.
Type | Represents a path to a type defined in this or another assembly.
Property | Represents a path to a property in a type.
Field | Represents a fully qualified path to a field in a type.
Method | Represents a fully qualified path to a method in a type.
Event | Represents a fully qualified path to an event.
Error | The compiler when generating the path could not resolve the type.


CXmlCodeElement

CXmlCodeElement Class

Represents a tokenised version of the inine <c> comment element.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.CXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class CXmlCodeElement : XmlCodeElement

The CXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | CXmlCodeElement(XmlNode) |


CXmlCodeElement Constructors

The CXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | CXmlCodeElement(XmlNode) |


CXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal CXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


DescriptionXmlCodeElement

DescriptionXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.DescriptionXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class DescriptionXmlCodeElement : XmlContainerCodeElement

The DescriptionXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | DescriptionXmlCodeElement(XmlNode) |


DescriptionXmlCodeElement Constructors

The DescriptionXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | DescriptionXmlCodeElement(XmlNode) |


DescriptionXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal DescriptionXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ErrorXmlCodeElement

ErrorXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.ErrorXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ErrorXmlCodeElement : XmlCodeElement

The ErrorXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
public constructor | ErrorXmlCodeElement(Exception) |


ErrorXmlCodeElement Constructors

The ErrorXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
public constructor | ErrorXmlCodeElement(Exception) |


ErrorXmlCodeElement(Exception)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ErrorXmlCodeElement(
Exception exception
)

Parameters

exception
Type: Exception


ExampleXmlCodeElement

ExampleXmlCodeElement Class

An internal representation of the example XML comment element.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ExampleXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ExampleXmlCodeElement : XmlContainerCodeElement

The ExampleXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ExampleXmlCodeElement(XmlNode) | Initialises a new instance of the ExampleXmlCodeElement class.


ExampleXmlCodeElement Constructors

The ExampleXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ExampleXmlCodeElement(XmlNode) | Initialises a new instance of the ExampleXmlCodeElement class.


ExampleXmlCodeElement(XmlNode)

Initialises a new instance of the ExampleXmlCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ExampleXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The associated XML node.


ExceptionXmlCodeElement

ExceptionXmlCodeElement Class

CodeElement that describes an exception that can be thrown.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ExceptionXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ExceptionXmlCodeElement : XmlContainerCodeElement

The ExceptionXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
public constructor | ExceptionXmlCodeElement(XmlNode) | Initialises a new instance of the ExceptionXmlCodeElement class.

Properties

 | Name | Summary
public properties | Member() | The path to the exception this exception element refers to.

Fields

 | Name | Description
private field | _member |


ExceptionXmlCodeElement Constructors

The ExceptionXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
public constructor | ExceptionXmlCodeElement(XmlNode) | Initialises a new instance of the ExceptionXmlCodeElement class.


ExceptionXmlCodeElement(XmlNode)

Initialises a new instance of the ExceptionXmlCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ExceptionXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The node describing the exception.


ExceptionXmlCodeElement Fields

The ExceptionXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _member |


_member

_member Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CRefPath _member


ExceptionXmlCodeElement Properties

The ExceptionXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Member() | The path to the exception this exception element refers to.


Member()

Member() Property

The path to the exception this exception element refers to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath this[] {
    get;
    set;
    }


ICommentSource

ICommentSource Interface

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public interface ICommentSource

The ICommentSource type exposes the following members.

Methods

 | Name | Summary
public method | Exists() | Indicates if the underlying source exists and can be used.
public method | GetComment(CRefPath) | Gets the comment associated with the CRefPath.
public method | GetSummary(CRefPath) | Returns just the summary element associated with the CRefPath.
public method | GetValue(CRefPath) |
public method | GetXml(CRefPath) |


ICommentSource Methods

The ICommentSource type exposes the following members.

Methods

 | Name | Summary
public method | Exists() | Indicates if the underlying source exists and can be used.
public method | GetComment(CRefPath) | Gets the comment associated with the CRefPath.
public method | GetSummary(CRefPath) | Returns just the summary element associated with the CRefPath.
public method | GetValue(CRefPath) |
public method | GetXml(CRefPath) |


Exists()

Exists() Method

Indicates if the underlying source exists and can be used.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract bool Exists()


GetComment(CRefPath)

GetComment(CRefPath) Method

Gets the comment associated with the CRefPath.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract XmlCodeComment GetComment(
    CRefPath crefPath
    )

Parameters

crefPath
Type: CRefPath
The identifier for the element to get the summary information.

Remarks

Implementers should return XmlCodeComment.Empty when the source is unable to resolve the path a comment in the source.


GetSummary(CRefPath)

GetSummary(CRefPath) Method

Returns just the summary element associated with the CRefPath.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract XmlCodeComment GetSummary(
    CRefPath crefPath
    )

Parameters

crefPath
Type: CRefPath
The identifier for the element to get the summary information.

Remarks

Implementers should return XmlCodeComment.Empty when the source is unable to resolve the path a comment in the source.


GetValue(CRefPath)

GetValue(CRefPath) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract XmlCodeComment GetValue(
    CRefPath crefPath
    )

Parameters

crefPath
Type: CRefPath


GetXml(CRefPath)

GetXml(CRefPath) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract string GetXml(
    CRefPath crefPath
    )

Parameters

crefPath
Type: CRefPath


ItalicXmlCodeElement

ItalicXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.ItalicXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ItalicXmlCodeElement : XmlCodeElement

The ItalicXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ItalicXmlCodeElement(XmlNode) |


ItalicXmlCodeElement Constructors

The ItalicXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ItalicXmlCodeElement(XmlNode) |


ItalicXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ItalicXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ListHeaderXmlCodeElement

ListHeaderXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ListHeaderXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ListHeaderXmlCodeElement : XmlContainerCodeElement

The ListHeaderXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ListHeaderXmlCodeElement(XmlNode) |


ListHeaderXmlCodeElement Constructors

The ListHeaderXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ListHeaderXmlCodeElement(XmlNode) |


ListHeaderXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ListHeaderXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ListItemXmlCodeElement

ListItemXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ListItemXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ListItemXmlCodeElement : XmlContainerCodeElement

The ListItemXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ListItemXmlCodeElement(XmlNode) |


ListItemXmlCodeElement Constructors

The ListItemXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ListItemXmlCodeElement(XmlNode) |


ListItemXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ListItemXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ListTypes

ListTypes Enumeration

An enumeration of the available types that a ListXmlCodeElementcan be.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum ListTypes : int

Members

Name | Description
Table | The list had a type of table and should be handled as a table.
Bullet | The list had a type of bullet and should be handled as a bulletted list.
Number | The list had a type of number and should be handled as a numbered list.


ListXmlCodeElement

ListXmlCodeElement Class

An internal representation of the list XML element.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ListXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ListXmlCodeElement : XmlContainerCodeElement

The ListXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ListXmlCodeElement(XmlNode) | Initialises a new instance of the ListXmlCodeElement class.

Methods

 | Name | Summary
public method | IsTable() | Checks the contents of the list to determine if it should be handled as a table or a list.

Properties

 | Name | Summary
public properties | ListType | Gets or sets the style for bullets displayed in this list.

Fields

 | Name | Description
private field | _listType |

Remarks

A list element can represent a numbered or bulletted list or a table by way of a type attribute. If no type attribute is specified it will default to a bulleted list.


ListXmlCodeElement Constructors

The ListXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ListXmlCodeElement(XmlNode) | Initialises a new instance of the ListXmlCodeElement class.


ListXmlCodeElement(XmlNode)

Initialises a new instance of the ListXmlCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ListXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The node the list is based on.


ListXmlCodeElement Fields

The ListXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _listType |


_listType

_listType Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ListTypes _listType


ListXmlCodeElement Methods

The ListXmlCodeElement type exposes the following members.

Methods

 | Name | Summary
public method | IsTable() | Checks the contents of the list to determine if it should be handled as a table or a list.


IsTable()

IsTable() Method

Checks the contents of the list to determine if it should be handled as a table or a list.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsTable()


ListXmlCodeElement Properties

The ListXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | ListType | Gets or sets the style for bullets displayed in this list.


ListType

ListType Property

Gets or sets the style for bullets displayed in this list.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ListTypes ListType {
    get;
    }


ParamRefXmlCodeElement

ParamRefXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.ParamRefXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ParamRefXmlCodeElement : XmlCodeElement

The ParamRefXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ParamRefXmlCodeElement(XmlNode) |


ParamRefXmlCodeElement Constructors

The ParamRefXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ParamRefXmlCodeElement(XmlNode) |


ParamRefXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ParamRefXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ParamXmlCodeElement

ParamXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ParamXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ParamXmlCodeElement : XmlContainerCodeElement

The ParamXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ParamXmlCodeElement(XmlNode) |

Properties

 | Name | Summary
public properties | Name() | The name of the parameter this code comment refers to.

Fields

 | Name | Description
private field | _name |


ParamXmlCodeElement Constructors

The ParamXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ParamXmlCodeElement(XmlNode) |


ParamXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ParamXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ParamXmlCodeElement Fields

The ParamXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _name |


_name

_name Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _name


ParamXmlCodeElement Properties

The ParamXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Name() | The name of the parameter this code comment refers to.


Name()

Name() Property

The name of the parameter this code comment refers to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


ParaXmlCodeElement

ParaXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ParaXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ParaXmlCodeElement : XmlContainerCodeElement

The ParaXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ParaXmlCodeElement(XmlNode) |


ParaXmlCodeElement Constructors

The ParaXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ParaXmlCodeElement(XmlNode) |


ParaXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ParaXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


PermissionXmlCodeElement

PermissionXmlCodeElement Class

Represents the permission XML code element.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.PermissionXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class PermissionXmlCodeElement : XmlContainerCodeElement

The PermissionXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | PermissionXmlCodeElement(XmlNode) | Initialises a new instance of the PermissionXmlCodeElement class.

Properties

 | Name | Summary
public properties | Member() | The member (i.e. permission set) this permission points to.

Fields

 | Name | Description
private field | _member |


PermissionXmlCodeElement Constructors

The PermissionXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | PermissionXmlCodeElement(XmlNode) | Initialises a new instance of the PermissionXmlCodeElement class.


PermissionXmlCodeElement(XmlNode)

Initialises a new instance of the PermissionXmlCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal PermissionXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The XML node representing the permission details.

Exceptions

Exception | Condition
AttributeRequiredException | The cref attribute was missing.


PermissionXmlCodeElement Fields

The PermissionXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _member |


PermissionXmlCodeElement Properties

The PermissionXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Member() | The member (i.e. permission set) this permission points to.


Member()

Member() Property

The member (i.e. permission set) this permission points to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath this[] {
    get;
    set;
    }


RemarksXmlCodeElement

RemarksXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.RemarksXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class RemarksXmlCodeElement : XmlContainerCodeElement

The RemarksXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | RemarksXmlCodeElement(XmlNode) |


RemarksXmlCodeElement Constructors

The RemarksXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | RemarksXmlCodeElement(XmlNode) |


RemarksXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal RemarksXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


ReturnsXmlCodeElement

ReturnsXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ReturnsXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ReturnsXmlCodeElement : XmlContainerCodeElement

The ReturnsXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ReturnsXmlCodeElement(XmlNode) |


ReturnsXmlCodeElement Constructors

The ReturnsXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ReturnsXmlCodeElement(XmlNode) |


ReturnsXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ReturnsXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


SeeAlsoXmlCodeElement

SeeAlsoXmlCodeElement Class

This XML element allows people to associate other useful elements to the current documentation. I.e. for further reading.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.SeeAlsoXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class SeeAlsoXmlCodeElement : XmlCodeElement

The SeeAlsoXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SeeAlsoXmlCodeElement(XmlNode) | Constructor

Properties

 | Name | Summary
public properties | Member() | Obtains the member this see also element refers to.

Fields

 | Name | Description
private field | _member |


SeeAlsoXmlCodeElement Constructors

The SeeAlsoXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SeeAlsoXmlCodeElement(XmlNode) | Constructor


SeeAlsoXmlCodeElement(XmlNode)

Constructor
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal SeeAlsoXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The node describing the seealso xml element.


SeeAlsoXmlCodeElement Fields

The SeeAlsoXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _member |


SeeAlsoXmlCodeElement Properties

The SeeAlsoXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Member() | Obtains the member this see also element refers to.


Member()

Member() Property

Obtains the member this see also element refers to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath this[] {
    get;
    set;
    }


SeeXmlCodeElement

SeeXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.SeeXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class SeeXmlCodeElement : XmlCodeElement

The SeeXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SeeXmlCodeElement(XmlNode) |

Properties

 | Name | Summary
public properties | Member() | The member this elements points to.

Fields

 | Name | Description
private field | _member |


SeeXmlCodeElement Constructors

The SeeXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SeeXmlCodeElement(XmlNode) |


SeeXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal SeeXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


SeeXmlCodeElement Fields

The SeeXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _member |


SeeXmlCodeElement Properties

The SeeXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Member() | The member this elements points to.


Member()

Member() Property

The member this elements points to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath this[] {
    get;
    set;
    }


SummaryXmlCodeElement

SummaryXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.SummaryXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class SummaryXmlCodeElement : XmlContainerCodeElement

The SummaryXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SummaryXmlCodeElement(XmlNode) |


SummaryXmlCodeElement Constructors

The SummaryXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SummaryXmlCodeElement(XmlNode) |


SummaryXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal SummaryXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


TermXmlCodeElement

TermXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.TermXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class TermXmlCodeElement : XmlContainerCodeElement

The TermXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TermXmlCodeElement(XmlNode) |


TermXmlCodeElement Constructors

The TermXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TermXmlCodeElement(XmlNode) |


TermXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TermXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


TextXmlCodeElement

TextXmlCodeElement Class

Not really an allowed xml code comment element; but this is used by the system to aid in the parsing of inline textual elements from other XmlCodeElement implementations.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.TextXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class TextXmlCodeElement : XmlCodeElement

The TextXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TextXmlCodeElement(XmlNode) | Initialises a new instance of the TextXmlCodeElement class.
private constructor | TextXmlCodeElement() |

Fields

 | Name | Description
private field | innerTextReplacement |
private field | titleTextReplacement |

Remarks

This class will only ever treat text as an inline element. Therefore it will strip multiple new lines and reduce them to single spaces. If the user wants the text over multiple lines they should use the para XmlCodeElement in their documentation.


TextXmlCodeElement Constructors

The TextXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TextXmlCodeElement(XmlNode) | Initialises a new instance of the TextXmlCodeElement class.
private constructor | TextXmlCodeElement() |


TextXmlCodeElement(XmlNode)

Initialises a new instance of the TextXmlCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TextXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode
The node containing the text.


TextXmlCodeElement()

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static TextXmlCodeElement()


TextXmlCodeElement Fields

The TextXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | innerTextReplacement |
private field | titleTextReplacement |


innerTextReplacement

innerTextReplacement Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Regex innerTextReplacement


titleTextReplacement

titleTextReplacement Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Regex titleTextReplacement


TypeParamRefXmlCodeElement

TypeParamRefXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.TypeParamRefXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class TypeParamRefXmlCodeElement : XmlCodeElement

The TypeParamRefXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TypeParamRefXmlCodeElement(XmlNode) |

Properties

 | Name | Summary
public properties | Name() | The name this parameter reference refers to.

Fields

 | Name | Description
private field | _name |


TypeParamRefXmlCodeElement Constructors

The TypeParamRefXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TypeParamRefXmlCodeElement(XmlNode) |


TypeParamRefXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeParamRefXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


TypeParamRefXmlCodeElement Fields

The TypeParamRefXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _name |


TypeParamRefXmlCodeElement Properties

The TypeParamRefXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Name() | The name this parameter reference refers to.


Name()

Name() Property

The name this parameter reference refers to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


TypeParamXmlCodeElement

TypeParamXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.TypeParamXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class TypeParamXmlCodeElement : XmlCodeElement

The TypeParamXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TypeParamXmlCodeElement(XmlNode) |

Properties

 | Name | Summary
public properties | Name() | The name this xml code element refers to.

Fields

 | Name | Description
private field | _name |


TypeParamXmlCodeElement Constructors

The TypeParamXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | TypeParamXmlCodeElement(XmlNode) |


TypeParamXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeParamXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


TypeParamXmlCodeElement Fields

The TypeParamXmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _name |


TypeParamXmlCodeElement Properties

The TypeParamXmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Name() | The name this xml code element refers to.


Name()

Name() Property

The name this xml code element refers to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


ValueXmlCodeElement

ValueXmlCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.ValueXmlCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class ValueXmlCodeElement : XmlContainerCodeElement

The ValueXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ValueXmlCodeElement(XmlNode) |


ValueXmlCodeElement Constructors

The ValueXmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | ValueXmlCodeElement(XmlNode) |


ValueXmlCodeElement(XmlNode)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal ValueXmlCodeElement(
XmlNode node
)

Parameters

node
Type: XmlNode


XmlCodeComment

XmlCodeComment Class

The details of the comments associated with a single member.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.XmlCodeComment
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class XmlCodeComment : XmlContainerCodeElement

The XmlCodeComment type exposes the following members.

Constructors

 | Class | Summary
private constructor | XmlCodeComment() | Static constructor
private constructor | XmlCodeComment() | Default constructor
sealed constructor | XmlCodeComment(XmlNode) | Initialises a new XmlCodeComment instance.

Properties

 | Name | Summary
public properties | Empty() | Gets a valid but empty XmlCodeComment reference.
public properties | Member() | The member which this XmlCodeComment is for.

Fields

 | Name | Description
private field | _empty |
private field | _member |


XmlCodeComment Constructors

The XmlCodeComment type exposes the following members.

Constructors

 | Class | Summary
private constructor | XmlCodeComment() | Static constructor
private constructor | XmlCodeComment() | Default constructor
sealed constructor | XmlCodeComment(XmlNode) | Initialises a new XmlCodeComment instance.


XmlCodeComment()

Static constructor
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static XmlCodeComment()


XmlCodeComment()

Default constructor
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XmlCodeComment()


XmlCodeComment(XmlNode)

Initialises a new XmlCodeComment instance.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal XmlCodeComment(
XmlNode node
)

Parameters

node
Type: XmlNode
The node to parse the comment details from.

Exceptions

Exception | Condition
System.ArgumentNullException | Thrown when the node is null.


XmlCodeComment Fields

The XmlCodeComment type exposes the following members.

Fields

 | Name | Description
private field | _empty |
private field | _member |


_empty

_empty Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XmlCodeComment _empty


XmlCodeComment Properties

The XmlCodeComment type exposes the following members.

Properties

 | Name | Summary
public properties | Empty() | Gets a valid but empty XmlCodeComment reference.
public properties | Member() | The member which this XmlCodeComment is for.


Empty()

Empty() Property

Gets a valid but empty XmlCodeComment reference.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeComment this[] {
    get;
    private set;
    }


Member()

Member() Property

The member which this XmlCodeComment is for.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CRefPath this[] {
    get;
    set;
    }


XmlCodeElement

XmlCodeElement Class

Base class for all the implementations of the XmlCodeComments.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.BoldXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.CodeXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.CXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.ErrorXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.ItalicXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.ParamRefXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.SeeAlsoXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.SeeXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.TextXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.TypeParamRefXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.TypeParamXmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract class XmlCodeElement

The XmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
protected constructor | XmlCodeElement(XmlCodeElements) | Initialises a new instance of the base class, to be called from all derived classes so the element type is populated.
private constructor | XmlCodeElement() |

Methods

 | Name | Summary
protected method | RemoveLeadingAndTrailingWhitespace(String) | Removes all the whitespace characters from the beginning and end of the provided content string.
protected method | RemoveNewLines(String) | Removes the new lines from all the areas in the string.

Properties

 | Name | Summary
public properties | Element | Gets the type of element this instance refers to.
public properties | IsBlock() | Indicates if this is a block level element.
public properties | IsInline() | Indicates if this is an inline level element.
public properties | Text() | Obtains a string value that contains the textual portion of the XmlCodeElement.

Fields

 | Name | Description
private field | _element |
private field | _isBlock |
private field | _isInline |
private field | _removeNewLines |
private field | _text |
sealed field | DefinedElements | Dictionary of all available XmlCodeElements and thier associated string representations.


XmlCodeElement Constructors

The XmlCodeElement type exposes the following members.

Constructors

 | Class | Summary
protected constructor | XmlCodeElement(XmlCodeElements) | Initialises a new instance of the base class, to be called from all derived classes so the element type is populated.
private constructor | XmlCodeElement() |


XmlCodeElement(XmlCodeElements)

Initialises a new instance of the base class, to be called from all derived classes so the element type is populated.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected XmlCodeElement(
XmlCodeElements element
)

Parameters

element
Type: XmlCodeElements
The type of element this instance represents.


XmlCodeElement()

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static XmlCodeElement()


XmlCodeElement Fields

The XmlCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _element |
private field | _isBlock |
private field | _isInline |
private field | _removeNewLines |
private field | _text |
sealed field | DefinedElements | Dictionary of all available XmlCodeElements and thier associated string representations.


_element

_element Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XmlCodeElements _element


_isBlock

_isBlock Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isBlock


_isInline

_isInline Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isInline


_removeNewLines

_removeNewLines Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Regex _removeNewLines


_text

_text Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _text


DefinedElements

DefinedElements Field

Dictionary of all available XmlCodeElements and thier associated string representations.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal Dictionary DefinedElements

Remarks

This was created because parsing enumerations uses reflection, which is slow, and also it may throw exceptions for types not supported; which could happen a lot.


XmlCodeElement Methods

The XmlCodeElement type exposes the following members.

Methods

 | Name | Summary
protected method | RemoveLeadingAndTrailingWhitespace(String) | Removes all the whitespace characters from the beginning and end of the provided content string.
protected method | RemoveNewLines(String) | Removes the new lines from all the areas in the string.


RemoveLeadingAndTrailingWhitespace(String)

RemoveLeadingAndTrailingWhitespace(String) Method

Removes all the whitespace characters from the beginning and end of the provided content string.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string RemoveLeadingAndTrailingWhitespace(
    string content
    )

Parameters

content
Type: String
The content to trim.


RemoveNewLines(String)

RemoveNewLines(String) Method

Removes the new lines from all the areas in the string.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string RemoveNewLines(
    string content
    )

Parameters

content
Type: String
The content to remove the new lines from.


XmlCodeElement Properties

The XmlCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Element | Gets the type of element this instance refers to.
public properties | IsBlock() | Indicates if this is a block level element.
public properties | IsInline() | Indicates if this is an inline level element.
public properties | Text() | Obtains a string value that contains the textual portion of the XmlCodeElement.


Element

Element Property

Gets the type of element this instance refers to.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeElements Element {
    get;
    }


IsBlock()

IsBlock() Property

Indicates if this is a block level element.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsInline()

IsInline() Property

Indicates if this is an inline level element.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


Text()

Text() Property

Obtains a string value that contains the textual portion of the XmlCodeElement.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


XmlCodeElementCollection

XmlCodeElementCollection Class

Manages a collection of XmlCodeElement instances.

Inheritance Hierarchy

  • System.Collections.Generic.List<>
    • TheBoxSoftware.Reflection.Comments.XmlCodeElementCollection
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class XmlCodeElementCollection : List<XmlCodeElement>

The XmlCodeElementCollection type exposes the following members.

Constructors

 | Class | Summary
public constructor | XmlCodeElementCollection() |


XmlCodeElementCollection Constructors

The XmlCodeElementCollection type exposes the following members.

Constructors

 | Class | Summary
public constructor | XmlCodeElementCollection() |


XmlCodeElementCollection()

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeElementCollection()


XmlCodeElements

XmlCodeElements Enumeration

Enumeration of supported XML Code Comment tags
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum XmlCodeElements : int

Members

Name | Description
C | The <c> tag gives you a way to indicate that text within a description should be marked as code. Use <code> to indicate multiple lines as code.
Code | The <code> tag gives you a way to indicate multiple lines as code. Use <c> to indicate that text within a description should be marked as code.
Example | The <example> tag lets you specify an example of how to use a method or other library member. This commonly involves using the <code> tag.
Exception | The <exception< tag lets you specify which exceptions can be thrown. This tag can be applied to definitions for methods, properties, events, and indexers.
Include | Used to point the compiler at an external comments file for the element being documented; this should never exist inside an xml comments file.
List | The <listheader> block is used to define the heading row of either a table or definition list. When defining a table, you only need to supply an entry for term in the heading. Each item in the list is specified with an <item> block. When creating a definition list, you will need to specify both term and description. However, for a table, bulleted list, or numbered list, you only need to supply an entry for description. A list or table can have as many <item> blocks as needed.
ListHeader | The <listheader> block is used to define the heading row of either a table or definition list. When defining a table, you only need to supply an entry for term in the heading. Further, the listheader is not required and should not be provided when a simple list is required.
ListItem | A list or table can have as many <item> blocks as needed.
Term | Only available in listheader and item elements of list blocks. This defines a term and is used when the list is to be presented as a definition list or a table.
Description | Only available in listheader and item elements of list blocks. This defines a description and is used when the list is to be presented as a definition list, list or table. If only the description is present the list will be presented as a simple list.
Para | The <para< tag is for use inside a tag, such as <summary>, <remarks>, or <returns>, and lets you add structure to the text.
Param | The <param< tag should be used in the comment for a method declaration to describe one of the parameters for the method.
ParamRef | The <paramref> tag gives you a way to indicate that a word in the code comments, for example in a <summary> or <remarks> block refers to a parameter. The XML file can be processed to format this word in some distinct way, such as with a bold or italic font.
Permission | The <permission> tag lets you document the access of a member. The PermissionSet class lets you specify access to a member.
Remarks | The <remarks> tag is used to add information about a type, supplementing the information specified with <summary>. This information is displayed in the Object Browser.
Returns | The <returns> tag should be used in the comment for a method declaration to describe the return value.
See | The <see> tag lets you specify a link from within text. Use <seealso> to indicate that text should be placed in a See Also section. Use the cref Attribute to create internal hyperlinks to documentation pages for code elements.
SeeAlso | The <seealso< tag lets you specify the text that you might want to appear in a See Also section. Use <see> to specify a link from within text.
Summary | The <summary< tag should be used to describe a type or a type member. Use <remarks > to add supplemental information to a type description. Use the cref Attribute to enable documentation tools such as Sandcastle to create internal hyperlinks to documentation pages for code elements. The text for the <summary> tag is the only source of information about the type in IntelliSense, and is also displayed in the Object Browser.
TypeParam | The <typeparam> tag should be used in the comment for a generic type or method declaration to describe a type parameter. Add a tag for each type parameter of the generic type or method.
TypeParamRef | Use this tag to enable consumers of the documentation file to format the word in some distinct way, for example in italics.
Value | The <value> tag lets you describe the value that a property represents. Note that when you add a property via code wizard in the Visual Studio .NET development environment, it will add a <summary> tag for the new property. You should then manually add a <value> tag to describe the value that the property represents.
B | The <b> tag lets you emphasise a portion of the comments.
I | The <i> tag lets you emphasise a portion of the comments.
Text | Not exactly an xml code element, but this is used by the parser to contain the textual elements stored in other XmlCodeElement instances.

Remarks

If this enumeration is increased make sure that the relevant modifications in the parsing methods XmlContainerCodeElement and the definition list is DefinedElements updated.


XmlCommentException

XmlCommentException Class

Describes errors that occur while using the members and methods defined to read XML code comments

Inheritance Hierarchy

  • System.Exception
    • TheBoxSoftware.Reflection.Comments.XmlCommentException
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class XmlCommentException : Exception,
    ISerializable,
    IExtendedException

The XmlCommentException type exposes the following members.

Constructors

 | Class | Summary
public constructor | XmlCommentException() | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String) | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String, String) | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String, Exception) | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String, String, Exception) | Initialises a new instance of the XmlCommentException.
protected constructor | XmlCommentException(SerializationInfo, StreamingContext) | Serialization constructor.

Methods

 | Name | Summary
public method | GetExtendedInformation() | Extracts as much information from the exception as possible and returns it as a formatted string.
public method | GetObjectData(SerializationInfo, StreamingContext) | Serializes the custom details of this exception to the SerializationInfo.

Properties

 | Name | Summary
public properties | Xml() | The XML of the comment that caused the exception.


XmlCommentException Constructors

The XmlCommentException type exposes the following members.

Constructors

 | Class | Summary
public constructor | XmlCommentException() | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String) | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String, String) | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String, Exception) | Initialises a new instance of the XmlCommentException.
public constructor | XmlCommentException(String, String, Exception) | Initialises a new instance of the XmlCommentException.
protected constructor | XmlCommentException(SerializationInfo, StreamingContext) | Serialization constructor.


XmlCommentException()

Initialises a new instance of the XmlCommentException.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCommentException()


XmlCommentException(String)

Initialises a new instance of the XmlCommentException.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCommentException(
string message
)

Parameters

message
Type: String
Message describing the error.


XmlCommentException(String, String)

Initialises a new instance of the XmlCommentException.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCommentException(
string xml,
string message
)

Parameters

xml
Type: String
The XML from the comment that caused the problem
message
Type: String
Message describing the error.


XmlCommentException(String, Exception)

Initialises a new instance of the XmlCommentException.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCommentException(
string message,
Exception innerException
)

Parameters

message
Type: String
Message describing the error.
innerException
Type: Exception
The thrown exception.


XmlCommentException(String, String, Exception)

Initialises a new instance of the XmlCommentException.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCommentException(
string xml,
string message,
Exception innerException
)

Parameters

xml
Type: String
The XML from the comment that caused the problem
message
Type: String
Message describing the error.
innerException
Type: Exception
The thrown exception.


XmlCommentException(SerializationInfo, StreamingContext)

Serialization constructor.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected XmlCommentException(
SerializationInfo info,
StreamingContext context
)

Parameters

info
Type: SerializationInfo
The info describing the exception.
context
Type: StreamingContext
The serialization context.


XmlCommentException Methods

The XmlCommentException type exposes the following members.

Methods

 | Name | Summary
public method | GetExtendedInformation() | Extracts as much information from the exception as possible and returns it as a formatted string.
public method | GetObjectData(SerializationInfo, StreamingContext) | Serializes the custom details of this exception to the SerializationInfo.


GetExtendedInformation()

GetExtendedInformation() Method

Extracts as much information from the exception as possible and returns it as a formatted string.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetExtendedInformation()


GetObjectData(SerializationInfo, StreamingContext)

GetObjectData(SerializationInfo, StreamingContext) Method

Serializes the custom details of this exception to the SerializationInfo.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
    )

Parameters

info
Type: SerializationInfo
The info to populate with custom details
context
Type: StreamingContext
The context


XmlCommentException Properties

The XmlCommentException type exposes the following members.

Properties

 | Name | Summary
public properties | Xml() | The XML of the comment that caused the exception.


Xml()

Xml() Property

The XML of the comment that caused the exception.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


XmlCommentFile

XmlCommentFile Class

Implementation of ICommentSource that uses an underlying XML Comment File.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCommentFile
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class XmlCommentFile: ICommentSource

The XmlCommentFile type exposes the following members.

Constructors

 | Class | Summary
public constructor | XmlCommentFile(String, IFileSystem) |

Methods

 | Name | Summary
public method | Exists() |
private method | FindCommentWithXPath(String) |
private method | FindXmlElement(String) |
public method | GetComment(CRefPath) |
public method | GetSummary(CRefPath) |
public method | GetValue(CRefPath) |
public method | GetXml(CRefPath) |
public method | Load() |

Properties

 | Name | Summary
public properties | IsLoaded |

Fields

 | Name | Description
private field | _document |
private field | _filename |
private field | _fileSystem |
private field | _isLoaded |
private field | _navigator |


XmlCommentFile Constructors

The XmlCommentFile type exposes the following members.

Constructors

 | Class | Summary
public constructor | XmlCommentFile(String, IFileSystem) |


XmlCommentFile(String, IFileSystem)

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCommentFile(
string filename,
IFileSystem fileSystem
)

Parameters

filename
Type: String
fileSystem
Type: IFileSystem


XmlCommentFile Fields

The XmlCommentFile type exposes the following members.

Fields

 | Name | Description
private field | _document |
private field | _filename |
private field | _fileSystem |
private field | _isLoaded |
private field | _navigator |


_document

_document Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XPathDocument _document


_filename

_filename Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _filename


_fileSystem

_fileSystem Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private IFileSystem _fileSystem


_isLoaded

_isLoaded Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isLoaded


_navigator

_navigator Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XPathNavigator _navigator


XmlCommentFile Methods

The XmlCommentFile type exposes the following members.

Methods

 | Name | Summary
public method | Exists() |
private method | FindCommentWithXPath(String) |
private method | FindXmlElement(String) |
public method | GetComment(CRefPath) |
public method | GetSummary(CRefPath) |
public method | GetValue(CRefPath) |
public method | GetXml(CRefPath) |
public method | Load() |


Exists()

Exists() Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool Exists()


FindCommentWithXPath(String)

FindCommentWithXPath(String) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XmlCodeComment FindCommentWithXPath(
    string xpath
    )

Parameters

xpath
Type: String


FindXmlElement(String)

FindXmlElement(String) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XmlNode FindXmlElement(
    string xpath
    )

Parameters

xpath
Type: String


GetComment(CRefPath)

GetComment(CRefPath) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeComment GetComment(
    CRefPath forMember
    )

Parameters

forMember
Type: CRefPath


GetSummary(CRefPath)

GetSummary(CRefPath) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeComment GetSummary(
    CRefPath forMember
    )

Parameters

forMember
Type: CRefPath


GetValue(CRefPath)

GetValue(CRefPath) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeComment GetValue(
    CRefPath forMember
    )

Parameters

forMember
Type: CRefPath


GetXml(CRefPath)

GetXml(CRefPath) Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetXml(
    CRefPath forMember
    )

Parameters

forMember
Type: CRefPath


Load()

Load() Method

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void Load()


XmlCommentFile Properties

The XmlCommentFile type exposes the following members.

Properties

 | Name | Summary
public properties | IsLoaded |


IsLoaded

IsLoaded Property

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsLoaded {
    get;
    }


XmlContainerCodeElement

XmlContainerCodeElement Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Comments.XmlCodeElement
      • TheBoxSoftware.Reflection.Comments.XmlContainerCodeElement
        • TheBoxSoftware.Reflection.Comments.DescriptionXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ExampleXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ExceptionXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ListHeaderXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ListItemXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ListXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ParamXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ParaXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.PermissionXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.RemarksXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ReturnsXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.SummaryXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.TermXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.ValueXmlCodeElement
        • TheBoxSoftware.Reflection.Comments.XmlCodeComment
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class XmlContainerCodeElement : XmlCodeElement

The XmlContainerCodeElement type exposes the following members.

Constructors

 | Class | Summary
protected constructor | XmlContainerCodeElement(XmlCodeElements) | Initialises a new instance of the XmlContainerCodeElement class.
sealed constructor | XmlContainerCodeElement() | Private default constructor

Methods

 | Name | Summary
protected method | Parse(XmlNode) | Parses the child elements in to instances of XmlCodeElementinstances and returns them as a collection.
sealed method | ParseChildren(XmlNode) | Parses the specified parentNode and returns the parsed elements.

Properties

 | Name | Summary
public properties | Elements() | Collection of all child elements for this XmlContainerCodeElement.

Fields

 | Name | Description
private field | _elements |


XmlContainerCodeElement Constructors

The XmlContainerCodeElement type exposes the following members.

Constructors

 | Class | Summary
protected constructor | XmlContainerCodeElement(XmlCodeElements) | Initialises a new instance of the XmlContainerCodeElement class.
sealed constructor | XmlContainerCodeElement() | Private default constructor


XmlContainerCodeElement(XmlCodeElements)

Initialises a new instance of the XmlContainerCodeElement class.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected XmlContainerCodeElement(
XmlCodeElements element
)

Parameters

element
Type: XmlCodeElements


XmlContainerCodeElement()

Private default constructor
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal XmlContainerCodeElement()

Remarks

It doesnt matter which type is passed through, this method can only be used internally. And currently helps with the static parse children method.


XmlContainerCodeElement Fields

The XmlContainerCodeElement type exposes the following members.

Fields

 | Name | Description
private field | _elements |


_elements

_elements Field

Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private XmlCodeElementCollection _elements


XmlContainerCodeElement Methods

The XmlContainerCodeElement type exposes the following members.

Methods

 | Name | Summary
protected method | Parse(XmlNode) | Parses the child elements in to instances of XmlCodeElementinstances and returns them as a collection.
sealed method | ParseChildren(XmlNode) | Parses the specified parentNode and returns the parsed elements.


Parse(XmlNode)

Parse(XmlNode) Method

Parses the child elements in to instances of XmlCodeElementinstances and returns them as a collection.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected XmlCodeElementCollection Parse(
    XmlNode parentNode
    )

Parameters

parentNode
Type: XmlNode
The block level element to parse.


ParseChildren(XmlNode)

ParseChildren(XmlNode) Method

Parses the specified parentNode and returns the parsed elements.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static XmlCodeElementCollection ParseChildren(
    XmlNode parentNode
    )

Parameters

parentNode
Type: XmlNode
The parent node to parse the xml code elements from.


XmlContainerCodeElement Properties

The XmlContainerCodeElement type exposes the following members.

Properties

 | Name | Summary
public properties | Elements() | Collection of all child elements for this XmlContainerCodeElement.


Elements()

Elements() Property

Collection of all child elements for this XmlContainerCodeElement.
Namespace: TheBoxSoftware.Reflection.CommentsAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public XmlCodeElementCollection this[] {
    get;
    set;
    }


TheBoxSoftware.Reflection.Core Namespaces

Namespace
TheBoxSoftware.Reflection.Core
TheBoxSoftware.Reflection.Core.COFF
TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolver
TheBoxSoftware.Reflection.Core.PE


TheBoxSoftware.Reflection.Core Namespace

Classes

 | Class | Summary
public class | ClrDirectoryNotFoundException | Thrown when the CLR directory can not be resolved due to the RVA of the directory not being correct or not resolving to a section in the file.
public class | Directory |
public class | FieldReader |
public class | NotAManagedLibraryException | Represents an error in the application where someone has attempted to load a native or non-managed library.
public class | Offset | Represents a cursor through a large file, the current value represents the current offset.
public class | PeCoffFile | Provides access to the details of a .NET PE/COFF file, implementation is from the pecoff_v8 Microsoft document.

Structures

 | Name | Summary
public structure | Version | Represents a version number


ClrDirectoryNotFoundException

ClrDirectoryNotFoundException Class

Thrown when the CLR directory can not be resolved due to the RVA of the directory not being correct or not resolving to a section in the file.

Inheritance Hierarchy

  • System.Exception
    • TheBoxSoftware.Reflection.Core.ClrDirectoryNotFoundException
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ClrDirectoryNotFoundException : Exception

The ClrDirectoryNotFoundException type exposes the following members.

Constructors

 | Class | Summary
public constructor | ClrDirectoryNotFoundException(String) |

Properties

 | Name | Summary
public properties | Filename |

Fields

 | Name | Description
private field | _filename |


ClrDirectoryNotFoundException Constructors

The ClrDirectoryNotFoundException type exposes the following members.

Constructors

 | Class | Summary
public constructor | ClrDirectoryNotFoundException(String) |


ClrDirectoryNotFoundException(String)

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ClrDirectoryNotFoundException(
string filename
)

Parameters

filename
Type: String


ClrDirectoryNotFoundException Fields

The ClrDirectoryNotFoundException type exposes the following members.

Fields

 | Name | Description
private field | _filename |


_filename

_filename Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _filename


ClrDirectoryNotFoundException Properties

The ClrDirectoryNotFoundException type exposes the following members.

Properties

 | Name | Summary
public properties | Filename |


Filename

Filename Property

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string Filename {
    get;
    }


Directory

Directory Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.Directory
      • TheBoxSoftware.Reflection.Core.COFF.CLRDirectory
      • TheBoxSoftware.Reflection.Core.COFF.MetadataDirectory
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class Directory

The Directory type exposes the following members.

Constructors

 | Class | Summary
public constructor | Directory() |

Methods

 | Name | Summary
public method | Create(DataDirectories, Byte[], UInt32) | Factory method for instantiating different directories from the file
public method | ReadDirectories(PeCoffFile) |

Properties

 | Name | Summary
public properties | Name() | The internal name of the directory

Fields

 | Name | Description
private field | _name |


Directory Constructors

The Directory type exposes the following members.

Constructors

 | Class | Summary
public constructor | Directory() |


Directory()

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Directory()


Directory Fields

The Directory type exposes the following members.

Fields

 | Name | Description
private field | _name |


_name

_name Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _name


Directory Methods

The Directory type exposes the following members.

Methods

 | Name | Summary
public method | Create(DataDirectories, Byte[], UInt32) | Factory method for instantiating different directories from the file
public method | ReadDirectories(PeCoffFile) |


Create(DataDirectories, Byte[], UInt32)

Create(DataDirectories, Byte[], UInt32) Method

Factory method for instantiating different directories from the file
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static Directory Create(
    DataDirectories directory,
    byte[] fileContents,
    uint address
    )

Parameters

directory
Type: DataDirectories
The type of directory to create
fileContents
Type: Byte
The contents of the file being read
address
Type: UInt32
The address of the directory


ReadDirectories(PeCoffFile)

ReadDirectories(PeCoffFile) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void ReadDirectories(
    PeCoffFile containingFile
    )

Parameters

containingFile
Type: PeCoffFile


Directory Properties

The Directory type exposes the following members.

Properties

 | Name | Summary
public properties | Name() | The internal name of the directory


Name()

Name() Property

The internal name of the directory
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


FieldReader

FieldReader Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.FieldReader
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static class FieldReader

The FieldReader type exposes the following members.

Methods

 | Name | Summary
public method | ToHexString(Byte[], Int32, Int32) |
public method | ToInt16(Byte[], Int32) |
public method | ToInt32(Byte[], Int32) |
public method | ToInt32(Byte[], Int32, Int32) |
public method | ToUInt16(Byte[], Int32) |
public method | ToUInt32(Byte[], Int32) |
public method | ToUInt32(Byte[], Int32, Int32) |


FieldReader Methods

The FieldReader type exposes the following members.

Methods

 | Name | Summary
public method | ToHexString(Byte[], Int32, Int32) |
public method | ToInt16(Byte[], Int32) |
public method | ToInt32(Byte[], Int32) |
public method | ToInt32(Byte[], Int32, Int32) |
public method | ToUInt16(Byte[], Int32) |
public method | ToUInt32(Byte[], Int32) |
public method | ToUInt32(Byte[], Int32, Int32) |


ToHexString(Byte[], Int32, Int32)

ToHexString(Byte[], Int32, Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static string ToHexString(
    byte[] source,
    int start,
    int length
    )

Parameters

source
Type: Byte
start
Type: Int32
length
Type: Int32


ToInt16(Byte[], Int32)

ToInt16(Byte[], Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static short ToInt16(
    byte[] value,
    int offset
    )

Parameters

value
Type: Byte
offset
Type: Int32


ToInt32(Byte[], Int32)

ToInt32(Byte[], Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static int ToInt32(
    byte[] value,
    int offset
    )

Parameters

value
Type: Byte
offset
Type: Int32


ToInt32(Byte[], Int32, Int32)

ToInt32(Byte[], Int32, Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static int ToInt32(
    byte[] value,
    int offset,
    int toRead
    )

Parameters

value
Type: Byte
offset
Type: Int32
toRead
Type: Int32


ToUInt16(Byte[], Int32)

ToUInt16(Byte[], Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static ushort ToUInt16(
    byte[] value,
    int offset
    )

Parameters

value
Type: Byte
offset
Type: Int32


ToUInt32(Byte[], Int32)

ToUInt32(Byte[], Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static uint ToUInt32(
    byte[] value,
    int offset
    )

Parameters

value
Type: Byte
offset
Type: Int32


ToUInt32(Byte[], Int32, Int32)

ToUInt32(Byte[], Int32, Int32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static uint ToUInt32(
    byte[] value,
    int offset,
    int toRead
    )

Parameters

value
Type: Byte
offset
Type: Int32
toRead
Type: Int32


NotAManagedLibraryException

NotAManagedLibraryException Class

Represents an error in the application where someone has attempted to load a native or non-managed library.

Inheritance Hierarchy

  • System.Exception
    • TheBoxSoftware.Reflection.Core.NotAManagedLibraryException
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class NotAManagedLibraryException : Exception

The NotAManagedLibraryException type exposes the following members.

Constructors

 | Class | Summary
public constructor | NotAManagedLibraryException(String) | Initialises a new instance of the NotAManagedLibraryException.


NotAManagedLibraryException Constructors

The NotAManagedLibraryException type exposes the following members.

Constructors

 | Class | Summary
public constructor | NotAManagedLibraryException(String) | Initialises a new instance of the NotAManagedLibraryException.


NotAManagedLibraryException(String)

Initialises a new instance of the NotAManagedLibraryException.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public NotAManagedLibraryException(
string message
)

Parameters

message
Type: String
The message describing the error.


Offset

Offset Class

Represents a cursor through a large file, the current value represents the current offset.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.Offset
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class Offset

The Offset type exposes the following members.

Constructors

 | Class | Summary
public constructor | Offset(Int32) | Initialises a new instance of the Offset structure

Methods

 | Name | Summary
public method | Shift(Int32) | Shifts the offset by the specified 'by' number, but returns the value before the shift operation.

Properties

 | Name | Summary
public properties | Current() | The current value of the offset

Fields

 | Name | Description
private field | _current |


Offset Constructors

The Offset type exposes the following members.

Constructors

 | Class | Summary
public constructor | Offset(Int32) | Initialises a new instance of the Offset structure


Offset(Int32)

Initialises a new instance of the Offset structure
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Offset(
int start
)

Parameters

start
Type: Int32
The starting offset


Offset Fields

The Offset type exposes the following members.

Fields

 | Name | Description
private field | _current |


_current

_current Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _current


Offset Methods

The Offset type exposes the following members.

Methods

 | Name | Summary
public method | Shift(Int32) | Shifts the offset by the specified 'by' number, but returns the value before the shift operation.


Shift(Int32)

Shift(Int32) Method

Shifts the offset by the specified 'by' number, but returns the value before the shift operation.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Shift(
    int by
    )

Parameters

by
Type: Int32
The number to shift the offset by

Remarks

This method allows the shift of the offset at the same time as its use allowing the current offset and its progression to be linked more closely making it more readable.


Offset Properties

The Offset type exposes the following members.

Properties

 | Name | Summary
public properties | Current() | The current value of the offset


Current()

Current() Property

The current value of the offset
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


PeCoffFile

PeCoffFile Class

Provides access to the details of a .NET PE/COFF file, implementation is from the pecoff_v8 Microsoft document.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.PeCoffFile
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class PeCoffFile

The PeCoffFile type exposes the following members.

Constructors

 | Class | Summary
public constructor | PeCoffFile(String, IFileSystem) | Initialises a new instance of the PeCoffFile

Methods

 | Name | Summary
public method | CanGetAddressFromRva(UInt32) |
private method | FindHeaderForRva(UInt32) |
sealed method | GetAddressFromRVA(UInt32) | Converts a Relative Virtual Address to a file offset
public method | GetMetadataDirectory() | Helper method to obtain the .NET metadata directory
public method | Initialise() |
private method | ReadDirectories(Dictionary<DataDirectories,DataDirectory>) | Reads the contents of the directories specified in the file header
private method | ReadFileContents() | Reads the contents of the PeCoff file in to our custom data structures
private method | ReadSectionHeaders(UInt16, Offset) | Reads the headers for all of the defined sections in the file

Properties

 | Name | Summary
public properties | Directories() | All of the directories for the PE/COFF file.
sealed properties | FileContents | The byte contents of the file.
public properties | FileName() | The full path and filename for the disk location of this PE/COFF file.
public properties | IsMetadataLoaded() | Indicates if the metadata has been loaded in its entirety from the PE/COFF file.
sealed properties | Map() | Internal mapping of metadata to reflected definitions.
public properties | SectionHeaders() | The headers for all the sections defined in the file

Fields

 | Name | Description
private field | _directories |
private field | _fileContents |
private field | _fileName |
private field | _fileSystem |
private field | _isMetadataLoaded |
private field | _map |
private field | _metadataDirectory |
private field | _sectionHeaders |
private constant | PeSignitureOffsetLocation |

See also

AssemblyDef


PeCoffFile Constructors

The PeCoffFile type exposes the following members.

Constructors

 | Class | Summary
public constructor | PeCoffFile(String, IFileSystem) | Initialises a new instance of the PeCoffFile


PeCoffFile(String, IFileSystem)

Initialises a new instance of the PeCoffFile
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PeCoffFile(
string filePath,
IFileSystem fileSystem
)

Parameters

filePath
Type: String
The physical location of the file
fileSystem
Type: IFileSystem
Object which can be used to access data from the file system


PeCoffFile Fields

The PeCoffFile type exposes the following members.

Fields

 | Name | Description
private field | _directories |
private field | _fileContents |
private field | _fileName |
private field | _fileSystem |
private field | _isMetadataLoaded |
private field | _map |
private field | _metadataDirectory |
private field | _sectionHeaders |
private constant | PeSignitureOffsetLocation |


_directories

_directories Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _directories


_fileContents

_fileContents Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _fileContents


_fileName

_fileName Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _fileName


_fileSystem

_fileSystem Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private IFileSystem _fileSystem


_isMetadataLoaded

_isMetadataLoaded Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isMetadataLoaded


_map

_map Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataToDefinitionMap _map


_metadataDirectory

_metadataDirectory Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataDirectory _metadataDirectory


_sectionHeaders

_sectionHeaders Field

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _sectionHeaders


PeSignitureOffsetLocation

PeSignitureOffsetLocation Constant

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const int PeSignitureOffsetLocation


PeCoffFile Methods

The PeCoffFile type exposes the following members.

Methods

 | Name | Summary
public method | CanGetAddressFromRva(UInt32) |
private method | FindHeaderForRva(UInt32) |
sealed method | GetAddressFromRVA(UInt32) | Converts a Relative Virtual Address to a file offset
public method | GetMetadataDirectory() | Helper method to obtain the .NET metadata directory
public method | Initialise() |
private method | ReadDirectories(Dictionary<DataDirectories,DataDirectory>) | Reads the contents of the directories specified in the file header
private method | ReadFileContents() | Reads the contents of the PeCoff file in to our custom data structures
private method | ReadSectionHeaders(UInt16, Offset) | Reads the headers for all of the defined sections in the file


CanGetAddressFromRva(UInt32)

CanGetAddressFromRva(UInt32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool CanGetAddressFromRva(
    uint rva
    )

Parameters

rva
Type: UInt32


FindHeaderForRva(UInt32)

FindHeaderForRva(UInt32) Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private SectionHeader FindHeaderForRva(
    uint rva
    )

Parameters

rva
Type: UInt32


GetAddressFromRVA(UInt32)

GetAddressFromRVA(UInt32) Method

Converts a Relative Virtual Address to a file offset
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal uint GetAddressFromRVA(
    uint rva
    )

Parameters

rva
Type: UInt32
The RVA to convert


GetMetadataDirectory()

GetMetadataDirectory() Method

Helper method to obtain the .NET metadata directory
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataDirectory GetMetadataDirectory()


Initialise()

Initialise() Method

Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void Initialise()


ReadDirectories(Dictionary<DataDirectories,DataDirectory>)

ReadDirectories(Dictionary<DataDirectories,DataDirectory>) Method

Reads the contents of the directories specified in the file header
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadDirectories(
    Dictionary<DataDirectories, DataDirectory> dataDirectories
    )

Parameters

dataDirectories
Type: Dictionary<,>
The data directories to initialise in hte PE header.


ReadFileContents()

ReadFileContents() Method

Reads the contents of the PeCoff file in to our custom data structures
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadFileContents()


ReadSectionHeaders(UInt16, Offset)

ReadSectionHeaders(UInt16, Offset) Method

Reads the headers for all of the defined sections in the file
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadSectionHeaders(
    ushort numberOfSections,
    Offset offset
    )

Parameters

numberOfSections
Type: UInt16
The number of sections in the file header to initialise.
offset
Type: Offset
The offset to the section headers


PeCoffFile Properties

The PeCoffFile type exposes the following members.

Properties

 | Name | Summary
public properties | Directories() | All of the directories for the PE/COFF file.
sealed properties | FileContents | The byte contents of the file.
public properties | FileName() | The full path and filename for the disk location of this PE/COFF file.
public properties | IsMetadataLoaded() | Indicates if the metadata has been loaded in its entirety from the PE/COFF file.
sealed properties | Map() | Internal mapping of metadata to reflected definitions.
public properties | SectionHeaders() | The headers for all the sections defined in the file


Directories()

Directories() Property

All of the directories for the PE/COFF file.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<DataDirectories, Directory> this[] {
    get;
    set;
    }


FileContents

FileContents Property

The byte contents of the file.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal byte[] FileContents {
    get;
    }


FileName()

FileName() Property

The full path and filename for the disk location of this PE/COFF file.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


IsMetadataLoaded()

IsMetadataLoaded() Property

Indicates if the metadata has been loaded in its entirety from the PE/COFF file.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


Map()

Map() Property

Internal mapping of metadata to reflected definitions.
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal MetadataToDefinitionMap this[] {
    get;
    set;
    }


SectionHeaders()

SectionHeaders() Property

The headers for all the sections defined in the file
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SectionHeader> this[] {
    get;
    set;
    }


Version

Version Structure

Represents a version number
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct Version

The Version type exposes the following members.

Constructors

 | Class | Summary
public constructor | Version(Int32, Int32, Int32, Int32) | Creates a new Version with the specified details
public constructor | Version(String, String, String, String) | Creates a new Version with the specified details

Methods

 | Name | Summary
public method | ToString() | Returns a string representation of this version specified as ">major<.>major<.>major<.>major<"

Fields

 | Name | Description
public field | Build | The build number
public field | Major | The major version number
public field | Minor | The minor version number
public field | Revision | The build revision number


Version Constructors

The Version type exposes the following members.

Constructors

 | Class | Summary
public constructor | Version(Int32, Int32, Int32, Int32) | Creates a new Version with the specified details
public constructor | Version(String, String, String, String) | Creates a new Version with the specified details


Version(Int32, Int32, Int32, Int32)

Creates a new Version with the specified details
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Version(
int major,
int minor,
int build,
int revision
)

Parameters

major
Type: Int32
The major number
minor
Type: Int32
The minor number
build
Type: Int32
The build number
revision
Type: Int32
The build revision


Version(String, String, String, String)

Creates a new Version with the specified details
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Version(
string major,
string minor,
string build,
string revision
)

Parameters

major
Type: String
The major number
minor
Type: String
The minor number
build
Type: String
The build number
revision
Type: String
The build revision


Version Fields

The Version type exposes the following members.

Fields

 | Name | Description
public field | Build | The build number
public field | Major | The major version number
public field | Minor | The minor version number
public field | Revision | The build revision number


Build

Build Field

The build number
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Build


Major

Major Field

The major version number
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Major


Minor

Minor Field

The minor version number
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Minor


Revision

Revision Field

The build revision number
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Revision


Version Methods

The Version type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Returns a string representation of this version specified as ">major<.>major<.>major<.>major<"


ToString()

ToString() Method

Returns a string representation of this version specified as ">major<.>major<.>major<.>major<"
Namespace: TheBoxSoftware.Reflection.CoreAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


TheBoxSoftware.Reflection.Core.COFF Namespace

Classes

 | Class | Summary
public class | AssemblyMetadataTableRow | Represents the details of an Assembly stored in metadata.
public class | AssemblyOSMetadataTableRow |
public class | AssemblyProcessorMetadataTableRow |
public class | AssemblyRefMetadataTableRow |
public class | AssemblyRefOSMetadataTableRow |
public class | AssemblyRefProcessorMetadataTableRow |
sealed class | BlobStream | The blob stream controls access to Signatures contained in the pe/coff file.
public class | ClassLayoutMetadataTableRow | Describes a layout of a type when it is required to be layed out the same as unmanaged structures
public class | CLRDirectory |
sealed class | CodedIndexResolver |
public class | ConstantMetadataTableRow | Used to store compile time, constant values for fields, parameters and properties
public class | Cor20Header |
public class | CustomAttributeMetadataTableRow |
public class | DeclSecurityMetadataTableRow | Security attributes which derive from SecurityAttribute, can be attached to TypeDef, a Method or an Assembly
public class | EventMapMetadataTableRow |
public class | EventMetadataTableRow |
public class | ExportedTypeMetadataTableRow | A type which is defined within other modules of this assembly. In essance, it stores TypeDef row numbers of all types tha are marked public in other modules that this Assembly comprises.
public class | FieldLayoutMetadataTableRow |
public class | FieldMarshalMetadataTableRow | Links an existing row in the Field or Param table to information in the blob heap that defines how that field or parameter should be marshalled.
public class | FieldMetadataTableRow |
public class | FieldRVAMetadataTableRow |
public class | FileMetadataTableRow |
public class | GenericParamConstraintMetadataTableRow |
public class | GenericParamMetadataTableRow |
public class | GuidStream | Represents the metadata GUID stream available in .net pe/coff files. And provides access to those details.
public class | ImplMapMetadataTableRow | Holds information about unmanaged methods that can be reached from managed code, using PInvoke dispatch.
public class | IndexDetails |
public class | InterfaceImplMetadataTableRow | Records the interfaces a type implements explicitly
public class | ManifestResourceMetadataTableRow |
public class | MemberRefMetadataTableRow |
public class | MetadataDirectory |
public class | MetadataHeader |
public class | MetadataRow |
public class | MetadataStream |
public class | MetadataTablesDictionary | Represents a dictionary of all of the metadata rows loaded from an assembly.
public class | MethodImplMetadataTableRow | Allows the compiler to override the default inheritance rules provided by the CLI.
public class | MethodMetadataTableRow | Describes a method definition loaded from the metadata tables in the pe/coff file.
public class | MethodSemanticsMetadataTableRow |
public class | MethodSpecMetadataTableRow |
public class | ModuleMetadataTableRow |
public class | ModuleRefMetadataTableRow | Created by a .module extern directive in the assembly
public class | NestedClassMetadataTableRow |
public class | ParamMetadataTableRow | Represents a single entry in the Param Metadata table.
public class | PropertyMapMetadataTableRow |
public class | PropertyMetadataTableRow |
public class | StandAloneSigMetadataTableRow |
public class | Stream |
public class | StringStream | The string stream which stores the strings for all metadata names and text.
public class | TypeDefMetadataTableRow |
public class | TypeRefMetadataTableRow |
public class | TypeSpecMetadataTableRow |
public class | USStream |

Structures

 | Name | Summary
public structure | BlobIndex | Represents an index in to the BlobHeap. This heap contains details such as Signatures and other userful metadata information.
public structure | CodedIndex | Represents a value which specifies both a table and an index in to that table from a single UInt16 or UInt32.
public structure | Index | Represents a simple index item, where the item is an entry in to - generall - a metadata table.
public structure | MetadataStreamHeader |
public structure | StringIndex | Represents an index in to the metadata StringStream.

Interfaces

 | Name | Summary
public interface | ICodedIndexResolver |
public interface | IIndexDetails |
public interface | IStringStream |

Enumerations

 | Name | Summary
public enum | AssemblyFlags |
public enum | AssemblyHashAlgorithms |
public enum | CodedIndexes |
public enum | Cor20Flags |
public enum | EventAttributes |
public enum | FieldAttributes | Enumeration of attributes defined against a field in the metadata.
public enum | FileAttributes |
public enum | GenericParamAttributes |
public enum | HeapOffsetSizes |
public enum | ManifestResourceAttributes |
public enum | MetadataTables | Enumeration of all the available metadata tables that can reside in a .net pe/coff file.
public enum | MethodAttributes |
public enum | MethodImplFlags | Flags describing a MethodMetadataTableRows implementation.
public enum | MethodSemanticsAttributes | An enumeration of available relationship references for methods to properties, events etc.
public enum | ParamAttributeFlags |
public enum | PInvokeAttributes |
public enum | PropertyAttributes | Flags for properties
public enum | Streams | Enumeration of all the streams that can be located in a PE/COFF file.
public enum | TypeAttributes |


AssemblyFlags

AssemblyFlags Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum AssemblyFlags : int

Members

Name | Description
PublicKey | The assembly reference holds the full (unhashed) public key.
SideBySideCompatible | The assembly is side-by-side compatible.
Reserved | Reserved
Retargetable | The implementation of this assembly at runtime is not expected to match the version seen at compile time.
EnableJitCompileTracking | Reserved. A conforming implementation of the CLI can ignore this setting on read; some implementations misht use this bit to indicate that a CIL-to-native-code compiler should generate CIL-to-native-code map.
DisableJitCompileOptimizer | Reserved (a conforming implementation of the CLI can ignor ethis setting on read; some implementations might use this bit to indicate that a CIL-to-native-code compiler should not generate optimised code.


AssemblyHashAlgorithms

AssemblyHashAlgorithms Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum AssemblyHashAlgorithms : uint

Members

Name | Description
None |
ReservedMD5 |
SHA1 |


AssemblyMetadataTableRow

AssemblyMetadataTableRow Class

Represents the details of an Assembly stored in metadata.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyMetadataTableRow : MetadataRow

The AssemblyMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the AssemblyMetadataTableRow class

Methods

 | Name | Summary
public method | GetVersion() | Returns a populated version class with the parsed version details for this assembly.

Properties

 | Name | Summary
public properties | BuildNumber() | Version details
public properties | Culture() | An index in to the string heap
public properties | Flags() | 4-byte bitmask of AssemblyFlags
public properties | HashAlgId() | 4-byte constant of AssemblyHashAlgorithm
public properties | MajorVersion() | Version details
public properties | MinorVersion() | Version details
public properties | Name() | An index in to the string heap
public properties | PublicKey() | An index in to the blob heap
public properties | RevisionNumber() | Version details

Fields

 | Name | Description
private field | _buildNumber |
private field | _culture |
private field | _flags |
private field | _hashAlgId |
private field | _majorVersion |
private field | _minorVersion |
private field | _nameIndex |
private field | _publicKey |
private field | _revisionNumber |

Remarks

Each PE/COFF file can only contain a reference to zero or one Assembly metadata row.


AssemblyMetadataTableRow Constructors

The AssemblyMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the AssemblyMetadataTableRow class


AssemblyMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the AssemblyMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails
Object which enables the retrieval of index sizes


AssemblyMetadataTableRow Fields

The AssemblyMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _buildNumber |
private field | _culture |
private field | _flags |
private field | _hashAlgId |
private field | _majorVersion |
private field | _minorVersion |
private field | _nameIndex |
private field | _publicKey |
private field | _revisionNumber |


_buildNumber

_buildNumber Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _buildNumber


_culture

_culture Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _culture


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private AssemblyFlags _flags


_hashAlgId

_hashAlgId Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private AssemblyHashAlgorithms _hashAlgId


_majorVersion

_majorVersion Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _majorVersion


_minorVersion

_minorVersion Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _minorVersion


_nameIndex

_nameIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _nameIndex


_publicKey

_publicKey Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _publicKey


_revisionNumber

_revisionNumber Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _revisionNumber


AssemblyMetadataTableRow Methods

The AssemblyMetadataTableRow type exposes the following members.

Methods

 | Name | Summary
public method | GetVersion() | Returns a populated version class with the parsed version details for this assembly.


GetVersion()

GetVersion() Method

Returns a populated version class with the parsed version details for this assembly.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Version GetVersion()


AssemblyMetadataTableRow Properties

The AssemblyMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | BuildNumber() | Version details
public properties | Culture() | An index in to the string heap
public properties | Flags() | 4-byte bitmask of AssemblyFlags
public properties | HashAlgId() | 4-byte constant of AssemblyHashAlgorithm
public properties | MajorVersion() | Version details
public properties | MinorVersion() | Version details
public properties | Name() | An index in to the string heap
public properties | PublicKey() | An index in to the blob heap
public properties | RevisionNumber() | Version details


BuildNumber()

BuildNumber() Property

Version details
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Culture()

Culture() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


Flags()

Flags() Property

4-byte bitmask of AssemblyFlags
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyFlags this[] {
    get;
    set;
    }


HashAlgId()

HashAlgId() Property

4-byte constant of AssemblyHashAlgorithm
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyHashAlgorithms this[] {
    get;
    set;
    }


MajorVersion()

MajorVersion() Property

Version details
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MinorVersion()

MinorVersion() Property

Version details
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Name()

Name() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


PublicKey()

PublicKey() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


RevisionNumber()

RevisionNumber() Property

Version details
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


AssemblyOSMetadataTableRow

AssemblyOSMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyOSMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyOSMetadataTableRow : MetadataRow

The AssemblyOSMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyOSMetadataTableRow(Byte[], Offset) | Initialises a new instance of the AssemblyOSMetadataTableRow class

Properties

 | Name | Summary
public properties | OSMajorVersion() | 4-byte constant
public properties | OSMinorVersion() | 4-byte constant
public properties | OSPlatformID() | 4-byte constant

Fields

 | Name | Description
private field | _osMajorVersion |
private field | _osMinorVersion |
private field | _osPlatformId |


AssemblyOSMetadataTableRow Constructors

The AssemblyOSMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyOSMetadataTableRow(Byte[], Offset) | Initialises a new instance of the AssemblyOSMetadataTableRow class


AssemblyOSMetadataTableRow(Byte[], Offset)

Initialises a new instance of the AssemblyOSMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyOSMetadataTableRow(
byte[] contents,
Offset offset
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the file


AssemblyOSMetadataTableRow Fields

The AssemblyOSMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _osMajorVersion |
private field | _osMinorVersion |
private field | _osPlatformId |


_osMajorVersion

_osMajorVersion Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _osMajorVersion


_osMinorVersion

_osMinorVersion Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _osMinorVersion


_osPlatformId

_osPlatformId Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _osPlatformId


AssemblyOSMetadataTableRow Properties

The AssemblyOSMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | OSMajorVersion() | 4-byte constant
public properties | OSMinorVersion() | 4-byte constant
public properties | OSPlatformID() | 4-byte constant


OSMajorVersion()

OSMajorVersion() Property

4-byte constant
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


OSMinorVersion()

OSMinorVersion() Property

4-byte constant
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


OSPlatformID()

OSPlatformID() Property

4-byte constant
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


AssemblyProcessorMetadataTableRow

AssemblyProcessorMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyProcessorMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyProcessorMetadataTableRow : MetadataRow

The AssemblyProcessorMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyProcessorMetadataTableRow(Byte[], Offset) | Initialises a new instance of the AssemblyProcessorMetadataTableRow class

Properties

 | Name | Summary
public properties | Processor() | 4-byte constant

Fields

 | Name | Description
private field | _processor |


AssemblyProcessorMetadataTableRow Constructors

The AssemblyProcessorMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyProcessorMetadataTableRow(Byte[], Offset) | Initialises a new instance of the AssemblyProcessorMetadataTableRow class


AssemblyProcessorMetadataTableRow(Byte[], Offset)

Initialises a new instance of the AssemblyProcessorMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyProcessorMetadataTableRow(
byte[] contents,
Offset offset
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset to the current row


AssemblyProcessorMetadataTableRow Fields

The AssemblyProcessorMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _processor |


_processor

_processor Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _processor


AssemblyProcessorMetadataTableRow Properties

The AssemblyProcessorMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Processor() | 4-byte constant


Processor()

Processor() Property

4-byte constant
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


AssemblyRefMetadataTableRow

AssemblyRefMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyRefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyRefMetadataTableRow : MetadataRow

The AssemblyRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRefMetadataTableRow() |
public constructor | AssemblyRefMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises an instance of the AssemblyRefMetadataTableRow class

Methods

 | Name | Summary
public method | GetVersion() | Returns a populated version class with the parsed version details for this assembly.

Properties

 | Name | Summary
public properties | BuildNumber() |
public properties | Culture() |
public properties | Flags() |
public properties | HashValue() |
public properties | MajorVersion() |
public properties | MinorVersion() |
public properties | Name() |
public properties | PublicKeyOrToken() |
public properties | RevisionNumber() |

Fields

 | Name | Description
private field | _buildNumber |
private field | _cultureIndex |
private field | _flags |
private field | _hashValue |
private field | _majorVersion |
private field | _minorVersion |
private field | _nameIndex |
private field | _publicKeyOrToken |
private field | _revisionNumber |


AssemblyRefMetadataTableRow Constructors

The AssemblyRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRefMetadataTableRow() |
public constructor | AssemblyRefMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises an instance of the AssemblyRefMetadataTableRow class


AssemblyRefMetadataTableRow()

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyRefMetadataTableRow()


AssemblyRefMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises an instance of the AssemblyRefMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyRefMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


AssemblyRefMetadataTableRow Fields

The AssemblyRefMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _buildNumber |
private field | _cultureIndex |
private field | _flags |
private field | _hashValue |
private field | _majorVersion |
private field | _minorVersion |
private field | _nameIndex |
private field | _publicKeyOrToken |
private field | _revisionNumber |


_cultureIndex

_cultureIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _cultureIndex


_hashValue

_hashValue Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _hashValue


_publicKeyOrToken

_publicKeyOrToken Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _publicKeyOrToken


AssemblyRefMetadataTableRow Methods

The AssemblyRefMetadataTableRow type exposes the following members.

Methods

 | Name | Summary
public method | GetVersion() | Returns a populated version class with the parsed version details for this assembly.


AssemblyRefMetadataTableRow Properties

The AssemblyRefMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | BuildNumber() |
public properties | Culture() |
public properties | Flags() |
public properties | HashValue() |
public properties | MajorVersion() |
public properties | MinorVersion() |
public properties | Name() |
public properties | PublicKeyOrToken() |
public properties | RevisionNumber() |


BuildNumber()

BuildNumber() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Culture()

Culture() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


Flags()

Flags() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyFlags this[] {
    get;
    set;
    }


HashValue()

HashValue() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


MajorVersion()

MajorVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MinorVersion()

MinorVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Name()

Name() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


PublicKeyOrToken()

PublicKeyOrToken() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


RevisionNumber()

RevisionNumber() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


AssemblyRefOSMetadataTableRow

AssemblyRefOSMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyRefOSMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyRefOSMetadataTableRow : MetadataRow

The AssemblyRefOSMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRefOSMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of AssemblyRefOSMetadataTableRow

Properties

 | Name | Summary
public properties | AssemblyRef() |
public properties | OSMajorVersion() |
public properties | OSMinorVersion() |
public properties | OSPlatformID() |

Fields

 | Name | Description
private field | _assemblyRef |
private field | _osMajorVersion |
private field | _osMinorVersion |
private field | _osPlatformId |


AssemblyRefOSMetadataTableRow Constructors

The AssemblyRefOSMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRefOSMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of AssemblyRefOSMetadataTableRow


AssemblyRefOSMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of AssemblyRefOSMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyRefOSMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


AssemblyRefOSMetadataTableRow Fields

The AssemblyRefOSMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _assemblyRef |
private field | _osMajorVersion |
private field | _osMinorVersion |
private field | _osPlatformId |


_assemblyRef

_assemblyRef Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _assemblyRef


AssemblyRefOSMetadataTableRow Properties

The AssemblyRefOSMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | AssemblyRef() |
public properties | OSMajorVersion() |
public properties | OSMinorVersion() |
public properties | OSPlatformID() |


AssemblyRef()

AssemblyRef() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


OSMajorVersion()

OSMajorVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


OSMinorVersion()

OSMinorVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


OSPlatformID()

OSPlatformID() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


AssemblyRefProcessorMetadataTableRow

AssemblyRefProcessorMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyRefProcessorMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class AssemblyRefProcessorMetadataTableRow : MetadataRow

The AssemblyRefProcessorMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRefProcessorMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the AssemblyRefProcessorMetadataTableRow class

Properties

 | Name | Summary
public properties | AssemblyRef() |
public properties | Processor() |

Fields

 | Name | Description
private field | _assemblyRef |
private field | _processor |


AssemblyRefProcessorMetadataTableRow Constructors

The AssemblyRefProcessorMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | AssemblyRefProcessorMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the AssemblyRefProcessorMetadataTableRow class


AssemblyRefProcessorMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the AssemblyRefProcessorMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public AssemblyRefProcessorMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


AssemblyRefProcessorMetadataTableRow Fields

The AssemblyRefProcessorMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _assemblyRef |
private field | _processor |


AssemblyRefProcessorMetadataTableRow Properties

The AssemblyRefProcessorMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | AssemblyRef() |
public properties | Processor() |


Processor()

Processor() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


BlobIndex

BlobIndex Structure

Represents an index in to the BlobHeap. This heap contains details such as Signatures and other userful metadata information.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct BlobIndex

The BlobIndex type exposes the following members.

Constructors

 | Class | Summary
public constructor | BlobIndex(Byte, Byte[], Signatures, Offset) |

Fields

 | Name | Description
public field | SignitureType |
public field | Value |


BlobIndex Constructors

The BlobIndex type exposes the following members.

Constructors

 | Class | Summary
public constructor | BlobIndex(Byte, Byte[], Signatures, Offset) |


BlobIndex(Byte, Byte[], Signatures, Offset)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BlobIndex(
byte sizeOfBlobIndexes,
byte[] fileContents,
Signatures signitureType,
Offset offset
)

Parameters

sizeOfBlobIndexes
Type: Byte
fileContents
Type: Byte
signitureType
Type: Signatures
offset
Type: Offset


BlobIndex Fields

The BlobIndex type exposes the following members.

Fields

 | Name | Description
public field | SignitureType |
public field | Value |


SignitureType

SignitureType Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Signatures SignitureType


Value

Value Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint Value


BlobStream

BlobStream Class

The blob stream controls access to Signatures contained in the pe/coff file.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Stream
      • TheBoxSoftware.Reflection.Core.COFF.BlobStream
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class BlobStream : Stream

The BlobStream type exposes the following members.

Constructors

 | Class | Summary
public constructor | BlobStream(Byte[], UInt32, Int32) | Initialises a new instance of the BlobStream class

Methods

 | Name | Summary
public method | GetByte(Int32) |
public method | GetLength(Int32) |
sealed method | GetLength() |
public method | GetRange(Int32, UInt32) |
public method | GetSigniture(UInt32, Signatures) | Retrives a parsed Signature for the specified startOffset and signiture type.
public method | GetSignitureContents(Int32) | Obtains the contents of the signiture as a byte array.

Fields

 | Name | Description
private field | _streamContents |


BlobStream Constructors

The BlobStream type exposes the following members.

Constructors

 | Class | Summary
public constructor | BlobStream(Byte[], UInt32, Int32) | Initialises a new instance of the BlobStream class


BlobStream(Byte[], UInt32, Int32)

Initialises a new instance of the BlobStream class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BlobStream(
byte[] copyFromContents,
uint address,
int size
)

Parameters

copyFromContents
Type: Byte
The array from which to copy the contents of the BlobStream from. Generall PeCoffFile.FileContents.
address
Type: UInt32
The start address of the blob stream
size
Type: Int32
The size of the stream


BlobStream Fields

The BlobStream type exposes the following members.

Fields

 | Name | Description
private field | _streamContents |


_streamContents

_streamContents Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _streamContents


BlobStream Methods

The BlobStream type exposes the following members.

Methods

 | Name | Summary
public method | GetByte(Int32) |
public method | GetLength(Int32) |
sealed method | GetLength() |
public method | GetRange(Int32, UInt32) |
public method | GetSigniture(UInt32, Signatures) | Retrives a parsed Signature for the specified startOffset and signiture type.
public method | GetSignitureContents(Int32) | Obtains the contents of the signiture as a byte array.


GetByte(Int32)

GetByte(Int32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte GetByte(
    int offset
    )

Parameters

offset
Type: Int32


GetLength(Int32)

GetLength(Int32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint GetLength(
    int offset
    )

Parameters

offset
Type: Int32


GetLength()

GetLength() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal int GetLength()


GetRange(Int32, UInt32)

GetRange(Int32, UInt32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte[] GetRange(
    int offset,
    uint size
    )

Parameters

offset
Type: Int32
size
Type: UInt32


GetSigniture(UInt32, Signatures)

GetSigniture(UInt32, Signatures) Method

Retrives a parsed Signature for the specified startOffset and signiture type.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Signature GetSigniture(
    uint startOffset,
    Signatures signiture
    )

Parameters

startOffset
Type: UInt32
The start of the signiture in the stream.
signiture
Type: Signatures
The type of signiture to parse.


GetSignitureContents(Int32)

GetSignitureContents(Int32) Method

Obtains the contents of the signiture as a byte array.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte[] GetSignitureContents(
    int startOffset
    )

Parameters

startOffset
Type: Int32
The start offset of the signiture in the stream.


ClassLayoutMetadataTableRow

ClassLayoutMetadataTableRow Class

Describes a layout of a type when it is required to be layed out the same as unmanaged structures

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ClassLayoutMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ClassLayoutMetadataTableRow : MetadataRow

The ClassLayoutMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ClassLayoutMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the ClassLayoutMetadataTableRow

Properties

 | Name | Summary
public properties | ClassSize() |
public properties | PackingSize() |
public properties | Parent() |

Fields

 | Name | Description
private field | _classSize |
private field | _packingSize |
private field | _parentIndex |


ClassLayoutMetadataTableRow Constructors

The ClassLayoutMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ClassLayoutMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the ClassLayoutMetadataTableRow


ClassLayoutMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the ClassLayoutMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ClassLayoutMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of this row
indexDetails
Type: IIndexDetails


ClassLayoutMetadataTableRow Fields

The ClassLayoutMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _classSize |
private field | _packingSize |
private field | _parentIndex |


_classSize

_classSize Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _classSize


_packingSize

_packingSize Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _packingSize


_parentIndex

_parentIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _parentIndex


ClassLayoutMetadataTableRow Properties

The ClassLayoutMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | ClassSize() |
public properties | PackingSize() |
public properties | Parent() |


ClassSize()

ClassSize() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


PackingSize()

PackingSize() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Parent()

Parent() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


CLRDirectory

CLRDirectory Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.Directory
      • TheBoxSoftware.Reflection.Core.COFF.CLRDirectory
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class CLRDirectory : Directory

The CLRDirectory type exposes the following members.

Constructors

 | Class | Summary
public constructor | CLRDirectory(Byte[], UInt32) |

Methods

 | Name | Summary
public method | ReadDirectories(PeCoffFile) |

Properties

 | Name | Summary
public properties | Header() |
public properties | Metadata() |

Fields

 | Name | Description
private field | _header |
private field | _metadata |


CLRDirectory Constructors

The CLRDirectory type exposes the following members.

Constructors

 | Class | Summary
public constructor | CLRDirectory(Byte[], UInt32) |


CLRDirectory(Byte[], UInt32)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CLRDirectory(
byte[] fileContents,
uint address
)

Parameters

fileContents
Type: Byte
address
Type: UInt32


CLRDirectory Fields

The CLRDirectory type exposes the following members.

Fields

 | Name | Description
private field | _header |
private field | _metadata |


_header

_header Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Cor20Header _header


_metadata

_metadata Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataDirectory _metadata


CLRDirectory Methods

The CLRDirectory type exposes the following members.

Methods

 | Name | Summary
public method | ReadDirectories(PeCoffFile) |


ReadDirectories(PeCoffFile)

ReadDirectories(PeCoffFile) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void ReadDirectories(
    PeCoffFile containingFile
    )

Parameters

containingFile
Type: PeCoffFile


CLRDirectory Properties

The CLRDirectory type exposes the following members.

Properties

 | Name | Summary
public properties | Header() |
public properties | Metadata() |


Header()

Header() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Cor20Header this[] {
    get;
    set;
    }


Metadata()

Metadata() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataDirectory this[] {
    get;
    set;
    }


CodedIndex

CodedIndex Structure

Represents a value which specifies both a table and an index in to that table from a single UInt16 or UInt32.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct CodedIndex

The CodedIndex type exposes the following members.

Constructors

 | Class | Summary
public constructor | CodedIndex(MetadataTables, UInt32) | Initialises a already determined instance of a CodedIndex class.

Methods

 | Name | Summary
public method | ToString() | Returns a string representation of this coded index

Properties

 | Name | Summary
public properties | Index() |
public properties | Table() |

Fields

 | Name | Description
private field | _index |
private field | _table |


CodedIndex Constructors

The CodedIndex type exposes the following members.

Constructors

 | Class | Summary
public constructor | CodedIndex(MetadataTables, UInt32) | Initialises a already determined instance of a CodedIndex class.


CodedIndex(MetadataTables, UInt32)

Initialises a already determined instance of a CodedIndex class.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex(
MetadataTables table,
uint index
)

Parameters

table
Type: MetadataTables
The table the coded index is for
index
Type: UInt32
The index in the table


CodedIndex Fields

The CodedIndex type exposes the following members.

Fields

 | Name | Description
private field | _index |
private field | _table |


_index

_index Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _index


_table

_table Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataTables _table


CodedIndex Methods

The CodedIndex type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Returns a string representation of this coded index


ToString()

ToString() Method

Returns a string representation of this coded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


CodedIndex Properties

The CodedIndex type exposes the following members.

Properties

 | Name | Summary
public properties | Index() |
public properties | Table() |


Index()

Index() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Table()

Table() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataTables this[] {
    get;
    set;
    }


CodedIndexes

CodedIndexes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum CodedIndexes : byte

Members

Name | Description
TypeDefOrRef |
HasConstant |
HasCustomAttribute |
HasFieldMarshall |
HasDeclSecurity |
MemberRefParent |
HasSemantics |
MethodDefOrRef |
MemberForwarded |
Implementation |
CustomAttributeType |
ResolutionScope |
TypeOrMethodDef |


CodedIndexResolver

CodedIndexResolver Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolver
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class CodedIndexResolver: ICodedIndexResolver

The CodedIndexResolver type exposes the following members.

Constructors

 | Class | Summary
public constructor | CodedIndexResolver(Dictionary<MetadataTables,Int32>) |

Methods

 | Name | Summary
private method | BuildDetailsMap(Dictionary<MetadataTables,Int32>) |
private method | DecodeIndex(UInt32, IndexDetails) |
private method | DetermineDetailsForIndexType(CodedIndexes) |
public method | GetSizeOfIndex(CodedIndexes) |
public method | Resolve(CodedIndexes, UInt32) |

Fields

 | Name | Description
private field | _detailsMap |


CodedIndexResolver Constructors

The CodedIndexResolver type exposes the following members.

Constructors

 | Class | Summary
public constructor | CodedIndexResolver(Dictionary<MetadataTables,Int32>) |


CodedIndexResolver(Dictionary<MetadataTables,Int32>)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndexResolver(
Dictionary<MetadataTables, int> rowsPerTableData
)

Parameters

rowsPerTableData
Type: Dictionary<,>


CodedIndexResolver Fields

The CodedIndexResolver type exposes the following members.

Fields

 | Name | Description
private field | _detailsMap |


_detailsMap

_detailsMap Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _detailsMap


CodedIndexResolver Methods

The CodedIndexResolver type exposes the following members.

Methods

 | Name | Summary
private method | BuildDetailsMap(Dictionary<MetadataTables,Int32>) |
private method | DecodeIndex(UInt32, IndexDetails) |
private method | DetermineDetailsForIndexType(CodedIndexes) |
public method | GetSizeOfIndex(CodedIndexes) |
public method | Resolve(CodedIndexes, UInt32) |


BuildDetailsMap(Dictionary<MetadataTables,Int32>)

BuildDetailsMap(Dictionary<MetadataTables,Int32>) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary<CodedIndexes, IndexDetails> BuildDetailsMap(
    Dictionary<MetadataTables, int> rowsPerTableData
    )

Parameters

rowsPerTableData
Type: Dictionary<,>


DecodeIndex(UInt32, IndexDetails)

DecodeIndex(UInt32, IndexDetails) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex DecodeIndex(
    uint value,
    IndexDetails withDetails
    )

Parameters

value
Type: UInt32
withDetails
Type: IndexDetails


DetermineDetailsForIndexType(CodedIndexes)

DetermineDetailsForIndexType(CodedIndexes) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private IndexDetails DetermineDetailsForIndexType(
    CodedIndexes codedIndex
    )

Parameters

codedIndex
Type: CodedIndexes


GetSizeOfIndex(CodedIndexes)

GetSizeOfIndex(CodedIndexes) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int GetSizeOfIndex(
    CodedIndexes indexType
    )

Parameters

indexType
Type: CodedIndexes


Resolve(CodedIndexes, UInt32)

Resolve(CodedIndexes, UInt32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex Resolve(
    CodedIndexes indexType,
    uint value
    )

Parameters

indexType
Type: CodedIndexes
value
Type: UInt32


ConstantMetadataTableRow

ConstantMetadataTableRow Class

Used to store compile time, constant values for fields, parameters and properties

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ConstantMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ConstantMetadataTableRow : MetadataRow

The ConstantMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstantMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ConstantMetadataTableRow

Properties

 | Name | Summary
public properties | Parent() | An index in to the Param, Field, or Property table. More precisely a HasConstant coded index
public properties | Type() | The type of field that represents the constant.
public properties | Value() | An index in to the Blob heap

Fields

 | Name | Description
private field | _parentIndex |
private field | _type |
private field | _valueIndex |

Remarks

Note that constant information does not directly influence runtime behaviour, although it is visible via reflection. Compilers inspect this information, at compile time, when importing metadata, but the value of the constant itself, if used, becomes embedded in into the CIL stream the compiler emits. There are no CIL instructions to access constant table at runtime.


ConstantMetadataTableRow Constructors

The ConstantMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstantMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ConstantMetadataTableRow


ConstantMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the ConstantMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ConstantMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents fo the file
offset
Type: Offset
The offset for the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


ConstantMetadataTableRow Fields

The ConstantMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _parentIndex |
private field | _type |
private field | _valueIndex |


_parentIndex

_parentIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _parentIndex


_type

_type Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ElementTypes _type


_valueIndex

_valueIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobIndex _valueIndex


ConstantMetadataTableRow Properties

The ConstantMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Parent() | An index in to the Param, Field, or Property table. More precisely a HasConstant coded index
public properties | Type() | The type of field that represents the constant.
public properties | Value() | An index in to the Blob heap


Parent()

Parent() Property

An index in to the Param, Field, or Property table. More precisely a HasConstant coded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Type()

Type() Property

The type of field that represents the constant.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypes this[] {
    get;
    set;
    }

Remarks

For a nullref value for FieldInit in ilasm is ELEMENT_TYPE_CLASSwith a 4-byte zero. Unlike uses of ELEMENT_TYPE_CLASS in Signatures, this one is not followed by a type token.


Value()

Value() Property

An index in to the Blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BlobIndex this[] {
    get;
    set;
    }


Cor20Flags

Cor20Flags Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum Cor20Flags : ulong

Members

Name | Description
ILOnly | The image file contains IL code only
Bit32Required | The image file can only be loaded in to a 32bit process
ILLibrary | This flag is obsolete
StrongNameSigned | The image file is protected with a strong name signiture
TrackedDebugData | The loader and the JIT compiler are required to track debug information


Cor20Header

Cor20Header Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Cor20Header
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class Cor20Header

The Cor20Header type exposes the following members.

Constructors

 | Class | Summary
public constructor | Cor20Header(Byte[], UInt32) |

Methods

 | Name | Summary
private method | GetRange(Byte[], Offset, Int32) |

Properties

 | Name | Summary
public properties | CB() | Size of the header in bytes
public properties | CodeManagerTable() | Reserved must be zero (first release of the runtime)
public properties | EntryPointToken() | Metadata identifier of the entry poitn for the image file. Can be 0 for DLL images. This field identifies a method belonging to this module or a module containing the entry point method.
public properties | ExportAddressTableJumps() | RVA and size of an array of addresses of jump thunks
public properties | Flags() |
public properties | MajorRuntimeVersion() | Major portion of the minimum version of the runtime required
public properties | ManagedNativeHeader() | Reserved set to zero
public properties | MetaData() | RVA and size of the meta data
public properties | MinorRuntimeVersion() | Minor portion of the minimum version of the runtime required
public properties | Resources() | RVA and size of managed resources
public properties | StrongNameSigniture() | RVA and size of the hash data fo rthis PE file, used by the loader for binding and versioning.
public properties | VTableFixups() | RVA and size in butes of an array of virtual table (v-table) fixups. Among current managed compilers, only the MC++ compiler and linker and the ILAsm compiler can produce this array.

Fields

 | Name | Description
private field | _cb |
private field | _codeManagerTable |
private field | _entryPointToken |
private field | _exportAddressTableJumps |
private field | _flags |
private field | _majorRuntimeVersion |
private field | _managedNativeHeader |
private field | _metadata |
private field | _minorRuntimeVersion |
private field | _resources |
private field | _strongNameSigniture |
private field | _vtableFixups |


Cor20Header Constructors

The Cor20Header type exposes the following members.

Constructors

 | Class | Summary
public constructor | Cor20Header(Byte[], UInt32) |


Cor20Header(Byte[], UInt32)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Cor20Header(
byte[] fileContents,
uint address
)

Parameters

fileContents
Type: Byte
address
Type: UInt32


Cor20Header Fields

The Cor20Header type exposes the following members.

Fields

 | Name | Description
private field | _cb |
private field | _codeManagerTable |
private field | _entryPointToken |
private field | _exportAddressTableJumps |
private field | _flags |
private field | _majorRuntimeVersion |
private field | _managedNativeHeader |
private field | _metadata |
private field | _minorRuntimeVersion |
private field | _resources |
private field | _strongNameSigniture |
private field | _vtableFixups |


_cb

_cb Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _cb


_codeManagerTable

_codeManagerTable Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _codeManagerTable


_entryPointToken

_entryPointToken Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _entryPointToken


_exportAddressTableJumps

_exportAddressTableJumps Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _exportAddressTableJumps


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Cor20Flags _flags


_majorRuntimeVersion

_majorRuntimeVersion Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _majorRuntimeVersion


_managedNativeHeader

_managedNativeHeader Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _managedNativeHeader


_metadata

_metadata Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _metadata


_minorRuntimeVersion

_minorRuntimeVersion Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _minorRuntimeVersion


_resources

_resources Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _resources


_strongNameSigniture

_strongNameSigniture Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _strongNameSigniture


_vtableFixups

_vtableFixups Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectory _vtableFixups


Cor20Header Methods

The Cor20Header type exposes the following members.

Methods

 | Name | Summary
private method | GetRange(Byte[], Offset, Int32) |


GetRange(Byte[], Offset, Int32)

GetRange(Byte[], Offset, Int32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte[] GetRange(
    byte[] fileContents,
    Offset start,
    int length
    )

Parameters

fileContents
Type: Byte
start
Type: Offset
length
Type: Int32


Cor20Header Properties

The Cor20Header type exposes the following members.

Properties

 | Name | Summary
public properties | CB() | Size of the header in bytes
public properties | CodeManagerTable() | Reserved must be zero (first release of the runtime)
public properties | EntryPointToken() | Metadata identifier of the entry poitn for the image file. Can be 0 for DLL images. This field identifies a method belonging to this module or a module containing the entry point method.
public properties | ExportAddressTableJumps() | RVA and size of an array of addresses of jump thunks
public properties | Flags() |
public properties | MajorRuntimeVersion() | Major portion of the minimum version of the runtime required
public properties | ManagedNativeHeader() | Reserved set to zero
public properties | MetaData() | RVA and size of the meta data
public properties | MinorRuntimeVersion() | Minor portion of the minimum version of the runtime required
public properties | Resources() | RVA and size of managed resources
public properties | StrongNameSigniture() | RVA and size of the hash data fo rthis PE file, used by the loader for binding and versioning.
public properties | VTableFixups() | RVA and size in butes of an array of virtual table (v-table) fixups. Among current managed compilers, only the MC++ compiler and linker and the ILAsm compiler can produce this array.


CB()

CB() Property

Size of the header in bytes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


CodeManagerTable()

CodeManagerTable() Property

Reserved must be zero (first release of the runtime)
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


EntryPointToken()

EntryPointToken() Property

Metadata identifier of the entry poitn for the image file. Can be 0 for DLL images. This field identifies a method belonging to this module or a module containing the entry point method.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


ExportAddressTableJumps()

ExportAddressTableJumps() Property

RVA and size of an array of addresses of jump thunks
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


Flags()

Flags() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Cor20Flags this[] {
    get;
    set;
    }


MajorRuntimeVersion()

MajorRuntimeVersion() Property

Major portion of the minimum version of the runtime required
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


ManagedNativeHeader()

ManagedNativeHeader() Property

Reserved set to zero
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


MetaData()

MetaData() Property

RVA and size of the meta data
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


MinorRuntimeVersion()

MinorRuntimeVersion() Property

Minor portion of the minimum version of the runtime required
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Resources()

Resources() Property

RVA and size of managed resources
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


StrongNameSigniture()

StrongNameSigniture() Property

RVA and size of the hash data fo rthis PE file, used by the loader for binding and versioning.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


VTableFixups()

VTableFixups() Property

RVA and size in butes of an array of virtual table (v-table) fixups. Among current managed compilers, only the MC++ compiler and linker and the ILAsm compiler can produce this array.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory this[] {
    get;
    set;
    }


CustomAttributeMetadataTableRow

CustomAttributeMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.CustomAttributeMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class CustomAttributeMetadataTableRow : MetadataRow

The CustomAttributeMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomAttributeMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the CustomAttributeMetadataTableRow

Properties

 | Name | Summary
public properties | Parent() | A HasCustomAttribute encoded index
public properties | Type() | A CustomAttributeType encoded index (Def or Ref tables)
public properties | Value() | An index in to the blob heap

Fields

 | Name | Description
private field | _parentIndex |
private field | _typeIndex |
private field | _value |


CustomAttributeMetadataTableRow Constructors

The CustomAttributeMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomAttributeMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the CustomAttributeMetadataTableRow


CustomAttributeMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the CustomAttributeMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CustomAttributeMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


CustomAttributeMetadataTableRow Fields

The CustomAttributeMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _parentIndex |
private field | _typeIndex |
private field | _value |


_typeIndex

_typeIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _typeIndex


_value

_value Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _value


CustomAttributeMetadataTableRow Properties

The CustomAttributeMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Parent() | A HasCustomAttribute encoded index
public properties | Type() | A CustomAttributeType encoded index (Def or Ref tables)
public properties | Value() | An index in to the blob heap


Parent()

Parent() Property

A HasCustomAttribute encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Type()

Type() Property

A CustomAttributeType encoded index (Def or Ref tables)
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Value()

Value() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


DeclSecurityMetadataTableRow

DeclSecurityMetadataTableRow Class

Security attributes which derive from SecurityAttribute, can be attached to TypeDef, a Method or an Assembly

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.DeclSecurityMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class DeclSecurityMetadataTableRow : MetadataRow

The DeclSecurityMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | DeclSecurityMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the DeclSecurityMetadataTableRow

Properties

 | Name | Summary
public properties | Action() | A 2 byte value
public properties | Parent() | An indexinto the MethodDef, TypeDef or Assembly tables. A HasDeclSecurity encoded index
public properties | PermissionSet() | An index in to the blob heap

Fields

 | Name | Description
private field | _action |
private field | _parentIndex |
private field | _permissionSet |


DeclSecurityMetadataTableRow Constructors

The DeclSecurityMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | DeclSecurityMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the DeclSecurityMetadataTableRow


DeclSecurityMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the DeclSecurityMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DeclSecurityMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the this row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


DeclSecurityMetadataTableRow Fields

The DeclSecurityMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _action |
private field | _parentIndex |
private field | _permissionSet |


_action

_action Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _action


_permissionSet

_permissionSet Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _permissionSet


DeclSecurityMetadataTableRow Properties

The DeclSecurityMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Action() | A 2 byte value
public properties | Parent() | An indexinto the MethodDef, TypeDef or Assembly tables. A HasDeclSecurity encoded index
public properties | PermissionSet() | An index in to the blob heap


Action()

Action() Property

A 2 byte value
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Parent()

Parent() Property

An indexinto the MethodDef, TypeDef or Assembly tables. A HasDeclSecurity encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


PermissionSet()

PermissionSet() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


EventAttributes

EventAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum EventAttributes : short

Members

Name | Description
None |
SpecialName |
RTSpecialName |


EventMapMetadataTableRow

EventMapMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.EventMapMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class EventMapMetadataTableRow : MetadataRow

The EventMapMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventMapMetadataTableRow() |
public constructor | EventMapMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new EventMapMetadataTableRow

Properties

 | Name | Summary
public properties | EventList() | An index in to the Event table. Marking the first of a contiguos list of Events.
public properties | Parent() | An index into the TypeDef table

Fields

 | Name | Description
private field | _eventListIndex |
private field | _parentIndex |


EventMapMetadataTableRow Constructors

The EventMapMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventMapMetadataTableRow() |
public constructor | EventMapMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new EventMapMetadataTableRow


EventMapMetadataTableRow()

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventMapMetadataTableRow()


EventMapMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new EventMapMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventMapMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


EventMapMetadataTableRow Fields

The EventMapMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _eventListIndex |
private field | _parentIndex |


_eventListIndex

_eventListIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _eventListIndex


EventMapMetadataTableRow Properties

The EventMapMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | EventList() | An index in to the Event table. Marking the first of a contiguos list of Events.
public properties | Parent() | An index into the TypeDef table


EventList()

EventList() Property

An index in to the Event table. Marking the first of a contiguos list of Events.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Parent()

Parent() Property

An index into the TypeDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


EventMetadataTableRow

EventMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.EventMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class EventMetadataTableRow : MetadataRow

The EventMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the EventMetadataTableRow class

Properties

 | Name | Summary
public properties | EventFlags() | EventAttributes mask
public properties | EventType() | An index into a TypeDef, TypeRef, or TypeSpec table, more precisely a TypeDefOrRef encoded index
public properties | Name() | An index in the string heap

Fields

 | Name | Description
private field | _eventFlags |
private field | _eventTypeIndex |
private field | _nameIndex |


EventMetadataTableRow Constructors

The EventMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the EventMetadataTableRow class


EventMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the EventMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


EventMetadataTableRow Fields

The EventMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _eventFlags |
private field | _eventTypeIndex |
private field | _nameIndex |


_eventFlags

_eventFlags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private EventAttributes _eventFlags


_eventTypeIndex

_eventTypeIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _eventTypeIndex


EventMetadataTableRow Properties

The EventMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | EventFlags() | EventAttributes mask
public properties | EventType() | An index into a TypeDef, TypeRef, or TypeSpec table, more precisely a TypeDefOrRef encoded index
public properties | Name() | An index in the string heap


EventFlags()

EventFlags() Property

EventAttributes mask
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventAttributes this[] {
    get;
    set;
    }


EventType()

EventType() Property

An index into a TypeDef, TypeRef, or TypeSpec table, more precisely a TypeDefOrRef encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Name()

Name() Property

An index in the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


ExportedTypeMetadataTableRow

ExportedTypeMetadataTableRow Class

A type which is defined within other modules of this assembly. In essance, it stores TypeDef row numbers of all types tha are marked public in other modules that this Assembly comprises.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ExportedTypeMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ExportedTypeMetadataTableRow : MetadataRow

The ExportedTypeMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ExportedTypeMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ExportedTypeMetadataTableRow class

Properties

 | Name | Summary
public properties | Flags() | 4-byte bitmask of TypeAttributes
public properties | Implementation() | An index in to the File, ExportedType or precisely Implementation coded index
public properties | TypeDefId() | 4-byte index in to the TypeDef table of another module in this Assembly. Hint, then search.
public properties | TypeName() | An index in to the string heap
public properties | TypeNamespace() | An index in to the string heap

Fields

 | Name | Description
private field | _flags |
private field | _implementationIndex |
private field | _typeDefId |
private field | _typeNameIndex |
private field | _typeNamespaceIndex |


ExportedTypeMetadataTableRow Constructors

The ExportedTypeMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ExportedTypeMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ExportedTypeMetadataTableRow class


ExportedTypeMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the ExportedTypeMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ExportedTypeMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


ExportedTypeMetadataTableRow Fields

The ExportedTypeMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _implementationIndex |
private field | _typeDefId |
private field | _typeNameIndex |
private field | _typeNamespaceIndex |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeAttributes _flags


_implementationIndex

_implementationIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _implementationIndex


_typeDefId

_typeDefId Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _typeDefId


_typeNameIndex

_typeNameIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _typeNameIndex


_typeNamespaceIndex

_typeNamespaceIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _typeNamespaceIndex


ExportedTypeMetadataTableRow Properties

The ExportedTypeMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | 4-byte bitmask of TypeAttributes
public properties | Implementation() | An index in to the File, ExportedType or precisely Implementation coded index
public properties | TypeDefId() | 4-byte index in to the TypeDef table of another module in this Assembly. Hint, then search.
public properties | TypeName() | An index in to the string heap
public properties | TypeNamespace() | An index in to the string heap


Flags()

Flags() Property

4-byte bitmask of TypeAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeAttributes this[] {
    get;
    set;
    }


Implementation()

Implementation() Property

An index in to the File, ExportedType or precisely Implementation coded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


TypeDefId()

TypeDefId() Property

4-byte index in to the TypeDef table of another module in this Assembly. Hint, then search.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


TypeName()

TypeName() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


TypeNamespace()

TypeNamespace() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


FieldAttributes

FieldAttributes Enumeration

Enumeration of attributes defined against a field in the metadata.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum FieldAttributes : int

Members

Name | Description
FieldAccessMask | These 3 bits contain one of the following values:
CompilerControlled | Member not referenceable
Private | Accessible only by the parent type
FamANDAssem | Accessible by sub-types only in this Assembly
Assembly | Accessibly by anyone in the Assembly
Family | Accessible only by type and sub-types
FamORAssem | Accessibly by sub-types anywhere, plus anyone in assembly
Public | Accessibly by anyone who has visibility to this scope field
Static | Defined on type, else per instance
InitOnly | Field can only be initialized, not written to after init
Literal | Value is compile time constant
NotSerialized | Reserved (to indicate this field should not be serialized when type is remoted)
SpecialName | Field is special
PInvokeImpl | Implementation is forwarded through PInvoke.
RTSpecialName | CLI provides 'special' behavior, depending upon the name of the field
HasFieldMarshal | Field has marshalling information
HasDefault | Field has default
HasFieldRVA | Field has RVA


FieldLayoutMetadataTableRow

FieldLayoutMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldLayoutMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class FieldLayoutMetadataTableRow : MetadataRow

The FieldLayoutMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldLayoutMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FieldLayoutMetadataTableRow

Properties

 | Name | Summary
public properties | Field() | An index to the field table
public properties | Offset() |

Fields

 | Name | Description
private field | _fieldIndex |
private field | _offset |


FieldLayoutMetadataTableRow Constructors

The FieldLayoutMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldLayoutMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FieldLayoutMetadataTableRow


FieldLayoutMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the FieldLayoutMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldLayoutMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


FieldLayoutMetadataTableRow Fields

The FieldLayoutMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _fieldIndex |
private field | _offset |


_fieldIndex

_fieldIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _fieldIndex


_offset

_offset Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _offset


FieldLayoutMetadataTableRow Properties

The FieldLayoutMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Field() | An index to the field table
public properties | Offset() |


Field()

Field() Property

An index to the field table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Offset()

Offset() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


FieldMarshalMetadataTableRow

FieldMarshalMetadataTableRow Class

Links an existing row in the Field or Param table to information in the blob heap that defines how that field or parameter should be marshalled.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldMarshalMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class FieldMarshalMetadataTableRow : MetadataRow

The FieldMarshalMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldMarshalMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the FieldMarshalMEtadataTableRow class

Properties

 | Name | Summary
public properties | NativeType() | An index in to the blob heap
public properties | Parent() | A HasFieldMarshal encoded index to the Field or Param tables

Fields

 | Name | Description
private field | _nativeTypeIndex |
private field | _parentIndex |


FieldMarshalMetadataTableRow Constructors

The FieldMarshalMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldMarshalMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the FieldMarshalMEtadataTableRow class


FieldMarshalMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the FieldMarshalMEtadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldMarshalMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


FieldMarshalMetadataTableRow Fields

The FieldMarshalMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _nativeTypeIndex |
private field | _parentIndex |


_nativeTypeIndex

_nativeTypeIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _nativeTypeIndex


FieldMarshalMetadataTableRow Properties

The FieldMarshalMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | NativeType() | An index in to the blob heap
public properties | Parent() | A HasFieldMarshal encoded index to the Field or Param tables


NativeType()

NativeType() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Parent()

Parent() Property

A HasFieldMarshal encoded index to the Field or Param tables
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


FieldMetadataTableRow

FieldMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class FieldMetadataTableRow : MetadataRow

The FieldMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FieldMetadataTableRow

Properties

 | Name | Summary
public properties | Flags() | A 2-byte mask of FieldAttributes
public properties | Name() | An index in to the string heap
public properties | Signiture() | An index in to the Blob heap

Fields

 | Name | Description
private field | _flags |
private field | _nameIndex |
private field | _signitureIndex |

Remarks

Modified to use 4-byte heap fields


FieldMetadataTableRow Constructors

The FieldMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FieldMetadataTableRow


FieldMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the FieldMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


FieldMetadataTableRow Fields

The FieldMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _nameIndex |
private field | _signitureIndex |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FieldAttributes _flags


_signitureIndex

_signitureIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobIndex _signitureIndex


FieldMetadataTableRow Properties

The FieldMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | A 2-byte mask of FieldAttributes
public properties | Name() | An index in to the string heap
public properties | Signiture() | An index in to the Blob heap


Flags()

Flags() Property

A 2-byte mask of FieldAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldAttributes this[] {
    get;
    set;
    }


Signiture()

Signiture() Property

An index in to the Blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BlobIndex this[] {
    get;
    set;
    }


FieldRVAMetadataTableRow

FieldRVAMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldRVAMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class FieldRVAMetadataTableRow : MetadataRow

The FieldRVAMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldRVAMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FieldRVAMetadataTableRow class

Properties

 | Name | Summary
public properties | Field() | An index into the Field table
public properties | RVA() | The RVA of the field

Fields

 | Name | Description
private field | _fieldIndex |
private field | _rva |


FieldRVAMetadataTableRow Constructors

The FieldRVAMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldRVAMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FieldRVAMetadataTableRow class


FieldRVAMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the FieldRVAMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldRVAMetadataTableRow(
byte[] content,
Offset offset,
IIndexDetails indexDetails
)

Parameters

content
Type: Byte
The content of the file
offset
Type: Offset
The offset for the current row
indexDetails
Type: IIndexDetails


FieldRVAMetadataTableRow Fields

The FieldRVAMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _fieldIndex |
private field | _rva |


_rva

_rva Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _rva


FieldRVAMetadataTableRow Properties

The FieldRVAMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Field() | An index into the Field table
public properties | RVA() | The RVA of the field


Field()

Field() Property

An index into the Field table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


RVA()

RVA() Property

The RVA of the field
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


FileAttributes

FileAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum FileAttributes : int

Members

Name | Description
ContainsMetadata |
ContainsNoMetadata |


FileMetadataTableRow

FileMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.FileMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class FileMetadataTableRow : MetadataRow

The FileMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FileMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FileMetadataTableRow class

Properties

 | Name | Summary
public properties | Flags() | A 4-byte bitmask of FileAttributes
public properties | HashValue() | An index in to the blob heap
public properties | Name() | An index in to the string heap

Fields

 | Name | Description
private field | _flags |
private field | _hashValue |
private field | _nameIndex |


FileMetadataTableRow Constructors

The FileMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | FileMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the FileMetadataTableRow class


FileMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the FileMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FileMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


FileMetadataTableRow Fields

The FileMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _hashValue |
private field | _nameIndex |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FileAttributes _flags


FileMetadataTableRow Properties

The FileMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | A 4-byte bitmask of FileAttributes
public properties | HashValue() | An index in to the blob heap
public properties | Name() | An index in to the string heap


Flags()

Flags() Property

A 4-byte bitmask of FileAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FileAttributes this[] {
    get;
    set;
    }


HashValue()

HashValue() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


GenericParamAttributes

GenericParamAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum GenericParamAttributes : short

Members

Name | Description
None |
VarianceMask |
Covariant |
Contravariant |
SpecialConstraintMask |
ReferenceTypeConstraint |
NotNullableValuleTypeConstraint |
DefaultConstructorConstraint |


GenericParamConstraintMetadataTableRow

GenericParamConstraintMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.GenericParamConstraintMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class GenericParamConstraintMetadataTableRow : MetadataRow

The GenericParamConstraintMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericParamConstraintMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the GenericParamConstraintMetadataTableRow class

Properties

 | Name | Summary
public properties | Constraint() | An index in to the TypeDef, TypeRef, TypeSpec table or more precisely a TypeDefOrRef coded index
public properties | Owner() | An index into the GenericParam table

Fields

 | Name | Description
private field | _constraint |
private field | _owner |


GenericParamConstraintMetadataTableRow Constructors

The GenericParamConstraintMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericParamConstraintMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the GenericParamConstraintMetadataTableRow class


GenericParamConstraintMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the GenericParamConstraintMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericParamConstraintMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


GenericParamConstraintMetadataTableRow Fields

The GenericParamConstraintMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _constraint |
private field | _owner |


_constraint

_constraint Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _constraint


_owner

_owner Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _owner


GenericParamConstraintMetadataTableRow Properties

The GenericParamConstraintMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Constraint() | An index in to the TypeDef, TypeRef, TypeSpec table or more precisely a TypeDefOrRef coded index
public properties | Owner() | An index into the GenericParam table


Constraint()

Constraint() Property

An index in to the TypeDef, TypeRef, TypeSpec table or more precisely a TypeDefOrRef coded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Owner()

Owner() Property

An index into the GenericParam table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


GenericParamMetadataTableRow

GenericParamMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.GenericParamMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class GenericParamMetadataTableRow : MetadataRow

The GenericParamMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericParamMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the GenericParamMetadataTableRow class

Properties

 | Name | Summary
public properties | Flags() | A 2-byte bitmask of GenericParamAttributes
public properties | Name() | An index in to the string heap
public properties | Number() | A 2-byte index of the generic parameter, numbered left to right
public properties | Owner() | An index in to the TypeDef, MethodDef; more precisley a TypeOrMethodDef encoded index

Fields

 | Name | Description
private field | _flags |
private field | _nameIndex |
private field | _number |
private field | _ownerIndex |


GenericParamMetadataTableRow Constructors

The GenericParamMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericParamMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the GenericParamMetadataTableRow class


GenericParamMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the GenericParamMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericParamMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


GenericParamMetadataTableRow Fields

The GenericParamMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _nameIndex |
private field | _number |
private field | _ownerIndex |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private GenericParamAttributes _flags


_number

_number Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _number


_ownerIndex

_ownerIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _ownerIndex


GenericParamMetadataTableRow Properties

The GenericParamMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | A 2-byte bitmask of GenericParamAttributes
public properties | Name() | An index in to the string heap
public properties | Number() | A 2-byte index of the generic parameter, numbered left to right
public properties | Owner() | An index in to the TypeDef, MethodDef; more precisley a TypeOrMethodDef encoded index


Flags()

Flags() Property

A 2-byte bitmask of GenericParamAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericParamAttributes this[] {
    get;
    set;
    }


Number()

Number() Property

A 2-byte index of the generic parameter, numbered left to right
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Owner()

Owner() Property

An index in to the TypeDef, MethodDef; more precisley a TypeOrMethodDef encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


GuidStream

GuidStream Class

Represents the metadata GUID stream available in .net pe/coff files. And provides access to those details.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Stream
      • TheBoxSoftware.Reflection.Core.COFF.GuidStream
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class GuidStream : Stream

The GuidStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | GuidStream(PeCoffFile, UInt32, Int32) | Initialises a new instance of the GuidStream class.

Methods

 | Name | Summary
public method | GetAllGUIDs() | Returns a collection of all the GUIDs defined in this stream.
public method | GetGuid(Int32) | Obtains the Guid at the specified index. The index provided is obtained from the property.

Fields

 | Name | Description
private field | _streamContents |
private constant | sizeOfGuid |


GuidStream Constructors

The GuidStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | GuidStream(PeCoffFile, UInt32, Int32) | Initialises a new instance of the GuidStream class.


GuidStream(PeCoffFile, UInt32, Int32)

Initialises a new instance of the GuidStream class.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal GuidStream(
PeCoffFile file,
uint address,
int size
)

Parameters

file
Type: PeCoffFile
The file which owns the stream.
address
Type: UInt32
The start address of the stream.
size
Type: Int32
The size of the stream.


GuidStream Fields

The GuidStream type exposes the following members.

Fields

 | Name | Description
private field | _streamContents |
private constant | sizeOfGuid |


sizeOfGuid

sizeOfGuid Constant

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const int sizeOfGuid


GuidStream Methods

The GuidStream type exposes the following members.

Methods

 | Name | Summary
public method | GetAllGUIDs() | Returns a collection of all the GUIDs defined in this stream.
public method | GetGuid(Int32) | Obtains the Guid at the specified index. The index provided is obtained from the property.


GetAllGUIDs()

GetAllGUIDs() Method

Returns a collection of all the GUIDs defined in this stream.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<int, Guid> GetAllGUIDs()


GetGuid(Int32)

GetGuid(Int32) Method

Obtains the Guid at the specified index. The index provided is obtained from the property.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Guid GetGuid(
    int index
    )

Parameters

index
Type: Int32
The index for the guid to obtain.

Exceptions

Exception | Condition
System.ArgumentException | The index was outside the boundaries for the stream, there is no guid available. Check the data in the exception for more information.


HeapOffsetSizes

HeapOffsetSizes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum HeapOffsetSizes : byte

Members

Name | Description
StringIsLarge |
GuidIsLarge |
BlobIsLarge |


ICodedIndexResolver

ICodedIndexResolver Interface

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public interface ICodedIndexResolver

The ICodedIndexResolver type exposes the following members.

Methods

 | Name | Summary
public method | GetSizeOfIndex(CodedIndexes) |
public method | Resolve(CodedIndexes, UInt32) |


ICodedIndexResolver Methods

The ICodedIndexResolver type exposes the following members.

Methods

 | Name | Summary
public method | GetSizeOfIndex(CodedIndexes) |
public method | Resolve(CodedIndexes, UInt32) |


GetSizeOfIndex(CodedIndexes)

GetSizeOfIndex(CodedIndexes) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract int GetSizeOfIndex(
    CodedIndexes indexType
    )

Parameters

indexType
Type: CodedIndexes


Resolve(CodedIndexes, UInt32)

Resolve(CodedIndexes, UInt32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract CodedIndex Resolve(
    CodedIndexes indexType,
    uint value
    )

Parameters

indexType
Type: CodedIndexes
value
Type: UInt32


IIndexDetails

IIndexDetails Interface

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public interface IIndexDetails

The IIndexDetails type exposes the following members.

Methods

 | Name | Summary
public method | GetSizeOfBlobIndex() |
public method | GetSizeOfGuidIndex() |
public method | GetSizeOfIndex(MetadataTables) |
public method | GetSizeOfStringIndex() |


IIndexDetails Methods

The IIndexDetails type exposes the following members.

Methods

 | Name | Summary
public method | GetSizeOfBlobIndex() |
public method | GetSizeOfGuidIndex() |
public method | GetSizeOfIndex(MetadataTables) |
public method | GetSizeOfStringIndex() |


GetSizeOfBlobIndex()

GetSizeOfBlobIndex() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract byte GetSizeOfBlobIndex()


GetSizeOfGuidIndex()

GetSizeOfGuidIndex() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract byte GetSizeOfGuidIndex()


GetSizeOfIndex(MetadataTables)

GetSizeOfIndex(MetadataTables) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract byte GetSizeOfIndex(
    MetadataTables forTable
    )

Parameters

forTable
Type: MetadataTables


GetSizeOfStringIndex()

GetSizeOfStringIndex() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract byte GetSizeOfStringIndex()


ImplMapMetadataTableRow

ImplMapMetadataTableRow Class

Holds information about unmanaged methods that can be reached from managed code, using PInvoke dispatch.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ImplMapMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ImplMapMetadataTableRow : MetadataRow

The ImplMapMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ImplMapMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ImplMapMetadataTableRow class

Properties

 | Name | Summary
public properties | ImportName() | An index in to the string heap
public properties | ImportScope() | An index into the ModuleRef table
public properties | MappingFlags() | A 2-byte mask of PInvokeAttributes
public properties | MemberForward() | An index in to the Field or MethodDef table, a MemberForwarded coded index. However it only ever references the MethodDef because Field is never exported

Fields

 | Name | Description
private field | _importName |
private field | _importScope |
private field | _mappingFlags |
private field | _memberForward |


ImplMapMetadataTableRow Constructors

The ImplMapMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ImplMapMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ImplMapMetadataTableRow class


ImplMapMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the ImplMapMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ImplMapMetadataTableRow(
byte[] content,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

content
Type: Byte
The content of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


ImplMapMetadataTableRow Fields

The ImplMapMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _importName |
private field | _importScope |
private field | _mappingFlags |
private field | _memberForward |


_importName

_importName Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _importName


_importScope

_importScope Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _importScope


_mappingFlags

_mappingFlags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PInvokeAttributes _mappingFlags


_memberForward

_memberForward Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _memberForward


ImplMapMetadataTableRow Properties

The ImplMapMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | ImportName() | An index in to the string heap
public properties | ImportScope() | An index into the ModuleRef table
public properties | MappingFlags() | A 2-byte mask of PInvokeAttributes
public properties | MemberForward() | An index in to the Field or MethodDef table, a MemberForwarded coded index. However it only ever references the MethodDef because Field is never exported


ImportName()

ImportName() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


ImportScope()

ImportScope() Property

An index into the ModuleRef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


MappingFlags()

MappingFlags() Property

A 2-byte mask of PInvokeAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PInvokeAttributes this[] {
    get;
    set;
    }


MemberForward()

MemberForward() Property

An index in to the Field or MethodDef table, a MemberForwarded coded index. However it only ever references the MethodDef because Field is never exported
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Index

Index Structure

Represents a simple index item, where the item is an entry in to - generall - a metadata table.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct Index

The Index type exposes the following members.

Constructors

 | Class | Summary
public constructor | Index(UInt32) | Private constructor which initialises the structure to a known index.
public constructor | Index(Byte[], Offset, Int32) |

Methods

 | Name | Summary
public method | ToString() |

Fields

 | Name | Description
public field | Value |


Index Constructors

The Index type exposes the following members.

Constructors

 | Class | Summary
public constructor | Index(UInt32) | Private constructor which initialises the structure to a known index.
public constructor | Index(Byte[], Offset, Int32) |


Index(UInt32)

Private constructor which initialises the structure to a known index.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index(
uint value
)

Parameters

value
Type: UInt32
The value for the index.

Remarks

This is currently only used internally to be able to convert implicitly between an integer and an Index structure.


Index(Byte[], Offset, Int32)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index(
byte[] contents,
Offset offset,
int sizeOfIndexes
)

Parameters

contents
Type: Byte
offset
Type: Offset
sizeOfIndexes
Type: Int32


Index Fields

The Index type exposes the following members.

Fields

 | Name | Description
public field | Value |


Index Methods

The Index type exposes the following members.

Methods

 | Name | Summary
public method | ToString() |


ToString()

ToString() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


IndexDetails

IndexDetails Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.IndexDetails
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class IndexDetails: IIndexDetails

The IndexDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | IndexDetails(Dictionary<MetadataTables,Int32>, Byte, Byte, Byte) |

Methods

 | Name | Summary
public method | GetSizeOfBlobIndex() |
public method | GetSizeOfGuidIndex() |
public method | GetSizeOfIndex(MetadataTables) |
public method | GetSizeOfStringIndex() |

Fields

 | Name | Description
private field | _rowsInTables |
private field | _sizeOfBlobIndex |
private field | _sizeOfGuidIndex |
private field | _sizeOfStringIndex |


IndexDetails Constructors

The IndexDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | IndexDetails(Dictionary<MetadataTables,Int32>, Byte, Byte, Byte) |


IndexDetails(Dictionary<MetadataTables,Int32>, Byte, Byte, Byte)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public IndexDetails(
Dictionary<MetadataTables, int> rowCountsInTables,
byte sizeOfStringIndex,
byte sizeOfGuidIndex,
byte sizeOfBlobIndex
)

Parameters

rowCountsInTables
Type: Dictionary<,>
sizeOfStringIndex
Type: Byte
sizeOfGuidIndex
Type: Byte
sizeOfBlobIndex
Type: Byte


IndexDetails Fields

The IndexDetails type exposes the following members.

Fields

 | Name | Description
private field | _rowsInTables |
private field | _sizeOfBlobIndex |
private field | _sizeOfGuidIndex |
private field | _sizeOfStringIndex |


_rowsInTables

_rowsInTables Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _rowsInTables


_sizeOfBlobIndex

_sizeOfBlobIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _sizeOfBlobIndex


_sizeOfGuidIndex

_sizeOfGuidIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _sizeOfGuidIndex


_sizeOfStringIndex

_sizeOfStringIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _sizeOfStringIndex


IndexDetails Methods

The IndexDetails type exposes the following members.

Methods

 | Name | Summary
public method | GetSizeOfBlobIndex() |
public method | GetSizeOfGuidIndex() |
public method | GetSizeOfIndex(MetadataTables) |
public method | GetSizeOfStringIndex() |


GetSizeOfBlobIndex()

GetSizeOfBlobIndex() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte GetSizeOfBlobIndex()


GetSizeOfGuidIndex()

GetSizeOfGuidIndex() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte GetSizeOfGuidIndex()


GetSizeOfIndex(MetadataTables)

GetSizeOfIndex(MetadataTables) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte GetSizeOfIndex(
    MetadataTables forTable
    )

Parameters

forTable
Type: MetadataTables


GetSizeOfStringIndex()

GetSizeOfStringIndex() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte GetSizeOfStringIndex()


InterfaceImplMetadataTableRow

InterfaceImplMetadataTableRow Class

Records the interfaces a type implements explicitly

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.InterfaceImplMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class InterfaceImplMetadataTableRow : MetadataRow

The InterfaceImplMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | InterfaceImplMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the InterfaceImplMetadataTableRow

Properties

 | Name | Summary
public properties | Class() | An index in to the TypeDef table
public properties | Interface() | An index in to the TypeDef, TypeRef, or TypeSpec table. More precisely a TypeDefOrRef coded index.

Fields

 | Name | Description
private field | _class |
private field | _interface |

Remarks

Updated for 4-byte heap indexes


InterfaceImplMetadataTableRow Constructors

The InterfaceImplMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | InterfaceImplMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the InterfaceImplMetadataTableRow


InterfaceImplMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the InterfaceImplMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public InterfaceImplMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of this row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


InterfaceImplMetadataTableRow Fields

The InterfaceImplMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _class |
private field | _interface |


_class

_class Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _class


_interface

_interface Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _interface


InterfaceImplMetadataTableRow Properties

The InterfaceImplMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Class() | An index in to the TypeDef table
public properties | Interface() | An index in to the TypeDef, TypeRef, or TypeSpec table. More precisely a TypeDefOrRef coded index.


Class()

Class() Property

An index in to the TypeDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Interface()

Interface() Property

An index in to the TypeDef, TypeRef, or TypeSpec table. More precisely a TypeDefOrRef coded index.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


IStringStream

IStringStream Interface

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public interface IStringStream

The IStringStream type exposes the following members.

Methods

 | Name | Summary
public method | GetAllStrings() |
public method | GetString(UInt32) |


IStringStream Methods

The IStringStream type exposes the following members.

Methods

 | Name | Summary
public method | GetAllStrings() |
public method | GetString(UInt32) |


GetAllStrings()

GetAllStrings() Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract Dictionary<int, string> GetAllStrings()


GetString(UInt32)

GetString(UInt32) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract string GetString(
    uint index
    )

Parameters

index
Type: UInt32


ManifestResourceAttributes

ManifestResourceAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum ManifestResourceAttributes : int

Members

Name | Description
VisibilityMask |
Public |
Private |


ManifestResourceMetadataTableRow

ManifestResourceMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ManifestResourceMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ManifestResourceMetadataTableRow : MetadataRow

The ManifestResourceMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ManifestResourceMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ManifestResourceMetadataTableRow class

Properties

 | Name | Summary
public properties | Flags() | A 4-byte bitmask of ManifestResourceAttributes
public properties | Implementation() | An index in to a File, AssemblyRef, or null; more precisely an Implementation coded index
public properties | Name() | An index in to the string heap
public properties | Offset() | A 4-byte constant

Fields

 | Name | Description
private field | _flags |
private field | _implementation |
private field | _name |
private field | _offset |


ManifestResourceMetadataTableRow Constructors

The ManifestResourceMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ManifestResourceMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the ManifestResourceMetadataTableRow class


ManifestResourceMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the ManifestResourceMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ManifestResourceMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of this current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


ManifestResourceMetadataTableRow Fields

The ManifestResourceMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _implementation |
private field | _name |
private field | _offset |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ManifestResourceAttributes _flags


_implementation

_implementation Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _implementation


_name

_name Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _name


ManifestResourceMetadataTableRow Properties

The ManifestResourceMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | A 4-byte bitmask of ManifestResourceAttributes
public properties | Implementation() | An index in to a File, AssemblyRef, or null; more precisely an Implementation coded index
public properties | Name() | An index in to the string heap
public properties | Offset() | A 4-byte constant


Flags()

Flags() Property

A 4-byte bitmask of ManifestResourceAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ManifestResourceAttributes this[] {
    get;
    set;
    }


Implementation()

Implementation() Property

An index in to a File, AssemblyRef, or null; more precisely an Implementation coded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Offset()

Offset() Property

A 4-byte constant
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


MemberRefMetadataTableRow

MemberRefMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.MemberRefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MemberRefMetadataTableRow : MetadataRow

The MemberRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MemberRefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MemberRefMetadataTableRow

Properties

 | Name | Summary
public properties | Class() | An index in to the MethodDef, ModuleRef, TypeRef, or TypeSpec tables, more precisely a MemberRefParent coded index.
public properties | Name() | An index in to the string heap
public properties | Signiture() | An index in to the blob heap

Fields

 | Name | Description
private field | _class |
private field | _name |
private field | _signiture |


MemberRefMetadataTableRow Constructors

The MemberRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MemberRefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MemberRefMetadataTableRow


MemberRefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the MemberRefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MemberRefMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of this row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


MemberRefMetadataTableRow Fields

The MemberRefMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _class |
private field | _name |
private field | _signiture |


_class

_class Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _class


_signiture

_signiture Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobIndex _signiture


MemberRefMetadataTableRow Properties

The MemberRefMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Class() | An index in to the MethodDef, ModuleRef, TypeRef, or TypeSpec tables, more precisely a MemberRefParent coded index.
public properties | Name() | An index in to the string heap
public properties | Signiture() | An index in to the blob heap


Class()

Class() Property

An index in to the MethodDef, ModuleRef, TypeRef, or TypeSpec tables, more precisely a MemberRefParent coded index.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Signiture()

Signiture() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BlobIndex this[] {
    get;
    set;
    }


MetadataDirectory

MetadataDirectory Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.Directory
      • TheBoxSoftware.Reflection.Core.COFF.MetadataDirectory
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MetadataDirectory : Directory

The MetadataDirectory type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataDirectory(PeCoffFile, UInt32) | Initialises a new instance of the MetadataDirectory

Methods

 | Name | Summary
sealed method | GetMetadataStream() | Helper method to obtain the stream of .NET metadata

Properties

 | Name | Summary
public properties | Header() |
public properties | Streams() |

Fields

 | Name | Description
private field | _header |
private field | _metadata |
private field | _streams |


MetadataDirectory Constructors

The MetadataDirectory type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataDirectory(PeCoffFile, UInt32) | Initialises a new instance of the MetadataDirectory


MetadataDirectory(PeCoffFile, UInt32)

Initialises a new instance of the MetadataDirectory
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataDirectory(
PeCoffFile file,
uint address
)

Parameters

file
Type: PeCoffFile
The contents of the file
address
Type: UInt32
The base address of the directory


MetadataDirectory Fields

The MetadataDirectory type exposes the following members.

Fields

 | Name | Description
private field | _header |
private field | _metadata |
private field | _streams |


_header

_header Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataHeader _header


_metadata

_metadata Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataStream _metadata


_streams

_streams Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _streams


MetadataDirectory Methods

The MetadataDirectory type exposes the following members.

Methods

 | Name | Summary
sealed method | GetMetadataStream() | Helper method to obtain the stream of .NET metadata


GetMetadataStream()

GetMetadataStream() Method

Helper method to obtain the stream of .NET metadata
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal MetadataStream GetMetadataStream()


MetadataDirectory Properties

The MetadataDirectory type exposes the following members.

Properties

 | Name | Summary
public properties | Header() |
public properties | Streams() |


Header()

Header() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataHeader this[] {
    get;
    set;
    }


Streams()

Streams() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<Streams, Stream> this[] {
    get;
    set;
    }


MetadataHeader

MetadataHeader Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataHeader
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MetadataHeader

The MetadataHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataHeader(Byte[], UInt32) |

Properties

 | Name | Summary
public properties | Flags() |
public properties | Headers() |
public properties | MajorVersion() |
public properties | MinorVersion() |
public properties | NumberOfMetaDataStreams() |
public properties | Reserved() |
public properties | Signiture() |
public properties | Version() |
public properties | VersionLength() |


MetadataHeader Constructors

The MetadataHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataHeader(Byte[], UInt32) |


MetadataHeader(Byte[], UInt32)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataHeader(
byte[] contents,
uint address
)

Parameters

contents
Type: Byte
address
Type: UInt32


MetadataHeader Properties

The MetadataHeader type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() |
public properties | Headers() |
public properties | MajorVersion() |
public properties | MinorVersion() |
public properties | NumberOfMetaDataStreams() |
public properties | Reserved() |
public properties | Signiture() |
public properties | Version() |
public properties | VersionLength() |


Flags()

Flags() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Headers()

Headers() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataStreamHeader[] this[] {
    get;
    set;
    }


NumberOfMetaDataStreams()

NumberOfMetaDataStreams() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Reserved()

Reserved() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Signiture()

Signiture() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Version()

Version() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


VersionLength()

VersionLength() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


MetadataRow

MetadataRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyOSMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyProcessorMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyRefMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyRefOSMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.AssemblyRefProcessorMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ClassLayoutMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ConstantMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.CustomAttributeMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.DeclSecurityMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.EventMapMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.EventMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ExportedTypeMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldLayoutMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldMarshalMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.FieldRVAMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.FileMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.GenericParamConstraintMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.GenericParamMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ImplMapMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.InterfaceImplMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ManifestResourceMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.MemberRefMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodImplMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodSemanticsMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodSpecMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ModuleMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ModuleRefMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.NestedClassMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.ParamMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.PropertyMapMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.PropertyMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.StandAloneSigMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.TypeDefMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.TypeRefMetadataTableRow
      • TheBoxSoftware.Reflection.Core.COFF.TypeSpecMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract class MetadataRow

The MetadataRow type exposes the following members.

Constructors

 | Class | Summary
protected constructor | MetadataRow() |

Properties

 | Name | Summary
public properties | FileOffset() |


MetadataRow Constructors

The MetadataRow type exposes the following members.

Constructors

 | Class | Summary
protected constructor | MetadataRow() |


MetadataRow()

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected MetadataRow()


MetadataRow Properties

The MetadataRow type exposes the following members.

Properties

 | Name | Summary
public properties | FileOffset() |


FileOffset()

FileOffset() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


MetadataStream

MetadataStream Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Stream
      • TheBoxSoftware.Reflection.Core.COFF.MetadataStream
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class MetadataStream : Stream

The MetadataStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | MetadataStream(PeCoffFile, UInt32) |

Methods

 | Name | Summary
public method | GetEntryFor(CodedIndex) | Obtains an entry in the specified table at the specified index
public method | GetEntryFor(MetadataTables, UInt32) | Obtains an entry in the specified table at the specified index

Properties

 | Name | Summary
public properties | OwningFile() |
public properties | SizeOfBlobIndexes | Returns the size (in bytes) of the indexes to the blob heap
public properties | SizeOfGuidIndexes | Returns the size (in bytes) of the indexes to the guid heap
public properties | SizeOfStringIndexes | Returns the size (in bytes) of the indexes to the string heap
public properties | Tables() |

Fields

 | Name | Description
private field | _heapOffsetSizes |
private field | _owningFile |
private field | _sizeOfBlobIndexes |
private field | _sizeOfGuidIndexes |
private field | _sizeOfStringIndexes | This is stored here because a coded index defenition map is relevant only for a single pecofffile and by association a metadatastream. If this is static in coded index (like it was) then the definitions will cause failures in the application. A map of initialised defenition entries. A definition is valid multiple times and storing this small structure will increase performance by reducing the number of row searches and lookups in the metadata tables.
private field | _tables |


MetadataStream Constructors

The MetadataStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | MetadataStream(PeCoffFile, UInt32) |


MetadataStream(PeCoffFile, UInt32)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal MetadataStream(
PeCoffFile file,
uint address
)

Parameters

file
Type: PeCoffFile
address
Type: UInt32


MetadataStream Fields

The MetadataStream type exposes the following members.

Fields

 | Name | Description
private field | _heapOffsetSizes |
private field | _owningFile |
private field | _sizeOfBlobIndexes |
private field | _sizeOfGuidIndexes |
private field | _sizeOfStringIndexes | This is stored here because a coded index defenition map is relevant only for a single pecofffile and by association a metadatastream. If this is static in coded index (like it was) then the definitions will cause failures in the application. A map of initialised defenition entries. A definition is valid multiple times and storing this small structure will increase performance by reducing the number of row searches and lookups in the metadata tables.
private field | _tables |


_heapOffsetSizes

_heapOffsetSizes Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private HeapOffsetSizes _heapOffsetSizes


_owningFile

_owningFile Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PeCoffFile _owningFile


_sizeOfBlobIndexes

_sizeOfBlobIndexes Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _sizeOfBlobIndexes


_sizeOfGuidIndexes

_sizeOfGuidIndexes Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _sizeOfGuidIndexes


_sizeOfStringIndexes

_sizeOfStringIndexes Field

This is stored here because a coded index defenition map is relevant only for a single pecofffile and by association a metadatastream. If this is static in coded index (like it was) then the definitions will cause failures in the application.

A map of initialised defenition entries. A definition is valid multiple times and storing this small structure will increase performance by reducing the number of row searches and lookups in the metadata tables.

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _sizeOfStringIndexes


_tables

_tables Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataTablesDictionary _tables


MetadataStream Methods

The MetadataStream type exposes the following members.

Methods

 | Name | Summary
public method | GetEntryFor(CodedIndex) | Obtains an entry in the specified table at the specified index
public method | GetEntryFor(MetadataTables, UInt32) | Obtains an entry in the specified table at the specified index


GetEntryFor(CodedIndex)

GetEntryFor(CodedIndex) Method

Obtains an entry in the specified table at the specified index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataRow GetEntryFor(
    CodedIndex codedIndex
    )

Parameters

codedIndex
Type: CodedIndex
The coded index decribing the metadata location.


GetEntryFor(MetadataTables, UInt32)

GetEntryFor(MetadataTables, UInt32) Method

Obtains an entry in the specified table at the specified index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataRow GetEntryFor(
    MetadataTables table,
    uint index
    )

Parameters

table
Type: MetadataTables
The table to get the metadata for
index
Type: UInt32
The index in the table


MetadataStream Properties

The MetadataStream type exposes the following members.

Properties

 | Name | Summary
public properties | OwningFile() |
public properties | SizeOfBlobIndexes | Returns the size (in bytes) of the indexes to the blob heap
public properties | SizeOfGuidIndexes | Returns the size (in bytes) of the indexes to the guid heap
public properties | SizeOfStringIndexes | Returns the size (in bytes) of the indexes to the string heap
public properties | Tables() |


OwningFile()

OwningFile() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PeCoffFile this[] {
    get;
    private set;
    }


SizeOfBlobIndexes

SizeOfBlobIndexes Property

Returns the size (in bytes) of the indexes to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte SizeOfBlobIndexes {
    get;
    }


SizeOfGuidIndexes

SizeOfGuidIndexes Property

Returns the size (in bytes) of the indexes to the guid heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte SizeOfGuidIndexes {
    get;
    }


SizeOfStringIndexes

SizeOfStringIndexes Property

Returns the size (in bytes) of the indexes to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte SizeOfStringIndexes {
    get;
    }


Tables()

Tables() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataTablesDictionary this[] {
    get;
    set;
    }


MetadataStreamHeader

MetadataStreamHeader Structure

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct MetadataStreamHeader

The MetadataStreamHeader type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | MetadataStreamHeader(Byte[], ref Offset) |

Methods

 | Name | Summary
private method | ReadName(Byte[], Offset) |

Fields

 | Name | Description
public field | Name |
public field | Offset |
public field | Size |


MetadataStreamHeader Constructors

The MetadataStreamHeader type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | MetadataStreamHeader(Byte[], ref Offset) |


MetadataStreamHeader(Byte[], ref Offset)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal MetadataStreamHeader(
byte[] contents,
ref Offset offset
)

Parameters

contents
Type: Byte
offset
Type: Offset


MetadataStreamHeader Fields

The MetadataStreamHeader type exposes the following members.

Fields

 | Name | Description
public field | Name |
public field | Offset |
public field | Size |


Name

Name Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string Name


Offset

Offset Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint Offset


Size

Size Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint Size


MetadataStreamHeader Methods

The MetadataStreamHeader type exposes the following members.

Methods

 | Name | Summary
private method | ReadName(Byte[], Offset) |


ReadName(Byte[], Offset)

ReadName(Byte[], Offset) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string ReadName(
    byte[] contents,
    Offset offset
    )

Parameters

contents
Type: Byte
offset
Type: Offset


MetadataTables

MetadataTables Enumeration

Enumeration of all the available metadata tables that can reside in a .net pe/coff file.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum MetadataTables : byte

Members

Name | Description
Module |
TypeRef |
TypeDef |
Unused1 |
Field |
Unused2 |
MethodDef |
Unused3 |
Param |
InterfaceImpl |
MemberRef |
Constant |
CustomAttribute |
FieldMarshal |
DeclSecurity |
ClassLayout |
FieldLayout |
StandAloneSig |
EventMap |
Unused4 |
Event |
PropertyMap |
Unused5 |
Property |
MethodSemantics |
MethodImpl |
ModuleRef |
TypeSpec |
ImplMap |
FieldRVA |
Unused6 |
Unused7 |
Assembly |
AssemblyProcessor |
AssemblyOS |
AssemblyRef |
AssemblyRefProcessor |
AssemblyRefOS |
File |
ExportedType |
ManifestResource |
NestedClass |
GenericParam |
MethodSpec |
GenericParamConstraint |
Unused8 |
Unused9 |
Unused10 |


MetadataTablesDictionary

MetadataTablesDictionary Class

Represents a dictionary of all of the metadata rows loaded from an assembly.

Inheritance Hierarchy

  • System.Collections.Generic.Dictionary<,>
    • TheBoxSoftware.Reflection.Core.COFF.MetadataTablesDictionary
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MetadataTablesDictionary : Dictionary<MetadataTables, MetadataRow[]>

The MetadataTablesDictionary type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataTablesDictionary() | Initialises a new instance of the MetadataTablesDictionary class.
public constructor | MetadataTablesDictionary(Int32) | Initialises a new instance of the MetadataTablesDictionary class.

Methods

 | Name | Summary
public method | GetEntryFor(MetadataTables, Int32) | Gets the metadata row information from the specified table at the specified index.
public method | GetGenericParametersFor(MetadataTables, Int32) | Obtains a collection of generic parameter metadata rows for the specified table and index.
public method | GetIndexFor(MetadataTables, MetadataRow) | Returns the index for a specified metadata row from a metadata table.
public method | SetMetadataTable(MetadataTables, MetadataRow[]) | Sets a populated array of MetadataRows against its associated metadata table.

Fields

 | Name | Description
private field | indexTable | Stores a set of values that relate a file offset (unique for any metadata row) against an index in its associated table. This is to reduce seek times when searching for elements. Whenever an entry is added to the dictionary its metadata rows should be added to this dictionary.

Remarks

Internally this stores the unique FileOffset against an index in a table for the stored MetadataRow items.


MetadataTablesDictionary Constructors

The MetadataTablesDictionary type exposes the following members.

Constructors

 | Class | Summary
public constructor | MetadataTablesDictionary() | Initialises a new instance of the MetadataTablesDictionary class.
public constructor | MetadataTablesDictionary(Int32) | Initialises a new instance of the MetadataTablesDictionary class.


MetadataTablesDictionary()

Initialises a new instance of the MetadataTablesDictionary class.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataTablesDictionary()


MetadataTablesDictionary(Int32)

Initialises a new instance of the MetadataTablesDictionary class.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataTablesDictionary(
int capacity
)

Parameters

capacity
Type: Int32
The starting capacity.

Remarks

This can be used to set the starting capacity to the number of metadata tables defined in the pe coff file. To reduce the number of internal re-dimensioning.


MetadataTablesDictionary Fields

The MetadataTablesDictionary type exposes the following members.

Fields

 | Name | Description
private field | indexTable | Stores a set of values that relate a file offset (unique for any metadata row) against an index in its associated table. This is to reduce seek times when searching for elements. Whenever an entry is added to the dictionary its metadata rows should be added to this dictionary.


indexTable

indexTable Field

Stores a set of values that relate a file offset (unique for any metadata row) against an index in its associated table. This is to reduce seek times when searching for elements. Whenever an entry is added to the dictionary its metadata rows should be added to this dictionary.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary indexTable


MetadataTablesDictionary Methods

The MetadataTablesDictionary type exposes the following members.

Methods

 | Name | Summary
public method | GetEntryFor(MetadataTables, Int32) | Gets the metadata row information from the specified table at the specified index.
public method | GetGenericParametersFor(MetadataTables, Int32) | Obtains a collection of generic parameter metadata rows for the specified table and index.
public method | GetIndexFor(MetadataTables, MetadataRow) | Returns the index for a specified metadata row from a metadata table.
public method | SetMetadataTable(MetadataTables, MetadataRow[]) | Sets a populated array of MetadataRows against its associated metadata table.


GetEntryFor(MetadataTables, Int32)

GetEntryFor(MetadataTables, Int32) Method

Gets the metadata row information from the specified table at the specified index.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MetadataRow GetEntryFor(
    MetadataTables table,
    int index
    )

Parameters

table
Type: MetadataTables
The table the metadata row resides in
index
Type: Int32
The index of the item in the table


GetGenericParametersFor(MetadataTables, Int32)

GetGenericParametersFor(MetadataTables, Int32) Method

Obtains a collection of generic parameter metadata rows for the specified table and index.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<GenericParamMetadataTableRow> GetGenericParametersFor(
    MetadataTables table,
    int index
    )

Parameters

table
Type: MetadataTables
The table to get the details for.
index
Type: Int32
The index of that table to get the details for.

Exceptions

Exception | Condition
System.InvalidOperationException | The table and index are invalid, please see the exception details for more information.

Remarks

This method will iterate over the GenericParam metadata table and search for entries whose parent is the specified table and index and return them.


GetIndexFor(MetadataTables, MetadataRow)

GetIndexFor(MetadataTables, MetadataRow) Method

Returns the index for a specified metadata row from a metadata table.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int GetIndexFor(
    MetadataTables table,
    MetadataRow entry
    )

Parameters

table
Type: MetadataTables
The table to get the metadata items index from
entry
Type: MetadataRow
The entry which resides in the metadata table


SetMetadataTable(MetadataTables, MetadataRow[])

SetMetadataTable(MetadataTables, MetadataRow[]) Method

Sets a populated array of MetadataRows against its associated metadata table.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public void SetMetadataTable(
    MetadataTables table,
    MetadataRow[] rows
    )

Parameters

table
Type: MetadataTables
The table the rows have been loaded from.
rows
Type: MetadataRow
The rows that make up the table.


MethodAttributes

MethodAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum MethodAttributes : int

Members

Name | Description
MemberAccessMask | These 3 bits contain one of the following values:
CompilerControlled | Member not referenceable
Private | Accessible only by the parent type
FamANDAssem | Accessible by sub-types only in this Assembly
Assem | Accessibly by anyone in the Assembly
Family | Accessible only by type and sub-types
FamORAssem | Accessibly by sub-types anywhere, plus anyone in assembly
Public | Accessibly by anyone who has visibility to this scope
Static | Defined on type, else per instance
Final | Method cannot be overridden
Virtual | Method is virtual
HideBySig | Method hides by name+sig, else just by name
VtableLayoutMask | Use this mask to retrieve vtable attributes. This bit contains
ReuseSlot | Method reuses existing slot in vtable
NewSlot | Method always gets a new slot in the vtable
Strict | Method can only be overriden if also accessible
Abstract | Method does not provide an implementation
SpecialName | Method is special
PInvokeImpl | Implementation is forwarded through PInvoke
UnmanagedExport | Reserved: shall be zero for conforming implementations
RTSpecialName | CLI provides 'special' behavior, depending upon the name of the method
HasSecurity | Method has security associate with it
RequireSecObject | Method calls another method containing security code.


MethodImplFlags

MethodImplFlags Enumeration

Flags describing a MethodMetadataTableRows implementation.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum MethodImplFlags : int

Members

Name | Description
CodeTypeMask | These 2 bits contain one of the following values:
IL | Method impl is CIL
Native | Method impl is native
OPTIL | Reserved: shall be zero in conforming implementations
Runtime | Method impl is provided by the runtime
ManagedMask | Flags specifying whether the code is managed or unmanaged. This bit contains one of the following values:
Unmanaged | Method impl is unmanaged, otherwise managed
Managed | Method impl is managed
ForwardRef | Implementation info and interop Indicates method is defined; used primarily in merge scenarios.
PreserveSig | Reserved: conforming implementations can ignore
InternalCall | Reserved: shall be zero in conforming implementations
Synchronized | Method is single threaded through the body
NoInlining | Method cannot be inlined
MaxMethodImplVal | Range check value

See also

Produced by the Live Documenter developed by The Box Software.


MethodImplMetadataTableRow

MethodImplMetadataTableRow Class

Allows the compiler to override the default inheritance rules provided by the CLI.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodImplMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MethodImplMetadataTableRow : MetadataRow

The MethodImplMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodImplMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MethodImplMetadataTableRow class

Properties

 | Name | Summary
public properties | Class() | An index into the TypeDef table
public properties | MethodBody() | An index in to a MethodDef or MemberRef, a MethodDefOrRef encoded index
public properties | MethodDeclaration() | An index in to a MethodDef or MemberRef table, a MethodDefOrRef encoded index

Fields

 | Name | Description
private field | _class |
private field | _methodBody |
private field | _methodDeclaration |


MethodImplMetadataTableRow Constructors

The MethodImplMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodImplMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MethodImplMetadataTableRow class


MethodImplMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the MethodImplMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodImplMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


MethodImplMetadataTableRow Fields

The MethodImplMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _class |
private field | _methodBody |
private field | _methodDeclaration |


_methodBody

_methodBody Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _methodBody


_methodDeclaration

_methodDeclaration Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _methodDeclaration


MethodImplMetadataTableRow Properties

The MethodImplMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Class() | An index into the TypeDef table
public properties | MethodBody() | An index in to a MethodDef or MemberRef, a MethodDefOrRef encoded index
public properties | MethodDeclaration() | An index in to a MethodDef or MemberRef table, a MethodDefOrRef encoded index


Class()

Class() Property

An index into the TypeDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


MethodBody()

MethodBody() Property

An index in to a MethodDef or MemberRef, a MethodDefOrRef encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


MethodDeclaration()

MethodDeclaration() Property

An index in to a MethodDef or MemberRef table, a MethodDefOrRef encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


MethodMetadataTableRow

MethodMetadataTableRow Class

Describes a method definition loaded from the metadata tables in the pe/coff file.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MethodMetadataTableRow : MetadataRow

The MethodMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the MethodMetadataTableRow class

Properties

 | Name | Summary
public properties | Flags() | A 2-byte bitmask of MethodAttributes
public properties | ImplFlags() | 2-byte bitmask of MethodImplAttributes
public properties | Name() | An index in to the string heap
public properties | ParamList() | An index in to the param table
public properties | RVA() | Address of the CIL method data
public properties | Signiture() | An index in to the blob heap

Fields

 | Name | Description
private field | _flags |
private field | _implFlags |
private field | _name |
private field | _paramList |
private field | _rva |
private field | _signiture |


MethodMetadataTableRow Constructors

The MethodMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the MethodMetadataTableRow class


MethodMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the MethodMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


MethodMetadataTableRow Fields

The MethodMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _implFlags |
private field | _name |
private field | _paramList |
private field | _rva |
private field | _signiture |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodAttributes _flags


_implFlags

_implFlags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodImplFlags _implFlags


_paramList

_paramList Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _paramList


MethodMetadataTableRow Properties

The MethodMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | A 2-byte bitmask of MethodAttributes
public properties | ImplFlags() | 2-byte bitmask of MethodImplAttributes
public properties | Name() | An index in to the string heap
public properties | ParamList() | An index in to the param table
public properties | RVA() | Address of the CIL method data
public properties | Signiture() | An index in to the blob heap


Flags()

Flags() Property

A 2-byte bitmask of MethodAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodAttributes this[] {
    get;
    set;
    }


ImplFlags()

ImplFlags() Property

2-byte bitmask of MethodImplAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodImplFlags this[] {
    get;
    set;
    }


ParamList()

ParamList() Property

An index in to the param table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


RVA()

RVA() Property

Address of the CIL method data
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


MethodSemanticsAttributes

MethodSemanticsAttributes Enumeration

An enumeration of available relationship references for methods to properties, events etc.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum MethodSemanticsAttributes : int

Members

Name | Description
Setter | Getter for a PropertyMetadataTableRow.
Getter | Setter for a PropertyMetadataTableRow.
Other | Other method for a PropertyMetadataTableRow or EventMetadataTableRow.
AddOn | Add method for a EventMetadataTableRow.
RemoveOn | Remove method for a EventMetadataTableRow.
Fire | Fire method for a EventMetadataTableRow.

See also

MethodSemanticsMetadataTableRow


MethodSemanticsMetadataTableRow

MethodSemanticsMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodSemanticsMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MethodSemanticsMetadataTableRow : MetadataRow

The MethodSemanticsMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodSemanticsMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MethodSemanticsMetadataTableRow class

Properties

 | Name | Summary
public properties | Association() | An index into the Event or Property table, a HasSemantics coded index
public properties | Method() | An index into the MethodDef table
public properties | Semantics() | A 2-byte bitmask of type MethodSemanticsAttributes.

Fields

 | Name | Description
private field | _association |
private field | _method |
private field | _semantics |

See also

MethodSemanticsAttributes


MethodSemanticsMetadataTableRow Constructors

The MethodSemanticsMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodSemanticsMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MethodSemanticsMetadataTableRow class


MethodSemanticsMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the MethodSemanticsMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodSemanticsMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


MethodSemanticsMetadataTableRow Fields

The MethodSemanticsMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _association |
private field | _method |
private field | _semantics |


_association

_association Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _association


_method

_method Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _method


_semantics

_semantics Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodSemanticsAttributes _semantics


MethodSemanticsMetadataTableRow Properties

The MethodSemanticsMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Association() | An index into the Event or Property table, a HasSemantics coded index
public properties | Method() | An index into the MethodDef table
public properties | Semantics() | A 2-byte bitmask of type MethodSemanticsAttributes.


Association()

Association() Property

An index into the Event or Property table, a HasSemantics coded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


Method()

Method() Property

An index into the MethodDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Semantics()

Semantics() Property

A 2-byte bitmask of type MethodSemanticsAttributes.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodSemanticsAttributes this[] {
    get;
    set;
    }


MethodSpecMetadataTableRow

MethodSpecMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.MethodSpecMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class MethodSpecMetadataTableRow : MetadataRow

The MethodSpecMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodSpecMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MethodSpecMetadataTableRow class

Properties

 | Name | Summary
public properties | Instantiation() | An index in to the blob heap
public properties | Method() | An index in to a MethodDef or MemberRef table, a MethodDefOrRef encoded index

Fields

 | Name | Description
private field | _instantiation |
private field | _method |


MethodSpecMetadataTableRow Constructors

The MethodSpecMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodSpecMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the MethodSpecMetadataTableRow class


MethodSpecMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the MethodSpecMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodSpecMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


MethodSpecMetadataTableRow Fields

The MethodSpecMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _instantiation |
private field | _method |


_instantiation

_instantiation Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _instantiation


_method

_method Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _method


MethodSpecMetadataTableRow Properties

The MethodSpecMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Instantiation() | An index in to the blob heap
public properties | Method() | An index in to a MethodDef or MemberRef table, a MethodDefOrRef encoded index


Instantiation()

Instantiation() Property

An index in to the blob heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Method()

Method() Property

An index in to a MethodDef or MemberRef table, a MethodDefOrRef encoded index
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


ModuleMetadataTableRow

ModuleMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ModuleMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ModuleMetadataTableRow : MetadataRow

The ModuleMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ModuleMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the ModuleMetadataTableRow class

Properties

 | Name | Summary
public properties | EncBaseId() | An index to the Guid heap, reserved shall be zero
public properties | EncId() | An index to the Guid heap, reserved shall be zero
public properties | Generation() | Reserved, shall be zero
public properties | Mvid() | An index to the Guid heap, to distinguish between two versions of the same module
public properties | Name() | Index to the string heap

Fields

 | Name | Description
private field | _encBaseId |
private field | _encId |
private field | _generation |
private field | _mvid |
private field | _name |

Remarks

Updated for 4-byte heap indexes


ModuleMetadataTableRow Constructors

The ModuleMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ModuleMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the ModuleMetadataTableRow class


ModuleMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the ModuleMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ModuleMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The byte contents of the file
offset
Type: Offset
The offset of this row
indexDetails
Type: IIndexDetails


ModuleMetadataTableRow Fields

The ModuleMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _encBaseId |
private field | _encId |
private field | _generation |
private field | _mvid |
private field | _name |


_encBaseId

_encBaseId Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _encBaseId


_encId

_encId Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _encId


_generation

_generation Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _generation


_mvid

_mvid Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _mvid


ModuleMetadataTableRow Properties

The ModuleMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | EncBaseId() | An index to the Guid heap, reserved shall be zero
public properties | EncId() | An index to the Guid heap, reserved shall be zero
public properties | Generation() | Reserved, shall be zero
public properties | Mvid() | An index to the Guid heap, to distinguish between two versions of the same module
public properties | Name() | Index to the string heap


EncBaseId()

EncBaseId() Property

An index to the Guid heap, reserved shall be zero
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


EncId()

EncId() Property

An index to the Guid heap, reserved shall be zero
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


Generation()

Generation() Property

Reserved, shall be zero
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Mvid()

Mvid() Property

An index to the Guid heap, to distinguish between two versions of the same module
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


Name()

Name() Property

Index to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


ModuleRefMetadataTableRow

ModuleRefMetadataTableRow Class

Created by a .module extern directive in the assembly

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ModuleRefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ModuleRefMetadataTableRow : MetadataRow

The ModuleRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ModuleRefMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the ModuleRefMetadataTableRow class

Properties

 | Name | Summary
public properties | Name() | An index in to the string heap

Fields

 | Name | Description
private field | _name |


ModuleRefMetadataTableRow Constructors

The ModuleRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ModuleRefMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the ModuleRefMetadataTableRow class


ModuleRefMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the ModuleRefMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ModuleRefMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


ModuleRefMetadataTableRow Fields

The ModuleRefMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _name |


ModuleRefMetadataTableRow Properties

The ModuleRefMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Name() | An index in to the string heap


NestedClassMetadataTableRow

NestedClassMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.NestedClassMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class NestedClassMetadataTableRow : MetadataRow

The NestedClassMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | NestedClassMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the NestedClassMetadataTableRow class

Properties

 | Name | Summary
public properties | EnclosingClass() | An index in to teh TypeDef table
public properties | NestedClass() | An index in to the TypeDef table

Fields

 | Name | Description
private field | _enclosingClass |
private field | _nestedClass |


NestedClassMetadataTableRow Constructors

The NestedClassMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | NestedClassMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the NestedClassMetadataTableRow class


NestedClassMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the NestedClassMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public NestedClassMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
indexDetails
Type: IIndexDetails


NestedClassMetadataTableRow Fields

The NestedClassMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _enclosingClass |
private field | _nestedClass |


_enclosingClass

_enclosingClass Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _enclosingClass


_nestedClass

_nestedClass Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _nestedClass


NestedClassMetadataTableRow Properties

The NestedClassMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | EnclosingClass() | An index in to teh TypeDef table
public properties | NestedClass() | An index in to the TypeDef table


EnclosingClass()

EnclosingClass() Property

An index in to teh TypeDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


NestedClass()

NestedClass() Property

An index in to the TypeDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


ParamAttributeFlags

ParamAttributeFlags Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum ParamAttributeFlags : ushort

Members

Name | Description
None |
In |
Out |
Optional |
ReservedMask |
HasDefault |
HasFieldMarshal |
Unused |


ParamMetadataTableRow

ParamMetadataTableRow Class

Represents a single entry in the Param Metadata table.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.ParamMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class ParamMetadataTableRow : MetadataRow

The ParamMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParamMetadataTableRow(Byte[], Offset, Byte) | Initialises a new instance of the ParamMetadataTableRow class

Properties

 | Name | Summary
public properties | Flags() | A 2-byte bitmask of ParamAttributes
public properties | Name() | Index in to the string heap
public properties | Sequence() | The sequence of the parameter

Fields

 | Name | Description
private field | _flags |
private field | _name |
private field | _sequence |

Remarks

The In, Out and Optional modifiers are specified in the Flags property. Further, if it is defined as optional the constant values supplied are recorded in the Constants Metadata directory p209 of .NET IL Assembler book. The constant can be accessed but the value is only available on the signature blob which makes it a little more difficult to access the value.


ParamMetadataTableRow Constructors

The ParamMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParamMetadataTableRow(Byte[], Offset, Byte) | Initialises a new instance of the ParamMetadataTableRow class


ParamMetadataTableRow(Byte[], Offset, Byte)

Initialises a new instance of the ParamMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParamMetadataTableRow(
byte[] contents,
Offset offset,
byte sizeOfStringIndex
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
sizeOfStringIndex
Type: Byte


ParamMetadataTableRow Fields

The ParamMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _flags |
private field | _name |
private field | _sequence |


_flags

_flags Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ParamAttributeFlags _flags


_sequence

_sequence Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _sequence


ParamMetadataTableRow Properties

The ParamMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Flags() | A 2-byte bitmask of ParamAttributes
public properties | Name() | Index in to the string heap
public properties | Sequence() | The sequence of the parameter


Flags()

Flags() Property

A 2-byte bitmask of ParamAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParamAttributeFlags this[] {
    get;
    set;
    }


Name()

Name() Property

Index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


Sequence()

Sequence() Property

The sequence of the parameter
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


PInvokeAttributes

PInvokeAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum PInvokeAttributes : short

Members

Name | Description
NoMangle |
CharSetMask |
CharSetNotSpec |
CharSetAnsi |
CharSetUnicode |
CharSetAuto |
SupportsLastError |
CallConvMask |
CallConvPlatformapi |
CallConvCdecl |
CallConvStdCall |
CallConvThisCall |
CallConvFastCall |


PropertyAttributes

PropertyAttributes Enumeration

Flags for properties
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum PropertyAttributes : ushort

Members

Name | Description
None | No attributes have been set
SpecialName | Property is special
RTSpecialName | Runtime (metadata and internal APIs) should check name encoding
HasDefault | Property has default
Unused | Reserved: shall be zero in a conforming implementation


PropertyMapMetadataTableRow

PropertyMapMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.PropertyMapMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class PropertyMapMetadataTableRow : MetadataRow

The PropertyMapMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyMapMetadataTableRow() |
public constructor | PropertyMapMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the PropertyMapMetadataTableRow

Properties

 | Name | Summary
public properties | Parent() | An index in to the TypeDef table
public properties | PropertyList() | An index in to the Property table

Fields

 | Name | Description
private field | _parent |
private field | _propertyList |


PropertyMapMetadataTableRow Constructors

The PropertyMapMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyMapMetadataTableRow() |
public constructor | PropertyMapMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the PropertyMapMetadataTableRow


PropertyMapMetadataTableRow()

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyMapMetadataTableRow()


PropertyMapMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the PropertyMapMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyMapMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset for this row
indexDetails
Type: IIndexDetails


PropertyMapMetadataTableRow Fields

The PropertyMapMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _parent |
private field | _propertyList |


_parent

_parent Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _parent


_propertyList

_propertyList Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _propertyList


PropertyMapMetadataTableRow Properties

The PropertyMapMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Parent() | An index in to the TypeDef table
public properties | PropertyList() | An index in to the Property table


Parent()

Parent() Property

An index in to the TypeDef table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


PropertyList()

PropertyList() Property

An index in to the Property table
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


PropertyMetadataTableRow

PropertyMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.PropertyMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class PropertyMetadataTableRow : MetadataRow

The PropertyMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the PropertyMetadataTableRow class

Properties

 | Name | Summary
public properties | Attributes() | A 2-byte bitmask of PropertyAttributes, only the values set are specified.
public properties | NameIndex() | An index in to the string heap
public properties | TypeIndex() | An index in to the blob heap for the signiture

Fields

 | Name | Description
private field | _attributes |
private field | _nameIndex |
private field | _typeIndex |


PropertyMetadataTableRow Constructors

The PropertyMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instance of the PropertyMetadataTableRow class


PropertyMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instance of the PropertyMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of this row
indexDetails
Type: IIndexDetails


PropertyMetadataTableRow Fields

The PropertyMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _attributes |
private field | _nameIndex |
private field | _typeIndex |


_attributes

_attributes Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PropertyAttributes _attributes


_typeIndex

_typeIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _typeIndex


PropertyMetadataTableRow Properties

The PropertyMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Attributes() | A 2-byte bitmask of PropertyAttributes, only the values set are specified.
public properties | NameIndex() | An index in to the string heap
public properties | TypeIndex() | An index in to the blob heap for the signiture


Attributes()

Attributes() Property

A 2-byte bitmask of PropertyAttributes, only the values set are specified.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyAttributes this[] {
    get;
    set;
    }


NameIndex()

NameIndex() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


TypeIndex()

TypeIndex() Property

An index in to the blob heap for the signiture
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


StandAloneSigMetadataTableRow

StandAloneSigMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.StandAloneSigMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class StandAloneSigMetadataTableRow : MetadataRow

The StandAloneSigMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | StandAloneSigMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instnace of the StandAloneSigMetadataTableRow

Properties

 | Name | Summary
public properties | Signiture() | An index in to the blob heap, which points to a signiture which is note referenced by a normal member

Fields

 | Name | Description
private field | _signiture |


StandAloneSigMetadataTableRow Constructors

The StandAloneSigMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | StandAloneSigMetadataTableRow(Byte[], Offset, IIndexDetails) | Initialises a new instnace of the StandAloneSigMetadataTableRow


StandAloneSigMetadataTableRow(Byte[], Offset, IIndexDetails)

Initialises a new instnace of the StandAloneSigMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StandAloneSigMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of teh file
offset
Type: Offset
The offset for this row
indexDetails
Type: IIndexDetails


StandAloneSigMetadataTableRow Fields

The StandAloneSigMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _signiture |


StandAloneSigMetadataTableRow Properties

The StandAloneSigMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Signiture() | An index in to the blob heap, which points to a signiture which is note referenced by a normal member


Signiture()

Signiture() Property

An index in to the blob heap, which points to a signiture which is note referenced by a normal member
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public BlobIndex this[] {
    get;
    set;
    }


Stream

Stream Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Stream
      • TheBoxSoftware.Reflection.Core.COFF.BlobStream
      • TheBoxSoftware.Reflection.Core.COFF.GuidStream
      • TheBoxSoftware.Reflection.Core.COFF.MetadataStream
      • TheBoxSoftware.Reflection.Core.COFF.StringStream
      • TheBoxSoftware.Reflection.Core.COFF.USStream
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class Stream

The Stream type exposes the following members.

Constructors

 | Class | Summary
public constructor | Stream() |

Methods

 | Name | Summary
public method | Create(PeCoffFile, UInt32, Int32, String) |

Properties

 | Name | Summary
public properties | Name() |
public properties | StreamType() |

Fields

 | Name | Description
private field | _name |
private field | _streamType |


Stream Constructors

The Stream type exposes the following members.

Constructors

 | Class | Summary
public constructor | Stream() |


Stream()

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Stream()


Stream Fields

The Stream type exposes the following members.

Fields

 | Name | Description
private field | _name |
private field | _streamType |


_name

_name Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _name


_streamType

_streamType Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Streams _streamType


Stream Methods

The Stream type exposes the following members.

Methods

 | Name | Summary
public method | Create(PeCoffFile, UInt32, Int32, String) |


Create(PeCoffFile, UInt32, Int32, String)

Create(PeCoffFile, UInt32, Int32, String) Method

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static Stream Create(
    PeCoffFile file,
    uint address,
    int size,
    string name
    )

Parameters

file
Type: PeCoffFile
address
Type: UInt32
size
Type: Int32
name
Type: String


Stream Properties

The Stream type exposes the following members.

Properties

 | Name | Summary
public properties | Name() |
public properties | StreamType() |


Name()

Name() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


StreamType()

StreamType() Property

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Streams this[] {
    get;
    set;
    }


Streams

Streams Enumeration

Enumeration of all the streams that can be located in a PE/COFF file.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum Streams : byte

Members

Name | Description
MetadataStream | The stream containing the .net metadata.
StringStream | The stream containing the strings referenced by the metadata.
BlobStream | The stream which contains the signiuture and other information for the metadata.
USStream | The stream which contains the user strings referenced by the metadata.
GuidStream | The stream which contains any referenced GUIDs in the metadata.


StringIndex

StringIndex Structure

Represents an index in to the metadata StringStream.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public struct StringIndex

The StringIndex type exposes the following members.

Constructors

 | Class | Summary
public constructor | StringIndex(Byte[], Byte, Offset) |

Fields

 | Name | Description
public field | Value |


StringIndex Constructors

The StringIndex type exposes the following members.

Constructors

 | Class | Summary
public constructor | StringIndex(Byte[], Byte, Offset) |


StringIndex(Byte[], Byte, Offset)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex(
byte[] fileContents,
byte sizeOfStringIndexes,
Offset offset
)

Parameters

fileContents
Type: Byte
sizeOfStringIndexes
Type: Byte
offset
Type: Offset


StringIndex Fields

The StringIndex type exposes the following members.

Fields

 | Name | Description
public field | Value |


StringStream

StringStream Class

The string stream which stores the strings for all metadata names and text.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Stream
      • TheBoxSoftware.Reflection.Core.COFF.StringStream
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class StringStream : Stream,
    IStringStream

The StringStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | StringStream(Byte[], UInt32, Int32) | Initialises a new instance of the StringStream class.

Methods

 | Name | Summary
public method | GetAllStrings() | Returns all the strings stored in this stream.
public method | GetString(UInt32) | Retrieves the string from the stream at the specified index. This index is retrieved from the property where implemented in the classes.

Fields

 | Name | Description
private field | _streamContents |
private constant | TerminatingChar |


StringStream Constructors

The StringStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | StringStream(Byte[], UInt32, Int32) | Initialises a new instance of the StringStream class.


StringStream(Byte[], UInt32, Int32)

Initialises a new instance of the StringStream class.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal StringStream(
byte[] fileContents,
uint address,
int size
)

Parameters

fileContents
Type: Byte
The file this stream is a part of.
address
Type: UInt32
The start address of the string stream.
size
Type: Int32
The size of the stream.

Exceptions

Exception | Condition
System.InvalidOperationException | The application encountered an invalid and unexpected character at the start of the stream.


StringStream Fields

The StringStream type exposes the following members.

Fields

 | Name | Description
private field | _streamContents |
private constant | TerminatingChar |


TerminatingChar

TerminatingChar Constant

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const char TerminatingChar


StringStream Methods

The StringStream type exposes the following members.

Methods

 | Name | Summary
public method | GetAllStrings() | Returns all the strings stored in this stream.
public method | GetString(UInt32) | Retrieves the string from the stream at the specified index. This index is retrieved from the property where implemented in the classes.


GetAllStrings()

GetAllStrings() Method

Returns all the strings stored in this stream.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<int, string> GetAllStrings()


GetString(UInt32)

GetString(UInt32) Method

Retrieves the string from the stream at the specified index. This index is retrieved from the property where implemented in the classes.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetString(
    uint index
    )

Parameters

index
Type: UInt32
The index.


TypeAttributes

TypeAttributes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum TypeAttributes : int

Members

Name | Description
VisibilityMask |
NotPublic |
Public |
NestedPublic |
NestedPrivate |
NestedFamily |
NestedAssembly |
NestedFamAndAssem |
NestedFamOrAssem |
LayoutMask |
AutoLayout |
SequentialLayout |
ExplicitLayout |
ClassSemanticMask |
Class |
Interface |
Abstract |
Sealed |
SpecialName |
Import |
Serializable |
StringFormatMask |
AnsiClass |
UnicodeClass |
AutoClass |
CustomFormatClass |
CustomStringFormatMask |
BeforeFieldInit |
RTSpecialName |
HasSecurity |


TypeDefMetadataTableRow

TypeDefMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.TypeDefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class TypeDefMetadataTableRow : MetadataRow

The TypeDefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises an instance of the TypeDefMetadataTableRow

Properties

 | Name | Summary
public properties | Extends() | An index in to the TypeDef, TypeRef, or TypeSpec table, more precisely TypeDefOrRef coded index.
public properties | FieldList() | An index in to the Field table, marking the first of a continuous run of fields for the type. It continues until the smaller of, the last row in the table, the next run of fields.
public properties | Flags() | A 4-byte bitmask of TypeAttributes
public properties | MethodList() | An index in to the MethodDef table, continuos list as above.
public properties | Name() | An index in to the string heap
public properties | Namespace() | An index in to the string heap

Fields

 | Name | Description
private field | _extends |
private field | _fieldList |
private field | _flags |
private field | _methodList |
private field | _nameIndex |
private field | _namespaceIndex |

Remarks

Updated for 4-byte heap indexes


TypeDefMetadataTableRow Constructors

The TypeDefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises an instance of the TypeDefMetadataTableRow


TypeDefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises an instance of the TypeDefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDefMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The contents of the file
offset
Type: Offset
The offset of the current row
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


TypeDefMetadataTableRow Fields

The TypeDefMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _extends |
private field | _fieldList |
private field | _flags |
private field | _methodList |
private field | _nameIndex |
private field | _namespaceIndex |


_extends

_extends Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _extends


_fieldList

_fieldList Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _fieldList


_methodList

_methodList Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Index _methodList


_namespaceIndex

_namespaceIndex Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StringIndex _namespaceIndex


TypeDefMetadataTableRow Properties

The TypeDefMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Extends() | An index in to the TypeDef, TypeRef, or TypeSpec table, more precisely TypeDefOrRef coded index.
public properties | FieldList() | An index in to the Field table, marking the first of a continuous run of fields for the type. It continues until the smaller of, the last row in the table, the next run of fields.
public properties | Flags() | A 4-byte bitmask of TypeAttributes
public properties | MethodList() | An index in to the MethodDef table, continuos list as above.
public properties | Name() | An index in to the string heap
public properties | Namespace() | An index in to the string heap


Extends()

Extends() Property

An index in to the TypeDef, TypeRef, or TypeSpec table, more precisely TypeDefOrRef coded index.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


FieldList()

FieldList() Property

An index in to the Field table, marking the first of a continuous run of fields for the type. It continues until the smaller of, the last row in the table, the next run of fields.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Flags()

Flags() Property

A 4-byte bitmask of TypeAttributes
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeAttributes this[] {
    get;
    set;
    }


MethodList()

MethodList() Property

An index in to the MethodDef table, continuos list as above.
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Index this[] {
    get;
    set;
    }


Namespace()

Namespace() Property

An index in to the string heap
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StringIndex this[] {
    get;
    set;
    }


TypeRefMetadataTableRow

TypeRefMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.TypeRefMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class TypeRefMetadataTableRow : MetadataRow

The TypeRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeRefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the TypeRefMetadataTableRow class

Properties

 | Name | Summary
public properties | Name() | An index in to the string heap
public properties | Namespace() | An index in to the string heap
public properties | ResolutionScope() | An index in to a Module, ModuleRef, AssemblyRef, or TypeRef table, or null. More precisely a ResolutionScope

Fields

 | Name | Description
private field | _nameIndex |
private field | _namespaceIndex |
private field | _resolutionScope |

Remarks

Updated for 4-byte heap indexes


TypeRefMetadataTableRow Constructors

The TypeRefMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeRefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails) | Initialises a new instance of the TypeRefMetadataTableRow class


TypeRefMetadataTableRow(Byte[], Offset, ICodedIndexResolver, IIndexDetails)

Initialises a new instance of the TypeRefMetadataTableRow class
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRefMetadataTableRow(
byte[] contents,
Offset offset,
ICodedIndexResolver resolver,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
The file contents
offset
Type: Offset
The offset for this entry
resolver
Type: ICodedIndexResolver
indexDetails
Type: IIndexDetails


TypeRefMetadataTableRow Fields

The TypeRefMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _nameIndex |
private field | _namespaceIndex |
private field | _resolutionScope |


_resolutionScope

_resolutionScope Field

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _resolutionScope


TypeRefMetadataTableRow Properties

The TypeRefMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Name() | An index in to the string heap
public properties | Namespace() | An index in to the string heap
public properties | ResolutionScope() | An index in to a Module, ModuleRef, AssemblyRef, or TypeRef table, or null. More precisely a ResolutionScope


ResolutionScope()

ResolutionScope() Property

An index in to a Module, ModuleRef, AssemblyRef, or TypeRef table, or null. More precisely a ResolutionScope
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    set;
    }


TypeSpecMetadataTableRow

TypeSpecMetadataTableRow Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.MetadataRow
      • TheBoxSoftware.Reflection.Core.COFF.TypeSpecMetadataTableRow
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class TypeSpecMetadataTableRow : MetadataRow

The TypeSpecMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSpecMetadataTableRow(Byte[], Offset, IIndexDetails) |

Properties

 | Name | Summary
public properties | Signiture() | An index in to the blob heap

Fields

 | Name | Description
private field | _signiture |


TypeSpecMetadataTableRow Constructors

The TypeSpecMetadataTableRow type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSpecMetadataTableRow(Byte[], Offset, IIndexDetails) |


TypeSpecMetadataTableRow(Byte[], Offset, IIndexDetails)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeSpecMetadataTableRow(
byte[] contents,
Offset offset,
IIndexDetails indexDetails
)

Parameters

contents
Type: Byte
offset
Type: Offset
indexDetails
Type: IIndexDetails


TypeSpecMetadataTableRow Fields

The TypeSpecMetadataTableRow type exposes the following members.

Fields

 | Name | Description
private field | _signiture |


TypeSpecMetadataTableRow Properties

The TypeSpecMetadataTableRow type exposes the following members.

Properties

 | Name | Summary
public properties | Signiture() | An index in to the blob heap


USStream

USStream Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.Stream
      • TheBoxSoftware.Reflection.Core.COFF.USStream
Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class USStream : Stream

The USStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | USStream(Byte[], Int32) |


USStream Constructors

The USStream type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | USStream(Byte[], Int32) |


USStream(Byte[], Int32)

Namespace: TheBoxSoftware.Reflection.Core.COFFAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal USStream(
byte[] contents,
int address
)

Parameters

contents
Type: Byte
address
Type: Int32


TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolver Namespace

Classes

 | Class | Summary
public class | IndexDetails |


IndexDetails

IndexDetails Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolver.IndexDetails
Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class IndexDetails

The IndexDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | IndexDetails() |

Methods

 | Name | Summary
public method | IsLarge() | Indicates if the coded index is larger than a 2byte value (16 bits)
public method | RequiredNumberOfBytes() | Returns the number of bytes required to hold this coded index

Fields

 | Name | Description
public field | BitsToRepresentTag |
public field | Mask |
public field | MaxRowsInTables |
public field | Tables |


IndexDetails Constructors

The IndexDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | IndexDetails() |


IndexDetails()

Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public IndexDetails()


IndexDetails Fields

The IndexDetails type exposes the following members.

Fields

 | Name | Description
public field | BitsToRepresentTag |
public field | Mask |
public field | MaxRowsInTables |
public field | Tables |


BitsToRepresentTag

BitsToRepresentTag Field

Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte BitsToRepresentTag


Mask

Mask Field

Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint Mask


MaxRowsInTables

MaxRowsInTables Field

Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint MaxRowsInTables


Tables

Tables Field

Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List Tables


IndexDetails Methods

The IndexDetails type exposes the following members.

Methods

 | Name | Summary
public method | IsLarge() | Indicates if the coded index is larger than a 2byte value (16 bits)
public method | RequiredNumberOfBytes() | Returns the number of bytes required to hold this coded index


IsLarge()

IsLarge() Method

Indicates if the coded index is larger than a 2byte value (16 bits)
Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsLarge()


RequiredNumberOfBytes()

RequiredNumberOfBytes() Method

Returns the number of bytes required to hold this coded index
Namespace: TheBoxSoftware.Reflection.Core.COFF.CodedIndexResolverAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int RequiredNumberOfBytes()


TheBoxSoftware.Reflection.Core.PE Namespace

Classes

 | Class | Summary
public class | DataDirectory | A data directory entry is a row in the data directory table in a PE file that refers to one of 16 predefined tables.
public class | FileHeader |
public class | PEHeader |
public class | SectionHeader |

Enumerations

 | Name | Summary
public enum | DataDirectories | Enumeration of all the available data directories in a MS PE/COFF file.
public enum | FileCharacteristics |
public enum | FileMagicNumbers |
public enum | MachineTypes |
public enum | SectionCharacteristics |


DataDirectories

DataDirectories Enumeration

Enumeration of all the available data directories in a MS PE/COFF file.
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum DataDirectories : byte

Members

Name | Description
ExportDirectory |
ImportTable |
ResourceTable |
ExceptionTable |
CertificateTable |
BaseRelocationTable |
DebugData |
AchitectureData |
GlobalPointer |
TLSTable |
LoadConfigurationTable |
BoundImportTable |
ImportAddressTable |
DelayImportDescriptor |
CommonLanguageRuntimeHeader |
Reserved |


DataDirectory

DataDirectory Class

A data directory entry is a row in the data directory table in a PE file that refers to one of 16 predefined tables.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.PE.DataDirectory
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class DataDirectory

The DataDirectory type exposes the following members.

Constructors

 | Class | Summary
public constructor | DataDirectory(Byte[], DataDirectories) |
public constructor | DataDirectory(Byte[]) | Constructor

Properties

 | Name | Summary
public properties | Directory() | The directory being represented
public properties | IsUsed | Boolean value indicating if this directory is in use
public properties | Size() | Size of directory in bytes
public properties | VirtualAddress() | Relative virtual address of the directory

Fields

 | Name | Description
private field | _directory |
private field | _size |
private field | _virtualAddress |
public constant | SizeInBytes |

Remarks

The table of directories start at offset 96 in a 32bit PE and 112 in a 64bit PE.


DataDirectory Constructors

The DataDirectory type exposes the following members.

Constructors

 | Class | Summary
public constructor | DataDirectory(Byte[], DataDirectories) |
public constructor | DataDirectory(Byte[]) | Constructor


DataDirectory(Byte[], DataDirectories)

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory(
byte[] data,
DataDirectories directory
)

Parameters

data
Type: Byte
The byte data to populate the instance with
directory
Type: DataDirectories

Exceptions

Exception | Condition
System.ArgumentException | Not enough byte data supplied


DataDirectory(Byte[])

Constructor
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectory(
byte[] data
)

Parameters

data
Type: Byte
The byte data to populate the instance with

Exceptions

Exception | Condition
System.ArgumentException | Not enough byte data supplied


DataDirectory Fields

The DataDirectory type exposes the following members.

Fields

 | Name | Description
private field | _directory |
private field | _size |
private field | _virtualAddress |
public constant | SizeInBytes |


_directory

_directory Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DataDirectories _directory


_size

_size Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _size


_virtualAddress

_virtualAddress Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _virtualAddress


SizeInBytes

SizeInBytes Constant

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const int SizeInBytes


DataDirectory Properties

The DataDirectory type exposes the following members.

Properties

 | Name | Summary
public properties | Directory() | The directory being represented
public properties | IsUsed | Boolean value indicating if this directory is in use
public properties | Size() | Size of directory in bytes
public properties | VirtualAddress() | Relative virtual address of the directory


Directory()

Directory() Property

The directory being represented
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DataDirectories this[] {
    get;
    set;
    }


IsUsed

IsUsed Property

Boolean value indicating if this directory is in use
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool IsUsed {
    get;
    }


Size()

Size() Property

Size of directory in bytes
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


VirtualAddress()

VirtualAddress() Property

Relative virtual address of the directory
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


FileCharacteristics

FileCharacteristics Enumeration

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum FileCharacteristics : ushort

Members

Name | Description
RelocsStripped |
ExecutableImage |
LineNumbersStripped |
LocalSymbolsStripped |
AggressiveWhiteSpaceTrim |
LargeAddressAware |
BytesReversedLoEndian |
Bit32Machine |
debugStripped |
RemovableRunFromSwap |
NetRunFromSwap |
System |
Dll |
UpSystemOnly |
BytesReversedHiEndian |


FileHeader

FileHeader Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.PE.FileHeader
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class FileHeader

The FileHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | FileHeader(Byte[], Offset) | Initialises the ImageFileHeader class and populates it with the specific data from the file contents

Properties

 | Name | Summary
public properties | Characteristics() |
public properties | Machine() |
public properties | NumberOfSections() |
public properties | NumberOfSymbols() |
public properties | PointerToSymbolTable() |
public properties | SizeOfOptionalHeader() |
public properties | TimeDateStamp() |

Fields

 | Name | Description
private field | _characteristics |
private field | _machine |
private field | _numberOfSections |
private field | _numberOfSymbols |
private field | _pointerToSymbolTable |
private field | _sizeOfOptionalHeader |
private field | _timeDateStamp |


FileHeader Constructors

The FileHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | FileHeader(Byte[], Offset) | Initialises the ImageFileHeader class and populates it with the specific data from the file contents


FileHeader(Byte[], Offset)

Initialises the ImageFileHeader class and populates it with the specific data from the file contents
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FileHeader(
byte[] fileContents,
Offset offset
)

Parameters

fileContents
Type: Byte
The contents of the file being read as an array
offset
Type: Offset
The offset for the image file header


FileHeader Fields

The FileHeader type exposes the following members.

Fields

 | Name | Description
private field | _characteristics |
private field | _machine |
private field | _numberOfSections |
private field | _numberOfSymbols |
private field | _pointerToSymbolTable |
private field | _sizeOfOptionalHeader |
private field | _timeDateStamp |


_characteristics

_characteristics Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FileCharacteristics _characteristics


_machine

_machine Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MachineTypes _machine


_numberOfSections

_numberOfSections Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _numberOfSections


_numberOfSymbols

_numberOfSymbols Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _numberOfSymbols


_pointerToSymbolTable

_pointerToSymbolTable Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _pointerToSymbolTable


_sizeOfOptionalHeader

_sizeOfOptionalHeader Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _sizeOfOptionalHeader


_timeDateStamp

_timeDateStamp Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _timeDateStamp


FileHeader Properties

The FileHeader type exposes the following members.

Properties

 | Name | Summary
public properties | Characteristics() |
public properties | Machine() |
public properties | NumberOfSections() |
public properties | NumberOfSymbols() |
public properties | PointerToSymbolTable() |
public properties | SizeOfOptionalHeader() |
public properties | TimeDateStamp() |


Characteristics()

Characteristics() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FileCharacteristics this[] {
    get;
    set;
    }


Machine()

Machine() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MachineTypes this[] {
    get;
    set;
    }


NumberOfSections()

NumberOfSections() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


NumberOfSymbols()

NumberOfSymbols() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


PointerToSymbolTable()

PointerToSymbolTable() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SizeOfOptionalHeader()

SizeOfOptionalHeader() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


TimeDateStamp()

TimeDateStamp() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


FileMagicNumbers

FileMagicNumbers Enumeration

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum FileMagicNumbers : ushort

Members

Name | Description
Bit32 |
Bit64 |
ROM |


MachineTypes

MachineTypes Enumeration

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum MachineTypes : int

Members

Name | Description
Unknown |
I386 |
R3000 |
R4000 |
R10000 |
WCEMIPSV2 |
Alpha |
PowerPC |
SH3 |
SH3E |
SH4 |
ARM |
THUMB |
IA64 |
MIPS16 |
MIPSFPU |
MIPSFPU16 |
Alpha64 |
AXP64 |
AMD64 |


PEHeader

PEHeader Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.PE.PEHeader
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class PEHeader

The PEHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | PEHeader(Byte[], Offset) |

Properties

 | Name | Summary
public properties | AddressOfEntryPoint() |
public properties | BaseOfCode() |
public properties | BaseOfData() |
public properties | Checksum() |
public properties | DataDirectories() |
public properties | DllCharacteristics() |
public properties | FileAlignment() |
public properties | ImageBase() |
public properties | Is32 |
public properties | LoaderFlags() |
public properties | Magic() |
public properties | MajorImageVersion() |
public properties | MajorLinkerVersion() |
public properties | MajorOperatingSystemVersion() |
public properties | MajorSubSystemVersion() |
public properties | MinorImageVersion() |
public properties | MinorLinkerVersion() |
public properties | MinorOperatingSystemVersion() |
public properties | MinorSubSystemVersion() |
public properties | NumberOfRVAAndSizes() |
public properties | SectionAlignment() |
public properties | Size() | The size in bytes of the PEHeader without data directories
public properties | SizeOfCode() |
public properties | SizeOfHeaders() |
public properties | SizeOfHeapCommit() |
public properties | SizeOfHeapReserve() |
public properties | SizeOfImage() |
public properties | SizeOfInitializedData() |
public properties | SizeOfStackCommit() |
public properties | SizeOfStackReserve() |
public properties | SizeOfUnitializedData() |
public properties | Subsystem() |
public properties | Win32VersionValue() |

Fields

 | Name | Description
private field | _addressOfEntryPoint |
private field | _baseOfCode |
private field | _baseOfData |
private field | _checksum |
private field | _dataDirectories |
private field | _dllCharacteristics |
private field | _fileAlignment |
private field | _imageBase |
private field | _loaderFlags |
private field | _magic |
private field | _majorImageVersion |
private field | _majorLinkerVersion |
private field | _majorOperatingSystemVersion |
private field | _majorSubSystemVersion |
private field | _minorImageVersion |
private field | _minorLinkerVersion |
private field | _minorOperatingSystemVersion |
private field | _minorSubSystemVersion |
private field | _numberOfRvaAndSizes |
private field | _sectionAlignment |
private field | _size |
private field | _sizeOfCode |
private field | _sizeOfHeaders |
private field | _sizeOfHeapCommit |
private field | _sizeOfHeapReserve |
private field | _sizeOfImage |
private field | _sizeOfInitializedData |
private field | _sizeOfStackCommit |
private field | _sizeOfStackReserve |
private field | _sizeOfUnitializedData |
private field | _subsystem |
private field | _win32VersionValue |
public constant | Size32Bit |
public constant | Size64Bit |


PEHeader Constructors

The PEHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | PEHeader(Byte[], Offset) |


PEHeader(Byte[], Offset)

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PEHeader(
byte[] fileContents,
Offset offset
)

Parameters

fileContents
Type: Byte
offset
Type: Offset


PEHeader Fields

The PEHeader type exposes the following members.

Fields

 | Name | Description
private field | _addressOfEntryPoint |
private field | _baseOfCode |
private field | _baseOfData |
private field | _checksum |
private field | _dataDirectories |
private field | _dllCharacteristics |
private field | _fileAlignment |
private field | _imageBase |
private field | _loaderFlags |
private field | _magic |
private field | _majorImageVersion |
private field | _majorLinkerVersion |
private field | _majorOperatingSystemVersion |
private field | _majorSubSystemVersion |
private field | _minorImageVersion |
private field | _minorLinkerVersion |
private field | _minorOperatingSystemVersion |
private field | _minorSubSystemVersion |
private field | _numberOfRvaAndSizes |
private field | _sectionAlignment |
private field | _size |
private field | _sizeOfCode |
private field | _sizeOfHeaders |
private field | _sizeOfHeapCommit |
private field | _sizeOfHeapReserve |
private field | _sizeOfImage |
private field | _sizeOfInitializedData |
private field | _sizeOfStackCommit |
private field | _sizeOfStackReserve |
private field | _sizeOfUnitializedData |
private field | _subsystem |
private field | _win32VersionValue |
public constant | Size32Bit |
public constant | Size64Bit |


_addressOfEntryPoint

_addressOfEntryPoint Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _addressOfEntryPoint


_baseOfCode

_baseOfCode Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _baseOfCode


_baseOfData

_baseOfData Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _baseOfData


_checksum

_checksum Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _checksum


_dataDirectories

_dataDirectories Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary _dataDirectories


_dllCharacteristics

_dllCharacteristics Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _dllCharacteristics


_fileAlignment

_fileAlignment Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _fileAlignment


_imageBase

_imageBase Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _imageBase


_loaderFlags

_loaderFlags Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _loaderFlags


_magic

_magic Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FileMagicNumbers _magic


_majorImageVersion

_majorImageVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _majorImageVersion


_majorLinkerVersion

_majorLinkerVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _majorLinkerVersion


_majorOperatingSystemVersion

_majorOperatingSystemVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _majorOperatingSystemVersion


_majorSubSystemVersion

_majorSubSystemVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _majorSubSystemVersion


_minorImageVersion

_minorImageVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _minorImageVersion


_minorLinkerVersion

_minorLinkerVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private byte _minorLinkerVersion


_minorOperatingSystemVersion

_minorOperatingSystemVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _minorOperatingSystemVersion


_minorSubSystemVersion

_minorSubSystemVersion Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _minorSubSystemVersion


_numberOfRvaAndSizes

_numberOfRvaAndSizes Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _numberOfRvaAndSizes


_sectionAlignment

_sectionAlignment Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sectionAlignment


_size

_size Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _size


_sizeOfCode

_sizeOfCode Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizeOfCode


_sizeOfHeaders

_sizeOfHeaders Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizeOfHeaders


_sizeOfHeapCommit

_sizeOfHeapCommit Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _sizeOfHeapCommit


_sizeOfHeapReserve

_sizeOfHeapReserve Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _sizeOfHeapReserve


_sizeOfImage

_sizeOfImage Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizeOfImage


_sizeOfInitializedData

_sizeOfInitializedData Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizeOfInitializedData


_sizeOfStackCommit

_sizeOfStackCommit Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _sizeOfStackCommit


_sizeOfStackReserve

_sizeOfStackReserve Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ulong _sizeOfStackReserve


_sizeOfUnitializedData

_sizeOfUnitializedData Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizeOfUnitializedData


_subsystem

_subsystem Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _subsystem


_win32VersionValue

_win32VersionValue Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _win32VersionValue


Size32Bit

Size32Bit Constant

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const int Size32Bit


Size64Bit

Size64Bit Constant

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public const int Size64Bit


PEHeader Properties

The PEHeader type exposes the following members.

Properties

 | Name | Summary
public properties | AddressOfEntryPoint() |
public properties | BaseOfCode() |
public properties | BaseOfData() |
public properties | Checksum() |
public properties | DataDirectories() |
public properties | DllCharacteristics() |
public properties | FileAlignment() |
public properties | ImageBase() |
public properties | Is32 |
public properties | LoaderFlags() |
public properties | Magic() |
public properties | MajorImageVersion() |
public properties | MajorLinkerVersion() |
public properties | MajorOperatingSystemVersion() |
public properties | MajorSubSystemVersion() |
public properties | MinorImageVersion() |
public properties | MinorLinkerVersion() |
public properties | MinorOperatingSystemVersion() |
public properties | MinorSubSystemVersion() |
public properties | NumberOfRVAAndSizes() |
public properties | SectionAlignment() |
public properties | Size() | The size in bytes of the PEHeader without data directories
public properties | SizeOfCode() |
public properties | SizeOfHeaders() |
public properties | SizeOfHeapCommit() |
public properties | SizeOfHeapReserve() |
public properties | SizeOfImage() |
public properties | SizeOfInitializedData() |
public properties | SizeOfStackCommit() |
public properties | SizeOfStackReserve() |
public properties | SizeOfUnitializedData() |
public properties | Subsystem() |
public properties | Win32VersionValue() |


AddressOfEntryPoint()

AddressOfEntryPoint() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


BaseOfCode()

BaseOfCode() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


BaseOfData()

BaseOfData() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Checksum()

Checksum() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


DataDirectories()

DataDirectories() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Dictionary<DataDirectories, DataDirectory> this[] {
    get;
    set;
    }


DllCharacteristics()

DllCharacteristics() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


FileAlignment()

FileAlignment() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


ImageBase()

ImageBase() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


Is32

Is32 Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool Is32 {
    get;
    }


LoaderFlags()

LoaderFlags() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Magic()

Magic() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FileMagicNumbers this[] {
    get;
    set;
    }


MajorImageVersion()

MajorImageVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MajorLinkerVersion()

MajorLinkerVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte this[] {
    get;
    set;
    }


MajorOperatingSystemVersion()

MajorOperatingSystemVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MajorSubSystemVersion()

MajorSubSystemVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MinorImageVersion()

MinorImageVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MinorLinkerVersion()

MinorLinkerVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte this[] {
    get;
    set;
    }


MinorOperatingSystemVersion()

MinorOperatingSystemVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


MinorSubSystemVersion()

MinorSubSystemVersion() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


NumberOfRVAAndSizes()

NumberOfRVAAndSizes() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SectionAlignment()

SectionAlignment() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Size()

Size() Property

The size in bytes of the PEHeader without data directories
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int this[] {
    get;
    set;
    }


SizeOfCode()

SizeOfCode() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SizeOfHeaders()

SizeOfHeaders() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SizeOfHeapCommit()

SizeOfHeapCommit() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


SizeOfHeapReserve()

SizeOfHeapReserve() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


SizeOfImage()

SizeOfImage() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SizeOfInitializedData()

SizeOfInitializedData() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SizeOfStackCommit()

SizeOfStackCommit() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


SizeOfStackReserve()

SizeOfStackReserve() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ulong this[] {
    get;
    set;
    }


SizeOfUnitializedData()

SizeOfUnitializedData() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


Subsystem()

Subsystem() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


Win32VersionValue()

Win32VersionValue() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SectionCharacteristics

SectionCharacteristics Enumeration

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum SectionCharacteristics : uint

Members

Name | Description
Reserved1 |
Reserved2 |
Reserved3 |
Reserved4 |
NoPadding |
Reserved5 |
ContainsCode |
ContainsInitialisedData |
ContainsUnitialisedData |
LinkOther |
LinkInfo |
Reserved6 |
LinkRemove |
LinkCOMDAT |
GlobalPointerRel |
MemoryPurgable |
MemoryLocked |
MemoryPreLoad |
Align1Byte |
Align2Bytes |
Align4Bytes |
Align8Bytes |
Align16Bytes |
Align32Bytes |
Align64Bytes |
Align128Bytes |
Align256Bytes |
Align512Bytes |
Align1024Bytes |
Align2048Bytes |
Align4096Bytes |
Align8192Bytes |
LinkNRelocationsOVFL |
MemoryDiscardable |
MemoryNotCached |
MemoryNotPaged |
MemoryShared |
MemoryExecute |
MemoryRead |
MemoryWrite |


SectionHeader

SectionHeader Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Core.PE.SectionHeader
Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class SectionHeader

The SectionHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | SectionHeader() |
public constructor | SectionHeader(Byte[], Offset) |

Methods

 | Name | Summary
private method | ReadName(Byte[], Offset) |

Properties

 | Name | Summary
public properties | Characteristics() |
public properties | Name() |
public properties | NumberOfLineNumbers() |
public properties | NumberOfRelocations() |
public properties | PointerToLinenumbers() |
public properties | PointerToRawData() |
public properties | PointerToRelocations() |
public properties | SizeOfRawData() |
public properties | VirtualAddress() |
public properties | VirtualSize() |

Fields

 | Name | Description
private field | _characteristics |
private field | _name |
private field | _numberOfLines |
private field | _numberOfRelocations |
private field | _pointerToLineNumbers |
private field | _pointerToRawData |
private field | _pointerToRelocations |
private field | _sizeOfRawData |
private field | _virtualAddress |
private field | _virtualSize |


SectionHeader Constructors

The SectionHeader type exposes the following members.

Constructors

 | Class | Summary
public constructor | SectionHeader() |
public constructor | SectionHeader(Byte[], Offset) |


SectionHeader()

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SectionHeader()


SectionHeader(Byte[], Offset)

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SectionHeader(
byte[] fileContents,
Offset offset
)

Parameters

fileContents
Type: Byte
offset
Type: Offset


SectionHeader Fields

The SectionHeader type exposes the following members.

Fields

 | Name | Description
private field | _characteristics |
private field | _name |
private field | _numberOfLines |
private field | _numberOfRelocations |
private field | _pointerToLineNumbers |
private field | _pointerToRawData |
private field | _pointerToRelocations |
private field | _sizeOfRawData |
private field | _virtualAddress |
private field | _virtualSize |


_characteristics

_characteristics Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private SectionCharacteristics _characteristics


_name

_name Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _name


_numberOfLines

_numberOfLines Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _numberOfLines


_numberOfRelocations

_numberOfRelocations Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _numberOfRelocations


_pointerToLineNumbers

_pointerToLineNumbers Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _pointerToLineNumbers


_pointerToRawData

_pointerToRawData Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _pointerToRawData


_pointerToRelocations

_pointerToRelocations Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _pointerToRelocations


_sizeOfRawData

_sizeOfRawData Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizeOfRawData


_virtualSize

_virtualSize Field

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _virtualSize


SectionHeader Methods

The SectionHeader type exposes the following members.

Methods

 | Name | Summary
private method | ReadName(Byte[], Offset) |


ReadName(Byte[], Offset)

ReadName(Byte[], Offset) Method

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string ReadName(
    byte[] fileContents,
    Offset offset
    )

Parameters

fileContents
Type: Byte
offset
Type: Offset


SectionHeader Properties

The SectionHeader type exposes the following members.

Properties

 | Name | Summary
public properties | Characteristics() |
public properties | Name() |
public properties | NumberOfLineNumbers() |
public properties | NumberOfRelocations() |
public properties | PointerToLinenumbers() |
public properties | PointerToRawData() |
public properties | PointerToRelocations() |
public properties | SizeOfRawData() |
public properties | VirtualAddress() |
public properties | VirtualSize() |


Characteristics()

Characteristics() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SectionCharacteristics this[] {
    get;
    set;
    }


Name()

Name() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


NumberOfLineNumbers()

NumberOfLineNumbers() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


NumberOfRelocations()

NumberOfRelocations() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


PointerToLinenumbers()

PointerToLinenumbers() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


PointerToRawData()

PointerToRawData() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


PointerToRelocations()

PointerToRelocations() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


SizeOfRawData()

SizeOfRawData() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


VirtualAddress()

VirtualAddress() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


VirtualSize()

VirtualSize() Property

Namespace: TheBoxSoftware.Reflection.Core.PEAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    set;
    }


TheBoxSoftware.Reflection.MethodDef Namespaces

Namespace
TheBoxSoftware.Reflection.MethodDef


TheBoxSoftware.Reflection.MethodDef Namespace

Classes

 | Class | Summary
private class | MethodDefBuilder |


MethodDefBuilder

MethodDefBuilder Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.MethodDef.MethodDefBuilder
Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private class MethodDefBuilder

The MethodDefBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodDefBuilder(BuildReferences, TypeDef, MethodMetadataTableRow) |

Methods

 | Name | Summary
public method | Build() |
private method | CalculateIndexes() |
private method | LoadGenericParameters() |
private method | LoadParameters() |
private method | SetMethodProperties() |

Fields

 | Name | Description
private field | _assembly |
private field | _blobStream |
private field | _container |
private field | _endOfMethodIndex |
private field | _fromRow |
private field | _map |
private field | _metadata |
private field | _metadataStream |
private field | _methodToBuild |
private field | _references |
private field | _rowIndex |


MethodDefBuilder Constructors

The MethodDefBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodDefBuilder(BuildReferences, TypeDef, MethodMetadataTableRow) |


MethodDefBuilder(BuildReferences, TypeDef, MethodMetadataTableRow)

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDefBuilder(
BuildReferences references,
TypeDef container,
MethodMetadataTableRow fromRow
)

Parameters

references
Type: BuildReferences
container
Type: TypeDef
fromRow
Type: MethodMetadataTableRow


MethodDefBuilder Fields

The MethodDefBuilder type exposes the following members.

Fields

 | Name | Description
private field | _assembly |
private field | _blobStream |
private field | _container |
private field | _endOfMethodIndex |
private field | _fromRow |
private field | _map |
private field | _metadata |
private field | _metadataStream |
private field | _methodToBuild |
private field | _references |
private field | _rowIndex |


_assembly

_assembly Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private AssemblyDef _assembly


_blobStream

_blobStream Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobStream _blobStream


_container

_container Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _container


_endOfMethodIndex

_endOfMethodIndex Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _endOfMethodIndex


_fromRow

_fromRow Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodMetadataTableRow _fromRow


_map

_map Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataToDefinitionMap _map


_metadata

_metadata Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataDirectory _metadata


_metadataStream

_metadataStream Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataStream _metadataStream


_methodToBuild

_methodToBuild Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _methodToBuild


_references

_references Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BuildReferences _references


_rowIndex

_rowIndex Field

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _rowIndex


MethodDefBuilder Methods

The MethodDefBuilder type exposes the following members.

Methods

 | Name | Summary
public method | Build() |
private method | CalculateIndexes() |
private method | LoadGenericParameters() |
private method | LoadParameters() |
private method | SetMethodProperties() |


Build()

Build() Method

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef Build()


CalculateIndexes()

CalculateIndexes() Method

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void CalculateIndexes()


LoadGenericParameters()

LoadGenericParameters() Method

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadGenericParameters()


LoadParameters()

LoadParameters() Method

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadParameters()


SetMethodProperties()

SetMethodProperties() Method

Namespace: TheBoxSoftware.Reflection.MethodDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void SetMethodProperties()


TheBoxSoftware.Reflection.Signatures Namespaces

Namespace
TheBoxSoftware.Reflection.Signatures


TheBoxSoftware.Reflection.Signatures Namespace

Classes

 | Class | Summary
sealed class | ArrayShapeSignatureToken | A signiture that describes the shape of an array as defined.
sealed class | CallingConventionSignatureToken | Represents a calling convention in a signiture.
sealed class | ConstraintSignatureToken | Represents a constraint in a signiture as a token. Constraints can only be Pinned.
sealed class | CountSignatureToken |
sealed class | CustomAttributeSignature | The signiture for a custom attribute as described in section 23.3 of ECMA 335.
sealed class | CustomModifierToken | A token that describes a modified reference to a TypeDef, TypeRef or TypeSpec entry in the metadata tables.
public class | DisplayNameSignitureConvertor | A SignatureConvertor implementation that creates user displayable names for types, methods and properties.
sealed class | ElementTypeSignatureToken | Class that represents the simplist single element when a type is involved in a signiture. Where for example a type can be represented simply as a base type a class, or a valuetype, the ElementTypeSignitureToken will contain the relevant details about it and provide a mechanism for resolving the type. Where a type is described by more than a single element; that element will have its superflous detail described in the TypeSignatureToken class.
sealed class | FieldSignature | Describes a field signiture, which is specified in the ECMA 23.2.4.
sealed class | GenericArgumentCountSignatureToken | An Int32 numeric value that indicates the number of generics arguments in a signiture.
sealed class | GenericParamaterCountSignatureToken | A token that represents the number of generic parameters.
sealed class | LocalVariableSignature | Represents a local variable signiture in the signiture blob. Details of the signiture are available in the ECMA at 23.2.6.
sealed class | MethodDefSignature | A signiture for a method definition as described in section 23.2.1 in ECMA 335.
sealed class | MethodRefSignature |
sealed class | ParameterCountSignatureToken | A representation of a ParameterCount token in a signiture.
sealed class | ParamSignatureToken | This class is able to parse and store details about Param entries in Signatures. The Param signiture type is detailed in ECMA 335 at section 23.2.10.
sealed class | PrologSignatureToken | A class which represents a prolog for a CustomAttributeSignature.
sealed class | PropertySignature | A rerepresentation of the property signiture as described in ECMA 23.2.5.
sealed class | ReturnTypeSignatureToken | Represents the group of SignitureTokens that are read together.
sealed class | SentinalSignatureToken | Represents a sentinal signiture token.
sealed class | Signature |
sealed class | SignatureBuilder |
public class | SignatureConvertor | A base implementation of a class that converts a signiture to another medium.
sealed class | SignatureToken |
sealed class | SignatureTokenContainer | Represents a container for one or more SignitureToken instances. This is a constuct that allows groups of tokens that are always parsed together to be represented and contained via a single class.
sealed class | TypeDetails | Provides details about a type and its surounding information.
sealed class | TypeSignatureToken | Represents an element of a signiture that can be used to resolve back to a type, however the type it resolves back to can be one of many things; see ECMA 335 23.2.12. A type can be represented by one or more tokens, hence this token derives from SignatureTokenContainer. However it will always have an ElementTypeSignatureTokenwhich should allow any resolving to be perfomed more easily.
sealed class | TypeSpecificationSignature | Represents a signiture for a type specification as detailed in section 23.2.14 in ECMA 335.

Enumerations

 | Name | Summary
sealed enum | CallingConventions |
public enum | ElementTypes |
public enum | Signatures | Enumeration of available major signiture types that can be defined in a .net assembly.
sealed enum | SignatureTokens |


ArrayShapeSignatureToken

ArrayShapeSignatureToken Class

A signiture that describes the shape of an array as defined.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.ArrayShapeSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class ArrayShapeSignatureToken : SignatureToken

The ArrayShapeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ArrayShapeSignatureToken(Byte[], Offset) | Initialises a new instance of the ArrayShapeSignitureToken which reads the array share signiture from the provided signiture at offset.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation e.g. '[1..6, 5, ,]' of the array shape token.

Properties

 | Name | Summary
public properties | LoBounds() | The values of those low boundaries.
public properties | Rank() | The number of ranks in the array shape.
public properties | Sizes() | The defined sizes

Fields

 | Name | Description
private field | _loBounds |
private field | _rank |
private field | _sizes |


ArrayShapeSignatureToken Constructors

The ArrayShapeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ArrayShapeSignatureToken(Byte[], Offset) | Initialises a new instance of the ArrayShapeSignitureToken which reads the array share signiture from the provided signiture at offset.


ArrayShapeSignatureToken(Byte[], Offset)

Initialises a new instance of the ArrayShapeSignitureToken which reads the array share signiture from the provided signiture at offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ArrayShapeSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob to read this token from.
offset
Type: Offset
The offset where this roken begins.


ArrayShapeSignatureToken Fields

The ArrayShapeSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _loBounds |
private field | _rank |
private field | _sizes |


_loBounds

_loBounds Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _loBounds


_rank

_rank Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _rank


_sizes

_sizes Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _sizes


ArrayShapeSignatureToken Methods

The ArrayShapeSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation e.g. '[1..6, 5, ,]' of the array shape token.


ToString()

ToString() Method

Produces a string representation e.g. '[1..6, 5, ,]' of the array shape token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


ArrayShapeSignatureToken Properties

The ArrayShapeSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | LoBounds() | The values of those low boundaries.
public properties | Rank() | The number of ranks in the array shape.
public properties | Sizes() | The defined sizes


LoBounds()

LoBounds() Property

The values of those low boundaries.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint[] this[] {
    get;
    private set;
    }


Rank()

Rank() Property

The number of ranks in the array shape.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    private set;
    }


Sizes()

Sizes() Property

The defined sizes
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint[] this[] {
    get;
    private set;
    }


CallingConventions

CallingConventions Enumeration

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal enum CallingConventions : int

Members

Name | Description
Default | Default ("normal") method with a fixed-length argument list. ILAsm has no keyword for this calling convention.
C |
StdCall |
ThisCall |
FastCall |
VarArg | Method with a variable-length argument list. The ILAsm keyword is vararg.
Field | Field. ILAsm has no keyword for this calling convention.
LocalSig | Local variables. ILAsm has no keyword for this calling convention.
Property | Property. ILAsm has no keyword for this calling convention.
Unmanaged | Unmanaged calling convention, not currently used by the runtime and not recognised by ILAsm
GenericInst |
NativeVarArg |
Max |
Mask |
Generic |
HasThis | Instance method that has an instance pointer (this) as an implicit first argument.
ExplicitThis | Method call signiture. This first explicitly specified parameter is the instance pointer. The ILAsm keywork is explicit.


CallingConventionSignatureToken

CallingConventionSignatureToken Class

Represents a calling convention in a signiture.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.CallingConventionSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CallingConventionSignatureToken : SignatureToken

The CallingConventionSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | CallingConventionSignatureToken(Byte[], Offset) | Initialises a new instance of CallingConventionSignitureToken from the signiture blob at the specified offset.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the calling convention token.

Properties

 | Name | Summary
public properties | Convention() | Describes the convention used in this token.

Fields

 | Name | Description
private field | _convention |


CallingConventionSignatureToken Constructors

The CallingConventionSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | CallingConventionSignatureToken(Byte[], Offset) | Initialises a new instance of CallingConventionSignitureToken from the signiture blob at the specified offset.


CallingConventionSignatureToken(Byte[], Offset)

Initialises a new instance of CallingConventionSignitureToken from the signiture blob at the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CallingConventionSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob to read from.
offset
Type: Offset
The offset in the blob to read from.


CallingConventionSignatureToken Fields

The CallingConventionSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _convention |


_convention

_convention Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CallingConventions _convention


CallingConventionSignatureToken Methods

The CallingConventionSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the calling convention token.


ToString()

ToString() Method

Produces a string representation of the calling convention token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


CallingConventionSignatureToken Properties

The CallingConventionSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Convention() | Describes the convention used in this token.


Convention()

Convention() Property

Describes the convention used in this token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CallingConventions this[] {
    get;
    private set;
    }


ConstraintSignatureToken

ConstraintSignatureToken Class

Represents a constraint in a signiture as a token. Constraints can only be Pinned.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.ConstraintSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class ConstraintSignatureToken : SignatureToken

The ConstraintSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstraintSignatureToken(Byte[], Offset) | Initialises a new instance of the ConstraintSignitureToken from the signitureat the specified offset.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32) | Checks if the entry at offset in the signitureheap is a token.
public method | ToString() | Produces a string representation of the constraint token [Constraint: {ElementType}]

Properties

 | Name | Summary
public properties | Constraint() | The constraint this token represents.

Fields

 | Name | Description
private field | _constraint |


ConstraintSignatureToken Constructors

The ConstraintSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstraintSignatureToken(Byte[], Offset) | Initialises a new instance of the ConstraintSignitureToken from the signitureat the specified offset.


ConstraintSignatureToken(Byte[], Offset)

Initialises a new instance of the ConstraintSignitureToken from the signitureat the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ConstraintSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture to load from.
offset
Type: Offset
The offset in the signiture.


ConstraintSignatureToken Fields

The ConstraintSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _constraint |


_constraint

_constraint Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ElementTypes _constraint


ConstraintSignatureToken Methods

The ConstraintSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32) | Checks if the entry at offset in the signitureheap is a token.
public method | ToString() | Produces a string representation of the constraint token [Constraint: {ElementType}]


IsToken(Byte[], Int32)

IsToken(Byte[], Int32) Method

Checks if the entry at offset in the signitureheap is a token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static bool IsToken(
    byte[] signiture,
    int offset
    )

Parameters

signiture
Type: Byte
The signiture to check.
offset
Type: Int32
The offset in the signiture.


ToString()

ToString() Method

Produces a string representation of the constraint token [Constraint: {ElementType}]
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


ConstraintSignatureToken Properties

The ConstraintSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Constraint() | The constraint this token represents.


Constraint()

Constraint() Property

The constraint this token represents.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypes this[] {
    get;
    private set;
    }


CountSignatureToken

CountSignatureToken Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.CountSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CountSignatureToken : SignatureToken

The CountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | CountSignatureToken(Byte[], Offset) | Initialises a new Count token from the provided signiture at offset.

Methods

 | Name | Summary
public method | ToString() |

Properties

 | Name | Summary
public properties | Count() |

Fields

 | Name | Description
private field | _count |


CountSignatureToken Constructors

The CountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | CountSignatureToken(Byte[], Offset) | Initialises a new Count token from the provided signiture at offset.


CountSignatureToken(Byte[], Offset)

Initialises a new Count token from the provided signiture at offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CountSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offset in the signiture.


CountSignatureToken Fields

The CountSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _count |


_count

_count Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _count


CountSignatureToken Methods

The CountSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() |


ToString()

ToString() Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


CountSignatureToken Properties

The CountSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Count() |


Count()

Count() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    set;
    }


CustomAttributeSignature

CustomAttributeSignature Class

The signiture for a custom attribute as described in section 23.3 of ECMA 335.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.CustomAttributeSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CustomAttributeSignature : Signature

The CustomAttributeSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomAttributeSignature(Byte[]) | Initialises a new instance of the CustomAttributeSigniture class.


CustomAttributeSignature Constructors

The CustomAttributeSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomAttributeSignature(Byte[]) | Initialises a new instance of the CustomAttributeSigniture class.


CustomAttributeSignature(Byte[])

Initialises a new instance of the CustomAttributeSigniture class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CustomAttributeSignature(
byte[] signiture
)

Parameters

signiture
Type: Byte
The byte contents of the signiture.

Exceptions

Exception | Condition
System.InvalidOperationException | Thrown when a value for the prolog differs from 0x0001. This indicates the incorrect signiture type is being read or the signiture contents are invalid.


CustomModifierToken

CustomModifierToken Class

A token that describes a modified reference to a TypeDef, TypeRef or TypeSpec entry in the metadata tables.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.CustomModifierToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CustomModifierToken : SignatureToken

The CustomModifierToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomModifierToken(Byte[], Offset) | Initialises a CustomModifier token from the signiture blob at the specified offset.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32) | Checks if the next token at the current offset can potentially be a CustomModifierToken.
private method | ReadEncodedDefOrRefToken(Byte[], Offset) | Reads a DefOrRefToken from the signiture which defines a compressed form of TypeRef, TypeSpec, or TypeDef token.
public method | ToString() | Produces a string representaion of the custom modifier token.

Properties

 | Name | Summary
public properties | Index() | The index to the TypeDef, TypeRef or TypeSpec metadata table.
public properties | Modifier() | The modifer for the token either CModOptional or CModRequired.

Fields

 | Name | Description
private field | _index |
private field | _modifier |


CustomModifierToken Constructors

The CustomModifierToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | CustomModifierToken(Byte[], Offset) | Initialises a CustomModifier token from the signiture blob at the specified offset.


CustomModifierToken(Byte[], Offset)

Initialises a CustomModifier token from the signiture blob at the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CustomModifierToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offset in the signiture.


CustomModifierToken Fields

The CustomModifierToken type exposes the following members.

Fields

 | Name | Description
private field | _index |
private field | _modifier |


_index

_index Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex _index


_modifier

_modifier Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ElementTypes _modifier


CustomModifierToken Methods

The CustomModifierToken type exposes the following members.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32) | Checks if the next token at the current offset can potentially be a CustomModifierToken.
private method | ReadEncodedDefOrRefToken(Byte[], Offset) | Reads a DefOrRefToken from the signiture which defines a compressed form of TypeRef, TypeSpec, or TypeDef token.
public method | ToString() | Produces a string representaion of the custom modifier token.


IsToken(Byte[], Int32)

IsToken(Byte[], Int32) Method

Checks if the next token at the current offset can potentially be a CustomModifierToken.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static bool IsToken(
    byte[] signiture,
    int offset
    )

Parameters

signiture
Type: Byte
The signiture to preview
offset
Type: Int32
The current offset in the signiture


ReadEncodedDefOrRefToken(Byte[], Offset)

ReadEncodedDefOrRefToken(Byte[], Offset) Method

Reads a DefOrRefToken from the signiture which defines a compressed form of TypeRef, TypeSpec, or TypeDef token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private CodedIndex ReadEncodedDefOrRefToken(
    byte[] signiture,
    Offset offset
    )

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offset in the signiture.


ToString()

ToString() Method

Produces a string representaion of the custom modifier token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


CustomModifierToken Properties

The CustomModifierToken type exposes the following members.

Properties

 | Name | Summary
public properties | Index() | The index to the TypeDef, TypeRef or TypeSpec metadata table.
public properties | Modifier() | The modifer for the token either CModOptional or CModRequired.


Index()

Index() Property

The index to the TypeDef, TypeRef or TypeSpec metadata table.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CodedIndex this[] {
    get;
    private set;
    }


Modifier()

Modifier() Property

The modifer for the token either CModOptional or CModRequired.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypes this[] {
    get;
    private set;
    }


DisplayNameSignitureConvertor

DisplayNameSignitureConvertor Class

A SignatureConvertor implementation that creates user displayable names for types, methods and properties.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureConvertor
      • TheBoxSoftware.Reflection.Signatures.DisplayNameSignitureConvertor
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public sealed class DisplayNameSignitureConvertor : SignatureConvertor

The DisplayNameSignitureConvertor type exposes the following members.

Constructors

 | Class | Summary
public constructor | DisplayNameSignitureConvertor(MethodDef, Boolean, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor.
public constructor | DisplayNameSignitureConvertor(MethodDef, Boolean, Boolean, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor.
public constructor | DisplayNameSignitureConvertor(PropertyDef, Boolean, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor
public constructor | DisplayNameSignitureConvertor(TypeDef, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor.
private constructor | DisplayNameSignitureConvertor() | Initialises a new instance of the DisplayNameSignitureConvertor.

Methods

 | Name | Summary
public method | Convert() | Implementation of the convert method, that is used to create a display version of the signiture this convertor has been instantiated with.
private method | ConvertAndIncludeParameters(StringBuilder) |
private method | ConvertAndIncludeTypeName(StringBuilder) |
sealed method | ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken) | Overridden convertor for arrays. Converts the ArrayShapeSignatureTokento its correct display name equivelant.
private method | ConvertMember() |
protected method | ConvertMVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for display.
protected method | ConvertVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for display.
protected method | GetTypeName(StringBuilder, TypeRef) | Obtains the type name for the specified TypeRef.
private method | ShouldConvertParameters() |
private method | ShouldIncludeParameters() |

Fields

 | Name | Description
private field | _includeNamespace |
private field | _includeParameters |
private field | _includeTypeName |
private field | _method |
private field | _property |
private field | _type |


DisplayNameSignitureConvertor Constructors

The DisplayNameSignitureConvertor type exposes the following members.

Constructors

 | Class | Summary
public constructor | DisplayNameSignitureConvertor(MethodDef, Boolean, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor.
public constructor | DisplayNameSignitureConvertor(MethodDef, Boolean, Boolean, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor.
public constructor | DisplayNameSignitureConvertor(PropertyDef, Boolean, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor
public constructor | DisplayNameSignitureConvertor(TypeDef, Boolean) | Initialises a new instance of the DisplayNameSignitureConvertor.
private constructor | DisplayNameSignitureConvertor() | Initialises a new instance of the DisplayNameSignitureConvertor.


DisplayNameSignitureConvertor(MethodDef, Boolean, Boolean)

Initialises a new instance of the DisplayNameSignitureConvertor.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DisplayNameSignitureConvertor(
MethodDef method,
bool includeNamespace,
bool includeParamaters
)

Parameters

method
Type: MethodDef
The method to obtain a display name for.
includeNamespace
Type: Boolean
Should the details of the namespace be included.
includeParamaters
Type: Boolean
Should the methods parameters be included.


DisplayNameSignitureConvertor(MethodDef, Boolean, Boolean, Boolean)

Initialises a new instance of the DisplayNameSignitureConvertor.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DisplayNameSignitureConvertor(
MethodDef method,
bool includeNamespace,
bool includeParameters,
bool isFromExtendedType
)

Parameters

method
Type: MethodDef
The method to obtain a display name for.
includeNamespace
Type: Boolean
Should the details of the namespace be included.
includeParameters
Type: Boolean
Should the methods parameters be included.
isFromExtendedType
Type: Boolean
Indicates this is an extension method from the type it is extending.


DisplayNameSignitureConvertor(PropertyDef, Boolean, Boolean)

Initialises a new instance of the DisplayNameSignitureConvertor
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DisplayNameSignitureConvertor(
PropertyDef property,
bool includeNamespace,
bool includeParamaters
)

Parameters

property
Type: PropertyDef
The property to obtain the display name for.
includeNamespace
Type: Boolean
Should the details of the namespace be included?
includeParamaters
Type: Boolean
Should the parameters for the property be included?


DisplayNameSignitureConvertor(TypeDef, Boolean)

Initialises a new instance of the DisplayNameSignitureConvertor.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DisplayNameSignitureConvertor(
TypeDef type,
bool includeNamespace
)

Parameters

type
Type: TypeDef
The type being converted.
includeNamespace
Type: Boolean
Should the details of the namespace be included in the display name.


DisplayNameSignitureConvertor()

Initialises a new instance of the DisplayNameSignitureConvertor.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DisplayNameSignitureConvertor()


DisplayNameSignitureConvertor Fields

The DisplayNameSignitureConvertor type exposes the following members.

Fields

 | Name | Description
private field | _includeNamespace |
private field | _includeParameters |
private field | _includeTypeName |
private field | _method |
private field | _property |
private field | _type |


_includeNamespace

_includeNamespace Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _includeNamespace


_includeParameters

_includeParameters Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _includeParameters


_includeTypeName

_includeTypeName Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _includeTypeName


_method

_method Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _method


_property

_property Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PropertyDef _property


_type

_type Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _type


DisplayNameSignitureConvertor Methods

The DisplayNameSignitureConvertor type exposes the following members.

Methods

 | Name | Summary
public method | Convert() | Implementation of the convert method, that is used to create a display version of the signiture this convertor has been instantiated with.
private method | ConvertAndIncludeParameters(StringBuilder) |
private method | ConvertAndIncludeTypeName(StringBuilder) |
sealed method | ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken) | Overridden convertor for arrays. Converts the ArrayShapeSignatureTokento its correct display name equivelant.
private method | ConvertMember() |
protected method | ConvertMVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for display.
protected method | ConvertVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for display.
protected method | GetTypeName(StringBuilder, TypeRef) | Obtains the type name for the specified TypeRef.
private method | ShouldConvertParameters() |
private method | ShouldIncludeParameters() |


Convert()

Convert() Method

Implementation of the convert method, that is used to create a display version of the signiture this convertor has been instantiated with.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string Convert()

Exceptions

Exception | Condition
ReflectionException | Thrown when an error occurs while processing the display name, see the exception details for more information.


ConvertAndIncludeParameters(StringBuilder)

ConvertAndIncludeParameters(StringBuilder) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ConvertAndIncludeParameters(
    StringBuilder converted
    )

Parameters

converted
Type: StringBuilder


ConvertAndIncludeTypeName(StringBuilder)

ConvertAndIncludeTypeName(StringBuilder) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ConvertAndIncludeTypeName(
    StringBuilder converted
    )

Parameters

converted
Type: StringBuilder


ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken)

ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken) Method

Overridden convertor for arrays. Converts the ArrayShapeSignatureTokento its correct display name equivelant.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal void ConvertArray(
    StringBuilder sb,
    TypeRef resolvedType,
    ArrayShapeSignatureToken shape
    )

Parameters

sb
Type: StringBuilder
The string being constructed containing the display name.
resolvedType
Type: TypeRef
The type the parameter has been resolved to
shape
Type: ArrayShapeSignatureToken
The signiture token detailing the shape of the array.


ConvertMember()

ConvertMember() Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string ConvertMember()


ConvertMVar(StringBuilder, UInt32, ParamDef)

ConvertMVar(StringBuilder, UInt32, ParamDef) Method

Converts a generic variable for display.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected void ConvertMVar(
    StringBuilder sb,
    uint sequence,
    ParamDef parameter
    )

Parameters

sb
Type: StringBuilder
The current display name for the signiture to append details to.
sequence
Type: UInt32
The sequence number of the current generic variable.
parameter
Type: ParamDef
The parameter definition information.


ConvertVar(StringBuilder, UInt32, ParamDef)

ConvertVar(StringBuilder, UInt32, ParamDef) Method

Converts a generic variable for display.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected void ConvertVar(
    StringBuilder sb,
    uint sequence,
    ParamDef parameter
    )

Parameters

sb
Type: StringBuilder
The current display name for the signiture to append details to.
sequence
Type: UInt32
The sequence number of the current generic variable
parameter
Type: ParamDef
The parameter definition information.


GetTypeName(StringBuilder, TypeRef)

GetTypeName(StringBuilder, TypeRef) Method

Obtains the type name for the specified TypeRef.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected void GetTypeName(
    StringBuilder sb,
    TypeRef type
    )

Parameters

sb
Type: StringBuilder
The current display name for the signiture to append the details to.
type
Type: TypeRef
The type to obtain the display name for.


ShouldConvertParameters()

ShouldConvertParameters() Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool ShouldConvertParameters()


ShouldIncludeParameters()

ShouldIncludeParameters() Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool ShouldIncludeParameters()


ElementTypes

ElementTypes Enumeration

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum ElementTypes : int

Members

Name | Description
End |
Void |
Boolean |
Char |
I1 |
U1 |
I2 |
U2 |
I4 |
U4 |
I8 |
U8 |
R4 |
R8 |
String |
Ptr |
ByRef |
ValueType |
Class |
Var |
Array |
GenericInstance |
TypedByRef |
I |
U |
FunctionPointer |
Object |
SZArray |
MVar |
CModRequired |
CModOptional |
Internal |
Max |
Modifier |
Sentinal |
Pinned |
R4_HFA |
R8_HFA |


ElementTypeSignatureToken

ElementTypeSignatureToken Class

Class that represents the simplist single element when a type is involved in a signiture. Where for example a type can be represented simply as a base type a class, or a valuetype, the ElementTypeSignitureToken will contain the relevant details about it and provide a mechanism for resolving the type.

Where a type is described by more than a single element; that element will have its superflous detail described in the TypeSignatureToken class.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.ElementTypeSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class ElementTypeSignatureToken : SignatureToken

The ElementTypeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ElementTypeSignatureToken(Byte[], Offset) | Instantiates a new instance of the ElementTypeSignitureToken class.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32, ElementTypes) | Checks if the token a the offset in the signitureis one of the allowed element types.
sealed method | ResolveToken(AssemblyDef) | Resolves a token (Defintion) in the provided assembly.
public method | ToString() | Produces a string representation of the element type token.

Properties

 | Name | Summary
public properties | Definition() | The definition of the specified element. This is populated when the element is a well known system type. Token will be 0;
public properties | ElementType() | The enumerated value indicating which type of element is contained in this token.
public properties | Token() | The token parameter to this element type, this is not always relevant so can be zero.

Fields

 | Name | Description
private field | _definition |
private field | _elementType |
private field | _token |

See also

TypeSignatureToken


ElementTypeSignatureToken Constructors

The ElementTypeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ElementTypeSignatureToken(Byte[], Offset) | Instantiates a new instance of the ElementTypeSignitureToken class.


ElementTypeSignatureToken(Byte[], Offset)

Instantiates a new instance of the ElementTypeSignitureToken class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypeSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture where this token is defined.
offset
Type: Offset
The current offset in the signiture to read the token.

Remarks

An ElementTypeSignitureToken details the element of a Type signiture. These elements are defined in section 23.1.16 in ECMA 335. Where a type can contain multiple ElementTypeSignitureTokens each building up to reveal more information about the type. This class will only ever provide a single item of detail.


ElementTypeSignatureToken Fields

The ElementTypeSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _definition |
private field | _elementType |
private field | _token |


_definition

_definition Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private object _definition


_elementType

_elementType Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ElementTypes _elementType


_token

_token Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _token


ElementTypeSignatureToken Methods

The ElementTypeSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32, ElementTypes) | Checks if the token a the offset in the signitureis one of the allowed element types.
sealed method | ResolveToken(AssemblyDef) | Resolves a token (Defintion) in the provided assembly.
public method | ToString() | Produces a string representation of the element type token.


IsToken(Byte[], Int32, ElementTypes)

IsToken(Byte[], Int32, ElementTypes) Method

Checks if the token a the offset in the signitureis one of the allowed element types.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static bool IsToken(
    byte[] signiture,
    int offset,
    ElementTypes allowed
    )

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Int32
The offset in the signiture.
allowed
Type: ElementTypes
The allowed element type flags.


ResolveToken(AssemblyDef)

ResolveToken(AssemblyDef) Method

Resolves a token (Defintion) in the provided assembly.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeRef ResolveToken(
    AssemblyDef assembly
    )

Parameters

assembly
Type: AssemblyDef
The assembly reference to resolve the token with.


ToString()

ToString() Method

Produces a string representation of the element type token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


ElementTypeSignatureToken Properties

The ElementTypeSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Definition() | The definition of the specified element. This is populated when the element is a well known system type. Token will be 0;
public properties | ElementType() | The enumerated value indicating which type of element is contained in this token.
public properties | Token() | The token parameter to this element type, this is not always relevant so can be zero.


Definition()

Definition() Property

The definition of the specified element. This is populated when the element is a well known system type. Token will be 0;
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public object this[] {
    get;
    set;
    }


ElementType()

ElementType() Property

The enumerated value indicating which type of element is contained in this token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypes this[] {
    get;
    private set;
    }


Token()

Token() Property

The token parameter to this element type, this is not always relevant so can be zero.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    private set;
    }


FieldSignature

FieldSignature Class

Describes a field signiture, which is specified in the ECMA 23.2.4.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.FieldSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class FieldSignature : Signature

The FieldSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldSignature(Byte[]) | Initialises a field signiture from the specified signiture blob.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the field signiture.


FieldSignature Constructors

The FieldSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldSignature(Byte[]) | Initialises a field signiture from the specified signiture blob.


FieldSignature(Byte[])

Initialises a field signiture from the specified signiture blob.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldSignature(
byte[] signiture
)

Parameters

signiture
Type: Byte
The signiture blob.


FieldSignature Methods

The FieldSignature type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the field signiture.


ToString()

ToString() Method

Produces a string representation of the field signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


GenericArgumentCountSignatureToken

GenericArgumentCountSignatureToken Class

An Int32 numeric value that indicates the number of generics arguments in a signiture.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.GenericArgumentCountSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class GenericArgumentCountSignatureToken : SignatureToken

The GenericArgumentCountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericArgumentCountSignatureToken(Byte[], Offset) | Initiailses a GenericArgumentCount token from the signiture at the specified offset.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of this generic argument count token.

Properties

 | Name | Summary
public properties | Count() | The number of generic arguments.

Fields

 | Name | Description
private field | _count |


GenericArgumentCountSignatureToken Constructors

The GenericArgumentCountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericArgumentCountSignatureToken(Byte[], Offset) | Initiailses a GenericArgumentCount token from the signiture at the specified offset.


GenericArgumentCountSignatureToken(Byte[], Offset)

Initiailses a GenericArgumentCount token from the signiture at the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericArgumentCountSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offsetin the signiture blob.


GenericArgumentCountSignatureToken Fields

The GenericArgumentCountSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _count |


_count

_count Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint _count


GenericArgumentCountSignatureToken Methods

The GenericArgumentCountSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of this generic argument count token.


ToString()

ToString() Method

Produces a string representation of this generic argument count token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


GenericArgumentCountSignatureToken Properties

The GenericArgumentCountSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Count() | The number of generic arguments.


Count()

Count() Property

The number of generic arguments.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    private set;
    }


GenericParamaterCountSignatureToken

GenericParamaterCountSignatureToken Class

A token that represents the number of generic parameters.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.GenericParamaterCountSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class GenericParamaterCountSignatureToken : SignatureToken

The GenericParamaterCountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericParamaterCountSignatureToken(Byte[], Offset) | Initialises a GenericParameterCount token from the signiture at the specified offset.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the generic parameter count token.

Fields

 | Name | Description
private field | _count |


GenericParamaterCountSignatureToken Constructors

The GenericParamaterCountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | GenericParamaterCountSignatureToken(Byte[], Offset) | Initialises a GenericParameterCount token from the signiture at the specified offset.


GenericParamaterCountSignatureToken(Byte[], Offset)

Initialises a GenericParameterCount token from the signiture at the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericParamaterCountSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offset in the signiture.


GenericParamaterCountSignatureToken Fields

The GenericParamaterCountSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _count |


GenericParamaterCountSignatureToken Methods

The GenericParamaterCountSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the generic parameter count token.


ToString()

ToString() Method

Produces a string representation of the generic parameter count token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


LocalVariableSignature

LocalVariableSignature Class

Represents a local variable signiture in the signiture blob. Details of the signiture are available in the ECMA at 23.2.6.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.LocalVariableSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class LocalVariableSignature : Signature

The LocalVariableSignature type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | LocalVariableSignature(Byte[]) | Initialise a new instance of a local variable signiture from the signitureprovided.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the local variable signiture.


LocalVariableSignature Constructors

The LocalVariableSignature type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | LocalVariableSignature(Byte[]) | Initialise a new instance of a local variable signiture from the signitureprovided.


LocalVariableSignature(Byte[])

Initialise a new instance of a local variable signiture from the signitureprovided.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal LocalVariableSignature(
byte[] signiture
)

Parameters

signiture
Type: Byte
The signiture blob.


LocalVariableSignature Methods

The LocalVariableSignature type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the local variable signiture.


ToString()

ToString() Method

Produces a string representation of the local variable signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


MethodDefSignature

MethodDefSignature Class

A signiture for a method definition as described in section 23.2.1 in ECMA 335.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.MethodDefSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class MethodDefSignature : Signature

The MethodDefSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodDefSignature(Byte[]) | Initialises a new instance of the MethoDefSigniture class.

Methods

 | Name | Summary
public method | GetCallingConvention(Byte[]) |
public method | ToString() |


MethodDefSignature Constructors

The MethodDefSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodDefSignature(Byte[]) | Initialises a new instance of the MethoDefSigniture class.


MethodDefSignature(Byte[])

Initialises a new instance of the MethoDefSigniture class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDefSignature(
byte[] signiture
)

Parameters

signiture
Type: Byte
The byte contents of the signiture.


MethodDefSignature Methods

The MethodDefSignature type exposes the following members.

Methods

 | Name | Summary
public method | GetCallingConvention(Byte[]) |
public method | ToString() |


GetCallingConvention(Byte[])

GetCallingConvention(Byte[]) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static CallingConventions GetCallingConvention(
    byte[] signiture
    )

Parameters

signiture
Type: Byte


MethodRefSignature

MethodRefSignature Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.MethodRefSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class MethodRefSignature : Signature

The MethodRefSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodRefSignature(Byte[]) |

Methods

 | Name | Summary
public method | ToString() |


MethodRefSignature Constructors

The MethodRefSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodRefSignature(Byte[]) |


MethodRefSignature(Byte[])

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodRefSignature(
byte[] signiture
)

Parameters

signiture
Type: Byte


MethodRefSignature Methods

The MethodRefSignature type exposes the following members.

Methods

 | Name | Summary
public method | ToString() |


ParameterCountSignatureToken

ParameterCountSignatureToken Class

A representation of a ParameterCount token in a signiture.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.ParameterCountSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class ParameterCountSignatureToken : SignatureToken

The ParameterCountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParameterCountSignatureToken(Byte[], Offset) | Initialises a new paramater count token from the provided signitureat the specified offset.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the parameter count token.

Properties

 | Name | Summary
public properties | Count() | The number of parameters.

Fields

 | Name | Description
private field | _count |


ParameterCountSignatureToken Constructors

The ParameterCountSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParameterCountSignatureToken(Byte[], Offset) | Initialises a new paramater count token from the provided signitureat the specified offset.


ParameterCountSignatureToken(Byte[], Offset)

Initialises a new paramater count token from the provided signitureat the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParameterCountSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offset in the signiture.


ParameterCountSignatureToken Fields

The ParameterCountSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _count |


ParameterCountSignatureToken Methods

The ParameterCountSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the parameter count token.


ToString()

ToString() Method

Produces a string representation of the parameter count token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


ParameterCountSignatureToken Properties

The ParameterCountSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Count() | The number of parameters.


Count()

Count() Property

The number of parameters.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint this[] {
    get;
    private set;
    }


ParamSignatureToken

ParamSignatureToken Class

This class is able to parse and store details about Param entries in Signatures. The Param signiture type is detailed in ECMA 335 at section 23.2.10.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.SignatureTokenContainer
        • TheBoxSoftware.Reflection.Signatures.ParamSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class ParamSignatureToken : SignatureTokenContainer

The ParamSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParamSignatureToken(Byte[], Offset) | Initialises a new instance of the ParamSignitureToken class from the provided signitureat the specified offset.

Methods

 | Name | Summary
public method | GetTypeDetails(ReflectedMember) |
public method | ResolveParameter(AssemblyDef, ParamDef) |
public method | ToString() | produces a string representation of the param signiture token.

Properties

 | Name | Summary
public properties | ElementType | The tokenised element from this parameter... may neeed to rethinked...
public properties | HasCustomModifier() | Indicates that this parameter has custom modifiers.
public properties | IsByRef() | Indicates if the ByRef ElementTypes entry is marked on this parameter.

Fields

 | Name | Description
private field | _elementType |
private field | _hasCustomModifier |
private field | _isByRef |
private field | _isTypeSigniture |


ParamSignatureToken Constructors

The ParamSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParamSignatureToken(Byte[], Offset) | Initialises a new instance of the ParamSignitureToken class from the provided signitureat the specified offset.


ParamSignatureToken(Byte[], Offset)

Initialises a new instance of the ParamSignitureToken class from the provided signitureat the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParamSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The contents of the signiture.
offset
Type: Offset
The offset of the current token.


ParamSignatureToken Fields

The ParamSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _elementType |
private field | _hasCustomModifier |
private field | _isByRef |
private field | _isTypeSigniture |


_elementType

_elementType Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ElementTypeSignatureToken _elementType


_hasCustomModifier

_hasCustomModifier Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _hasCustomModifier


_isByRef

_isByRef Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isByRef


_isTypeSigniture

_isTypeSigniture Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private bool _isTypeSigniture


ParamSignatureToken Methods

The ParamSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | GetTypeDetails(ReflectedMember) |
public method | ResolveParameter(AssemblyDef, ParamDef) |
public method | ToString() | produces a string representation of the param signiture token.


GetTypeDetails(ReflectedMember)

GetTypeDetails(ReflectedMember) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails GetTypeDetails(
    ReflectedMember member
    )

Parameters

member
Type: ReflectedMember


ResolveParameter(AssemblyDef, ParamDef)

ResolveParameter(AssemblyDef, ParamDef) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef ResolveParameter(
    AssemblyDef assembly,
    ParamDef declaringParameter
    )

Parameters

assembly
Type: AssemblyDef
declaringParameter
Type: ParamDef


ToString()

ToString() Method

produces a string representation of the param signiture token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


ParamSignatureToken Properties

The ParamSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | ElementType | The tokenised element from this parameter... may neeed to rethinked...
public properties | HasCustomModifier() | Indicates that this parameter has custom modifiers.
public properties | IsByRef() | Indicates if the ByRef ElementTypes entry is marked on this parameter.


ElementType

ElementType Property

The tokenised element from this parameter... may neeed to rethinked...
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypeSignatureToken ElementType {
    get;
    }


HasCustomModifier()

HasCustomModifier() Property

Indicates that this parameter has custom modifiers.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    private set;
    }


IsByRef()

IsByRef() Property

Indicates if the ByRef ElementTypes entry is marked on this parameter.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    private set;
    }


PrologSignatureToken

PrologSignatureToken Class

A class which represents a prolog for a CustomAttributeSignature.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.PrologSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class PrologSignatureToken : SignatureToken

The PrologSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | PrologSignatureToken(Byte[], Offset) | Initialises a new instance of the PrologSignitureToken class.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the prolog token.

Properties

 | Name | Summary
public properties | Value() | The value of the token.

Fields

 | Name | Description
private field | _value |


PrologSignatureToken Constructors

The PrologSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | PrologSignatureToken(Byte[], Offset) | Initialises a new instance of the PrologSignitureToken class.


PrologSignatureToken(Byte[], Offset)

Initialises a new instance of the PrologSignitureToken class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PrologSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The byte contents of the signiture.
offset
Type: Offset
The start offset of the this token.


PrologSignatureToken Fields

The PrologSignatureToken type exposes the following members.

Fields

 | Name | Description
private field | _value |


_value

_value Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ushort _value


PrologSignatureToken Methods

The PrologSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representation of the prolog token.


ToString()

ToString() Method

Produces a string representation of the prolog token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


PrologSignatureToken Properties

The PrologSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | Value() | The value of the token.


Value()

Value() Property

The value of the token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ushort this[] {
    get;
    private set;
    }


PropertySignature

PropertySignature Class

A rerepresentation of the property signiture as described in ECMA 23.2.5.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.PropertySignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class PropertySignature : Signature

The PropertySignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertySignature(Byte[]) | Initialises a new instance of the property signiture from the provided signiture.

Methods

 | Name | Summary
public method | ToString() | Produces a string representaion of the property signiture.


PropertySignature Constructors

The PropertySignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertySignature(Byte[]) | Initialises a new instance of the property signiture from the provided signiture.


PropertySignature(Byte[])

Initialises a new instance of the property signiture from the provided signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertySignature(
byte[] signiture
)

Parameters

signiture
Type: Byte
The signiture blob.


PropertySignature Methods

The PropertySignature type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Produces a string representaion of the property signiture.


ToString()

ToString() Method

Produces a string representaion of the property signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


ReturnTypeSignatureToken

ReturnTypeSignatureToken Class

Represents the group of SignitureTokens that are read together.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.SignatureTokenContainer
        • TheBoxSoftware.Reflection.Signatures.ReturnTypeSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class ReturnTypeSignatureToken : SignatureTokenContainer

The ReturnTypeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ReturnTypeSignatureToken(Byte[], Offset) | Initialises a new instance of the ReturnTypeSignitureToken class.

Methods

 | Name | Summary
public method | GetTypeDetails(ReflectedMember) |
sealed method | ResolveType(AssemblyDef, ReflectedMember) |
public method | ToString() | Produces a string representation of the return type signiture.


ReturnTypeSignatureToken Constructors

The ReturnTypeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | ReturnTypeSignatureToken(Byte[], Offset) | Initialises a new instance of the ReturnTypeSignitureToken class.


ReturnTypeSignatureToken(Byte[], Offset)

Initialises a new instance of the ReturnTypeSignitureToken class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReturnTypeSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture to read.
offset
Type: Offset
The offset to start processing at.


ReturnTypeSignatureToken Methods

The ReturnTypeSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | GetTypeDetails(ReflectedMember) |
sealed method | ResolveType(AssemblyDef, ReflectedMember) |
public method | ToString() | Produces a string representation of the return type signiture.


ResolveType(AssemblyDef, ReflectedMember)

ResolveType(AssemblyDef, ReflectedMember) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeRef ResolveType(
    AssemblyDef assembly,
    ReflectedMember member
    )

Parameters

assembly
Type: AssemblyDef
member
Type: ReflectedMember


ToString()

ToString() Method

Produces a string representation of the return type signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


SentinalSignatureToken

SentinalSignatureToken Class

Represents a sentinal signiture token.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.SentinalSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class SentinalSignatureToken : SignatureToken

The SentinalSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | SentinalSignatureToken(Byte[], Offset) | Initialises a new instance of the sentinal signiture from the provided signitureat the specified offset.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32) |
public method | ToString() | Produces a string representation of the sentinal signiture token.


SentinalSignatureToken Constructors

The SentinalSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | SentinalSignatureToken(Byte[], Offset) | Initialises a new instance of the sentinal signiture from the provided signitureat the specified offset.


SentinalSignatureToken(Byte[], Offset)

Initialises a new instance of the sentinal signiture from the provided signitureat the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SentinalSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture blob.
offset
Type: Offset
The offset in the signiture.


SentinalSignatureToken Methods

The SentinalSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | IsToken(Byte[], Int32) |
public method | ToString() | Produces a string representation of the sentinal signiture token.


IsToken(Byte[], Int32)

IsToken(Byte[], Int32) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static bool IsToken(
    byte[] signiture,
    int offset
    )

Parameters

signiture
Type: Byte
offset
Type: Int32


ToString()

ToString() Method

Produces a string representation of the sentinal signiture token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


Signature

Signature Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.CustomAttributeSignature
      • TheBoxSoftware.Reflection.Signatures.FieldSignature
      • TheBoxSoftware.Reflection.Signatures.LocalVariableSignature
      • TheBoxSoftware.Reflection.Signatures.MethodDefSignature
      • TheBoxSoftware.Reflection.Signatures.MethodRefSignature
      • TheBoxSoftware.Reflection.Signatures.PropertySignature
      • TheBoxSoftware.Reflection.Signatures.TypeSpecificationSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class Signature

The Signature type exposes the following members.

Constructors

 | Class | Summary
public constructor | Signature() |
protected constructor | Signature(Signatures) | Initialises a new instance of the Signiture class.

Methods

 | Name | Summary
public method | Create(Byte[], Offset, Signatures) | Factory method for creating new Signatures.
public method | GetParameterTokens() | Returns a collection of all the parameter tokens defined in this signiture.
public method | GetReturnTypeToken() | Returns the token that describes the return type defined in the signiture.
public method | ToString() |

Properties

 | Name | Summary
public properties | Tokens() |
public properties | Type() | Describes the type of signiture.

Fields

 | Name | Description
private field | _tokens |
private field | _type |


Signature Constructors

The Signature type exposes the following members.

Constructors

 | Class | Summary
public constructor | Signature() |
protected constructor | Signature(Signatures) | Initialises a new instance of the Signiture class.


Signature()

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Signature()


Signature(Signatures)

Initialises a new instance of the Signiture class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected Signature(
Signatures tokenType
)

Parameters

tokenType
Type: Signatures
The type of signiture being represented.


Signature Fields

The Signature type exposes the following members.

Fields

 | Name | Description
private field | _tokens |
private field | _type |


_tokens

_tokens Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _tokens


_type

_type Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Signatures _type


Signature Methods

The Signature type exposes the following members.

Methods

 | Name | Summary
public method | Create(Byte[], Offset, Signatures) | Factory method for creating new Signatures.
public method | GetParameterTokens() | Returns a collection of all the parameter tokens defined in this signiture.
public method | GetReturnTypeToken() | Returns the token that describes the return type defined in the signiture.
public method | ToString() |


Create(Byte[], Offset, Signatures)

Create(Byte[], Offset, Signatures) Method

Factory method for creating new Signatures.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static Signature Create(
    byte[] source,
    Offset offset,
    Signatures tokenType
    )

Parameters

source
Type: Byte
The contents of the library the signiture is being read from
offset
Type: Offset
The offset to the start of the signiture
tokenType
Type: Signatures
The type of signiture being read.


GetParameterTokens()

GetParameterTokens() Method

Returns a collection of all the parameter tokens defined in this signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ParamSignatureToken> GetParameterTokens()


GetReturnTypeToken()

GetReturnTypeToken() Method

Returns the token that describes the return type defined in the signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ReturnTypeSignatureToken GetReturnTypeToken()


Signature Properties

The Signature type exposes the following members.

Properties

 | Name | Summary
public properties | Tokens() |
public properties | Type() | Describes the type of signiture.


Tokens()

Tokens() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SignatureToken> this[] {
    get;
    protected set;
    }


Type()

Type() Property

Describes the type of signiture.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Signatures this[] {
    get;
    set;
    }


SignatureBuilder

SignatureBuilder Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureBuilder
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class SignatureBuilder

The SignatureBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | SignatureBuilder(BlobStream) |

Methods

 | Name | Summary
private method | DecompressUInt(Int32) |
public method | GetLength(Int32) |
public method | GetSignitureBytes(Int32) |
public method | Read(Int32) |
private method | ReadFieldSignature(Signature) |
private method | ReadMethodSignature(Byte[], Signature) |
private method | ReadPropertySignature(Signature) |
private method | ReadReturnTypeSignature(Signature, Byte[], Offset) |

Fields

 | Name | Description
private field | _stream |
private constant | CompressedByteMask |
private constant | CompressedIntMask |
private constant | CompressedShortMask |


SignatureBuilder Constructors

The SignatureBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | SignatureBuilder(BlobStream) |


SignatureBuilder(BlobStream)

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SignatureBuilder(
BlobStream underlyingStream
)

Parameters

underlyingStream
Type: BlobStream


SignatureBuilder Fields

The SignatureBuilder type exposes the following members.

Fields

 | Name | Description
private field | _stream |
private constant | CompressedByteMask |
private constant | CompressedIntMask |
private constant | CompressedShortMask |


_stream

_stream Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BlobStream _stream


CompressedByteMask

CompressedByteMask Constant

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const uint CompressedByteMask


CompressedIntMask

CompressedIntMask Constant

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const uint CompressedIntMask


CompressedShortMask

CompressedShortMask Constant

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private const uint CompressedShortMask


SignatureBuilder Methods

The SignatureBuilder type exposes the following members.

Methods

 | Name | Summary
private method | DecompressUInt(Int32) |
public method | GetLength(Int32) |
public method | GetSignitureBytes(Int32) |
public method | Read(Int32) |
private method | ReadFieldSignature(Signature) |
private method | ReadMethodSignature(Byte[], Signature) |
private method | ReadPropertySignature(Signature) |
private method | ReadReturnTypeSignature(Signature, Byte[], Offset) |


DecompressUInt(Int32)

DecompressUInt(Int32) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private uint DecompressUInt(
    int offset
    )

Parameters

offset
Type: Int32


GetLength(Int32)

GetLength(Int32) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public uint GetLength(
    int offset
    )

Parameters

offset
Type: Int32


GetSignitureBytes(Int32)

GetSignitureBytes(Int32) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public byte[] GetSignitureBytes(
    int offset
    )

Parameters

offset
Type: Int32


Read(Int32)

Read(Int32) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Signature Read(
    int offset
    )

Parameters

offset
Type: Int32


ReadFieldSignature(Signature)

ReadFieldSignature(Signature) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadFieldSignature(
    Signature created
    )

Parameters

created
Type: Signature


ReadMethodSignature(Byte[], Signature)

ReadMethodSignature(Byte[], Signature) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadMethodSignature(
    byte[] signitureBytes,
    Signature created
    )

Parameters

signitureBytes
Type: Byte
created
Type: Signature


ReadPropertySignature(Signature)

ReadPropertySignature(Signature) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadPropertySignature(
    Signature created
    )

Parameters

created
Type: Signature


ReadReturnTypeSignature(Signature, Byte[], Offset)

ReadReturnTypeSignature(Signature, Byte[], Offset) Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void ReadReturnTypeSignature(
    Signature created,
    byte[] signature,
    Offset offset
    )

Parameters

created
Type: Signature
signature
Type: Byte
offset
Type: Offset


SignatureConvertor

SignatureConvertor Class

A base implementation of a class that converts a signiture to another medium.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureConvertor
      • TheBoxSoftware.Reflection.Signatures.DisplayNameSignitureConvertor
      • TheBoxSoftware.Reflection.Comments.CRefPath
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract class SignatureConvertor

The SignatureConvertor type exposes the following members.

Constructors

 | Class | Summary
protected constructor | SignatureConvertor() |

Methods

 | Name | Summary
protected method | Convert(MethodDef) | Converts the method parameters to a cref path implementation, this in itself is not enough. This is used by the cref parse methods.
private method | Convert(StringBuilder, AssemblyDef, ParamDef, SignatureToken, ElementTypes, TypeRef) | Method which performs the actual conversion of a signiture to a cref string.
sealed method | ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken) | Overridden convertor for arrays. Converts the ArrayShapeSignatureTokento its correct cref name equivelant.
protected method | ConvertMVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for cref.
protected method | ConvertVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for cref.
protected method | GetTypeName(StringBuilder, TypeRef) | Obtains the type name for the specified TypeRef.

Properties

 | Name | Summary
public properties | ElementName() | Gets or sets a string that is the value of the element name from the cref path.
public properties | Namespace() | Gets or sets a string that indicates the namespace the type parsed from the cref path resides in.
public properties | Parameters() | A string representing the parameter section of the CRefPath.
public properties | TypeName() | Gets or sets a string that indicates the name of the type from the CRef path.

Fields

 | Name | Description
private field | _elementName |
private field | _namespace |
private field | _parameters |
private field | _typeName |
protected field | ByRef |
protected field | ByRefAtFront |
protected field | GenericEnd |
protected field | GenericStart |
protected field | IncludeFirstParameter |
protected field | ParameterSeperater |

See also

CRefPath


SignatureConvertor Constructors

The SignatureConvertor type exposes the following members.

Constructors

 | Class | Summary
protected constructor | SignatureConvertor() |


SignatureConvertor()

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected SignatureConvertor()


SignatureConvertor Fields

The SignatureConvertor type exposes the following members.

Fields

 | Name | Description
private field | _elementName |
private field | _namespace |
private field | _parameters |
private field | _typeName |
protected field | ByRef |
protected field | ByRefAtFront |
protected field | GenericEnd |
protected field | GenericStart |
protected field | IncludeFirstParameter |
protected field | ParameterSeperater |


_elementName

_elementName Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _elementName


_namespace

_namespace Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _namespace


_parameters

_parameters Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _parameters


_typeName

_typeName Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _typeName


ByRef

ByRef Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string ByRef


ByRefAtFront

ByRefAtFront Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected bool ByRefAtFront


GenericEnd

GenericEnd Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string GenericEnd


GenericStart

GenericStart Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string GenericStart


IncludeFirstParameter

IncludeFirstParameter Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected bool IncludeFirstParameter


ParameterSeperater

ParameterSeperater Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string ParameterSeperater


SignatureConvertor Methods

The SignatureConvertor type exposes the following members.

Methods

 | Name | Summary
protected method | Convert(MethodDef) | Converts the method parameters to a cref path implementation, this in itself is not enough. This is used by the cref parse methods.
private method | Convert(StringBuilder, AssemblyDef, ParamDef, SignatureToken, ElementTypes, TypeRef) | Method which performs the actual conversion of a signiture to a cref string.
sealed method | ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken) | Overridden convertor for arrays. Converts the ArrayShapeSignatureTokento its correct cref name equivelant.
protected method | ConvertMVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for cref.
protected method | ConvertVar(StringBuilder, UInt32, ParamDef) | Converts a generic variable for cref.
protected method | GetTypeName(StringBuilder, TypeRef) | Obtains the type name for the specified TypeRef.


Convert(MethodDef)

Convert(MethodDef) Method

Converts the method parameters to a cref path implementation, this in itself is not enough. This is used by the cref parse methods.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string Convert(
    MethodDef method
    )

Parameters

method
Type: MethodDef
The method to convert the parameters for.


Convert(StringBuilder, AssemblyDef, ParamDef, SignatureToken, ElementTypes, TypeRef)

Convert(StringBuilder, AssemblyDef, ParamDef, SignatureToken, ElementTypes, TypeRef) Method

Method which performs the actual conversion of a signiture to a cref string.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void Convert(
    StringBuilder sb,
    AssemblyDef assembly,
    ParamDef param,
    SignatureToken currentToken,
    ElementTypes elementType,
    TypeRef resolvedType
    )

Parameters

sb
Type: StringBuilder
The string builder to hold the converted text
assembly
Type: AssemblyDef
The assembly the current parameter is defined in
param
Type: ParamDef
The parameter definition, required for token resolution
currentToken
Type: SignatureToken
The current token to converty
elementType
Type: ElementTypes
The type of element the token represents
resolvedType
Type: TypeRef
The resolved type for this token.


ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken)

ConvertArray(StringBuilder, TypeRef, ArrayShapeSignatureToken) Method

Overridden convertor for arrays. Converts the ArrayShapeSignatureTokento its correct cref name equivelant.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal void ConvertArray(
    StringBuilder sb,
    TypeRef resolvedType,
    ArrayShapeSignatureToken shape
    )

Parameters

sb
Type: StringBuilder
The string being constructed containing the cref name.
resolvedType
Type: TypeRef
The type the parameter has been resolved to
shape
Type: ArrayShapeSignatureToken
The signiture token detailing the shape of the array.


ConvertMVar(StringBuilder, UInt32, ParamDef)

ConvertMVar(StringBuilder, UInt32, ParamDef) Method

Converts a generic variable for cref.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected void ConvertMVar(
    StringBuilder sb,
    uint sequence,
    ParamDef parameter
    )

Parameters

sb
Type: StringBuilder
The current cref name for the signiture to append details to.
sequence
Type: UInt32
The sequence number of the current generic variable
parameter
Type: ParamDef
The parameter definition information.


ConvertVar(StringBuilder, UInt32, ParamDef)

ConvertVar(StringBuilder, UInt32, ParamDef) Method

Converts a generic variable for cref.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected void ConvertVar(
    StringBuilder sb,
    uint sequence,
    ParamDef parameter
    )

Parameters

sb
Type: StringBuilder
The current cref name for the signiture to append details to.
sequence
Type: UInt32
The sequence number of the current generic variable
parameter
Type: ParamDef
The parameter definition information.


GetTypeName(StringBuilder, TypeRef)

GetTypeName(StringBuilder, TypeRef) Method

Obtains the type name for the specified TypeRef.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected void GetTypeName(
    StringBuilder sb,
    TypeRef type
    )

Parameters

sb
Type: StringBuilder
The current cref name for the signiture to append the details to.
type
Type: TypeRef
The type to obtain the display name for.


SignatureConvertor Properties

The SignatureConvertor type exposes the following members.

Properties

 | Name | Summary
public properties | ElementName() | Gets or sets a string that is the value of the element name from the cref path.
public properties | Namespace() | Gets or sets a string that indicates the namespace the type parsed from the cref path resides in.
public properties | Parameters() | A string representing the parameter section of the CRefPath.
public properties | TypeName() | Gets or sets a string that indicates the name of the type from the CRef path.


ElementName()

ElementName() Property

Gets or sets a string that is the value of the element name from the cref path.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


Namespace()

Namespace() Property

Gets or sets a string that indicates the namespace the type parsed from the cref path resides in.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


Parameters()

Parameters() Property

A string representing the parameter section of the CRefPath.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


TypeName()

TypeName() Property

Gets or sets a string that indicates the name of the type from the CRef path.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string this[] {
    get;
    set;
    }


Signatures

Signatures Enumeration

Enumeration of available major signiture types that can be defined in a .net assembly.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum Signatures : byte

Members

Name | Description
MethodDef | Signiture which describes the signiture or of a method or global function.
MethodRef | Signiture which describes a call signiture of a method. Normally, this call signiture shall match exactly the Signiture specified in the definition of the target method.
Field | Signiture which captures a fields definition.
Property | Signiture which captures a property definition. This includes details of the getter and setter methods.
LocalVariable | Signiture which captures the types of all the local variables in a method.
TypeSpecification | Signiture which captures a desription for a type.
MethodSpecification | Signiture which captures a description of a generic method.
CustomAttribute | Signiture which captures the values defined against an attribute decleration.


SignatureToken

SignatureToken Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.ArrayShapeSignatureToken
      • TheBoxSoftware.Reflection.Signatures.CallingConventionSignatureToken
      • TheBoxSoftware.Reflection.Signatures.ConstraintSignatureToken
      • TheBoxSoftware.Reflection.Signatures.CountSignatureToken
      • TheBoxSoftware.Reflection.Signatures.CustomModifierToken
      • TheBoxSoftware.Reflection.Signatures.ElementTypeSignatureToken
      • TheBoxSoftware.Reflection.Signatures.GenericArgumentCountSignatureToken
      • TheBoxSoftware.Reflection.Signatures.GenericParamaterCountSignatureToken
      • TheBoxSoftware.Reflection.Signatures.ParameterCountSignatureToken
      • TheBoxSoftware.Reflection.Signatures.PrologSignatureToken
      • TheBoxSoftware.Reflection.Signatures.SentinalSignatureToken
      • TheBoxSoftware.Reflection.Signatures.SignatureTokenContainer
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class SignatureToken

The SignatureToken type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SignatureToken(SignatureTokens) | Initialises a new instance of the SignitureToken class.
private constructor | SignatureToken() |

Methods

 | Name | Summary
sealed method | GetCompressedValue(Byte[], Offset) | Returns the uncompressed value from a compressed field.

Properties

 | Name | Summary
public properties | TokenType() | Indicates the type of SignitureToken

Fields

 | Name | Description
private constant | CompressedByteMask |
private constant | CompressedIntMask |
private constant | CompressedShortMask |


SignatureToken Constructors

The SignatureToken type exposes the following members.

Constructors

 | Class | Summary
sealed constructor | SignatureToken(SignatureTokens) | Initialises a new instance of the SignitureToken class.
private constructor | SignatureToken() |


SignatureToken(SignatureTokens)

Initialises a new instance of the SignitureToken class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal SignatureToken(
SignatureTokens tokenType
)

Parameters

tokenType
Type: SignatureTokens
The type of token.


SignatureToken()

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private SignatureToken()


SignatureToken Fields

The SignatureToken type exposes the following members.

Fields

 | Name | Description
private constant | CompressedByteMask |
private constant | CompressedIntMask |
private constant | CompressedShortMask |


SignatureToken Methods

The SignatureToken type exposes the following members.

Methods

 | Name | Summary
sealed method | GetCompressedValue(Byte[], Offset) | Returns the uncompressed value from a compressed field.


GetCompressedValue(Byte[], Offset)

GetCompressedValue(Byte[], Offset) Method

Returns the uncompressed value from a compressed field.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal static uint GetCompressedValue(
    byte[] contents,
    Offset offset
    )

Parameters

contents
Type: Byte
The contents of the signiture
offset
Type: Offset
The offset of the values first byte

Exceptions

Exception | Condition
System.InvalidOperationException | The first byte of the compressed value is not a valid value.


SignatureToken Properties

The SignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | TokenType() | Indicates the type of SignitureToken


TokenType()

TokenType() Property

Indicates the type of SignitureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SignatureTokens this[] {
    get;
    set;
    }


SignatureTokenContainer

SignatureTokenContainer Class

Represents a container for one or more SignitureToken instances. This is a constuct that allows groups of tokens that are always parsed together to be represented and contained via a single class.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.SignatureTokenContainer
        • TheBoxSoftware.Reflection.Signatures.ParamSignatureToken
        • TheBoxSoftware.Reflection.Signatures.ReturnTypeSignatureToken
        • TheBoxSoftware.Reflection.Signatures.TypeSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal abstract class SignatureTokenContainer : SignatureToken

The SignatureTokenContainer type exposes the following members.

Constructors

 | Class | Summary
protected constructor | SignatureTokenContainer(SignatureTokens) | Initialises a new instance of the SignitureTokenContainer class.

Properties

 | Name | Summary
public properties | Tokens() |

Fields

 | Name | Description
private field | _childTokens |


SignatureTokenContainer Constructors

The SignatureTokenContainer type exposes the following members.

Constructors

 | Class | Summary
protected constructor | SignatureTokenContainer(SignatureTokens) | Initialises a new instance of the SignitureTokenContainer class.


SignatureTokenContainer(SignatureTokens)

Initialises a new instance of the SignitureTokenContainer class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected SignatureTokenContainer(
SignatureTokens tokenType
)

Parameters

tokenType
Type: SignatureTokens
The type of signiture token represented.


SignatureTokenContainer Fields

The SignatureTokenContainer type exposes the following members.

Fields

 | Name | Description
private field | _childTokens |


_childTokens

_childTokens Field

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private List _childTokens


SignatureTokenContainer Properties

The SignatureTokenContainer type exposes the following members.

Properties

 | Name | Summary
public properties | Tokens() |


Tokens()

Tokens() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SignatureToken> this[] {
    get;
    set;
    }


SignatureTokens

SignatureTokens Enumeration

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal enum SignatureTokens : int

Members

Name | Description
CallingConvention |
GenericParameterCount |
ParameterCount |
Sentinal |
Field |
Property |
LocalSigniture |
Count |
Constraint |
ElementType |
TypeDefOrRefEncodedToken |
ArrayShape |
ReturnType |
CustomModifier |
Param |
Type |
GenericArgumentCount |
Prolog |


TypeDetails

TypeDetails Class

Provides details about a type and its surounding information.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.TypeDetails
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class TypeDetails

The TypeDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDetails() |

Properties

 | Name | Summary
public properties | ArrayOf() | The type details for the array. This is relevant when the type has the IsArray property set to true. Further this Type property is no longer valid.
public properties | ArrayShape() |
public properties | GenericParameters() |
public properties | IsArray() |
public properties | IsByRef() |
public properties | IsGenericInstance() | Indicates that the Type is a generic type and has one or more arguments specified in GenericParameters.
public properties | IsMultidemensionalArray() |
public properties | IsPointer() |
public properties | Type() | The major type details this could be any TypeRef based class. Including generic parameter, TypeSpec and TypeDef and Ref instances.


TypeDetails Constructors

The TypeDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDetails() |


TypeDetails()

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails()


TypeDetails Properties

The TypeDetails type exposes the following members.

Properties

 | Name | Summary
public properties | ArrayOf() | The type details for the array. This is relevant when the type has the IsArray property set to true. Further this Type property is no longer valid.
public properties | ArrayShape() |
public properties | GenericParameters() |
public properties | IsArray() |
public properties | IsByRef() |
public properties | IsGenericInstance() | Indicates that the Type is a generic type and has one or more arguments specified in GenericParameters.
public properties | IsMultidemensionalArray() |
public properties | IsPointer() |
public properties | Type() | The major type details this could be any TypeRef based class. Including generic parameter, TypeSpec and TypeDef and Ref instances.


ArrayOf()

ArrayOf() Property

The type details for the array. This is relevant when the type has the IsArray property set to true. Further this Type property is no longer valid.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails this[] {
    get;
    set;
    }


ArrayShape()

ArrayShape() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ArrayShapeSignatureToken this[] {
    get;
    set;
    }


GenericParameters()

GenericParameters() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<TypeDetails> this[] {
    get;
    set;
    }


IsArray()

IsArray() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsByRef()

IsByRef() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsGenericInstance()

IsGenericInstance() Property

Indicates that the Type is a generic type and has one or more arguments specified in GenericParameters.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsMultidemensionalArray()

IsMultidemensionalArray() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


IsPointer()

IsPointer() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public bool this[] {
    get;
    set;
    }


Type()

Type() Property

The major type details this could be any TypeRef based class. Including generic parameter, TypeSpec and TypeDef and Ref instances.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef this[] {
    get;
    set;
    }


TypeSignatureToken

TypeSignatureToken Class

Represents an element of a signiture that can be used to resolve back to a type, however the type it resolves back to can be one of many things; see ECMA 335 23.2.12.

A type can be represented by one or more tokens, hence this token derives from SignatureTokenContainer. However it will always have an ElementTypeSignatureTokenwhich should allow any resolving to be perfomed more easily.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.SignatureToken
      • TheBoxSoftware.Reflection.Signatures.SignatureTokenContainer
        • TheBoxSoftware.Reflection.Signatures.TypeSignatureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class TypeSignatureToken : SignatureTokenContainer

The TypeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSignatureToken(Byte[], Offset) | Initialises a new TypeSigniture from the signiture starting at the specified offset.

Methods

 | Name | Summary
public method | GetGenericArgumentCount() |
public method | GetTypeDetails(ReflectedMember) |
sealed method | ResolveType(AssemblyDef, ReflectedMember) | Attempts to resolve the type.
sealed method | ResolveType(AssemblyDef, ParamDef) | Attempts to resolve the type.
public method | ToString() | Produces a string representation of the Type token.

Properties

 | Name | Summary
public properties | ElementType() | The ElementType details for this TypeSignitureToken


TypeSignatureToken Constructors

The TypeSignatureToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSignatureToken(Byte[], Offset) | Initialises a new TypeSigniture from the signiture starting at the specified offset.


TypeSignatureToken(Byte[], Offset)

Initialises a new TypeSigniture from the signiture starting at the specified offset.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeSignatureToken(
byte[] signiture,
Offset offset
)

Parameters

signiture
Type: Byte
The signiture to parse the type from.
offset
Type: Offset
The offset to start reading from.


TypeSignatureToken Methods

The TypeSignatureToken type exposes the following members.

Methods

 | Name | Summary
public method | GetGenericArgumentCount() |
public method | GetTypeDetails(ReflectedMember) |
sealed method | ResolveType(AssemblyDef, ReflectedMember) | Attempts to resolve the type.
sealed method | ResolveType(AssemblyDef, ParamDef) | Attempts to resolve the type.
public method | ToString() | Produces a string representation of the Type token.


GetGenericArgumentCount()

GetGenericArgumentCount() Method

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public GenericArgumentCountSignatureToken GetGenericArgumentCount()


ResolveType(AssemblyDef, ReflectedMember)

ResolveType(AssemblyDef, ReflectedMember) Method

Attempts to resolve the type.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeRef ResolveType(
    AssemblyDef assembly,
    ReflectedMember member
    )

Parameters

assembly
Type: AssemblyDef
member
Type: ReflectedMember


ResolveType(AssemblyDef, ParamDef)

ResolveType(AssemblyDef, ParamDef) Method

Attempts to resolve the type.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal TypeRef ResolveType(
    AssemblyDef assembly,
    ParamDef parameter
    )

Parameters

assembly
Type: AssemblyDef
parameter
Type: ParamDef


ToString()

ToString() Method

Produces a string representation of the Type token.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


TypeSignatureToken Properties

The TypeSignatureToken type exposes the following members.

Properties

 | Name | Summary
public properties | ElementType() | The ElementType details for this TypeSignitureToken


ElementType()

ElementType() Property

The ElementType details for this TypeSignitureToken
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ElementTypeSignatureToken this[] {
    get;
    set;
    }


TypeSpecificationSignature

TypeSpecificationSignature Class

Represents a signiture for a type specification as detailed in section 23.2.14 in ECMA 335.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Signatures.Signature
      • TheBoxSoftware.Reflection.Signatures.TypeSpecificationSignature
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class TypeSpecificationSignature : Signature

The TypeSpecificationSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSpecificationSignature(Byte[]) | Instantiates a new instance of the TypeSpecificationSigniture class.

Methods

 | Name | Summary
public method | GetTypeDetails(ReflectedMember) | Obtains the details of the type.
public method | ToString() |

Properties

 | Name | Summary
public properties | TypeToken() |


TypeSpecificationSignature Constructors

The TypeSpecificationSignature type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeSpecificationSignature(Byte[]) | Instantiates a new instance of the TypeSpecificationSigniture class.


TypeSpecificationSignature(Byte[])

Instantiates a new instance of the TypeSpecificationSigniture class.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeSpecificationSignature(
byte[] signiture
)

Parameters

signiture
Type: Byte
The actual signiture contents.


TypeSpecificationSignature Methods

The TypeSpecificationSignature type exposes the following members.

Methods

 | Name | Summary
public method | GetTypeDetails(ReflectedMember) | Obtains the details of the type.
public method | ToString() |


GetTypeDetails(ReflectedMember)

GetTypeDetails(ReflectedMember) Method

Obtains the details of the type.
Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails GetTypeDetails(
    ReflectedMember member
    )

Parameters

member
Type: ReflectedMember
The member to resolve against.


TypeSpecificationSignature Properties

The TypeSpecificationSignature type exposes the following members.

Properties

 | Name | Summary
public properties | TypeToken() |


TypeToken()

TypeToken() Property

Namespace: TheBoxSoftware.Reflection.SignaturesAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeSignatureToken this[] {
    get;
    set;
    }


TheBoxSoftware.Reflection.Syntax Namespaces

Namespace
TheBoxSoftware.Reflection.Syntax
TheBoxSoftware.Reflection.Syntax.CSharp
TheBoxSoftware.Reflection.Syntax.VisualBasic


TheBoxSoftware.Reflection.Syntax Namespace

Classes

 | Class | Summary
sealed class | ClassSyntax |
sealed class | ConstantSyntax | Class that interogates a member for the details required to declare a constant.
sealed class | ConstructorSyntax |
sealed class | DelegateSyntax |
sealed class | EnumSyntax |
sealed class | EventSyntax | Allows the caller to obtain details of an event in a structured way.
sealed class | FieldSyntax |
sealed class | IndexorSyntax | Provides access to details of an Indexor defined in the metadata.
sealed class | InterfaceSyntax |
sealed class | MethodSyntax |
sealed class | OperatorSyntax |
sealed class | ParameterDetails | Details class which provides access to information necessary to understand the construction of a parameter.
sealed class | ParameterSyntax |
sealed class | PropertySyntax | Provides access to the important information for creating formatted syntax for PropertyDefs.
sealed class | StructSyntax |
sealed class | Syntax | A base class for all Syntax classes that provides useful methods and properties for managing the required syntax information for concrete implementations.
public class | SyntaxFactory | Static Factory class for instantiating syntax IFormatter implementations.
public class | SyntaxToken | A SyntaxToken is a string that represents an element of a syntax block. A SyntaxToken is a string and a SyntaxTokens type.
public class | SyntaxTokenCollection | Manages a collection of SyntaxTokens.

Interfaces

 | Name | Summary
sealed interface | IClassFormatter | Interface defining a template for a formatters for class syntax.
sealed interface | IConstantFormatter |
sealed interface | IConstructorFormatter |
sealed interface | IDelegateFormatter |
sealed interface | IEnumerationFormatter |
sealed interface | IEventFormatter |
sealed interface | IFieldFormatter |
public interface | IFormatter | Interface defining a simple method that allows callers of implementing classes access to an definition not an implementation of a formatter.
sealed interface | IIndexorFormatter | Defines the basic requirements for the information that a Formatter that implements this interface should return.
sealed interface | IInterfaceFormatter |
sealed interface | IMethodFormatter |
sealed interface | IOperatorFormatter | Interface for sytax related classes to implement a standard mechanism for formatting operator overloads.
sealed interface | IPropertyFormatter |
sealed interface | IStructFormatter |

Enumerations

 | Name | Summary
sealed enum | Inheritance |
public enum | Languages |
public enum | SyntaxTokens | Enumeration of token types that SyntaxToken can be.


ClassSyntax

ClassSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.ClassSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class ClassSyntax : Syntax

The ClassSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ClassSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.

Methods

 | Name | Summary
public method | GetBaseClass() | Obtains the name of the base type this class implements.
public method | GetGenericParameters() | Obtains details of the generic parameters associated with this type.
public method | GetIdentifier() | Obtains the identifier for the class.
public method | GetInheritance() | Obtains the inheritance modifier for the class.
public method | GetInterfaces() | Obtains the names of all the interfaces this class implements.
public method | GetVisibility() | Obtains the visibility modifier for the class.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.

Fields

 | Name | Description
private field | _type |


ClassSyntax Constructors

The ClassSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ClassSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.


ClassSyntax(TypeDef)

Initialises a new instance of the ClassSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ClassSyntax(
TypeDef type
)

Parameters

type
Type: TypeDef
The type to retrieve syntax details for.


ClassSyntax Fields

The ClassSyntax type exposes the following members.

Fields

 | Name | Description
private field | _type |


_type

_type Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _type


ClassSyntax Methods

The ClassSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetBaseClass() | Obtains the name of the base type this class implements.
public method | GetGenericParameters() | Obtains details of the generic parameters associated with this type.
public method | GetIdentifier() | Obtains the identifier for the class.
public method | GetInheritance() | Obtains the inheritance modifier for the class.
public method | GetInterfaces() | Obtains the names of all the interfaces this class implements.
public method | GetVisibility() | Obtains the visibility modifier for the class.


GetBaseClass()

GetBaseClass() Method

Obtains the name of the base type this class implements.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails GetBaseClass()


GetGenericParameters()

GetGenericParameters() Method

Obtains details of the generic parameters associated with this type.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<GenericTypeRef> GetGenericParameters()

Remarks

This method is only really valid when the type IsGenericproperty has been set to true.


GetIdentifier()

GetIdentifier() Method

Obtains the identifier for the class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetIdentifier()


GetInheritance()

GetInheritance() Method

Obtains the inheritance modifier for the class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Inheritance GetInheritance()

Remarks

Although the language specification does not specify a static modifier here, classes which are defined as both abstract and sealed seems to be the way to define the static modifier in the metadata. That is a static class can not have instances created and can not be derived from.


GetInterfaces()

GetInterfaces() Method

Obtains the names of all the interfaces this class implements.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails[] GetInterfaces()


GetVisibility()

GetVisibility() Method

Obtains the visibility modifier for the class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetVisibility()


ClassSyntax Properties

The ClassSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.


Class

Class Property

Access to the class reference being represented by this syntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef Class {
    get;
    }


ConstantSyntax

ConstantSyntax Class

Class that interogates a member for the details required to declare a constant.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.ConstantSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class ConstantSyntax : Syntax

The ConstantSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstantSyntax(FieldDef) | Initialises a new instance of the ConstantSyntax class.

Methods

 | Name | Summary
public method | GetAttributes() |
public method | GetIdentifier() |
public method | GetType() | Obtains the name of type which this field is.
public method | GetVisibility() | Obtains the visibility of the constant value.

Fields

 | Name | Description
private field | _field |


ConstantSyntax Constructors

The ConstantSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstantSyntax(FieldDef) | Initialises a new instance of the ConstantSyntax class.


ConstantSyntax(FieldDef)

Initialises a new instance of the ConstantSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ConstantSyntax(
FieldDef field
)

Parameters

field
Type: FieldDef
The field to obtain the syntax details for.


ConstantSyntax Fields

The ConstantSyntax type exposes the following members.

Fields

 | Name | Description
private field | _field |


_field

_field Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FieldDef _field


ConstantSyntax Methods

The ConstantSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetAttributes() |
public method | GetIdentifier() |
public method | GetType() | Obtains the name of type which this field is.
public method | GetVisibility() | Obtains the visibility of the constant value.


GetAttributes()

GetAttributes() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string[] GetAttributes()


GetIdentifier()

GetIdentifier() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetIdentifier()


GetType()

GetType() Method

Obtains the name of type which this field is.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef GetType()


GetVisibility()

GetVisibility() Method

Obtains the visibility of the constant value.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetVisibility()


ConstructorSyntax

ConstructorSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.ConstructorSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class ConstructorSyntax : Syntax

The ConstructorSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstructorSyntax(MethodDef) |

Methods

 | Name | Summary
public method | GetIdentifier() | Obtains the cleaned up identifier for the method.
public method | GetInheritance() |
public method | GetParameters() |
public method | GetVisibility() |

Properties

 | Name | Summary
public properties | Method |

Fields

 | Name | Description
private field | _method |
private field | _signiture |


ConstructorSyntax Constructors

The ConstructorSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ConstructorSyntax(MethodDef) |


ConstructorSyntax(MethodDef)

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ConstructorSyntax(
MethodDef method
)

Parameters

method
Type: MethodDef


ConstructorSyntax Fields

The ConstructorSyntax type exposes the following members.

Fields

 | Name | Description
private field | _method |
private field | _signiture |


_method

_method Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _method


_signiture

_signiture Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Signature _signiture


ConstructorSyntax Methods

The ConstructorSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetIdentifier() | Obtains the cleaned up identifier for the method.
public method | GetInheritance() |
public method | GetParameters() |
public method | GetVisibility() |


GetIdentifier()

GetIdentifier() Method

Obtains the cleaned up identifier for the method.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetIdentifier()


GetInheritance()

GetInheritance() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Inheritance GetInheritance()


GetParameters()

GetParameters() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ParameterDetails> GetParameters()


GetVisibility()

GetVisibility() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetVisibility()


ConstructorSyntax Properties

The ConstructorSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Method |


Method

Method Property

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef Method {
    get;
    }


DelegateSyntax

DelegateSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.DelegateSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class DelegateSyntax : Syntax

The DelegateSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | DelegateSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.

Methods

 | Name | Summary
public method | GetGenericParameters() | Obtains details of the generic parameters associated with this type.
public method | GetIdentifier() | Obtains the identifier for the delegate.
public method | GetParameters() |
public method | GetReturnType() |
public method | GetVisibility() | Obtains the visibility modifier for the class.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.
public properties | Method |

Fields

 | Name | Description
private field | _invokeMethodSyntax |
private field | _type |


DelegateSyntax Constructors

The DelegateSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | DelegateSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.


DelegateSyntax(TypeDef)

Initialises a new instance of the ClassSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public DelegateSyntax(
TypeDef type
)

Parameters

type
Type: TypeDef
The type to retrieve syntax details for.


DelegateSyntax Fields

The DelegateSyntax type exposes the following members.

Fields

 | Name | Description
private field | _invokeMethodSyntax |
private field | _type |


_invokeMethodSyntax

_invokeMethodSyntax Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodSyntax _invokeMethodSyntax


DelegateSyntax Methods

The DelegateSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetGenericParameters() | Obtains details of the generic parameters associated with this type.
public method | GetIdentifier() | Obtains the identifier for the delegate.
public method | GetParameters() |
public method | GetReturnType() |
public method | GetVisibility() | Obtains the visibility modifier for the class.


GetIdentifier()

GetIdentifier() Method

Obtains the identifier for the delegate.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetIdentifier()


GetReturnType()

GetReturnType() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails GetReturnType()


DelegateSyntax Properties

The DelegateSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.
public properties | Method |


Method

Method Property

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodSyntax Method {
    get;
    }


EnumSyntax

EnumSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.EnumSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class EnumSyntax : Syntax

The EnumSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | EnumSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.

Methods

 | Name | Summary
public method | GetIdentifier() | Obtains the identifier for the class.
public method | GetUnderlyingType() |
public method | GetVisibility() | Obtains the visibility modifier for the enumeration.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.

Fields

 | Name | Description
private field | _type |


EnumSyntax Constructors

The EnumSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | EnumSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.


EnumSyntax(TypeDef)

Initialises a new instance of the ClassSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EnumSyntax(
TypeDef type
)

Parameters

type
Type: TypeDef
The type to retrieve syntax details for.


EnumSyntax Fields

The EnumSyntax type exposes the following members.

Fields

 | Name | Description
private field | _type |


EnumSyntax Methods

The EnumSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetIdentifier() | Obtains the identifier for the class.
public method | GetUnderlyingType() |
public method | GetVisibility() | Obtains the visibility modifier for the enumeration.


GetUnderlyingType()

GetUnderlyingType() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef GetUnderlyingType()


GetVisibility()

GetVisibility() Method

Obtains the visibility modifier for the enumeration.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetVisibility()


EnumSyntax Properties

The EnumSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.


EventSyntax

EventSyntax Class

Allows the caller to obtain details of an event in a structured way.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.EventSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class EventSyntax : Syntax

The EventSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventSyntax(EventDef) | Initialises a new instance of the EventSyntax class.

Methods

 | Name | Summary
public method | GetIdentifier() |
public method | GetInheritance() |
public method | GetType() |
public method | GetVisbility() | Obtains the visibility for the event.

Fields

 | Name | Description
private field | _add |
private field | _eventDef |
private field | _remove |


EventSyntax Constructors

The EventSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventSyntax(EventDef) | Initialises a new instance of the EventSyntax class.


EventSyntax(EventDef)

Initialises a new instance of the EventSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventSyntax(
EventDef eventDef
)

Parameters

eventDef
Type: EventDef
The details of the event to get the information from.


EventSyntax Fields

The EventSyntax type exposes the following members.

Fields

 | Name | Description
private field | _add |
private field | _eventDef |
private field | _remove |


_add

_add Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _add


_eventDef

_eventDef Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private EventDef _eventDef


_remove

_remove Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _remove


EventSyntax Methods

The EventSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetIdentifier() |
public method | GetInheritance() |
public method | GetType() |
public method | GetVisbility() | Obtains the visibility for the event.


GetType()

GetType() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails GetType()


GetVisbility()

GetVisbility() Method

Obtains the visibility for the event.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetVisbility()

Remarks

This visibility of an event, as with a property, is determined by the most accessible method.


FieldSyntax

FieldSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.FieldSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class FieldSyntax : Syntax

The FieldSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldSyntax(FieldDef) |

Methods

 | Name | Summary
public method | GetIdentifier() |
public method | GetType() | Obtains the name of type which this field is.
public method | GetVisibility() |

Fields

 | Name | Description
private field | _field |


FieldSyntax Constructors

The FieldSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | FieldSyntax(FieldDef) |


FieldSyntax(FieldDef)

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public FieldSyntax(
FieldDef field
)

Parameters

field
Type: FieldDef


FieldSyntax Fields

The FieldSyntax type exposes the following members.

Fields

 | Name | Description
private field | _field |


FieldSyntax Methods

The FieldSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetIdentifier() |
public method | GetType() | Obtains the name of type which this field is.
public method | GetVisibility() |


IClassFormatter

IClassFormatter Interface

Interface defining a template for a formatters for class syntax.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IClassFormatter : IFormatter

The IClassFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ClassSyntax) | Returns the fully formatted class.
public method | FormatClassBase(ClassSyntax) | Returns a formatted version of the class base decleration.
public method | FormatInheritance(ClassSyntax) | Returns a formatted version of the class inheritance modifier. Abstract, Sealed etc.
public method | FormatVisibility(ClassSyntax) | Returns a formatted version of the class visibility. Public, Private etc.


IClassFormatter Methods

The IClassFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ClassSyntax) | Returns the fully formatted class.
public method | FormatClassBase(ClassSyntax) | Returns a formatted version of the class base decleration.
public method | FormatInheritance(ClassSyntax) | Returns a formatted version of the class inheritance modifier. Abstract, Sealed etc.
public method | FormatVisibility(ClassSyntax) | Returns a formatted version of the class visibility. Public, Private etc.


Format(ClassSyntax)

Format(ClassSyntax) Method

Returns the fully formatted class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The class details to format.

Remarks

When implementing; this method will orchestrate the calling and formatting of the individual Format methods.


FormatClassBase(ClassSyntax)

FormatClassBase(ClassSyntax) Method

Returns a formatted version of the class base decleration.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatClassBase(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The class to format.


FormatInheritance(ClassSyntax)

FormatInheritance(ClassSyntax) Method

Returns a formatted version of the class inheritance modifier. Abstract, Sealed etc.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The class to format.


FormatVisibility(ClassSyntax)

FormatVisibility(ClassSyntax) Method

Returns a formatted version of the class visibility. Public, Private etc.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The class to format.


IConstantFormatter

IConstantFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IConstantFormatter : IFormatter

The IConstantFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ConstantSyntax) |
public method | GetType(ConstantSyntax) |
public method | GetVisibility(ConstantSyntax) |


IConstantFormatter Methods

The IConstantFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ConstantSyntax) |
public method | GetType(ConstantSyntax) |
public method | GetVisibility(ConstantSyntax) |


Format(ConstantSyntax)

Format(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


GetType(ConstantSyntax)

GetType(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken GetType(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


GetVisibility(ConstantSyntax)

GetVisibility(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> GetVisibility(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


IConstructorFormatter

IConstructorFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IConstructorFormatter : IFormatter

The IConstructorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ConstructorSyntax) |
public method | FormatInheritance(ConstructorSyntax) |
public method | FormatParameters(ConstructorSyntax) |
public method | FormatVisibility(ConstructorSyntax) |


IConstructorFormatter Methods

The IConstructorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ConstructorSyntax) |
public method | FormatInheritance(ConstructorSyntax) |
public method | FormatParameters(ConstructorSyntax) |
public method | FormatVisibility(ConstructorSyntax) |


Format(ConstructorSyntax)

Format(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatInheritance(ConstructorSyntax)

FormatInheritance(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatParameters(ConstructorSyntax)

FormatParameters(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatParameters(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatVisibility(ConstructorSyntax)

FormatVisibility(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


IDelegateFormatter

IDelegateFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IDelegateFormatter : IFormatter

The IDelegateFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(DelegateSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(DelegateSyntax) |
public method | FormatVisibility(DelegateSyntax) |


IDelegateFormatter Methods

The IDelegateFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(DelegateSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(DelegateSyntax) |
public method | FormatVisibility(DelegateSyntax) |


Format(DelegateSyntax)

Format(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


FormatParameters(MethodSyntax)

FormatParameters(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatParameters(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatReturnType(DelegateSyntax)

FormatReturnType(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatReturnType(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


FormatVisibility(DelegateSyntax)

FormatVisibility(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


IEnumerationFormatter

IEnumerationFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IEnumerationFormatter : IFormatter

The IEnumerationFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(EnumSyntax) | Returns the fully formatted enumeration.
public method | FormatVisibility(EnumSyntax) | Returns a formatted version of the enumeration visibility. Public, Private etc.


IEnumerationFormatter Methods

The IEnumerationFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(EnumSyntax) | Returns the fully formatted enumeration.
public method | FormatVisibility(EnumSyntax) | Returns a formatted version of the enumeration visibility. Public, Private etc.


Format(EnumSyntax)

Format(EnumSyntax) Method

Returns the fully formatted enumeration.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    EnumSyntax syntax
    )

Parameters

syntax
Type: EnumSyntax
The enumeration details to format.

Remarks

When implementing; this method will orchestrate the calling and formatting of the individual Format methods.


FormatVisibility(EnumSyntax)

FormatVisibility(EnumSyntax) Method

Returns a formatted version of the enumeration visibility. Public, Private etc.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    EnumSyntax syntax
    )

Parameters

syntax
Type: EnumSyntax
The enumeration to format.


IEventFormatter

IEventFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IEventFormatter : IFormatter

The IEventFormatter type exposes the following members.

Methods

 | Name | Summary
public method | FormatIdentifier(EventSyntax) |
public method | FormatInheritance(EventSyntax) |
public method | FormatType(EventSyntax) |
public method | FormatVisibility(EventSyntax) |


IEventFormatter Methods

The IEventFormatter type exposes the following members.

Methods

 | Name | Summary
public method | FormatIdentifier(EventSyntax) |
public method | FormatInheritance(EventSyntax) |
public method | FormatType(EventSyntax) |
public method | FormatVisibility(EventSyntax) |


FormatIdentifier(EventSyntax)

FormatIdentifier(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatIdentifier(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatInheritance(EventSyntax)

FormatInheritance(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatType(EventSyntax)

FormatType(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatType(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatVisibility(EventSyntax)

FormatVisibility(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


IFieldFormatter

IFieldFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IFieldFormatter : IFormatter

The IFieldFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(FieldSyntax) |
public method | GetType(FieldSyntax) |
public method | GetVisibility(FieldSyntax) |


IFieldFormatter Methods

The IFieldFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(FieldSyntax) |
public method | GetType(FieldSyntax) |
public method | GetVisibility(FieldSyntax) |


Format(FieldSyntax)

Format(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


GetType(FieldSyntax)

GetType(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken GetType(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


GetVisibility(FieldSyntax)

GetVisibility(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> GetVisibility(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


IFormatter

IFormatter Interface

Interface defining a simple method that allows callers of implementing classes access to an definition not an implementation of a formatter.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public interface IFormatter

The IFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() | Method to return the format of a specific Syntaxclass.


IFormatter Methods

The IFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() | Method to return the format of a specific Syntaxclass.


Format()

Format() Method

Method to return the format of a specific Syntaxclass.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format()

Remarks

Implementors should, when implementing this method, call the more strongly typed IFormatter interfaces format method while passing in the private Syntax reference.


IIndexorFormatter

IIndexorFormatter Interface

Defines the basic requirements for the information that a Formatter that implements this interface should return.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IIndexorFormatter : IFormatter

The IIndexorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(IndexorSyntax) |
public method | FormatGetVisibility(IndexorSyntax) |
public method | FormatIdentifier(IndexorSyntax) |
public method | FormatInheritance(IndexorSyntax) |
public method | FormatSetVisibility(IndexorSyntax) |
public method | FormatType(IndexorSyntax) |
public method | FormatVisibility(IndexorSyntax) |


IIndexorFormatter Methods

The IIndexorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(IndexorSyntax) |
public method | FormatGetVisibility(IndexorSyntax) |
public method | FormatIdentifier(IndexorSyntax) |
public method | FormatInheritance(IndexorSyntax) |
public method | FormatSetVisibility(IndexorSyntax) |
public method | FormatType(IndexorSyntax) |
public method | FormatVisibility(IndexorSyntax) |


Format(IndexorSyntax)

Format(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatGetVisibility(IndexorSyntax)

FormatGetVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatGetVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatIdentifier(IndexorSyntax)

FormatIdentifier(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatIdentifier(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatInheritance(IndexorSyntax)

FormatInheritance(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatSetVisibility(IndexorSyntax)

FormatSetVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatSetVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatType(IndexorSyntax)

FormatType(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatType(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatVisibility(IndexorSyntax)

FormatVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


IInterfaceFormatter

IInterfaceFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IInterfaceFormatter : IFormatter

The IInterfaceFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(InterfaceSyntax) | Returns the fully formatted interface.
public method | FormatInterfaceBase(InterfaceSyntax) | Returns a formatted version of the interface base decleration.
public method | FormatVisibility(InterfaceSyntax) | Returns a formatted version of the interface visibility. Public, Private etc.


IInterfaceFormatter Methods

The IInterfaceFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(InterfaceSyntax) | Returns the fully formatted interface.
public method | FormatInterfaceBase(InterfaceSyntax) | Returns a formatted version of the interface base decleration.
public method | FormatVisibility(InterfaceSyntax) | Returns a formatted version of the interface visibility. Public, Private etc.


Format(InterfaceSyntax)

Format(InterfaceSyntax) Method

Returns the fully formatted interface.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax
The class details to format.

Remarks

When implementing; this method will orchestrate the calling and formatting of the individual Format methods.


FormatInterfaceBase(InterfaceSyntax)

FormatInterfaceBase(InterfaceSyntax) Method

Returns a formatted version of the interface base decleration.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatInterfaceBase(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax
The ineterface to format.


FormatVisibility(InterfaceSyntax)

FormatVisibility(InterfaceSyntax) Method

Returns a formatted version of the interface visibility. Public, Private etc.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax
The interface to format.


IMethodFormatter

IMethodFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IMethodFormatter : IFormatter

The IMethodFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(MethodSyntax) |
public method | FormatInheritance(MethodSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(MethodSyntax) |
public method | FormatVisibility(MethodSyntax) |


IMethodFormatter Methods

The IMethodFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(MethodSyntax) |
public method | FormatInheritance(MethodSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(MethodSyntax) |
public method | FormatVisibility(MethodSyntax) |


Format(MethodSyntax)

Format(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatInheritance(MethodSyntax)

FormatInheritance(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatReturnType(MethodSyntax)

FormatReturnType(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatReturnType(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatVisibility(MethodSyntax)

FormatVisibility(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


IndexorSyntax

IndexorSyntax Class

Provides access to details of an Indexor defined in the metadata.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.IndexorSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class IndexorSyntax : Syntax

The IndexorSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | IndexorSyntax(PropertyDef) | Initialises a new instance of the EventSyntax class.

Methods

 | Name | Summary
public method | GetGetterVisibility() | Obtains the Visibility of the getter method of the property.
public method | GetIdentifier() | Obtains the name of the property. This will always be 'Item' for indexors.
public method | GetInheritance() | Obtains details of how this member is inherited in base classes.
public method | GetSetterVisibility() | Obtains the Visibility of the setter method of the property.
public method | GetType() | Obtains a class that describes the details of types defined in this property.
public method | GetVisibility() | Obtains the Visibility of the member.

Properties

 | Name | Summary
public properties | GetMethod | A reference to the get method for this property.
public properties | SetMethod | A reference to the set method for this property.

Fields

 | Name | Description
private field | _get |
private field | _propertyDef |
private field | _set |


IndexorSyntax Constructors

The IndexorSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | IndexorSyntax(PropertyDef) | Initialises a new instance of the EventSyntax class.


IndexorSyntax(PropertyDef)

Initialises a new instance of the EventSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public IndexorSyntax(
PropertyDef propertyDef
)

Parameters

propertyDef
Type: PropertyDef
The details of the event to get the information from.


IndexorSyntax Fields

The IndexorSyntax type exposes the following members.

Fields

 | Name | Description
private field | _get |
private field | _propertyDef |
private field | _set |


_get

_get Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _get


_propertyDef

_propertyDef Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PropertyDef _propertyDef


_set

_set Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodDef _set


IndexorSyntax Methods

The IndexorSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetGetterVisibility() | Obtains the Visibility of the getter method of the property.
public method | GetIdentifier() | Obtains the name of the property. This will always be 'Item' for indexors.
public method | GetInheritance() | Obtains details of how this member is inherited in base classes.
public method | GetSetterVisibility() | Obtains the Visibility of the setter method of the property.
public method | GetType() | Obtains a class that describes the details of types defined in this property.
public method | GetVisibility() | Obtains the Visibility of the member.


GetGetterVisibility()

GetGetterVisibility() Method

Obtains the Visibility of the getter method of the property.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetGetterVisibility()


GetIdentifier()

GetIdentifier() Method

Obtains the name of the property. This will always be 'Item' for indexors.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetIdentifier()


GetInheritance()

GetInheritance() Method

Obtains details of how this member is inherited in base classes.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Inheritance GetInheritance()


GetSetterVisibility()

GetSetterVisibility() Method

Obtains the Visibility of the setter method of the property.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetSetterVisibility()


GetType()

GetType() Method

Obtains a class that describes the details of types defined in this property.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails GetType()


GetVisibility()

GetVisibility() Method

Obtains the Visibility of the member.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetVisibility()


IndexorSyntax Properties

The IndexorSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | GetMethod | A reference to the get method for this property.
public properties | SetMethod | A reference to the set method for this property.


GetMethod

GetMethod Property

A reference to the get method for this property.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef GetMethod {
    get;
    }


SetMethod

SetMethod Property

A reference to the set method for this property.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef SetMethod {
    get;
    }


Inheritance

Inheritance Enumeration

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal enum Inheritance : int

Members

Name | Description
Default |
Abstract |
Sealed |
Static |
Virtual |
Override |


InterfaceSyntax

InterfaceSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.InterfaceSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class InterfaceSyntax : Syntax

The InterfaceSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | InterfaceSyntax(TypeDef) | Initialises a new instance of the InterfaceSyntax class.

Methods

 | Name | Summary
public method | GetBaseClass() | Obtains the name of the base type this class implements.
public method | GetIdentifier() | Obtains the identifier for the class.
public method | GetInterfaces() | Obtains the names of all the interfaces this class implements.
public method | GetVisibility() | Obtains the visibility modifier for the class.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.

Fields

 | Name | Description
private field | _type |


InterfaceSyntax Constructors

The InterfaceSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | InterfaceSyntax(TypeDef) | Initialises a new instance of the InterfaceSyntax class.


InterfaceSyntax(TypeDef)

Initialises a new instance of the InterfaceSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public InterfaceSyntax(
TypeDef type
)

Parameters

type
Type: TypeDef
The type to retrieve syntax details for.

Exceptions

Exception | Condition
System.InvalidOperationException | Thrown when the provided type is not an interface.


InterfaceSyntax Fields

The InterfaceSyntax type exposes the following members.

Fields

 | Name | Description
private field | _type |


InterfaceSyntax Methods

The InterfaceSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetBaseClass() | Obtains the name of the base type this class implements.
public method | GetIdentifier() | Obtains the identifier for the class.
public method | GetInterfaces() | Obtains the names of all the interfaces this class implements.
public method | GetVisibility() | Obtains the visibility modifier for the class.


GetBaseClass()

GetBaseClass() Method

Obtains the name of the base type this class implements.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetBaseClass()


GetInterfaces()

GetInterfaces() Method

Obtains the names of all the interfaces this class implements.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef[] GetInterfaces()


InterfaceSyntax Properties

The InterfaceSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Class | Access to the class reference being represented by this syntax class.


IOperatorFormatter

IOperatorFormatter Interface

Interface for sytax related classes to implement a standard mechanism for formatting operator overloads.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IOperatorFormatter : IFormatter

The IOperatorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(OperatorSyntax) |
public method | FormatInheritance(OperatorSyntax) |
public method | FormatName(OperatorSyntax) |
public method | FormatParameters(OperatorSyntax) |
public method | FormatReturnType(OperatorSyntax) |
public method | FormatVisibility(OperatorSyntax) |


IOperatorFormatter Methods

The IOperatorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(OperatorSyntax) |
public method | FormatInheritance(OperatorSyntax) |
public method | FormatName(OperatorSyntax) |
public method | FormatParameters(OperatorSyntax) |
public method | FormatReturnType(OperatorSyntax) |
public method | FormatVisibility(OperatorSyntax) |


Format(OperatorSyntax)

Format(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatInheritance(OperatorSyntax)

FormatInheritance(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatName(OperatorSyntax)

FormatName(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatName(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatParameters(OperatorSyntax)

FormatParameters(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatParameters(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatReturnType(OperatorSyntax)

FormatReturnType(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatReturnType(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatVisibility(OperatorSyntax)

FormatVisibility(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


IPropertyFormatter

IPropertyFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IPropertyFormatter : IFormatter

The IPropertyFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(PropertySyntax) |
public method | FormatGetVisibility(PropertySyntax) |
public method | FormatIdentifier(PropertySyntax) |
public method | FormatInheritance(PropertySyntax) |
public method | FormatSetVisibility(PropertySyntax) |
public method | FormatType(PropertySyntax) |
public method | FormatVisibility(PropertySyntax) |


IPropertyFormatter Methods

The IPropertyFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(PropertySyntax) |
public method | FormatGetVisibility(PropertySyntax) |
public method | FormatIdentifier(PropertySyntax) |
public method | FormatInheritance(PropertySyntax) |
public method | FormatSetVisibility(PropertySyntax) |
public method | FormatType(PropertySyntax) |
public method | FormatVisibility(PropertySyntax) |


Format(PropertySyntax)

Format(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatGetVisibility(PropertySyntax)

FormatGetVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatGetVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatIdentifier(PropertySyntax)

FormatIdentifier(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatIdentifier(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatInheritance(PropertySyntax)

FormatInheritance(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxToken FormatInheritance(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatSetVisibility(PropertySyntax)

FormatSetVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatSetVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatType(PropertySyntax)

FormatType(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatType(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatVisibility(PropertySyntax)

FormatVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


IStructFormatter

IStructFormatter Interface

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal interface IStructFormatter : IFormatter

The IStructFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(StructSyntax) |
public method | FormatInterfaces(StructSyntax) |
public method | FormatVisibility(StructSyntax) |


IStructFormatter Methods

The IStructFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(StructSyntax) |
public method | FormatInterfaces(StructSyntax) |
public method | FormatVisibility(StructSyntax) |


Format(StructSyntax)

Format(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract SyntaxTokenCollection Format(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


FormatInterfaces(StructSyntax)

FormatInterfaces(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatInterfaces(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


FormatVisibility(StructSyntax)

FormatVisibility(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public abstract List<SyntaxToken> FormatVisibility(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


Languages

Languages Enumeration

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum Languages : int

Members

Name | Description
CSharp |
VisualBasic |


MethodSyntax

MethodSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.MethodSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class MethodSyntax : Syntax

The MethodSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodSyntax(MethodDef) |

Methods

 | Name | Summary
public method | GetGenericParameters() | Obtains a collection of GenericTypeRef instances detailing the generic types for this method.
public method | GetIdentifier() | Obtains the cleaned up identifier for the method.
public method | GetInheritance() |
public method | GetParameters() | Collects and returns all of the parameters for the associated MethodDef.
public method | GetReturnType() |
public method | GetVisibility() |

Properties

 | Name | Summary
public properties | Method |

Fields

 | Name | Description
private field | _method |
private field | _signiture |


MethodSyntax Constructors

The MethodSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | MethodSyntax(MethodDef) |


MethodSyntax(MethodDef)

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodSyntax(
MethodDef method
)

Parameters

method
Type: MethodDef


MethodSyntax Fields

The MethodSyntax type exposes the following members.

Fields

 | Name | Description
private field | _method |
private field | _signiture |


MethodSyntax Methods

The MethodSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetGenericParameters() | Obtains a collection of GenericTypeRef instances detailing the generic types for this method.
public method | GetIdentifier() | Obtains the cleaned up identifier for the method.
public method | GetInheritance() |
public method | GetParameters() | Collects and returns all of the parameters for the associated MethodDef.
public method | GetReturnType() |
public method | GetVisibility() |


GetGenericParameters()

GetGenericParameters() Method

Obtains a collection of GenericTypeRef instances detailing the generic types for this method.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<GenericTypeRef> GetGenericParameters()

Remarks

This method is only valid when the IsGeneric property has been set to true.


GetParameters()

GetParameters() Method

Collects and returns all of the parameters for the associated MethodDef.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<ParameterDetails> GetParameters()


MethodSyntax Properties

The MethodSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Method |


OperatorSyntax

OperatorSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.OperatorSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class OperatorSyntax : Syntax

The OperatorSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | OperatorSyntax(MethodDef) |

Methods

 | Name | Summary
public method | GetGenericParameters() | Obtains a collection of GenericTypeRef instances detailing the generic types for this method.
public method | GetIdentifier() | Obtains the cleaned up identifier for the method.
public method | GetInheritance() |
public method | GetParameters() |
public method | GetReturnType() |
public method | GetVisibility() |

Properties

 | Name | Summary
public properties | Method |

Fields

 | Name | Description
private field | _method |
private field | _signiture |


OperatorSyntax Constructors

The OperatorSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | OperatorSyntax(MethodDef) |


OperatorSyntax(MethodDef)

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public OperatorSyntax(
MethodDef method
)

Parameters

method
Type: MethodDef


OperatorSyntax Fields

The OperatorSyntax type exposes the following members.

Fields

 | Name | Description
private field | _method |
private field | _signiture |


OperatorSyntax Methods

The OperatorSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetGenericParameters() | Obtains a collection of GenericTypeRef instances detailing the generic types for this method.
public method | GetIdentifier() | Obtains the cleaned up identifier for the method.
public method | GetInheritance() |
public method | GetParameters() |
public method | GetReturnType() |
public method | GetVisibility() |


GetIdentifier()

GetIdentifier() Method

Obtains the cleaned up identifier for the method.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string GetIdentifier()

Remarks

Operators have names such as op_Equality, but when actually producing the overload in code is == (c#). This will return the name as defined metadata, e.g. op_Equality - it is up to the language specific implementation to convert that to a more suitable representation.


OperatorSyntax Properties

The OperatorSyntax type exposes the following members.

Properties

 | Name | Summary
public properties | Method |


ParameterDetails

ParameterDetails Class

Details class which provides access to information necessary to understand the construction of a parameter.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.ParameterDetails
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class ParameterDetails

The ParameterDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParameterDetails() | Initialises a new instance of the ParameterDetails class.
public constructor | ParameterDetails(ParamDef, TypeDetails) | Initialises a new instance of the ParameterDetails class.

Properties

 | Name | Summary
public properties | Name | The name of the parameter.
public properties | Parameter | The underlying parameter
public properties | TypeDetails() | The full details of the type.

Fields

 | Name | Description
private field | _parameter |


ParameterDetails Constructors

The ParameterDetails type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParameterDetails() | Initialises a new instance of the ParameterDetails class.
public constructor | ParameterDetails(ParamDef, TypeDetails) | Initialises a new instance of the ParameterDetails class.


ParameterDetails()

Initialises a new instance of the ParameterDetails class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParameterDetails()


ParameterDetails(ParamDef, TypeDetails)

Initialises a new instance of the ParameterDetails class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParameterDetails(
ParamDef parameter,
TypeDetails details
)

Parameters

parameter
Type: ParamDef
The details of the parameter.
details
Type: TypeDetails
The details of the type for the parameter.


ParameterDetails Fields

The ParameterDetails type exposes the following members.

Fields

 | Name | Description
private field | _parameter |


_parameter

_parameter Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ParamDef _parameter


ParameterDetails Properties

The ParameterDetails type exposes the following members.

Properties

 | Name | Summary
public properties | Name | The name of the parameter.
public properties | Parameter | The underlying parameter
public properties | TypeDetails() | The full details of the type.


Name

Name Property

The name of the parameter.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string Name {
    get;
    }


Parameter

Parameter Property

The underlying parameter
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParamDef Parameter {
    get;
    }


TypeDetails()

TypeDetails() Property

The full details of the type.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDetails this[] {
    get;
    set;
    }


ParameterSyntax

ParameterSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.ParameterSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class ParameterSyntax

The ParameterSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParameterSyntax(ParamDef, ParamSignatureToken) |

Fields

 | Name | Description
private field | _param |
private field | _signitureToken |


ParameterSyntax Constructors

The ParameterSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | ParameterSyntax(ParamDef, ParamSignatureToken) |


ParameterSyntax(ParamDef, ParamSignatureToken)

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public ParameterSyntax(
ParamDef param,
ParamSignatureToken signitureToken
)

Parameters

param
Type: ParamDef
signitureToken
Type: ParamSignatureToken


ParameterSyntax Fields

The ParameterSyntax type exposes the following members.

Fields

 | Name | Description
private field | _param |
private field | _signitureToken |


_param

_param Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ParamDef _param


_signitureToken

_signitureToken Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ParamSignatureToken _signitureToken


PropertySyntax

PropertySyntax Class

Provides access to the important information for creating formatted syntax for PropertyDefs.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.PropertySyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class PropertySyntax : Syntax

The PropertySyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertySyntax(PropertyDef) | Initialises a new instance of the EventSyntax class.

Methods

 | Name | Summary
public method | GetGetterVisibility() |
public method | GetIdentifier() |
public method | GetInheritance() |
public method | GetSetterVisibility() |
public method | GetType() |
public method | GetVisibility() |

Properties

 | Name | Summary
public properties | GetMethod |
public properties | SetMethod |

Fields

 | Name | Description
private field | _get |
private field | _propertyDef |
private field | _set |


PropertySyntax Constructors

The PropertySyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertySyntax(PropertyDef) | Initialises a new instance of the EventSyntax class.


PropertySyntax(PropertyDef)

Initialises a new instance of the EventSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertySyntax(
PropertyDef propertyDef
)

Parameters

propertyDef
Type: PropertyDef
The details of the event to get the information from.


PropertySyntax Fields

The PropertySyntax type exposes the following members.

Fields

 | Name | Description
private field | _get |
private field | _propertyDef |
private field | _set |


PropertySyntax Methods

The PropertySyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetGetterVisibility() |
public method | GetIdentifier() |
public method | GetInheritance() |
public method | GetSetterVisibility() |
public method | GetType() |
public method | GetVisibility() |


GetGetterVisibility()

GetGetterVisibility() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetGetterVisibility()


GetSetterVisibility()

GetSetterVisibility() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public Visibility GetSetterVisibility()


PropertySyntax Properties

The PropertySyntax type exposes the following members.

Properties

 | Name | Summary
public properties | GetMethod |
public properties | SetMethod |


GetMethod

GetMethod Property

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef GetMethod {
    get;
    }


SetMethod

SetMethod Property

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public MethodDef SetMethod {
    get;
    }


StructSyntax

StructSyntax Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.StructSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class StructSyntax : Syntax

The StructSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | StructSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.

Methods

 | Name | Summary
public method | GetIdentifier() |
public method | GetInterfaces() |
public method | GetVisibility() |

Fields

 | Name | Description
private field | _type |


StructSyntax Constructors

The StructSyntax type exposes the following members.

Constructors

 | Class | Summary
public constructor | StructSyntax(TypeDef) | Initialises a new instance of the ClassSyntax class.


StructSyntax(TypeDef)

Initialises a new instance of the ClassSyntax class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public StructSyntax(
TypeDef type
)

Parameters

type
Type: TypeDef
The type to retrieve syntax details for.


StructSyntax Fields

The StructSyntax type exposes the following members.

Fields

 | Name | Description
private field | _type |


StructSyntax Methods

The StructSyntax type exposes the following members.

Methods

 | Name | Summary
public method | GetIdentifier() |
public method | GetInterfaces() |
public method | GetVisibility() |


GetInterfaces()

GetInterfaces() Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeRef[] GetInterfaces()


Syntax

Syntax Class

A base class for all Syntax classes that provides useful methods and properties for managing the required syntax information for concrete implementations.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.Syntax
      • TheBoxSoftware.Reflection.Syntax.ClassSyntax
      • TheBoxSoftware.Reflection.Syntax.ConstantSyntax
      • TheBoxSoftware.Reflection.Syntax.ConstructorSyntax
      • TheBoxSoftware.Reflection.Syntax.DelegateSyntax
      • TheBoxSoftware.Reflection.Syntax.EnumSyntax
      • TheBoxSoftware.Reflection.Syntax.EventSyntax
      • TheBoxSoftware.Reflection.Syntax.FieldSyntax
      • TheBoxSoftware.Reflection.Syntax.IndexorSyntax
      • TheBoxSoftware.Reflection.Syntax.InterfaceSyntax
      • TheBoxSoftware.Reflection.Syntax.MethodSyntax
      • TheBoxSoftware.Reflection.Syntax.OperatorSyntax
      • TheBoxSoftware.Reflection.Syntax.PropertySyntax
      • TheBoxSoftware.Reflection.Syntax.StructSyntax
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal abstract class Syntax

The Syntax type exposes the following members.

Constructors

 | Class | Summary
protected constructor | Syntax() |

Methods

 | Name | Summary
protected method | ConvertMethodInheritance(MethodAttributes) |
protected method | ConvertTypeInheritance(TypeAttributes) |
protected method | GetTypeName(TypeRef) | Obtains the name of the type provided. This class will remove any superflous characters from the name to return the name that the user will understand and had entered when creating the type.


Syntax Constructors

The Syntax type exposes the following members.

Constructors

 | Class | Summary
protected constructor | Syntax() |


Syntax()

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected Syntax()


Syntax Methods

The Syntax type exposes the following members.

Methods

 | Name | Summary
protected method | ConvertMethodInheritance(MethodAttributes) |
protected method | ConvertTypeInheritance(TypeAttributes) |
protected method | GetTypeName(TypeRef) | Obtains the name of the type provided. This class will remove any superflous characters from the name to return the name that the user will understand and had entered when creating the type.


ConvertMethodInheritance(MethodAttributes)

ConvertMethodInheritance(MethodAttributes) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected Inheritance ConvertMethodInheritance(
    MethodAttributes attributes
    )

Parameters

attributes
Type: MethodAttributes


ConvertTypeInheritance(TypeAttributes)

ConvertTypeInheritance(TypeAttributes) Method

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected Inheritance ConvertTypeInheritance(
    TypeAttributes attributes
    )

Parameters

attributes
Type: TypeAttributes


GetTypeName(TypeRef)

GetTypeName(TypeRef) Method

Obtains the name of the type provided. This class will remove any superflous characters from the name to return the name that the user will understand and had entered when creating the type.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected string GetTypeName(
    TypeRef type
    )

Parameters

type
Type: TypeRef
The type to get the name of.

Remarks

.NET Framework will add special characters to names to allow, for example, generic methods to be overloaded. These characeters are removed in this method and the user defined name of the type is returned. // User creates type public class MyGenericType<T> // Framework outputs MyGenericType`1 // Method returns MyGenericType


SyntaxFactory

SyntaxFactory Class

Static Factory class for instantiating syntax IFormatter implementations.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.SyntaxFactory
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static class SyntaxFactory

The SyntaxFactory type exposes the following members.

Methods

 | Name | Summary
public method | Create(ReflectedMember, Languages) | Instantiates the correct IFormatter implementation based on the provided member and langauge.
private method | CreateFormatter(Syntax, Languages) | Instantiates a IFormatter implementing class for the provided syntax and language.
private method | CreateSyntax(ReflectedMember) | Returns a correctly typed and instantiated Syntax class for the specified member.

Remarks

The syntax system works from here. The Create method is called and the Factory will then instantiate the correct classes to format the member.

There are a number of classes that interact with each other to provide the formatting. First the Syntax class, provides a wrapper to the member to make it easy to obtain the important information for the member. This class is language agnostic. The second portion provides language dependant formatters to provide the langauge syntax for the member.

First a Interface is created to provide the basic mechanisms that all formatters should adhere to. Then each langauge dependant formatter implements that interface and provides the language specific Syntax blocks which can be used outside of the library

When creating new Formatter Interfaces the interface should derive from the IFormatter interface to make sure implementing classes implement the Format method.

Finally, it is important to note that formatters should implement formatting based on the language specification for the language they are formatting for.


SyntaxFactory Methods

The SyntaxFactory type exposes the following members.

Methods

 | Name | Summary
public method | Create(ReflectedMember, Languages) | Instantiates the correct IFormatter implementation based on the provided member and langauge.
private method | CreateFormatter(Syntax, Languages) | Instantiates a IFormatter implementing class for the provided syntax and language.
private method | CreateSyntax(ReflectedMember) | Returns a correctly typed and instantiated Syntax class for the specified member.


Create(ReflectedMember, Languages)

Create(ReflectedMember, Languages) Method

Instantiates the correct IFormatter implementation based on the provided member and langauge.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static IFormatter Create(
    ReflectedMember member,
    Languages language
    )

Parameters

member
Type: ReflectedMember
The member to create the formatter for.
language
Type: Languages
The language the formatter should be for.


CreateFormatter(Syntax, Languages)

CreateFormatter(Syntax, Languages) Method

Instantiates a IFormatter implementing class for the provided syntax and language.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static IFormatter CreateFormatter(
    Syntax syntax,
    Languages language
    )

Parameters

syntax
Type: Syntax
The syntax to create a formatter for.
language
Type: Languages
The language the formatter should be.


CreateSyntax(ReflectedMember)

CreateSyntax(ReflectedMember) Method

Returns a correctly typed and instantiated Syntax class for the specified member.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static Syntax CreateSyntax(
    ReflectedMember member
    )

Parameters

member
Type: ReflectedMember
The member to create a Syntax instance for.


SyntaxToken

SyntaxToken Class

A SyntaxToken is a string that represents an element of a syntax block. A SyntaxToken is a string and a SyntaxTokens type.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.SyntaxToken
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class SyntaxToken

The SyntaxToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | SyntaxToken(String, SyntaxTokens) | Initialises a new instance of the SyntaxToken class.

Properties

 | Name | Summary
public properties | Content | A string representing the actual displayable content for the token.
public properties | TokenType | Represents the type of token this SyntaxToken represents.

Fields

 | Name | Description
private field | _content |
private field | _tokenType |

Remarks

A IFormatter will return a list of syntax tokens. Here is an example of how to use SyntaxTokens:

List<SyntaxToken> tokens = new List<SyntaxToken>();

tokens.AddRange(this.GetVisibility(syntax));
tokens.Add(new SyntaxToken(" ", SyntaxTokens.Text));
tokens.Add(new SyntaxToken("const", SyntaxTokens.Keyword));
tokens.Add(new SyntaxToken(" ", SyntaxTokens.Text));
tokens.Add(this.GetType(syntax));
tokens.Add(new SyntaxToken(" ", SyntaxTokens.Text));
tokens.Add(new SyntaxToken(syntax.GetIdentifier(), SyntaxTokens.Text));

return tokens;

See also

SyntaxTokens


SyntaxToken Constructors

The SyntaxToken type exposes the following members.

Constructors

 | Class | Summary
public constructor | SyntaxToken(String, SyntaxTokens) | Initialises a new instance of the SyntaxToken class.


SyntaxToken(String, SyntaxTokens)

Initialises a new instance of the SyntaxToken class.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken(
string content,
SyntaxTokens tokenType
)

Parameters

content
Type: String
The tokens content
tokenType
Type: SyntaxTokens
The type of token.


SyntaxToken Fields

The SyntaxToken type exposes the following members.

Fields

 | Name | Description
private field | _content |
private field | _tokenType |


_content

_content Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private string _content


_tokenType

_tokenType Field

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private SyntaxTokens _tokenType


SyntaxToken Properties

The SyntaxToken type exposes the following members.

Properties

 | Name | Summary
public properties | Content | A string representing the actual displayable content for the token.
public properties | TokenType | Represents the type of token this SyntaxToken represents.


Content

Content Property

A string representing the actual displayable content for the token.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string Content {
    get;
    }


TokenType

TokenType Property

Represents the type of token this SyntaxToken represents.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokens TokenType {
    get;
    }


SyntaxTokenCollection

SyntaxTokenCollection Class

Manages a collection of SyntaxTokens.

Inheritance Hierarchy

  • System.Collections.Generic.List<>
    • TheBoxSoftware.Reflection.Syntax.SyntaxTokenCollection
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public class SyntaxTokenCollection : List<SyntaxToken>

The SyntaxTokenCollection type exposes the following members.

Constructors

 | Class | Summary
public constructor | SyntaxTokenCollection() |

Methods

 | Name | Summary
public method | ToString() | Returns a unformatted string representation of the syntax represented by the collection of SyntaxTokens.


SyntaxTokenCollection Constructors

The SyntaxTokenCollection type exposes the following members.

Constructors

 | Class | Summary
public constructor | SyntaxTokenCollection() |


SyntaxTokenCollection()

Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection()


SyntaxTokenCollection Methods

The SyntaxTokenCollection type exposes the following members.

Methods

 | Name | Summary
public method | ToString() | Returns a unformatted string representation of the syntax represented by the collection of SyntaxTokens.


ToString()

ToString() Method

Returns a unformatted string representation of the syntax represented by the collection of SyntaxTokens.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public string ToString()


SyntaxTokens

SyntaxTokens Enumeration

Enumeration of token types that SyntaxToken can be.
Namespace: TheBoxSoftware.Reflection.SyntaxAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public enum SyntaxTokens : byte

Members

Name | Description
Text | This is a normal text token.
Keyword | This token represents a keyword.


TheBoxSoftware.Reflection.Syntax.CSharp Namespace

Classes

 | Class | Summary
public class | Constants | Set of constant instances which represent the common tokens used for c sharp syntax formatting.
sealed class | CSharpClassFormatter |
sealed class | CSharpConstantFormatter |
sealed class | CSharpConstructorFormatter |
sealed class | CSharpDelegateFormatter |
sealed class | CSharpEnumerationFormatter |
sealed class | CSharpEventFormatter |
sealed class | CSharpFieldFormatter |
sealed class | CSharpFormatter | Base class with methods that are useful for all C# formatting classes.
sealed class | CSharpIndexerFormatter | Provides C# Language specific formatting of indexers.
sealed class | CSharpInterfaceFormatter |
sealed class | CSharpMethodFormatter |
sealed class | CSharpOperatorFormatter |
sealed class | CSharpPropertyFormatter |
sealed class | CSharpStructFormatter |


Constants

Constants Class

Set of constant instances which represent the common tokens used for c sharp syntax formatting.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.Constants
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static class Constants

The Constants type exposes the following members.

Constructors

 | Class | Summary
private constructor | Constants() |

Fields

 | Name | Description
public field | ArrayEmpty |
public field | ArrayEnd |
public field | ArrayStart |
public field | GenericEnd |
public field | GenericStart |
public field | KeywordAbstract |
public field | KeywordClass |
public field | KeywordConstant |
public field | KeywordDelegate |
public field | KeywordEnumeration |
public field | KeywordEvent |
public field | KeywordEventAdd |
public field | KeywordEventRemove |
public field | KeywordExplicit |
public field | KeywordGet |
public field | KeywordImplicit |
public field | KeywordInterface |
public field | KeywordInternal |
public field | KeywordOperator |
public field | KeywordOut |
public field | KeywordPointer |
public field | KeywordPrivate |
public field | KeywordProtected |
public field | KeywordPublic |
public field | KeywordRef |
public field | KeywordSealed |
public field | KeywordSet |
public field | KeywordStatic |
public field | KeywordStruct |
public field | KeywordThis |
public field | Space |
public field | TypeBoolean |
public field | TypeByte |
public field | TypeChar |
public field | TypeDouble |
public field | TypeFloat |
public field | TypeInt |
public field | TypeLong |
public field | TypeObject |
public field | TypeSByte |
public field | TypeShort |
public field | TypeString |
public field | TypeUInt |
public field | TypeULong |
public field | TypeUShort |
public field | TypeVoid |

See also

Produced by the Live Documenter developed by The Box Software.


Constants Constructors

The Constants type exposes the following members.

Constructors

 | Class | Summary
private constructor | Constants() |


Constants()

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static Constants()


Constants Fields

The Constants type exposes the following members.

Fields

 | Name | Description
public field | ArrayEmpty |
public field | ArrayEnd |
public field | ArrayStart |
public field | GenericEnd |
public field | GenericStart |
public field | KeywordAbstract |
public field | KeywordClass |
public field | KeywordConstant |
public field | KeywordDelegate |
public field | KeywordEnumeration |
public field | KeywordEvent |
public field | KeywordEventAdd |
public field | KeywordEventRemove |
public field | KeywordExplicit |
public field | KeywordGet |
public field | KeywordImplicit |
public field | KeywordInterface |
public field | KeywordInternal |
public field | KeywordOperator |
public field | KeywordOut |
public field | KeywordPointer |
public field | KeywordPrivate |
public field | KeywordProtected |
public field | KeywordPublic |
public field | KeywordRef |
public field | KeywordSealed |
public field | KeywordSet |
public field | KeywordStatic |
public field | KeywordStruct |
public field | KeywordThis |
public field | Space |
public field | TypeBoolean |
public field | TypeByte |
public field | TypeChar |
public field | TypeDouble |
public field | TypeFloat |
public field | TypeInt |
public field | TypeLong |
public field | TypeObject |
public field | TypeSByte |
public field | TypeShort |
public field | TypeString |
public field | TypeUInt |
public field | TypeULong |
public field | TypeUShort |
public field | TypeVoid |


ArrayEmpty

ArrayEmpty Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken ArrayEmpty


ArrayEnd

ArrayEnd Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken ArrayEnd


ArrayStart

ArrayStart Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken ArrayStart


GenericEnd

GenericEnd Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GenericEnd


GenericStart

GenericStart Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GenericStart


KeywordAbstract

KeywordAbstract Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordAbstract


KeywordClass

KeywordClass Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordClass


KeywordConstant

KeywordConstant Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordConstant


KeywordDelegate

KeywordDelegate Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordDelegate


KeywordEnumeration

KeywordEnumeration Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordEnumeration


KeywordEvent

KeywordEvent Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordEvent


KeywordEventAdd

KeywordEventAdd Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordEventAdd


KeywordEventRemove

KeywordEventRemove Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordEventRemove


KeywordExplicit

KeywordExplicit Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordExplicit


KeywordGet

KeywordGet Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordGet


KeywordImplicit

KeywordImplicit Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordImplicit


KeywordInterface

KeywordInterface Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordInterface


KeywordInternal

KeywordInternal Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordInternal


KeywordOperator

KeywordOperator Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordOperator


KeywordOut

KeywordOut Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordOut


KeywordPointer

KeywordPointer Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordPointer


KeywordPrivate

KeywordPrivate Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordPrivate


KeywordProtected

KeywordProtected Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordProtected


KeywordPublic

KeywordPublic Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordPublic


KeywordRef

KeywordRef Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordRef


KeywordSealed

KeywordSealed Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordSealed


KeywordSet

KeywordSet Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordSet


KeywordStatic

KeywordStatic Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordStatic


KeywordStruct

KeywordStruct Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordStruct


KeywordThis

KeywordThis Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordThis


Space

Space Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken Space


TypeBoolean

TypeBoolean Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeBoolean


TypeByte

TypeByte Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeByte


TypeChar

TypeChar Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeChar


TypeDouble

TypeDouble Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeDouble


TypeFloat

TypeFloat Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeFloat


TypeInt

TypeInt Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeInt


TypeLong

TypeLong Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeLong


TypeObject

TypeObject Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeObject


TypeSByte

TypeSByte Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeSByte


TypeShort

TypeShort Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeShort


TypeString

TypeString Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeString


TypeUInt

TypeUInt Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeUInt


TypeULong

TypeULong Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeULong


TypeUShort

TypeUShort Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeUShort


TypeVoid

TypeVoid Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeVoid


CSharpClassFormatter

CSharpClassFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpClassFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpClassFormatter : CSharpFormatter,
    IClassFormatter,
    IFormatter

The CSharpClassFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpClassFormatter(ClassSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(ClassSyntax) | Formats the provided syntax instance based on a c# class decleration.
public method | FormatClassBase(ClassSyntax) | Foramts the class base portion of a class decleration.
public method | FormatInheritance(ClassSyntax) | Formats the inheritance modifier for a c# class.
public method | FormatVisibility(ClassSyntax) | Foramts the visibility modifier for a c# class.

Fields

 | Name | Description
private field | _syntax |

Remarks

class-declaration:
    attributes(opt) class-modifiers(opt) class identifier class-base(opt) class-body

class-modifiers:
    class-modifier
    class-modifiers   class-modifier
class-modifier:
    new
    public
    protected
    internal
    private
    abstract
    sealed

class-base:
    :   class-type
    :   interface-type-list
    :   class-type   ,   interface-type-list
interface-type-list:
    interface-type
    interface-type-list   ,   interface-type


CSharpClassFormatter Constructors

The CSharpClassFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpClassFormatter(ClassSyntax) |


CSharpClassFormatter(ClassSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpClassFormatter(
ClassSyntax syntax
)

Parameters

syntax
Type: ClassSyntax


CSharpClassFormatter Fields

The CSharpClassFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ClassSyntax _syntax


CSharpClassFormatter Methods

The CSharpClassFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(ClassSyntax) | Formats the provided syntax instance based on a c# class decleration.
public method | FormatClassBase(ClassSyntax) | Foramts the class base portion of a class decleration.
public method | FormatInheritance(ClassSyntax) | Formats the inheritance modifier for a c# class.
public method | FormatVisibility(ClassSyntax) | Foramts the visibility modifier for a c# class.


Format()

Format() Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format()


Format(ClassSyntax)

Format(ClassSyntax) Method

Formats the provided syntax instance based on a c# class decleration.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The syntax for format.


FormatClassBase(ClassSyntax)

FormatClassBase(ClassSyntax) Method

Foramts the class base portion of a class decleration.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatClassBase(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The syntax details for the class.


FormatInheritance(ClassSyntax)

FormatInheritance(ClassSyntax) Method

Formats the inheritance modifier for a c# class.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The syntax to format.

Remarks

The inheritance of a class is part of the modifiers section of the decleration. The modifiers are defined as:


FormatVisibility(ClassSyntax)

FormatVisibility(ClassSyntax) Method

Foramts the visibility modifier for a c# class.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax
The syntax to format.

Remarks

The visibility of a class is part of the modifiers section of the decleration. The modifiers are defined as:


CSharpConstantFormatter

CSharpConstantFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpConstantFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpConstantFormatter : CSharpFormatter,
    IConstantFormatter,
    IFormatter

The CSharpConstantFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpConstantFormatter(ConstantSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstantSyntax) |
public method | GetType(ConstantSyntax) |
public method | GetVisibility(ConstantSyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpConstantFormatter Constructors

The CSharpConstantFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpConstantFormatter(ConstantSyntax) |


CSharpConstantFormatter(ConstantSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpConstantFormatter(
ConstantSyntax syntax
)

Parameters

syntax
Type: ConstantSyntax


CSharpConstantFormatter Fields

The CSharpConstantFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ConstantSyntax _syntax


CSharpConstantFormatter Methods

The CSharpConstantFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstantSyntax) |
public method | GetType(ConstantSyntax) |
public method | GetVisibility(ConstantSyntax) |


Format(ConstantSyntax)

Format(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


GetType(ConstantSyntax)

GetType(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GetType(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


GetVisibility(ConstantSyntax)

GetVisibility(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> GetVisibility(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


CSharpConstructorFormatter

CSharpConstructorFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpConstructorFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpConstructorFormatter : CSharpFormatter,
    IConstructorFormatter,
    IFormatter

The CSharpConstructorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpConstructorFormatter(ConstructorSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstructorSyntax) |
public method | FormatInheritance(ConstructorSyntax) |
public method | FormatParameters(ConstructorSyntax) |
public method | FormatVisibility(ConstructorSyntax) |

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


CSharpConstructorFormatter Constructors

The CSharpConstructorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpConstructorFormatter(ConstructorSyntax) |


CSharpConstructorFormatter(ConstructorSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpConstructorFormatter(
ConstructorSyntax syntax
)

Parameters

syntax
Type: ConstructorSyntax


CSharpConstructorFormatter Fields

The CSharpConstructorFormatter type exposes the following members.

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


_signiture

_signiture Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Signature _signiture


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ConstructorSyntax _syntax


CSharpConstructorFormatter Methods

The CSharpConstructorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstructorSyntax) |
public method | FormatInheritance(ConstructorSyntax) |
public method | FormatParameters(ConstructorSyntax) |
public method | FormatVisibility(ConstructorSyntax) |


Format(ConstructorSyntax)

Format(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatInheritance(ConstructorSyntax)

FormatInheritance(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatParameters(ConstructorSyntax)

FormatParameters(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatParameters(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatVisibility(ConstructorSyntax)

FormatVisibility(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


CSharpDelegateFormatter

CSharpDelegateFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpDelegateFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpDelegateFormatter : CSharpFormatter,
    IDelegateFormatter,
    IFormatter

The CSharpDelegateFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpDelegateFormatter(DelegateSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(DelegateSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(DelegateSyntax) |
public method | FormatVisibility(DelegateSyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpDelegateFormatter Constructors

The CSharpDelegateFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpDelegateFormatter(DelegateSyntax) |


CSharpDelegateFormatter(DelegateSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpDelegateFormatter(
DelegateSyntax syntax
)

Parameters

syntax
Type: DelegateSyntax


CSharpDelegateFormatter Fields

The CSharpDelegateFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DelegateSyntax _syntax


CSharpDelegateFormatter Methods

The CSharpDelegateFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(DelegateSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(DelegateSyntax) |
public method | FormatVisibility(DelegateSyntax) |


Format(DelegateSyntax)

Format(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


FormatParameters(MethodSyntax)

FormatParameters(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatParameters(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatReturnType(DelegateSyntax)

FormatReturnType(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatReturnType(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


FormatVisibility(DelegateSyntax)

FormatVisibility(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


CSharpEnumerationFormatter

CSharpEnumerationFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpEnumerationFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpEnumerationFormatter : CSharpFormatter,
    IEnumerationFormatter,
    IFormatter

The CSharpEnumerationFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpEnumerationFormatter(EnumSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(EnumSyntax) |
public method | FormatVisibility(EnumSyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpEnumerationFormatter Constructors

The CSharpEnumerationFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpEnumerationFormatter(EnumSyntax) |


CSharpEnumerationFormatter(EnumSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpEnumerationFormatter(
EnumSyntax syntax
)

Parameters

syntax
Type: EnumSyntax


CSharpEnumerationFormatter Fields

The CSharpEnumerationFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private EnumSyntax _syntax


CSharpEnumerationFormatter Methods

The CSharpEnumerationFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(EnumSyntax) |
public method | FormatVisibility(EnumSyntax) |


Format(EnumSyntax)

Format(EnumSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    EnumSyntax syntax
    )

Parameters

syntax
Type: EnumSyntax


FormatVisibility(EnumSyntax)

FormatVisibility(EnumSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    EnumSyntax syntax
    )

Parameters

syntax
Type: EnumSyntax


CSharpEventFormatter

CSharpEventFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpEventFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpEventFormatter : CSharpFormatter,
    IEventFormatter,
    IFormatter

The CSharpEventFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpEventFormatter(EventSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(EventSyntax) |
public method | FormatIdentifier(EventSyntax) |
public method | FormatInheritance(EventSyntax) |
public method | FormatType(EventSyntax) |
public method | FormatVisibility(EventSyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpEventFormatter Constructors

The CSharpEventFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpEventFormatter(EventSyntax) |


CSharpEventFormatter(EventSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpEventFormatter(
EventSyntax syntax
)

Parameters

syntax
Type: EventSyntax


CSharpEventFormatter Fields

The CSharpEventFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private EventSyntax _syntax


CSharpEventFormatter Methods

The CSharpEventFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(EventSyntax) |
public method | FormatIdentifier(EventSyntax) |
public method | FormatInheritance(EventSyntax) |
public method | FormatType(EventSyntax) |
public method | FormatVisibility(EventSyntax) |


Format(EventSyntax)

Format(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatIdentifier(EventSyntax)

FormatIdentifier(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatIdentifier(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatInheritance(EventSyntax)

FormatInheritance(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatType(EventSyntax)

FormatType(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatType(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatVisibility(EventSyntax)

FormatVisibility(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


CSharpFieldFormatter

CSharpFieldFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFieldFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpFieldFormatter : CSharpFormatter,
    IFieldFormatter,
    IFormatter

The CSharpFieldFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpFieldFormatter(FieldSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(FieldSyntax) |
public method | GetType(FieldSyntax) |
public method | GetVisibility(FieldSyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpFieldFormatter Constructors

The CSharpFieldFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpFieldFormatter(FieldSyntax) |


CSharpFieldFormatter(FieldSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpFieldFormatter(
FieldSyntax syntax
)

Parameters

syntax
Type: FieldSyntax


CSharpFieldFormatter Fields

The CSharpFieldFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FieldSyntax _syntax


CSharpFieldFormatter Methods

The CSharpFieldFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(FieldSyntax) |
public method | GetType(FieldSyntax) |
public method | GetVisibility(FieldSyntax) |


Format(FieldSyntax)

Format(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


GetType(FieldSyntax)

GetType(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GetType(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


GetVisibility(FieldSyntax)

GetVisibility(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> GetVisibility(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


CSharpFormatter

CSharpFormatter Class

Base class with methods that are useful for all C# formatting classes.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpClassFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpConstantFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpConstructorFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpDelegateFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpEnumerationFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpEventFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFieldFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpIndexerFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpInterfaceFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpMethodFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpOperatorFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpPropertyFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpStructFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal abstract class CSharpFormatter

The CSharpFormatter type exposes the following members.

Constructors

 | Class | Summary
protected constructor | CSharpFormatter() |

Methods

 | Name | Summary
protected method | FormatGenericParameters(List<GenericTypeRef>) |
public method | FormatInheritance(Inheritance) | Formats the inheritance modifier for C#.
protected method | FormatParameterModifiers(ParameterDetails) |
protected method | FormatTypeDetails(TypeDetails) |
protected method | FormatTypeName(TypeRef) | Returns the language specific type name for the specified type. For example in C# System.Boolean is referenced via the bool keyword.
protected method | FormatTypeName(TypeRef[]) |
protected method | FormatVisibility(Visibility) | Foramts the visibility modifier.

Fields

 | Name | Description
private field | defaultTypes | Collection of all the types defined in this language with a language specific short form.


CSharpFormatter Constructors

The CSharpFormatter type exposes the following members.

Constructors

 | Class | Summary
protected constructor | CSharpFormatter() |


CSharpFormatter()

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected CSharpFormatter()


CSharpFormatter Fields

The CSharpFormatter type exposes the following members.

Fields

 | Name | Description
private field | defaultTypes | Collection of all the types defined in this language with a language specific short form.


defaultTypes

defaultTypes Field

Collection of all the types defined in this language with a language specific short form.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary defaultTypes


CSharpFormatter Methods

The CSharpFormatter type exposes the following members.

Methods

 | Name | Summary
protected method | FormatGenericParameters(List<GenericTypeRef>) |
public method | FormatInheritance(Inheritance) | Formats the inheritance modifier for C#.
protected method | FormatParameterModifiers(ParameterDetails) |
protected method | FormatTypeDetails(TypeDetails) |
protected method | FormatTypeName(TypeRef) | Returns the language specific type name for the specified type. For example in C# System.Boolean is referenced via the bool keyword.
protected method | FormatTypeName(TypeRef[]) |
protected method | FormatVisibility(Visibility) | Foramts the visibility modifier.


FormatGenericParameters(List<GenericTypeRef>)

FormatGenericParameters(List<GenericTypeRef>) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatGenericParameters(
    List<GenericTypeRef> genericTypes
    )

Parameters

genericTypes
Type: List<>


FormatInheritance(Inheritance)

FormatInheritance(Inheritance) Method

Formats the inheritance modifier for C#.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    Inheritance inheritance
    )

Parameters

inheritance
Type: Inheritance
The modifier to format.


FormatParameterModifiers(ParameterDetails)

FormatParameterModifiers(ParameterDetails) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatParameterModifiers(
    ParameterDetails details
    )

Parameters

details
Type: ParameterDetails


FormatTypeDetails(TypeDetails)

FormatTypeDetails(TypeDetails) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatTypeDetails(
    TypeDetails details
    )

Parameters

details
Type: TypeDetails


FormatTypeName(TypeRef)

FormatTypeName(TypeRef) Method

Returns the language specific type name for the specified type. For example in C# System.Boolean is referenced via the bool keyword.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected SyntaxToken FormatTypeName(
    TypeRef type
    )

Parameters

type
Type: TypeRef
The type to get the name for.


FormatTypeName(TypeRef[])

FormatTypeName(TypeRef[]) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatTypeName(
    TypeRef[] types
    )

Parameters

types
Type: TypeRef


FormatVisibility(Visibility)

FormatVisibility(Visibility) Method

Foramts the visibility modifier.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatVisibility(
    Visibility visibility
    )

Parameters

visibility
Type: Visibility
The visibility to format.


CSharpIndexerFormatter

CSharpIndexerFormatter Class

Provides C# Language specific formatting of indexers.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpIndexerFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpIndexerFormatter : CSharpFormatter,
    IIndexorFormatter,
    IFormatter

The CSharpIndexerFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpIndexerFormatter(IndexorSyntax) | Initialises a new instance of the CSharpIndexorFormatter.

Methods

 | Name | Summary
public method | Format() |
public method | Format(IndexorSyntax) | Formats the indexer based on the language specification as a collection of syntax tokens.
public method | FormatGetVisibility(IndexorSyntax) |
public method | FormatIdentifier(IndexorSyntax) |
public method | FormatInheritance(IndexorSyntax) |
public method | FormatSetVisibility(IndexorSyntax) |
public method | FormatType(IndexorSyntax) |
public method | FormatVisibility(IndexorSyntax) |

Fields

 | Name | Description
private field | _syntax |

Remarks

The C# Langauge Specification states that indexers should be displayed as follows:

indexer-declaration:
    attributesopt   indexer-modifiersopt   indexer-declarator   {   accessor-declarations   }
    indexer-modifiers:
    indexer-modifier
    indexer-modifiers   indexer-modifier
indexer-modifier:
    new
    public
    protected
    internal
    private
    virtual
    sealed
    override
    abstract
    extern
indexer-declarator:
    type   this   [   formal-parameter-list   ]
    type   interface-type   .   this   [   formal-parameter-list   ]


CSharpIndexerFormatter Constructors

The CSharpIndexerFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpIndexerFormatter(IndexorSyntax) | Initialises a new instance of the CSharpIndexorFormatter.


CSharpIndexerFormatter(IndexorSyntax)

Initialises a new instance of the CSharpIndexorFormatter.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpIndexerFormatter(
IndexorSyntax syntax
)

Parameters

syntax
Type: IndexorSyntax
The syntax containing the information about the member.


CSharpIndexerFormatter Fields

The CSharpIndexerFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private IndexorSyntax _syntax


CSharpIndexerFormatter Methods

The CSharpIndexerFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(IndexorSyntax) | Formats the indexer based on the language specification as a collection of syntax tokens.
public method | FormatGetVisibility(IndexorSyntax) |
public method | FormatIdentifier(IndexorSyntax) |
public method | FormatInheritance(IndexorSyntax) |
public method | FormatSetVisibility(IndexorSyntax) |
public method | FormatType(IndexorSyntax) |
public method | FormatVisibility(IndexorSyntax) |


Format(IndexorSyntax)

Format(IndexorSyntax) Method

Formats the indexer based on the language specification as a collection of syntax tokens.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax
The syntax class that describes the indexer.


FormatGetVisibility(IndexorSyntax)

FormatGetVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatGetVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatIdentifier(IndexorSyntax)

FormatIdentifier(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatIdentifier(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatInheritance(IndexorSyntax)

FormatInheritance(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatSetVisibility(IndexorSyntax)

FormatSetVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatSetVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatType(IndexorSyntax)

FormatType(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatType(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatVisibility(IndexorSyntax)

FormatVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


CSharpInterfaceFormatter

CSharpInterfaceFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpInterfaceFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpInterfaceFormatter : CSharpFormatter,
    IInterfaceFormatter,
    IFormatter

The CSharpInterfaceFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpInterfaceFormatter(InterfaceSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(InterfaceSyntax) |
public method | FormatInterfaceBase(InterfaceSyntax) | Formats the interface base decleration for a c# interface.
public method | FormatVisibility(InterfaceSyntax) | Formats the visibility modifier for the interface.

Fields

 | Name | Description
private field | _syntax |

Remarks

interface-declaration:
    attributes(opt) interface-modifiers(opt) interface identifier interface-base(opt)


CSharpInterfaceFormatter Constructors

The CSharpInterfaceFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpInterfaceFormatter(InterfaceSyntax) |


CSharpInterfaceFormatter(InterfaceSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpInterfaceFormatter(
InterfaceSyntax syntax
)

Parameters

syntax
Type: InterfaceSyntax


CSharpInterfaceFormatter Fields

The CSharpInterfaceFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private InterfaceSyntax _syntax


CSharpInterfaceFormatter Methods

The CSharpInterfaceFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(InterfaceSyntax) |
public method | FormatInterfaceBase(InterfaceSyntax) | Formats the interface base decleration for a c# interface.
public method | FormatVisibility(InterfaceSyntax) | Formats the visibility modifier for the interface.


Format(InterfaceSyntax)

Format(InterfaceSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax

Remarks

interface-declaration:
    attributes(opt) interface-modifiers(opt) interface identifier interface-base(opt)


FormatInterfaceBase(InterfaceSyntax)

FormatInterfaceBase(InterfaceSyntax) Method

Formats the interface base decleration for a c# interface.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatInterfaceBase(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax
The syntax to format.

Remarks

interface-base:
    ;   interface-type-list


FormatVisibility(InterfaceSyntax)

FormatVisibility(InterfaceSyntax) Method

Formats the visibility modifier for the interface.
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax
The syntax to format.

Remarks

interface-modifiers:
    interface-modifier
    interface-modifiers   interface-modifier
interface-modifier:
    new
    public
    protected
    internal
    private


CSharpMethodFormatter

CSharpMethodFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpMethodFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpMethodFormatter : CSharpFormatter,
    IMethodFormatter,
    IFormatter

The CSharpMethodFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpMethodFormatter(MethodSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(MethodSyntax) |
public method | FormatInheritance(MethodSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(MethodSyntax) |
public method | FormatVisibility(MethodSyntax) |

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


CSharpMethodFormatter Constructors

The CSharpMethodFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpMethodFormatter(MethodSyntax) |


CSharpMethodFormatter(MethodSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpMethodFormatter(
MethodSyntax syntax
)

Parameters

syntax
Type: MethodSyntax


CSharpMethodFormatter Fields

The CSharpMethodFormatter type exposes the following members.

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodSyntax _syntax


CSharpMethodFormatter Methods

The CSharpMethodFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(MethodSyntax) |
public method | FormatInheritance(MethodSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(MethodSyntax) |
public method | FormatVisibility(MethodSyntax) |


Format(MethodSyntax)

Format(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatInheritance(MethodSyntax)

FormatInheritance(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatReturnType(MethodSyntax)

FormatReturnType(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatReturnType(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatVisibility(MethodSyntax)

FormatVisibility(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


CSharpOperatorFormatter

CSharpOperatorFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpOperatorFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpOperatorFormatter : CSharpFormatter,
    IOperatorFormatter,
    IFormatter

The CSharpOperatorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpOperatorFormatter(OperatorSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(OperatorSyntax) |
public method | FormatInheritance(OperatorSyntax) |
public method | FormatName(OperatorSyntax) |
public method | FormatParameters(OperatorSyntax) |
public method | FormatReturnType(OperatorSyntax) |
public method | FormatVisibility(OperatorSyntax) |

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


CSharpOperatorFormatter Constructors

The CSharpOperatorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpOperatorFormatter(OperatorSyntax) |


CSharpOperatorFormatter(OperatorSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpOperatorFormatter(
OperatorSyntax syntax
)

Parameters

syntax
Type: OperatorSyntax


CSharpOperatorFormatter Fields

The CSharpOperatorFormatter type exposes the following members.

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private OperatorSyntax _syntax


CSharpOperatorFormatter Methods

The CSharpOperatorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(OperatorSyntax) |
public method | FormatInheritance(OperatorSyntax) |
public method | FormatName(OperatorSyntax) |
public method | FormatParameters(OperatorSyntax) |
public method | FormatReturnType(OperatorSyntax) |
public method | FormatVisibility(OperatorSyntax) |


Format(OperatorSyntax)

Format(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatInheritance(OperatorSyntax)

FormatInheritance(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatName(OperatorSyntax)

FormatName(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatName(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatParameters(OperatorSyntax)

FormatParameters(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatParameters(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatReturnType(OperatorSyntax)

FormatReturnType(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatReturnType(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatVisibility(OperatorSyntax)

FormatVisibility(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


CSharpPropertyFormatter

CSharpPropertyFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpPropertyFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpPropertyFormatter : CSharpFormatter,
    IPropertyFormatter,
    IFormatter

The CSharpPropertyFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpPropertyFormatter(PropertySyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(PropertySyntax) |
public method | FormatGetVisibility(PropertySyntax) |
public method | FormatIdentifier(PropertySyntax) |
public method | FormatInheritance(PropertySyntax) |
public method | FormatSetVisibility(PropertySyntax) |
public method | FormatType(PropertySyntax) |
public method | FormatVisibility(PropertySyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpPropertyFormatter Constructors

The CSharpPropertyFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpPropertyFormatter(PropertySyntax) |


CSharpPropertyFormatter(PropertySyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpPropertyFormatter(
PropertySyntax syntax
)

Parameters

syntax
Type: PropertySyntax


CSharpPropertyFormatter Fields

The CSharpPropertyFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PropertySyntax _syntax


CSharpPropertyFormatter Methods

The CSharpPropertyFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(PropertySyntax) |
public method | FormatGetVisibility(PropertySyntax) |
public method | FormatIdentifier(PropertySyntax) |
public method | FormatInheritance(PropertySyntax) |
public method | FormatSetVisibility(PropertySyntax) |
public method | FormatType(PropertySyntax) |
public method | FormatVisibility(PropertySyntax) |


Format(PropertySyntax)

Format(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatGetVisibility(PropertySyntax)

FormatGetVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatGetVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatIdentifier(PropertySyntax)

FormatIdentifier(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatIdentifier(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatInheritance(PropertySyntax)

FormatInheritance(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatSetVisibility(PropertySyntax)

FormatSetVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatSetVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatType(PropertySyntax)

FormatType(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatType(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatVisibility(PropertySyntax)

FormatVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


CSharpStructFormatter

CSharpStructFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpFormatter
      • TheBoxSoftware.Reflection.Syntax.CSharp.CSharpStructFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class CSharpStructFormatter : CSharpFormatter,
    IStructFormatter,
    IFormatter

The CSharpStructFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpStructFormatter(StructSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(StructSyntax) |
public method | FormatInterfaces(StructSyntax) |
public method | FormatVisibility(StructSyntax) |

Fields

 | Name | Description
private field | _syntax |


CSharpStructFormatter Constructors

The CSharpStructFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | CSharpStructFormatter(StructSyntax) |


CSharpStructFormatter(StructSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public CSharpStructFormatter(
StructSyntax syntax
)

Parameters

syntax
Type: StructSyntax


CSharpStructFormatter Fields

The CSharpStructFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StructSyntax _syntax


CSharpStructFormatter Methods

The CSharpStructFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(StructSyntax) |
public method | FormatInterfaces(StructSyntax) |
public method | FormatVisibility(StructSyntax) |


Format(StructSyntax)

Format(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


FormatInterfaces(StructSyntax)

FormatInterfaces(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatInterfaces(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


FormatVisibility(StructSyntax)

FormatVisibility(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.CSharpAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


TheBoxSoftware.Reflection.Syntax.VisualBasic Namespace

Classes

 | Class | Summary
public class | Constants |
sealed class | VBClassFormatter |
sealed class | VBConstantFormatter |
sealed class | VBConstructorFormatter |
sealed class | VBDelegateFormatter |
sealed class | VBEnumerationFormatter |
sealed class | VBEventFormatter |
sealed class | VBFieldFormatter |
sealed class | VBFormatter | Base class with methods that are useful for all VB formatting classes.
sealed class | VBIndexorFormatter | Provides a formatting implementation for Indexor properties in VB.NET. Below is an example of how indexors are formatted in VB.NET: Public Property Item(index As Integer) As Object
sealed class | VBInterfaceFormatter |
sealed class | VBMethodFormatter |
sealed class | VBOperatorFormatter |
sealed class | VBPropertyFormatter |
sealed class | VBStructFormatter |


Constants

Constants Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.Constants
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public static class Constants

The Constants type exposes the following members.

Constructors

 | Class | Summary
private constructor | Constants() |

Fields

 | Name | Description
public field | ArrayEmpty |
public field | ArrayEnd |
public field | ArrayStart |
public field | GenericEnd |
public field | GenericStart |
public field | KeywordAbstract |
public field | KeywordAs |
public field | KeywordClass |
public field | KeywordFunction |
public field | KeywordInternal |
public field | KeywordPointer |
public field | KeywordPrivate |
public field | KeywordProtected |
public field | KeywordPublic |
public field | KeywordSealed |
public field | KeywordStatic |
public field | KeywordSub |
public field | Space |
public field | TypeBoolean |
public field | TypeByte |
public field | TypeChar |
public field | TypeDouble |
public field | TypeFloat |
public field | TypeInt |
public field | TypeLong |
public field | TypeObject |
public field | TypeSByte |
public field | TypeShort |
public field | TypeString |
public field | TypeUInt |
public field | TypeULong |
public field | TypeUShort |
public field | TypeVoid |


Constants()

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private static Constants()


Constants Fields

The Constants type exposes the following members.

Fields

 | Name | Description
public field | ArrayEmpty |
public field | ArrayEnd |
public field | ArrayStart |
public field | GenericEnd |
public field | GenericStart |
public field | KeywordAbstract |
public field | KeywordAs |
public field | KeywordClass |
public field | KeywordFunction |
public field | KeywordInternal |
public field | KeywordPointer |
public field | KeywordPrivate |
public field | KeywordProtected |
public field | KeywordPublic |
public field | KeywordSealed |
public field | KeywordStatic |
public field | KeywordSub |
public field | Space |
public field | TypeBoolean |
public field | TypeByte |
public field | TypeChar |
public field | TypeDouble |
public field | TypeFloat |
public field | TypeInt |
public field | TypeLong |
public field | TypeObject |
public field | TypeSByte |
public field | TypeShort |
public field | TypeString |
public field | TypeUInt |
public field | TypeULong |
public field | TypeUShort |
public field | TypeVoid |


ArrayEmpty

ArrayEmpty Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken ArrayEmpty


ArrayEnd

ArrayEnd Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken ArrayEnd


ArrayStart

ArrayStart Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken ArrayStart


GenericEnd

GenericEnd Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GenericEnd


GenericStart

GenericStart Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GenericStart


KeywordAbstract

KeywordAbstract Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordAbstract


KeywordAs

KeywordAs Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordAs


KeywordClass

KeywordClass Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordClass


KeywordFunction

KeywordFunction Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordFunction


KeywordInternal

KeywordInternal Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordInternal


KeywordPointer

KeywordPointer Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordPointer


KeywordPrivate

KeywordPrivate Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordPrivate


KeywordProtected

KeywordProtected Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordProtected


KeywordPublic

KeywordPublic Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordPublic


KeywordSealed

KeywordSealed Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordSealed


KeywordStatic

KeywordStatic Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordStatic


KeywordSub

KeywordSub Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken KeywordSub


Space

Space Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken Space


TypeBoolean

TypeBoolean Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeBoolean


TypeByte

TypeByte Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeByte


TypeChar

TypeChar Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeChar


TypeDouble

TypeDouble Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeDouble


TypeFloat

TypeFloat Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeFloat


TypeInt

TypeInt Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeInt


TypeLong

TypeLong Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeLong


TypeObject

TypeObject Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeObject


TypeSByte

TypeSByte Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeSByte


TypeShort

TypeShort Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeShort


TypeString

TypeString Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeString


TypeUInt

TypeUInt Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeUInt


TypeULong

TypeULong Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeULong


TypeUShort

TypeUShort Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeUShort


TypeVoid

TypeVoid Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken TypeVoid


VBClassFormatter

VBClassFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBClassFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBClassFormatter : VBFormatter,
    IClassFormatter,
    IFormatter

The VBClassFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBClassFormatter(ClassSyntax) |

Methods

 | Name | Summary
public method | Format(ClassSyntax) |
public method | Format() |
public method | FormatClassBase(ClassSyntax) |
public method | FormatInheritance(ClassSyntax) |
public method | FormatVisibility(ClassSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBClassFormatter Constructors

The VBClassFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBClassFormatter(ClassSyntax) |


VBClassFormatter(ClassSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBClassFormatter(
ClassSyntax syntax
)

Parameters

syntax
Type: ClassSyntax


VBClassFormatter Fields

The VBClassFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ClassSyntax _syntax


VBClassFormatter Methods

The VBClassFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format(ClassSyntax) |
public method | Format() |
public method | FormatClassBase(ClassSyntax) |
public method | FormatInheritance(ClassSyntax) |
public method | FormatVisibility(ClassSyntax) |


Format(ClassSyntax)

Format(ClassSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax


Format()

Format() Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format()


FormatClassBase(ClassSyntax)

FormatClassBase(ClassSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatClassBase(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax


FormatInheritance(ClassSyntax)

FormatInheritance(ClassSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax


FormatVisibility(ClassSyntax)

FormatVisibility(ClassSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    ClassSyntax syntax
    )

Parameters

syntax
Type: ClassSyntax


VBConstantFormatter

VBConstantFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBConstantFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBConstantFormatter : VBFormatter,
    IConstantFormatter,
    IFormatter

The VBConstantFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBConstantFormatter(ConstantSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstantSyntax) |
public method | GetType(ConstantSyntax) |
public method | GetVisibility(ConstantSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBConstantFormatter Constructors

The VBConstantFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBConstantFormatter(ConstantSyntax) |


VBConstantFormatter(ConstantSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBConstantFormatter(
ConstantSyntax syntax
)

Parameters

syntax
Type: ConstantSyntax


VBConstantFormatter Fields

The VBConstantFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ConstantSyntax _syntax


VBConstantFormatter Methods

The VBConstantFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstantSyntax) |
public method | GetType(ConstantSyntax) |
public method | GetVisibility(ConstantSyntax) |


Format(ConstantSyntax)

Format(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


GetType(ConstantSyntax)

GetType(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GetType(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


GetVisibility(ConstantSyntax)

GetVisibility(ConstantSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> GetVisibility(
    ConstantSyntax syntax
    )

Parameters

syntax
Type: ConstantSyntax


VBConstructorFormatter

VBConstructorFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBConstructorFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBConstructorFormatter : VBFormatter,
    IConstructorFormatter,
    IFormatter

The VBConstructorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBConstructorFormatter(ConstructorSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstructorSyntax) |
public method | FormatInheritance(ConstructorSyntax) |
public method | FormatParameters(ConstructorSyntax) |
public method | FormatVisibility(ConstructorSyntax) |

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


VBConstructorFormatter Constructors

The VBConstructorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBConstructorFormatter(ConstructorSyntax) |


VBConstructorFormatter(ConstructorSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBConstructorFormatter(
ConstructorSyntax syntax
)

Parameters

syntax
Type: ConstructorSyntax


VBConstructorFormatter Fields

The VBConstructorFormatter type exposes the following members.

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


_signiture

_signiture Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Signature _signiture


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private ConstructorSyntax _syntax


VBConstructorFormatter Methods

The VBConstructorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(ConstructorSyntax) |
public method | FormatInheritance(ConstructorSyntax) |
public method | FormatParameters(ConstructorSyntax) |
public method | FormatVisibility(ConstructorSyntax) |


Format(ConstructorSyntax)

Format(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatInheritance(ConstructorSyntax)

FormatInheritance(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatParameters(ConstructorSyntax)

FormatParameters(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatParameters(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


FormatVisibility(ConstructorSyntax)

FormatVisibility(ConstructorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    ConstructorSyntax syntax
    )

Parameters

syntax
Type: ConstructorSyntax


VBDelegateFormatter

VBDelegateFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBDelegateFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBDelegateFormatter : VBFormatter,
    IDelegateFormatter,
    IFormatter

The VBDelegateFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBDelegateFormatter(DelegateSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(DelegateSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(DelegateSyntax) |
public method | FormatVisibility(DelegateSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBDelegateFormatter Constructors

The VBDelegateFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBDelegateFormatter(DelegateSyntax) |


VBDelegateFormatter(DelegateSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBDelegateFormatter(
DelegateSyntax syntax
)

Parameters

syntax
Type: DelegateSyntax


VBDelegateFormatter Fields

The VBDelegateFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private DelegateSyntax _syntax


VBDelegateFormatter Methods

The VBDelegateFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(DelegateSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(DelegateSyntax) |
public method | FormatVisibility(DelegateSyntax) |


Format(DelegateSyntax)

Format(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


FormatParameters(MethodSyntax)

FormatParameters(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatParameters(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatReturnType(DelegateSyntax)

FormatReturnType(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatReturnType(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


FormatVisibility(DelegateSyntax)

FormatVisibility(DelegateSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    DelegateSyntax syntax
    )

Parameters

syntax
Type: DelegateSyntax


VBEnumerationFormatter

VBEnumerationFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBEnumerationFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBEnumerationFormatter : VBFormatter,
    IEnumerationFormatter,
    IFormatter

The VBEnumerationFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBEnumerationFormatter(EnumSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(EnumSyntax) |
public method | FormatVisibility(EnumSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBEnumerationFormatter Constructors

The VBEnumerationFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBEnumerationFormatter(EnumSyntax) |


VBEnumerationFormatter(EnumSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBEnumerationFormatter(
EnumSyntax syntax
)

Parameters

syntax
Type: EnumSyntax


VBEnumerationFormatter Fields

The VBEnumerationFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private EnumSyntax _syntax


VBEnumerationFormatter Methods

The VBEnumerationFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(EnumSyntax) |
public method | FormatVisibility(EnumSyntax) |


Format(EnumSyntax)

Format(EnumSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    EnumSyntax syntax
    )

Parameters

syntax
Type: EnumSyntax


FormatVisibility(EnumSyntax)

FormatVisibility(EnumSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    EnumSyntax syntax
    )

Parameters

syntax
Type: EnumSyntax


VBEventFormatter

VBEventFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBEventFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBEventFormatter : VBFormatter,
    IEventFormatter,
    IFormatter

The VBEventFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBEventFormatter(EventSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(EventSyntax) |
public method | FormatIdentifier(EventSyntax) |
public method | FormatInheritance(EventSyntax) |
public method | FormatType(EventSyntax) |
public method | FormatVisibility(EventSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBEventFormatter Constructors

The VBEventFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBEventFormatter(EventSyntax) |


VBEventFormatter(EventSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBEventFormatter(
EventSyntax syntax
)

Parameters

syntax
Type: EventSyntax


VBEventFormatter Fields

The VBEventFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private EventSyntax _syntax


VBEventFormatter Methods

The VBEventFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(EventSyntax) |
public method | FormatIdentifier(EventSyntax) |
public method | FormatInheritance(EventSyntax) |
public method | FormatType(EventSyntax) |
public method | FormatVisibility(EventSyntax) |


Format(EventSyntax)

Format(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatIdentifier(EventSyntax)

FormatIdentifier(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatIdentifier(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatInheritance(EventSyntax)

FormatInheritance(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatType(EventSyntax)

FormatType(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatType(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


FormatVisibility(EventSyntax)

FormatVisibility(EventSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    EventSyntax syntax
    )

Parameters

syntax
Type: EventSyntax


VBFieldFormatter

VBFieldFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFieldFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBFieldFormatter : VBFormatter,
    IFieldFormatter,
    IFormatter

The VBFieldFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBFieldFormatter(FieldSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(FieldSyntax) |
public method | GetType(FieldSyntax) |
public method | GetVisibility(FieldSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBFieldFormatter Constructors

The VBFieldFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBFieldFormatter(FieldSyntax) |


VBFieldFormatter(FieldSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBFieldFormatter(
FieldSyntax syntax
)

Parameters

syntax
Type: FieldSyntax


VBFieldFormatter Fields

The VBFieldFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private FieldSyntax _syntax


VBFieldFormatter Methods

The VBFieldFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(FieldSyntax) |
public method | GetType(FieldSyntax) |
public method | GetVisibility(FieldSyntax) |


Format(FieldSyntax)

Format(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


GetType(FieldSyntax)

GetType(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken GetType(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


GetVisibility(FieldSyntax)

GetVisibility(FieldSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> GetVisibility(
    FieldSyntax syntax
    )

Parameters

syntax
Type: FieldSyntax


VBFormatter

VBFormatter Class

Base class with methods that are useful for all VB formatting classes.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBClassFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBConstantFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBConstructorFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBDelegateFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBEnumerationFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBEventFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFieldFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBIndexorFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBInterfaceFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBMethodFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBOperatorFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBPropertyFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBStructFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class VBFormatter

The VBFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBFormatter() |

Methods

 | Name | Summary
protected method | FormatGenericParameters(List<GenericTypeRef>) | Formats the generic types for a the specified genericTypes.
protected method | FormatInheritance(Inheritance) |
protected method | FormatParameterModifiers(ParameterDetails) |
protected method | FormatTypeDetails(TypeDetails) |
protected method | FormatTypeName(TypeRef) | Returns the language specific type name for the specified type. For example in C# System.Boolean is referenced via the bool keyword.
protected method | FormatTypeName(TypeRef[]) |
protected method | FormatVisibility(Visibility) |
protected method | IsMethodFunction(TypeDetails) |

Fields

 | Name | Description
private field | defaultTypes | Collection of all the types defined in this language with a language specific short form.


VBFormatter Constructors

The VBFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBFormatter() |


VBFormatter()

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBFormatter()


VBFormatter Fields

The VBFormatter type exposes the following members.

Fields

 | Name | Description
private field | defaultTypes | Collection of all the types defined in this language with a language specific short form.


defaultTypes

defaultTypes Field

Collection of all the types defined in this language with a language specific short form.
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private Dictionary defaultTypes


VBFormatter Methods

The VBFormatter type exposes the following members.

Methods

 | Name | Summary
protected method | FormatGenericParameters(List<GenericTypeRef>) | Formats the generic types for a the specified genericTypes.
protected method | FormatInheritance(Inheritance) |
protected method | FormatParameterModifiers(ParameterDetails) |
protected method | FormatTypeDetails(TypeDetails) |
protected method | FormatTypeName(TypeRef) | Returns the language specific type name for the specified type. For example in C# System.Boolean is referenced via the bool keyword.
protected method | FormatTypeName(TypeRef[]) |
protected method | FormatVisibility(Visibility) |
protected method | IsMethodFunction(TypeDetails) |


FormatGenericParameters(List<GenericTypeRef>)

FormatGenericParameters(List<GenericTypeRef>) Method

Formats the generic types for a the specified genericTypes.
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatGenericParameters(
    List<GenericTypeRef> genericTypes
    )

Parameters

genericTypes
Type: List<>
The types to format.


FormatInheritance(Inheritance)

FormatInheritance(Inheritance) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected SyntaxToken FormatInheritance(
    Inheritance inheritance
    )

Parameters

inheritance
Type: Inheritance


FormatParameterModifiers(ParameterDetails)

FormatParameterModifiers(ParameterDetails) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatParameterModifiers(
    ParameterDetails details
    )

Parameters

details
Type: ParameterDetails


FormatTypeDetails(TypeDetails)

FormatTypeDetails(TypeDetails) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatTypeDetails(
    TypeDetails details
    )

Parameters

details
Type: TypeDetails


FormatTypeName(TypeRef)

FormatTypeName(TypeRef) Method

Returns the language specific type name for the specified type. For example in C# System.Boolean is referenced via the bool keyword.
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected SyntaxToken FormatTypeName(
    TypeRef type
    )

Parameters

type
Type: TypeRef
The type to get the name for.


FormatTypeName(TypeRef[])

FormatTypeName(TypeRef[]) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatTypeName(
    TypeRef[] types
    )

Parameters

types
Type: TypeRef


FormatVisibility(Visibility)

FormatVisibility(Visibility) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected List<SyntaxToken> FormatVisibility(
    Visibility visibility
    )

Parameters

visibility
Type: Visibility


IsMethodFunction(TypeDetails)

IsMethodFunction(TypeDetails) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

protected bool IsMethodFunction(
    TypeDetails details
    )

Parameters

details
Type: TypeDetails


VBIndexorFormatter

VBIndexorFormatter Class

Provides a formatting implementation for Indexor properties in VB.NET.

Below is an example of how indexors are formatted in VB.NET: Public Property Item(index As Integer) As Object

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBIndexorFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal class VBIndexorFormatter : VBFormatter,
    IIndexorFormatter,
    IFormatter

The VBIndexorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBIndexorFormatter(IndexorSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(IndexorSyntax) |
public method | FormatGetVisibility(IndexorSyntax) |
public method | FormatIdentifier(IndexorSyntax) |
public method | FormatInheritance(IndexorSyntax) |
public method | FormatSetVisibility(IndexorSyntax) |
public method | FormatType(IndexorSyntax) |
public method | FormatVisibility(IndexorSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBIndexorFormatter Constructors

The VBIndexorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBIndexorFormatter(IndexorSyntax) |


VBIndexorFormatter(IndexorSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBIndexorFormatter(
IndexorSyntax syntax
)

Parameters

syntax
Type: IndexorSyntax


VBIndexorFormatter Fields

The VBIndexorFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private IndexorSyntax _syntax


VBIndexorFormatter Methods

The VBIndexorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(IndexorSyntax) |
public method | FormatGetVisibility(IndexorSyntax) |
public method | FormatIdentifier(IndexorSyntax) |
public method | FormatInheritance(IndexorSyntax) |
public method | FormatSetVisibility(IndexorSyntax) |
public method | FormatType(IndexorSyntax) |
public method | FormatVisibility(IndexorSyntax) |


Format(IndexorSyntax)

Format(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatGetVisibility(IndexorSyntax)

FormatGetVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatGetVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatIdentifier(IndexorSyntax)

FormatIdentifier(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatIdentifier(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatInheritance(IndexorSyntax)

FormatInheritance(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatSetVisibility(IndexorSyntax)

FormatSetVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatSetVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatType(IndexorSyntax)

FormatType(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatType(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


FormatVisibility(IndexorSyntax)

FormatVisibility(IndexorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    IndexorSyntax syntax
    )

Parameters

syntax
Type: IndexorSyntax


VBInterfaceFormatter

VBInterfaceFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBInterfaceFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBInterfaceFormatter : VBFormatter,
    IInterfaceFormatter,
    IFormatter

The VBInterfaceFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBInterfaceFormatter(InterfaceSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(InterfaceSyntax) |
public method | FormatInterfaceBase(InterfaceSyntax) |
public method | FormatVisibility(InterfaceSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBInterfaceFormatter Constructors

The VBInterfaceFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBInterfaceFormatter(InterfaceSyntax) |


VBInterfaceFormatter(InterfaceSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBInterfaceFormatter(
InterfaceSyntax syntax
)

Parameters

syntax
Type: InterfaceSyntax


VBInterfaceFormatter Fields

The VBInterfaceFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private InterfaceSyntax _syntax


VBInterfaceFormatter Methods

The VBInterfaceFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(InterfaceSyntax) |
public method | FormatInterfaceBase(InterfaceSyntax) |
public method | FormatVisibility(InterfaceSyntax) |


Format(InterfaceSyntax)

Format(InterfaceSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax


FormatInterfaceBase(InterfaceSyntax)

FormatInterfaceBase(InterfaceSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatInterfaceBase(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax


FormatVisibility(InterfaceSyntax)

FormatVisibility(InterfaceSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    InterfaceSyntax syntax
    )

Parameters

syntax
Type: InterfaceSyntax


VBMethodFormatter

VBMethodFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBMethodFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBMethodFormatter : VBFormatter,
    IMethodFormatter,
    IFormatter

The VBMethodFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBMethodFormatter(MethodSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(MethodSyntax) |
public method | FormatInheritance(MethodSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(MethodSyntax) |
public method | FormatVisibility(MethodSyntax) |

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


VBMethodFormatter Constructors

The VBMethodFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBMethodFormatter(MethodSyntax) |


VBMethodFormatter(MethodSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBMethodFormatter(
MethodSyntax syntax
)

Parameters

syntax
Type: MethodSyntax


VBMethodFormatter Fields

The VBMethodFormatter type exposes the following members.

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MethodSyntax _syntax


VBMethodFormatter Methods

The VBMethodFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(MethodSyntax) |
public method | FormatInheritance(MethodSyntax) |
public method | FormatParameters(MethodSyntax) |
public method | FormatReturnType(MethodSyntax) |
public method | FormatVisibility(MethodSyntax) |


Format(MethodSyntax)

Format(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatInheritance(MethodSyntax)

FormatInheritance(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatReturnType(MethodSyntax)

FormatReturnType(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatReturnType(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


FormatVisibility(MethodSyntax)

FormatVisibility(MethodSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    MethodSyntax syntax
    )

Parameters

syntax
Type: MethodSyntax


VBOperatorFormatter

VBOperatorFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBOperatorFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBOperatorFormatter : VBFormatter,
    IOperatorFormatter,
    IFormatter

The VBOperatorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBOperatorFormatter(OperatorSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(OperatorSyntax) |
public method | FormatInheritance(OperatorSyntax) |
public method | FormatName(OperatorSyntax) |
public method | FormatParameters(OperatorSyntax) |
public method | FormatReturnType(OperatorSyntax) |
public method | FormatVisibility(OperatorSyntax) |

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


VBOperatorFormatter Constructors

The VBOperatorFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBOperatorFormatter(OperatorSyntax) |


VBOperatorFormatter(OperatorSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBOperatorFormatter(
OperatorSyntax syntax
)

Parameters

syntax
Type: OperatorSyntax


VBOperatorFormatter Fields

The VBOperatorFormatter type exposes the following members.

Fields

 | Name | Description
private field | _signiture |
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private OperatorSyntax _syntax


VBOperatorFormatter Methods

The VBOperatorFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(OperatorSyntax) |
public method | FormatInheritance(OperatorSyntax) |
public method | FormatName(OperatorSyntax) |
public method | FormatParameters(OperatorSyntax) |
public method | FormatReturnType(OperatorSyntax) |
public method | FormatVisibility(OperatorSyntax) |


Format(OperatorSyntax)

Format(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatInheritance(OperatorSyntax)

FormatInheritance(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatName(OperatorSyntax)

FormatName(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatName(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatParameters(OperatorSyntax)

FormatParameters(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatParameters(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatReturnType(OperatorSyntax)

FormatReturnType(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatReturnType(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


FormatVisibility(OperatorSyntax)

FormatVisibility(OperatorSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    OperatorSyntax syntax
    )

Parameters

syntax
Type: OperatorSyntax


VBPropertyFormatter

VBPropertyFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBPropertyFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBPropertyFormatter : VBFormatter,
    IPropertyFormatter,
    IFormatter

The VBPropertyFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBPropertyFormatter(PropertySyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(PropertySyntax) |
public method | FormatGetVisibility(PropertySyntax) |
public method | FormatIdentifier(PropertySyntax) |
public method | FormatInheritance(PropertySyntax) |
public method | FormatSetVisibility(PropertySyntax) |
public method | FormatType(PropertySyntax) |
public method | FormatVisibility(PropertySyntax) |

Fields

 | Name | Description
private field | _syntax |


VBPropertyFormatter Constructors

The VBPropertyFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBPropertyFormatter(PropertySyntax) |


VBPropertyFormatter(PropertySyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBPropertyFormatter(
PropertySyntax syntax
)

Parameters

syntax
Type: PropertySyntax


VBPropertyFormatter Fields

The VBPropertyFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private PropertySyntax _syntax


VBPropertyFormatter Methods

The VBPropertyFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(PropertySyntax) |
public method | FormatGetVisibility(PropertySyntax) |
public method | FormatIdentifier(PropertySyntax) |
public method | FormatInheritance(PropertySyntax) |
public method | FormatSetVisibility(PropertySyntax) |
public method | FormatType(PropertySyntax) |
public method | FormatVisibility(PropertySyntax) |


Format(PropertySyntax)

Format(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatGetVisibility(PropertySyntax)

FormatGetVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatGetVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatIdentifier(PropertySyntax)

FormatIdentifier(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatIdentifier(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatInheritance(PropertySyntax)

FormatInheritance(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxToken FormatInheritance(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatSetVisibility(PropertySyntax)

FormatSetVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatSetVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatType(PropertySyntax)

FormatType(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatType(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


FormatVisibility(PropertySyntax)

FormatVisibility(PropertySyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    PropertySyntax syntax
    )

Parameters

syntax
Type: PropertySyntax


VBStructFormatter

VBStructFormatter Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBFormatter
      • TheBoxSoftware.Reflection.Syntax.VisualBasic.VBStructFormatter
Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

internal sealed class VBStructFormatter : VBFormatter,
    IStructFormatter,
    IFormatter

The VBStructFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBStructFormatter(StructSyntax) |

Methods

 | Name | Summary
public method | Format() |
public method | Format(StructSyntax) |
public method | FormatInterfaces(StructSyntax) |
public method | FormatVisibility(StructSyntax) |

Fields

 | Name | Description
private field | _syntax |


VBStructFormatter Constructors

The VBStructFormatter type exposes the following members.

Constructors

 | Class | Summary
public constructor | VBStructFormatter(StructSyntax) |


VBStructFormatter(StructSyntax)

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public VBStructFormatter(
StructSyntax syntax
)

Parameters

syntax
Type: StructSyntax


VBStructFormatter Fields

The VBStructFormatter type exposes the following members.

Fields

 | Name | Description
private field | _syntax |


_syntax

_syntax Field

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private StructSyntax _syntax


VBStructFormatter Methods

The VBStructFormatter type exposes the following members.

Methods

 | Name | Summary
public method | Format() |
public method | Format(StructSyntax) |
public method | FormatInterfaces(StructSyntax) |
public method | FormatVisibility(StructSyntax) |


Format(StructSyntax)

Format(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public SyntaxTokenCollection Format(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


FormatInterfaces(StructSyntax)

FormatInterfaces(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatInterfaces(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


FormatVisibility(StructSyntax)

FormatVisibility(StructSyntax) Method

Namespace: TheBoxSoftware.Reflection.Syntax.VisualBasicAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public List<SyntaxToken> FormatVisibility(
    StructSyntax syntax
    )

Parameters

syntax
Type: StructSyntax


TheBoxSoftware.Reflection.TypeDef Namespaces

Namespace
TheBoxSoftware.Reflection.TypeDef


TheBoxSoftware.Reflection.TypeDef Namespace

Classes

 | Class | Summary
private class | EventMapComparer | Internal comparer to enable fast binary searching of the event table.
private class | PropertyMapComparer | Internal comparer to enable fast binary searching of the property table.
private class | TypeDefBuilder |


EventMapComparer

EventMapComparer Class

Internal comparer to enable fast binary searching of the event table.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.TypeDef.EventMapComparer
Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private class EventMapComparer: IComparer<MetadataRow>

The EventMapComparer type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventMapComparer() |

Methods

 | Name | Summary
public method | Compare(MetadataRow, MetadataRow) |
public method | Compare(EventMapMetadataTableRow, EventMapMetadataTableRow) |


EventMapComparer Constructors

The EventMapComparer type exposes the following members.

Constructors

 | Class | Summary
public constructor | EventMapComparer() |


EventMapComparer()

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public EventMapComparer()


EventMapComparer Methods

The EventMapComparer type exposes the following members.

Methods

 | Name | Summary
public method | Compare(MetadataRow, MetadataRow) |
public method | Compare(EventMapMetadataTableRow, EventMapMetadataTableRow) |


Compare(MetadataRow, MetadataRow)

Compare(MetadataRow, MetadataRow) Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Compare(
    MetadataRow x,
    MetadataRow y
    )

Parameters

x
Type: MetadataRow
y
Type: MetadataRow


Compare(EventMapMetadataTableRow, EventMapMetadataTableRow)

Compare(EventMapMetadataTableRow, EventMapMetadataTableRow) Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Compare(
    EventMapMetadataTableRow x,
    EventMapMetadataTableRow y
    )

Parameters

x
Type: EventMapMetadataTableRow
y
Type: EventMapMetadataTableRow


PropertyMapComparer

PropertyMapComparer Class

Internal comparer to enable fast binary searching of the property table.

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.TypeDef.PropertyMapComparer
Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private class PropertyMapComparer: IComparer<MetadataRow>

The PropertyMapComparer type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyMapComparer() |

Methods

 | Name | Summary
public method | Compare(MetadataRow, MetadataRow) |
public method | Compare(PropertyMapMetadataTableRow, PropertyMapMetadataTableRow) |


PropertyMapComparer Constructors

The PropertyMapComparer type exposes the following members.

Constructors

 | Class | Summary
public constructor | PropertyMapComparer() |


PropertyMapComparer()

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public PropertyMapComparer()


PropertyMapComparer Methods

The PropertyMapComparer type exposes the following members.

Methods

 | Name | Summary
public method | Compare(MetadataRow, MetadataRow) |
public method | Compare(PropertyMapMetadataTableRow, PropertyMapMetadataTableRow) |


Compare(PropertyMapMetadataTableRow, PropertyMapMetadataTableRow)

Compare(PropertyMapMetadataTableRow, PropertyMapMetadataTableRow) Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public int Compare(
    PropertyMapMetadataTableRow x,
    PropertyMapMetadataTableRow y
    )

Parameters

x
Type: PropertyMapMetadataTableRow
y
Type: PropertyMapMetadataTableRow


TypeDefBuilder

TypeDefBuilder Class

Inheritance Hierarchy

  • System.Object
    • TheBoxSoftware.Reflection.TypeDef.TypeDefBuilder
Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private class TypeDefBuilder

The TypeDefBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDefBuilder(BuildReferences, TypeDefMetadataTableRow) |

Methods

 | Name | Summary
public method | Build() |
private method | CalculateIndexes() |
private method | LoadEvents() |
private method | LoadFields() |
private method | LoadGenericParameters() |
private method | LoadMethods() |
private method | LoadProperties() |
private method | SetTypeProperties() |

Fields

 | Name | Description
private field | _assembly |
private field | _builtType |
private field | _fromRow |
private field | _indexInMetadataTable |
private field | _map |
private field | _metadata |
private field | _metadataStream |
private field | _nextRowIndex |
private field | _references |
private field | _rowIndex |


TypeDefBuilder Constructors

The TypeDefBuilder type exposes the following members.

Constructors

 | Class | Summary
public constructor | TypeDefBuilder(BuildReferences, TypeDefMetadataTableRow) |


TypeDefBuilder(BuildReferences, TypeDefMetadataTableRow)

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDefBuilder(
BuildReferences references,
TypeDefMetadataTableRow fromRow
)

Parameters

references
Type: BuildReferences
fromRow
Type: TypeDefMetadataTableRow


TypeDefBuilder Fields

The TypeDefBuilder type exposes the following members.

Fields

 | Name | Description
private field | _assembly |
private field | _builtType |
private field | _fromRow |
private field | _indexInMetadataTable |
private field | _map |
private field | _metadata |
private field | _metadataStream |
private field | _nextRowIndex |
private field | _references |
private field | _rowIndex |


_assembly

_assembly Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private AssemblyDef _assembly


_builtType

_builtType Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDef _builtType


_fromRow

_fromRow Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private TypeDefMetadataTableRow _fromRow


_indexInMetadataTable

_indexInMetadataTable Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _indexInMetadataTable


_map

_map Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataToDefinitionMap _map


_metadata

_metadata Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataDirectory _metadata


_metadataStream

_metadataStream Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private MetadataStream _metadataStream


_nextRowIndex

_nextRowIndex Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _nextRowIndex


_references

_references Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private BuildReferences _references


_rowIndex

_rowIndex Field

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private int _rowIndex


TypeDefBuilder Methods

The TypeDefBuilder type exposes the following members.

Methods

 | Name | Summary
public method | Build() |
private method | CalculateIndexes() |
private method | LoadEvents() |
private method | LoadFields() |
private method | LoadGenericParameters() |
private method | LoadMethods() |
private method | LoadProperties() |
private method | SetTypeProperties() |


Build()

Build() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

public TypeDef Build()


CalculateIndexes()

CalculateIndexes() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void CalculateIndexes()


LoadEvents()

LoadEvents() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadEvents()


LoadFields()

LoadFields() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadFields()


LoadGenericParameters()

LoadGenericParameters() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadGenericParameters()


LoadMethods()

LoadMethods() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadMethods()


LoadProperties()

LoadProperties() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void LoadProperties()


SetTypeProperties()

SetTypeProperties() Method

Namespace: TheBoxSoftware.Reflection.TypeDefAssembly: TheBoxSoftware.Reflection in (theboxsoftware.reflection.dll)

Syntax

private void SetTypeProperties()